Agilent Technologies
N5161A/62A/81A/82A/
83A

MXG Signal Generators

User’s Guide

Agilent Technologies



Notices

© Agilent Technologies, Inc. 2006-2009

No part of this manual may be reproduced in
any form or by any means (including elec-
tronic storage and retrieval or translation

into a foreign language) without prior agree-

ment and written consent from Agilent
Technologies, Inc. as governed by United
States and international copyright laws.
Manual Part Number

N5180-90003
Edition

May 2009
Printed in USA

Agilent Technologies, Inc.
3501 Stevens Creek Blvd.
Santa Clara, CA 95052 USA

Warranty

The material contained in this docu-
ment is provided “as is,” and is sub-
ject to being changed, without notice,
in future editions. Further, to the max-
imum extent permitted by applicable
law, Agilent disclaims all warranties,
either express or implied, with regard
to this manual and any information
contained herein, including but not
limited to the implied warranties of
merchantability and fitness for a par-
ticular purpose. Agilent shall not be
liable for errors or for incidental or
consequential damages in connec-
tion with the furnishing, use, or per-
formance of this document or of any
information contained herein. Should
Agilent and the user have a separate
written agreement with warranty
terms covering the material in this
document that conflict with these
terms, the warranty terms in the sep-
arate agreement shall control.

Technology Licenses

The hardware and/or software described in
this document are furnished under a license
and may be used or copied only in accor-
dance with the terms of such license.

Restricted Rights Legend

U.S. Government Restricted Rights. Soft-
ware and technical data rights granted to
the federal government include only those
rights customarily provided to end user cus-
tomers. Agilent provides this customary
commercial license in Software and techni-
cal data pursuant to FAR 12.211 (Technical
Data) and 12.212 (Computer Software) and,
for the Department of Defense, DFARS
252.227-7015 (Technical Data - Commercial
Items) and DFARS 227.7202-3 (Rights in
Commercial Computer Software or Com-
puter Software Documentation).

Safety Notices

A CAUTION notice denotes a haz-
ard. It calls attention to an operat-
ing procedure, practice, or the like
that, if not correctly performed or
adhered to, could result in damage
to the product or loss of important
data. Do not proceed beyond a
CAUTION notice until the indicated
conditions are fully understood and
met.

A WARNING notice denotes a
hazard. It calls attention to an
operating procedure, practice, or
the like that, if not correctly per-
formed or adhered to, could result
in personal injury or death. Do not
proceed beyond a WARNING
notice until the indicated condi-
tions are fully understood and
met.

Users Guide



Contents

1 Signal Generator Overview

Signal Generator Features . . . . . . . . . . . . 2
Modes of Operation . . . . . . . . . . . . e e e e e 4
Continuous Wave . . . . . . . . 4
Swept Signal . . . . . . 4
Analog Modulation . . . . . . . . . e e 4
Digital Modulation (N5162A/82A with Options 651, 652, or 654 Only) . . ... ... ... . ... 4
Front Panel Overview — N5181A/82A MXG . . . . . . . . . e e e e e e e 5
1. Host USB . . . . . e 5
2. Display . . . . e 5
3. SoftReYS . . . o e 5
4. Numeric Keypad . . . . . . . . o 6
5. Arrows and Select. . . . . . .. 6
6. Page UD . . . . . . . e 6
7. MENUS . . . e 6
8. Trigger . . . . . e e 6
9. Local Cancel/(EsC) . . . . . . . e e e 6
10. Help . . . oo e e e e 7
11. Preset and User Preset. . . . . . . . . . e 7
12. RF Output . . . . . . o 7
13. RF On/Off and LED. . . . . . . . . . 7
14. Mod On/Off and LED. . . . . . . . . . . 7
15. Page DOWN. . . . . . . L e e e 7
16. I Input (vector models only) . . . . . . . . . . e 7
17. Q Input (vector models only). . . . . . . . . .. e 8
18. Knob. . . . o o e 8
19. Incr Set . . . . e 8
20. Return . . . . .. 8
21. More and LED . . . . . . e e e e 8
22. Power Switch and LEDs . . . . . . . . . e 8
Front Panel Overview — N5161A/62A MXG ATE . . . . . . . . . . . . .. . . .. 9
N5161A/62A MXG ATE Front Panel Functions. . . . . . ... ... ... ... .. ... ........ 9
1. Host USB . . . . e e e e 9
2. Power Switch and LEDs. . . . . . . . . . . . e e e e 10
3. LAN LED . . . . . e e 10
4. 1688 LED . . . . . e 10
5. ERROR LED. . . . . . e e 10
6. LAN Reset Hardkey . . . . . . . . . . . e 10
Front Panel Display — N5181A/82A/83A MXG . . . . . . . e e e 11
1. Active Function Area. . . . . . . . . . . . . 11
2. Frequency Area . . . . . . . . . . 11

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User's Guide iii



Contents

3. ANNUNCIAtOTS . . . . . . o o e 11
4. Amplitude Area . . . . . . .. 12
5. Error Message ATea . . . . . . . . . o i i it e e e e e 12
6. Text Area . . . . . . . . e 13
7. Softkey Label Area . . . . . . . . . e 13
Blank Front Panel Display — N5161A/62A MXG ATE . . . . ... ... . . .. . . .. 13
N5161A/62A MXG ATE - Web Enabled Display . . . . . ... ... ... ... .. ... ....... 13
ANnunciators. . . . . .. L e e 13
Rear Panel Overview — N5161A/62A1/81A/82A MXG . . . o o oo 15
1. AC Power Receptacle. . . . . . . . . . e 15
2. SWEEP OUT . . . . . e 15
............................................................ 16
4. FM . 16
5. PULSE . . . . e 16
6. TRIG IN . . . o e e 16
7. TRIG OUT . . . . e e e e e e e e 16
8. REF IN. .« . e 17
9. 10 MHz OUT . . . . . . e e e 17
10. GPIB . . . e 17
11, LAN . 17
12. Device USB . . . . . . 17
Digital Modulation Connectors (Vector Models Only). . . . . ... ... ... ... .. ....... 18
I OUT, Q OUT, OUT, OUT . . . . . . e e e e e e 18
EXT CLK . . . 18
EVENT 1 . @ 19
PAT TRIG. . . . . o e e e e 19
DIGITAL BUS I/O . . . o e e e e e e e e e e e 19
AUX T/0. . o 20
Rear Panel Overview — NBI83A MXG . . . . . . . . o e e e 21
1. AC Power Receptacle. . . . . . . . . . e 21
2. SWEEP OUT . . . . . 21
3. AM L e 22
4. FM . 22
5. PULSE . . . . e 22
6. TRIG IN . . . e 22
7. TRIG OUT . . . . e e e e e 22
8. REF IN. . . e 22
9. 10 MHz OUT . . . . o e e e e e e e 23
10. GPIB . . . e 23
11, LAN . 23
12. Device USB . . . . . . o e 23

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User's Guide



Contents

13. Z AXIS OUTPUT . . . . . e e e 23
14. ALC INPUT . . . . e e 24

2  Setting Preferences & Enabling Options

User Preferences . . . . . . . . . e 26
Display Settings . . . . . . . . . e e e 26
Power On and Preset . . . . . . . . . e 27
Front Panel Knob Resolution . . . . . .. .. ... . . e 28
Setting Time and Date. . . . . . . . . . e 28
Reference Oscillator Tune . . . . . . . . . . e 29

Upgrading Firmware. . . . . . . . . . e e e e 29

Remote Operation Preferences . . . . . . . . . . . . . 30
GPIB Address and Remote Language . . . . . . . . . . .. . . ... e 30
Configuring the LAN Interface . . . . . . . . . . . . . . . e 31
Enabling LAN Services: “Browser,” “Sockets,” “VXI-11" and “LXI-B” . .. ... ......... 32
Configuring the Remote Languages . . . . . .. . . . . . . . . .. 33
Configuring the Preset Languages . . . . . . . . . . . . . . it 35

Enabling an Option . . . . . . . . . . e e e e 37
Viewing Options and Licenses. . . . . . . . . . . . . . e 38

Hardware Assembly Installation and Removal Softkeys. . . . .. ... ... .. ... .......... 39
Hardware Assembly Installation and Removal Softkeys. . . . ... ... ... ... ........ 39

3 Basic Operation

Presetting the Signal Generator. . . . . . . . . . . . . 42
Viewing Key Descriptions. . . . . . . . . . e 42
Entering and Editing Numbers and Text. . . . . . . . .. . . .. . . . 43
Entering Numbers and Moving the Cursor. . . . . . .. .. .. .. ... . ... 43
Entering Alpha Characters. . . . . . . . . . . . e e 43
Example: Using a Table Editor . . . . . . . .. ... ... . . . . . e 44
Setting Frequency and Power (Amplitude) . . ... ... ... . .. .. . ... . 45
Example: Configuring a 700 MHz, —20 dBm Continuous Wave Output. . . . .. ... ... ... 46
Using an External Reference Oscillator. . . . . ... ... ... ... .. .. .. ... ... ...... 46
Setting ALC Bandwidth Control . . . . .. . . .. . . . e 47
Configuring a Swept Output. . . . . . . . . . e e 48
Routing Signals . . . . . . . . . e e e e 49
SteP SWeeD . . . . o o o e e 49
List SWeep . . . . . e e e 57
Example: Using a Single Sweep. . . . . . . . . . e 60
Example: Manual Control of Sweep . . . . . . . . . . . . . ... e 61

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide v



Contents

Modulating the Carrier Signal . . . . . . . . . . . . e 61
Example. . . . . . e 61
Simultaneous Modulation. . . . . .. .. ... L 63

Working with Files. . . . . . . . o e 63
File Softkeys. . . . . .« . L e 64
Viewing a List of Stored Files . . . . . . . . . .. . e 65
Storing a File . . . . . . . o e 66
Loading (Recalling) a Stored File . . . . . . . . . ... . . . . e 68
Moving a File from One Media to Another . . . . .. .. ... ... ... ... . ... . ...... 69
Working with Instrument State Files . . . . . .. . .. ... . .. . . . 70
Selecting the Default Storage Media. . . . . . . ... . ... .. .. . 74

Reading Error Messages . . . . . . . . o i i e 75
Error Message Format. . . . . . . . . . . 75

4  Using Analog Modulation (Option UNT Only)

The Basic Procedure . . . . . .. . . . . . e 78
Using an External Modulation Source . . . . . . ... .. ... . .. e 79
Removing a DC Offset. . . . . . . . . . . 79

5 Optimizing Performance

Using the Dual Power Meter Display . . . . . . . . . . . . . e 82
Example: Dual Power Meter Calibration . . . . . . .. .. ... .. ... .. . . ... ... . ..... 85
Using Flatness Correction . . . . . . . . . . . e 90
Creating a User Flatness Correction Array . . . .. . . . .. . ... .. 92
Recalling and Applying a User Flatness Correction Array . . ... ... .............. 98
Using External Leveling (NHI83A Only) . . . . . . . . . o e e 99
Option 1E1 Output Attenuator Behavior and Use. . . . . ... ... ... ... .......... 102
Configure External Leveling. . . . . . . . . . . . . e 103
Using Unleveled Operating Modes . . . . . . . . . . . . i e et e e 107
ALC Off Mode. . . . . o o e 107
Power Search Mode . . . . . . . . . . e 108
Using an Output Offset, Reference, or Multiplier . . . . . ... ... ... ... ... .......... 109
Setting an Output Offset . . . . . . . . . . . . e 109
Setting an Output Reference. . . . . . . . . .. . . L 110
Setting a Frequency Multiplier . . . . . . . . . .. .. L 111
Using the Frequency and Phase Reference Softkeys . . . ... ... ... ... ... .......... 112
Using Free Run, Step Dwell, and Timer Trigger. . . . . . . . . ... ... .. . ... ... ... 113
Understanding Free Run, Step Dwell, and Timer Trigger Setup. . . . . ... ... ....... 113
Using LXI (Option ALB only) (Option ALB) . . . .. ... . ... .. . . .. . . . ... 115
Understanding LXI Clocks . . . . . . . . e 115

vi Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Contents

.......................................... Getting Started With LXI117
For More Information . . . . . . . . . . . . e 120
Using a USB Keyboard . . . . . . . . . . e 121
6  Using Pulse Modulation (Option UNU or UNW)

Pulse Characteristics. . . . . . . . . . 125

The Basic Procedure. . . . . . . . . 127

Example. . . . . . 127

7 Basic Digital Operation—No BBG Option Installed

I/Q Modulation . . . . . . . . . e 130

Configuring the Front Panel Inputs . . . . . .. .. ... ... ... ... .. ... .. ... .. ... 131
8 Basic Digital Operation (Option 651/652/654)

Waveform File Basics . . . . . . . . e e e 134
Signal Generator Memory. . . . . . . . . . o o i e e 134
Dual ARB Player . . . . . . . . e e e 134

Storing, Loading, and Playing a Waveform Segment . . .. ... .. ... ... ............. 136
Loading a Waveform Segment into BBG Media. . . . ... .. ... ... ... ... ....... 136
Storing/Renaming a Waveform Segment to Internal or USB Media. . . . .. ... ... .... 137
Playing a Waveform Segment . . . . . . . . .. . . .. .. 137

Waveform Sequences. . . . . . . . . . 139
Creating a Sequence . . . . . . . . . . i e e e e 140
Viewing the Contents of a Sequence . . . ... .. ... . . ... ... ... 141
Editing a Sequence. . . . . . . . . e e 141
Playing a Sequence. . . . . . . . . . . e e e 142

Saving a Waveform’s Settings & Parameters . . . ... ... ... .. .. . . . ... ... . ... 143
Viewing and Modifying Header Information . ... ... ... ... ... ... ... ..... 145
Viewing & Editing a Header without Selecting the Waveform . ... ... .. .......... 147

Using Waveform Markers . . . . . . . . . . i e e e e e e e 149
Waveform Marker Concepts . . . . . . . . . . e 150
Accessing Marker Utilities . . . . . . . . . e 154
Viewing Waveform Segment Markers. . . . . .. . . ... . ... ... 155
Clearing Marker Points from a Waveform Segment . . ... ... ... ............... 155
Setting Marker Points in a Waveform Segment. . . . ... ... ... .. ... .. ......... 156
Viewing a Marker Pulse. . . . . . . . . . e 159
Using the RF Blanking Marker Function. . . . ... ... ... .. ... . ... . ... ..... 160
Setting Marker Polarity . . . . . . . . . .. e e 162

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User's Guide vii



Contents

Controlling Markers in a Waveform Sequence . . ... ... ... ... ... ... ....... 162
Using the EVENT Output Signal as an Instrument Trigger. . . ... ... ... ... ...... 165
Triggering a Waveform . . . . . . . . . . e e e 166
Trigger Type . . . . o o o e e e 167
Trigger Source. . . . . . . . . e e e e 168
Example: Segment Advance Triggering . . . . . . . . . . . ... e 169
Example: Gated Triggering. . . . . . . . . . . . e 170
Example: External Triggering . . . . . . . . . . . . 172
Clipping a Waveform . . . . . . . . . . e e e 173
How Power Peaks Develop. . . . . . . . . . e 174
How Peaks Cause Spectral Regrowth . . . . . .. ... ... .. ... ... .. .. .. .. ..... 176
How Clipping Reduces Peak-to—Average Power . . . ... ... ... ... .. ... ....... 177
Configuring Circular Clipping. . . . . . . . . . . e e e e e e e e 180
Configuring Rectangular Clipping . . . . . . . . . . . . e 181
Scaling a Waveform . . . . . . . . . . e e e 182
How DAC Over-Range Errors Occur . . ... ... .. .. ... .. 183
How Scaling Eliminates DAC Over-Range Errors . . . . ... ... ... ... ........... 184
Setting Waveform Runtime Scaling. . . . . .. .. ... ... . .. .. 185
Setting Waveform Scaling. . . . . . . . . . . .. e 186
Setting the Baseband Frequency Offset . . . .. . ... ... . .. .. ... . . .. . . ... . . ..., 188
DAC Over-Range Conditions and Scaling . . . ... ... ... ... ... ... . .......... 190
I/Q Modulation . . . . . . . . L e e e 192
Using the Rear Panel I and Q Outputs. . . . .. ... . ... ... ... . . . ... 193
Configuring the Front Panel Inputs. . . . .. .. ... ... ... ... . .. .. .. . ... . .... 194
I/Q Adjustments . . . . . . . . e 195
I/Q Calibration . . . . . . . . . . e e 196
Using the Equalization Filter . . . . . . . . . . . . 198
Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter. . 200
Creating a User-Defined FIR Filter Using the FIR Table Editor . . ... ... ......... 201
Modifying a FIR Filter Using the FIR Table Editor. . . . . . ... ... .. ... .. .......... 206
Loading the Default Gaussian FIR File. . . . .. ... ... .. ... .. ... ... ... ...... 207
Modifying the Coefficients . . . . . . . . . . . . e 208
Storing the Filter to Memory . . . . . . . . . . . . e e e 209
Setting the Real-Time Modulation Filter. . . . . . ... ... ... ... ... . .. . . . . . .. .. ... 210
Multiple Baseband Generator Synchronization. . .. ... ... ... ... . ... ............ 211
Understanding the Master/Slave System . . . . . ... . ... ... ... ... ... ........ 214
Equipment Setup . . . . . . . . L e 215
Configuring the Setup. . . . . . . . . . e 215

Making Changes to the Multiple Synchronization Setup and Resynchronizing the Master/Slave
SYSteIM. . . . . . e e e e e 217

viii

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User's Guide



10

1"

Contents

Understanding Option 012 (LO In/Out for Phase Coherency) with Multiple Baseband Generator

Synchronization . . . . . . . . . . e e e e e 218
Configuring the Option 012 (LO In/Out for Phase Coherency) with MIMO. . ... ... ... 218
Waveform Licensing for Firmware Version > A.01.50. . . . .. ... ... .. ... ... ........ 222
Understanding Waveform Licensing . . . . . .. ... ... . .. . .. . .. 222
Installing an Option N5182-22x or Option NHI182A-25x . . . .. ... ... ... .. ...... 222
Licensing a Signal Generator Waveform . . . . ... ... ... ... . .. ... . ... . ... ... 222
Waveform 5-Pack Licensing (Options 221-229) for Firmware Version < A.01.50. .. ... .. .. 230
Understanding Waveform 5-Pack Licensing . . . ... ... ... ... ... ... ... ....... 230
Installing an Option N5182A-22x Waveform 5-Pack . .. ... ... ... ...... Licensing230
Licensing a Signal Generator Waveform File . . . .. .. ... ... .. ... ... ...... 231
Waveform 5-Pack Licensing Softkeys Overview. . . . . ... ... ... ... ... ......... 231
Using Waveform 5-Pack History . . . .. .. .. .. . . .. . i 237
Waveform 5-Pack Warning Messages . . . . . . . . . o it it e e 241

Adding Real-Time Noise to a Signal (Option 403)

Adding Real-Time Noise to a Dual ARB Waveform. . .. ... ... ................... 243
Eb/No Adjustment Softkeys for Real Time I/Q Baseband AWGN . ... ... .......... 246
Using Real Time I/Q Baseband AWGN . . . . . . . . . . .. . it 249

Real-Time Phase Noise Impairments (Option 432)

Real-Time Phase Noise Impairment. . . . . . .. .. .. .. .. . i 252
The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments . ... ... .. .. 253
Understanding the Phase Noise Adjustments . . . . .. ... ... ... ... . ... . . .. ...... 255
DAC Over-Range Conditions and Scaling . . . ... ... .. .. ... . ... . ... . ... 256

Custom Digital Modulation (Option 431)

Custom Modulation . . . . .. .. .. . e 2568
ARB Custom Modulation Waveform Generator . . ... ... .. ... .. ... ... ...... 258
Using the Arbitrary Waveform Generator . . .. .. ... ... . ... . ... ... 263
Using Predefined Custom TDMA Digital Modulation . . . ... ... ... ... .......... 263
Creating a Custom TDMA Digital Modulation State. . . ... .................... 265
Storing a Custom TDMA Digital Modulation State. . . . .. ... ... ... ............ 267
Recalling a Custom TDMA Digital Modulation State . . ... .................... 269
Creating a Custom Multicarrier TDMA Digital Modulation State . ... ... .......... 270
Storing a Custom Multicarrier TDMA Digital Modulation State . . ... ... .......... 272
Applying Changes to an Active Multicarrier TDMA Digital Modulation State . ... ... .. 272
Using Finite Impulse Response (FIR) Filters in ARB Custom Modulation . . ... ......... 273
Creating a User-Defined FIR Filter Using the FIR Table Editor . ... ... .......... 273

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User's Guide ix



Contents

Modifying a FIR Filter Using the FIR Table Editor. . . . . ... ... ... ... . ... ....... 278
Loading the Default Gaussian FIR File. . . . . . ... . ... ... . .. . .. . . . . ... . .... 279
Modifying the Coefficients . . . . . . . . . . . . . e 280
Storing the Filter to Memory . . . . . . . . . . . e 281

Differential Encoding . . . . . . . . . . e 281
Using Differential Encoding . . . . . . . . . . . . ... e 285

12 Multitone and Two—Tone Waveforms (Option 430)

Creating a Custom Two-Tone Waveform. . . . . ... ... . ... ... . ... ... ... 289

Creating a Custom Multitone Waveform . . . . . . ... .. ... . .. ... 289

Using Two-Tone Modulation . . . . .. .. ... ... e e 290
Two-Tone Modulation Softkeys. . . . . . . .. . . . . . . . 291
Creating a Two-Tone Waveform . . . . . ... .. .. . . ... . . 291
Viewing a Two-Tone Waveform. . . . . .. ... ... . .. . . e 292
Minimizing Carrier Feedthrough . . . . . . . . . . . ... . .. . . . . . 293
Changing the Alignment of a Two-Tone Waveform. . .. ... ... ... ............. 294

Using Multitone Modulation. . . . . . . . . ... . . e 296
Multitone Modulation Softkeys . . . . . . . .. ... .. 296
Initializing the Multitone Setup Table Editor. . . . . .. ... ... .. ... ... ....... 296
Configuring Tone Powers and Tone Phases . . . . ... ... ... ... ... . ... .. ...... 297
Removing a Tone . . . . . . . . . e 297
Generating the Waveform. . . . . . . . . . . ... . e 297
Configuring the RF Output . . . ... . . . . . . . . e 298
Applying Changes to an Active Multitone Signal . . ... ... ... ... ............. 298

13  Working in a Secure Environment

Understanding Memory Types . . . . . . . . e e 301

Removing Data from Memory (Option 006 Only) . . . . . .. ... ... ... . ... .. ... ..... 304
Erase All . . . . . 304
Erase and Overwrite All . . . . . . . . e 305
Erase and Sanitize All . . . . . . . . e 305
Removing Persistent State Information Not Removed During Erase . . . ... ... ... ... 305
Secure Mode . . . . . . . 306
Securing a Nonfunctioning Instrument . . . . . . ... ... ... . ... . 306

Using the Secure Display (Option 006 Only). . . . . ... ... ... ... . ... ... .... 307

14 Troubleshooting

Display . . . . . e 310
The Display is Too Dark to Read . . . ... ... ... . .. . ... ... i 310
The Display Turns Black when Using USB Media. . . . .. ... ... ............... 310

X Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User's Guide



Contents

Signal Generator Lock-Up . . . . . . . .. e 310
RF Output . . . . . . e e 310
No RF Output . . . . . . . . e e 310
Power Supply Shuts Down . . . . . . . . . e 310
No Modulation at the RF Output. . . . . . ... ... . . 310
RF Output Power too Low . . . . . . . . . e 311
Distortion . . . . . . . . 311
Signal Loss While Working with a Spectrum Analyzer. ... ... ... ... .. ......... 311
Signal Loss While Working with a Mixer. . . . . ... ... ... ... . ... . ..., 311
SWEED .« o o o e e 313
Cannot Turn Off Sweep. . . . . . . . . . e 313
Sweep Appears Stalled . . . . . . . . ... 313
Incorrect List Sweep Dwell Time. . . . . . . . . . . . . .. ... . e 313
List Sweep Information is Missing from a Recalled Register. . . . ... ... .. ........ 313
Amplitude Does Not Change in List or Step Sweep. . . . . . .. ... .. ... . ... ..... 313
Internal Media Data Storage. . . . . . . . . . . . . e e 314
Instrument State Saved but the Register is Empty or Contains the Wrong State. . . . . . . 314
USB Media Data Storage . . . . . . . . . . e e e 314
Instrument Recognizes USB Media Connection, but Does Not Display Files . . . . ... ... 314
Preset . . . . 314
The Signal Generator Does Not Respond. . . . . ... ... ... ... ... ... .. . ..... 314
Pressing Preset Performs a User Preset . . .. .. ... ... . ... ... ... ... ... ..... 314
Error Messages . . . . . . . o o i e e e e 315
Error Message Types. . . . . . . o o i i i e e e e e 315
Error Message File . . . . . . . . . 315
Front Panel Tests. . . . . . . . . 316
Self Test OVErVIEW . . . . . . . . . e e e e e e e e e e e e e e e e e e e 317
Licenses . . . . . o e 319
A Time-Based License Quits Working. . . . . . . ... .. ... ... .. .. .. .. . ... ... 319
Cannot Load a Time-Based License. . . . . . . .. . ... . . ... . ... 319
Contacting Agilent Technologies . . . . . . . . . . . . . . . e 319
Returning a Signal Generator to Agilent. . . . . .. .. ... ... .. .. ... .. .. .. .. ... 319

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User's Guide xi



Contents

xii

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User's Guide



Documentation Overview

Installation Guide ¢ Safety Information
* Receiving the Instrument
* Environmental & Electrical Requirements
* Basic Setup
* Accessories
*  Operation Verification
* Regulatory Information

User’s Guide ¢ Signal Generator Overview
* Setting Preferences & Enabling Options
* Basic Operation
* Optimizing Performance
* Using Analog Modulation (Option UNT Only)
¢ Using Pulse Modulation (Option UNU Only)
* Basic Digital Operation - No BBG Option Installed
* Basic Digital Operation (Option 651/652/654)
* Adding Real-Time Noise to a Signal (Option 403)
* Real-Time Phase Noise Impairments (Option 432)
* Custom Digital Modulation (Option 431)
*  Multitone and Two-Tone Waveform Generator (Option 430)
* Working in a Secure Environment
* Troubleshooting

Programming Guide * Getting Started with Remote Operation

* Using IO Interfaces

* Programming Examples

* Programming the Status Register System

* Creating and Downloading Files

* Creating and Downloading User-Data Files

Agilent N5161A/62A/81A/82A/83M MXG Signal Generators User's Guide xiii



SCPI Reference e SCPI Basics
¢ Basic Function Commands
¢ LXI System Commands
* System Commands
* Analog Modulation Commands
¢ Arb Commands
¢ Real-Time Commands
* Nb5161A/62A/81A/82A SCPI Command Compatibility
* N5183A SCPI Command Compatibility

Service Guide *  Troubleshooting
* Replaceable Parts
* Assembly Replacement
¢ Post-Repair Procedures
¢ Safety and Regulatory Information

¢ Instrument History

Key Help? * Key function description
* Related SCPI commands

@Press the Help hardkey, and then the key for which you wish help.
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1 Signal Generator Overview

NOTE

The N5161A/62A MXG ATE is identical to the N5181A/82A with the exception that they do
not have front panel functionality (no display or keys). Instead all functionality is controlled
through SCPI commands or the Web-Enabled MXG. For signal generator functionality, refer
to the Users Guide. For information on the Web-Enabled MXG, refer to the Installation
Guide, the Programming Guide and the SCPI Command Reference.

MXG ATE blank front panel models, N5161A and N5162A signal generators, are part of the
MXG instrument family and unless otherwise indicated, all references to the MXG are
inclusive of the MXG ATE instruments.

Full Option ALB LXI-B feature implementation is only available on instruments with
firmware >A.01.50. A license may be required to enable this feature and to download
firmware versions >A.01.50. For information on new firmware releases, go to
hitp://www.agilent.com/find/upgradeassistant.

e Signal Generator Features on page 2

* Modes of Operation on page 4

*  Front Panel Overview — N5181A/82A MXG on page 5

* Front Panel Overview — N5161A/62A MXG ATE on page 9

* Front Panel Display - N5181A/82A/83A MXG on page 11

* Blank Front Panel Display — N5161A/62A MXG ATE on page 13
* Rear Panel Overview — N5161A/62A1/81A/82A MXG on page 15

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Signal Generator Overview
Signal Generator Features

Signal Generator Features

« N5161A1/N5181A, RF analog models: 100 kHz to 12, 3, or 6 GHz (Options 5012, 503, and 506
respectively)

N5162A1/N5182A7 RF vector models: 100 kHz to 3 or 6 GHz (Options 503, and 506 respectively)

N5183A, Microwave analog model: 100 kHz to 20, 31.8, or 40 GHz (Options 520, 532, and 540
respectively)

¢ electronic attenuator (N6161A/62A/81A/82A only)

* mechanical attenuator (N5183A with Option 1E1 only)

* step & list sweep of frequency, power, or frequency and power
¢ vector models can include waveforms in list sweep

¢ pulse modulation (Option UNU)

¢ narrow pulse modulation (Option UNW)

* analog differential I/Q outputs (vector models, Option 1EL)
* analog modulation: AM, FM, and ®M (Option UNT)

e arbitrary I/Q waveform playback up to 125 MSa/s (vector models, Option 654)
* automatic leveling control (ALC); power calibration

¢  bandwidth control (ALC)

¢ deep amplitude modulation providing greater dynamic range
* enhanced assembly replacement

* external AM, FM, and ®M inputs (Option UNT)

* external analog I/Q inputs (vector models)

¢ flexible reference input, 1 - 50 MHz (Option 1ER)

¢ GPIB, USB 2.0, and 100Base-T LAN interfaces

e improved signal to noise ratio

¢ LO In/Out (Option 012)

* LXI is supported (Option ALB)

¢ Digital Bus I/O compatibility with the PXB

* manual power search (ALC off) (Option 099 and or instruments starting with serial numbers
4818 and greater)

* multiple baseband generator synchronization when using multiple signal generators (master/slave
setup)

¢ narrow pulse modulation (Option UNW)

* phase noise interference (vector models, Option 432)

IThe N5161A/62A - Automated Test Equipment (ATE) have a blank front panel (i.e. no front panel display,
hardkeys or softkeys).

2Optiom 501 is not applicable to the N5161A.
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Signal Generator Overview
Signal Generator Features

¢ SCPI and IVI-COM driver

* user flatness correction

¢ user settable maximum power limit

¢ two channel power meter display

* 10 MHz reference oscillator with external output
¢ 8648/ESG code compatible

¢ real-time modulation filtering

e with Signal Studio Software, vector models can generate 802.11 WLAN, W-CDMA, cdma2000,
1xEV-DO, GSM, EDGE, and more

For more details on hardware, firmware, software, and documentation features and options, refer to
the data sheet shipped with the signal generator and available from the Agilent Technologies website.

1. Open: http:;//www.agilent.com/find/mxg
2. Select the desired model number.

3. In the options and price list section, click price list.

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide 3



Signal Generator Overview
Modes of Operation

Modes of Operation

Depending on the model and installed options, the Agilent MXG signal generator provides up to four
basic modes of operation: continuous wave (CW), swept signal, analog modulation, and digital
modulation.

Continuous Wave

In this mode, the signal generator produces a continuous wave signal. The signal generator is set to
a single frequency and power level. Both the N5161A/81A and N5162A/82A can produce a CW signal.

Swept Signal

In this mode, the signal generator sweeps over a range of frequencies and/or power levels. Both the
N5161A/81A and N5162A/82A provide list and step sweep functionality.

Analog Modulation

In this mode, the signal generator modulates a CW signal with an analog signal. The analog
modulation types available depend on the installed options.

Option UNT provides AM, FM, and ®M modulations. Some of these modulations can be used together.

NOTE The Mod On/Off hardkey and LED functionality are only valid for MXGs with Option UNT
installed.

Refer to 14. Mod On/Off and LED.

Options UNU and UNW provide standard and narrow pulse modulation capability, respectively.

Digital Modulation (N5162A/82A with Options 651, 652, or 654 Only)

NOTE The internal baseband generator speed upgrade Options 670, 671, and 672 are option
upgrades that require Option 651 and 652 to have been loaded at the factory (refer to the
Data Sheet for more information). Any references to 651, 6562, or 654 are inclusive of 671,
672, and 674.

In this mode, the signal generator modulates a CW signal with a arbitrary I/Q waveform. I/Q
modulation is only available on the N5162A/82A. An internal baseband generator (Option 651, 652, or
654) adds the following digital modulation formats:

e Custom Arb Waveform Generator mode can produce a single-modulated carrier or
multiple-modulated carriers. Each modulated carrier waveform must be calculated and generated
before it can be output; this signal generation occurs on the internal baseband generator. Once a
waveform has been created, it can be stored and recalled, which enables repeatable playback of
test signals. To learn more, refer to “Using the Arbitrary Waveform Generator” on page 263.

*  Multitone mode produces up to 64 continuous wave signals (or tones). Like the Two Tone mode,
the frequency spacing between the signals and the amplitudes are adjustable. To learn more, refer
to “Creating a Custom Multitone Waveform” on page 289.
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Signal Generator Overview
Front Panel Overview — N5181A/82A MXG

* Two-tone mode produces two separate continuous wave signals (or tones). The frequency spacing
between the signals and the amplitudes are adjustable. To learn more, refer to Chapter 12,
"Multitone and Two-Tone Waveforms (Option 430)".

e Dual ARB mode is used to control the playback sequence of waveform segments that have been
written into the ARB memory located on the internal baseband generator. These waveforms can
be generated by the internal baseband generator using the Custom Arb Waveform Generator
mode, or downloaded through a remote interface into the ARB memory. To learn more, refer to
“Dual ARB Player” on page 134.

Front Panel Overview — N5181A/82A MXG

5. Arrows and Select 8. Trigger
7.MENUS 11. Preset
4.Numeric 9. Local and and User
1.Host USB 2. Display 3. Softkeys Keypad Cancel/(Esc) 10. Help Preset
6. Page Up
r ~
X1 £ Agilent e
| S &) ™
- o E] ek Q -
o O0O@ 0 & -
o 00O :
o B = 2\ —_
@ 88 QQ °
>\ | 18.Knob 16. 1 Input | ‘1,12' Rli
L utpu
I =

17. Q Input

21. More and LED
15. Page Down
22. Power Switch and LEDs 20.Return 19. Incr Set 14. Mod On/Off and LED

13. RF On/Off and LED

1. Host USB

Connector Type A
USB Protocol 2.0

Use this universal serial bus (USB) to connect a USB Flash Drive (UFD) for data transfer. You can
connect or disconnect a USB device without shutting down or restarting the signal generator. The
instrument also has a rear panel device USB connector (see page 17) used to remotely control the
instrument.

2. Display

The LCD screen provides information on the current function. Information can include status
indicators, frequency and amplitude settings, and error messages. Labels for the softkeys are located
on the right hand side of the display. See also, “Front Panel Display — N5181A/82A/83A MXG” on
page 11.

3. Softkeys

A softkey activates the function indicated by the displayed label to the left of the key.
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4. Numeric Keypad

The numeric keypad comprises the 0 through 9 hardkeys, a decimal point hardkey, a minus sign
hardkey, and a backspace hardkey. See “Entering and Editing Numbers and Text” on page 43.

5. Arrows and Select

The Select and arrow hardkeys enable you to select items on the signal generator’s display for editing.
See “Entering and Editing Numbers and Text” on page 43.

6. Page Up

In a table editor, use this hardkey to display a previous page. See “Example: Using a Table Editor” on
page 44. When text does not fit on one page in the display area, use this key in conjunction with the
Page Down key (page 7) to scroll text.

7. MENUS

These hardkeys open softkey menus that enable you to configure instrument functions or access
information.

See page 133 See page 77

Reserved for See page 63
future use.

So6 page 45H Mode ] {A.M ﬂ File ] [Ermr %See bage 75
Aux FMi Save Ltility

See page 45“ Fotn { i 3 ( [ %See page 25
lia Pulse | [ Recall

See page 48“ [ { ﬁ-‘ [ H—See page 42

See page 123 See page 70

Active only on
vector models.

8. Trigger

When trigger mode is set to Trigger Key, this hardkey initiates an immediate trigger event for a
function such as a list or step sweep.

9. Local Cancel/(Esc)

This hardkey deactivates remote operation and returns the signal generator to front panel control,
cancels an active function entry, and cancels long operations (such an IQ calibration).
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Front Panel Overview — N5181A/82A MXG

10. Help

Use this key to display a description of any hardkey or softkey. See “Viewing Key Descriptions” on
page 42.

11. Preset and User Preset

These hardkeys set the signal generator to a known state (factory or user-defined). See “Presetting
the Signal Generator” on page 42.

12. RF Output

Connector Standard: female Type-N
Option 1IEM: Rear panel female Type-N
Impedance: 50 Q

Damage Levels 50 Vdc, 2 W maximum RF power

13. RF On/Off and LED

This hardkey toggles the operating state of the RF signal present at the RF OUTPUT connector. The
RF On/0ff LED lights when RF output is enabled.

14. Mod On/Off and LED

This hardkey enables or disables the modulation of the output carrier signal by an active modulation
format. This hardkey does not set up or activate a format (see “Modulating the Carrier Signal” on
page 61).

The MOD ON/OFF LED lights when modulation of the output is enabled.

NOTE The Mod On/Off hardkey and LED functionality are only valid for MXGs with Option UNT
installed.

15. Page Down

In a table editor, use this hardkey to display the next page. See “Example: Using a Table Editor” on
page 44. When text does not fit on one page in the display area, use this key in conjunction with the
Page Up key (page 6) to scroll text.

16. I Input (vector models only)

Connector Type: female BNC Impedance: 50 Q
Signal An externally supplied analog, in-phase component of I/Q modulation.
The signal level is /.2 +Q2 = 0.5 V5 for a calibrated output level.

Damage Levels 1 Vins

See also, “I/Q Modulation” on page 192.
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17. Q Input (vector models only)

Connector Type: female BNC Impedance: 50 Q
Signal An externally supplied analog, quadrature-phase component of I/Q modulation.

The signal level is |2 +Q2 = 0.5 V,,s for a calibrated output level.

Damage Levels 1 Vins

See also, “I/Q Modulation” on page 192.

18. Knob

Rotating the knob increases or decreases a numeric value, or moves the highlight to the next digit,
character, or item in a list. See also, “Front Panel Knob Resolution” on page 28.

19. Incr Set

This hardkey enables you to set the increment value of the currently active function. The increment
value also affects how much each turn of the knob changes an active function’s value, according to
the knob’s current ratio setting (see “Front Panel Knob Resolution” on page 28).

20. Return

This hardkey enables you to retrace key presses. In a menu with more than one level, the Return key
returns to the prior menu page.

21. More and LED

When a menu contains more softkey labels than can be displayed, the More LED lights and a More
message displays below the labels. To display the next group of labels, press the More hardkey.

22. Power Switch and LEDs

This switch selects the standby mode or the power on mode. In the standby position, the yellow LED
lights and all signal generator functions deactivate. The signal generator remains connected to the
line power, and some power is consumed by some internal circuits. In the on position, the green LED
lights and the signal generator functions activate.
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Front Panel Overview —N5161A/62A MXG ATE

1.HostUSB
(o B ]
1 Agilent Technologies MXG ATE Vector Signal Generator L OT——
Ns162A 100ktHz3 GHz
-
o i
6. LAN Reset
2. Power Switch and LEDs 3.LAN 5. ERROR

4.1588

Nb5161A/62A MXG ATE Front Panel Functions

The MXG ATE is identical to an MXG with a front panel display, except that the front panel,
hardkeys and softkeys functionality are only available through SCPI commands or the Web-Enabled
MXG. For information on the Web-Enabled MXG, refer to the Installation Guide, the Programming
Guide and the SCPI Command Reference.

Functions unique to the MXG ATE:
e LAN LED (page 10).

* 1588 LED (page 10).

* ERROR LED (page 10).

e LAN Reset Hardkey (page 10).

For more information, refer to the Service Guide.

1. Host USB

Connector Type A
USB Protocol 2.0

Use this universal serial bus (USB) to connect a USB Flash Drive (UFD) for data transfer. You can
connect or disconnect a USB device without shutting down or restarting the signal generator. The
instrument also has a rear panel device USB connector (see page 17) used to remotely control the
instrument.
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2. Power Switch and LEDs

This switch selects the standby mode or the power on mode. In the standby position, the yellow LED
lights and all signal generator functions deactivate. The signal generator remains connected to the
line power, and some power is consumed by some internal circuits. In the on position, the green LED
lights and the signal generator functions activate.

3. LAN LED

The LAN LED is used to indicate the LAN status.

e If the LED is off, the LAN is down.

e If the LED is blinking, the LAN is being configured (1.2 second duty cycle).

* A 400ms duty cycle indicates the instrument has been placed into LAN Identify mode. (Refer to
:INPut : LAN[:SET] : IDENtifier command).

e If the LED is solidly lit, the LAN is up and functional.
e If the LED fails to function, refer to the Service Guide.

4. 1588 LED

The 1588 LED indicates when the instrument is locked to an external 1588 clock.

e If the 1588 green LED is on, a 1588 signal has been detected on the TRIG OUT BNC on the rear
panel.

e If the 1588 green LED is off, no 1588 signal is detected on the TRIG OUT BNC on the rear panel.
e If the LED fails to function, refer to the Service Guide.

5. ERROR LED

The ERROR LED indicates when there are unread errors in the error queue.
e If Auto reboot is disabled, the LED will blink when an exception occurs during power up.

e If the LED fails to function, refer to the Service Guide.

6. LAN Reset Hardkey

NOTE This hardkey is enabled for fail-safe and diagnostic mode and should rarely be used. If the
LAN Reset hardkey has been pressed and then the power is cycled on the instrument, the
web-server will be enabled after reboot.

The LAN Reset is used to access the diagnostics mode during power up.
¢ Refer to the SCPI Command Reference for equivalent remote commands.

e If the LAN Reset fails to function, refer to the Service Guide.
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Front Panel Display — N5181A/82A/83A MXG

1. Active Function Area 2. Frequency Area 3. Annunciators 4. Amplitude Area

FREQUERCY 6.000 000 000 00 &x= ““P_Liwa']z.oo dbn

Scroll Bar

If there is more
text than can be
displayed on one
screen, a scroll
bar appears here.
Use the Page Up
and Page Down
keys to scroll
through the text.

5. Error Message Area 6. Text Area 7. Softkey Label Area

1. Active Function Area

This area displays the currently active function. For example, if frequency is the active function, the
current frequency setting appears. If the currently active function has an increment value associated
with it, that value also appears.

2. Frequency Area

This area displays the current frequency setting.

3. Annunciators

Annunciators show the status of some of the signal generator functions, and indicate error
conditions. An annunciator position may be used by more than one annunciator; in this case, only
one of the functions sharing a given position can be active at a given time.

This annunciator appears when...

M Phase modulation is on. If you turn frequency modulation on, the FM annunciator replaces ®M.

ARB The ARB generator is on.

ALC OFF The ALC circuit is disabled. The UNLEVEL annunciator appears in the same position if the ALC is enabled and
is unable to maintain the output level.

AM Amplitude modulation is on.

ARMED A sweep has been initiated and the signal generator is waiting for the sweep trigger event.

ATTNHOLD The attenuator hold function is on. When this function is on, the attenuator is held at its current setting.

AWGN Real Time I/Q Baseband additive white Gaussian noise is on.
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This annunciator appears when...

BBG DAC A DAC overflow is occurring, adjust the runtime scaling adjust until the BBG DAC annunciator turns off.
Another annunciator, UNLOCK, appears in the same position and has priority over the BBG DAC annunciator
(see UNLOCK, below).

DETHTR The ALC detector heater is not up to temperature. To meet ALC specifications the heater must be at
temperature.

DIGBUS The digital bus is in use.

DIGMOD Custom Arb waveform generator is on.

ERR An error message is placed in the error queue. This annunciator does not turn off until you either view all of
the error messages or clear the error queue (see “Reading Error Messages” on page 75).

EXTREF An external frequency reference is applied.

FM Frequency modulation is on. If you turn phase modulation on, the ®M annunciator replaces FM.

I/Q 1/Q vector modulation is on.

L The signal generator is in listener mode and is receiving information or commands over the GPIB, USB, or
VXI-11/Sockets (LAN) interface.

M-TONE Multitone waveform generator is on.

MULT A frequency multiplier is set (see “Setting a Frequency Multiplier” on page 111).

OFFS An output offset is set (see “Setting an Output Offset” on page 109).

PN Phase noise interference is on.

PULSE Pulse modulation is on.

R The signal generator is remotely controlled over the GPIB, USB, or VXI-11/Sockets (LAN) interface. When the
signal generator is in remote mode, the keypad is locked out. To unlock the keypad, press Local.

REF An output reference is set (see “Setting an Output Reference” on page 110).

RF OFF The signal generator’s RF Output is not enabled.

S The signal generator has generated a service request (SRQ) over the GPIB, USB, or VXI-11/Sockets (LAN)
interface.

SWEEP The signal generator is currently sweeping in list or step mode.

SWMAN The signal generator is in manual sweep mode.

T The signal generator is in talker mode and is transmitting information over the GPIB, USB, or VXI-11/Sockets
(LAN) interface.

T-TONE Two-Tone waveform generator is on.

UNLEVEL The signal generator is unable to maintain the correct output level. This is not necessarily an indication of

instrument failure; unleveled conditions can occur during normal operation. Another annunciator, ALC OFF,
appears in the same position when the ALC circuit is disabled (see ALC OFF, above).

UNLOCK Any of the phase locked loops cannot maintain phase lock. To determine which loop is unlocked, examine the
error messages (see “Reading Error Messages” on page 75).

WINIT The signal generator is waiting for you to initiate a single sweep.

4. Amplitude Area

This area displays the current output power level setting (If the RF Output is off, this area is greyed
out).

b. Error Message Area

This area displays abbreviated error messages. If multiple messages occur, only the most recent
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message remains displayed. See “Reading Error Messages” on page 75.

6. Text Area
This area displays signal generator status information, such as the modulation status, and other

information such as sweep lists and file catalogs. This area also enables you to perform functions
such as managing information (entering information, and displaying or deleting files).

1. Softkey Label Area

This area displays labels that define the function of the softkeys located immediately to the right of
the display. Softkey labels change, depending on the function selected.

Blank Front Panel Display — N5161A/62A MXG ATE

N5161A/62A MXG ATE — Web Enabled Display

The MXG ATE only has display information available through a LAN connection to the Web Server
(“11. LAN” on page 17). For more information on the Web-Enabled MXG, refer to Programming
Guide.

Annunciators

NOTE On the N5161A/62A, the following listing of annunciators are only displayed and visible
through the Web-Enabled MXG. Refer to Programming Guide, “Using the Web Browser”.

Annunciators show the status of some of the signal generator functions, and indicate error
conditions. An annunciator position may be used by more than one annunciator; in this case, only
one of the functions sharing a given position can be active at a given time.

This annunciator appears when...

M Phase modulation is on. If you turn frequency modulation on, the FM annunciator replaces ®M.

ARB The ARB generator is on.

ALC OFF The ALC circuit is disabled. The UNLEVEL annunciator appears in the same position if the ALC is enabled and
is unable to maintain the output level.

AM Amplitude modulation is on.

ARMED A sweep has been initiated and the signal generator is waiting for the sweep trigger event.

ATTNHOLD The attenuator hold function is on. When this function is on, the attenuator is held at its current setting.

BBG DAC A DAC overflow is occurring, adjust the runtime scaling adjust until the BBG DAC annunciator turns off.

Another annunciator, UNLOCK, appears in the same position and has priority over the BBG DAC annunciator
(see UNLOCK, below).

DETHTR The ALC detector heater is not up to temperature. To meet ALC specifications the heater must be at
temperature.

AWGN Real Time I/Q Baseband additive white Gaussian noise is on.

DIGBUS The digital bus is in use.

DIGMOD Custom Arb waveform generator is on.
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This annunciator appears when...

ERR An error message is placed in the error queue. This annunciator does not turn off until you either view all of
the error messages or clear the error queue (see “Reading Error Messages” on page 75).

EXTREF An external frequency reference is applied.

FM Frequency modulation is on. If you turn phase modulation on, the ®M annunciator replaces FM.

I/Q 1/Q vector modulation is on.

L The signal generator is in listener mode and is receiving information or commands over the GPIB, USB, or
VXI-11/Sockets (LAN) interface.

M-TONE Multitone waveform generator is on.

MULT A frequency multiplier is set (see “Setting a Frequency Multiplier” on page 111).

OFFS An output offset is set (see “Setting an Output Offset” on page 109).

PN Phase noise interference is on.

PULSE Pulse modulation is on.

R The signal generator is remotely controlled over the GPIB, USB, or VXI-11/Sockets (LAN) interface. When the
signal generator is in remote mode, the keypad is locked out. To unlock the keypad, press Local.

REF An output reference is set (see “Setting an Output Reference” on page 110).

RF OFF The signal generator’s RF Output is not enabled.

S The signal generator has generated a service request (SRQ) over the GPIB, USB, or VXI-
11/Sockets (LAN) interface.

SWEEP The signal generator is currently sweeping in list or step mode.

SWMAN The signal generator is in manual sweep mode.

T The signal generator is in talker mode and is transmitting information over the GPIB, USB, or VXI-11/Sockets
(LAN) interface.

T-TONE Two-Tone waveform generator is on.

UNLEVEL The signal generator is unable to maintain the correct output level. This is not necessarily an indication of
instrument failure; unleveled conditions can occur during normal operation. Another annunciator, ALC OFF,
appears in the same position when the ALC circuit is disabled (see ALC OFF, above).

UNLOCK Any of the phase locked loops cannot maintain phase lock. To determine which loop is unlocked, examine the
error messages (see “Reading Error Messages” on page 75).

WINIT The signal generator is waiting for you to initiate a single sweep.
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Rear Panel Overview — N5161A"/62A1/81A/82A MXG

Digital Modulation Connectors (Vector Models Only) on page 18 1. AC Power Receptacle

; Gour exto__ evewri  partai . b e X

Option 1EM ) 7.TRIG OUT
only 6.TRIGIN
See page 7
2. SWEEP OUT 5.PULSE 8.REF IN 12. Device USB

1. AC Power Receptacle

The AC power cord receptacle accepts a three-pronged AC power cord that is supplied with the
signal generator. For details on line setting requirements and the power cord, see the
Installation Guide.

CAUTION To avoid the loss of data, GPIB settings, or current user instrument states that have not
been permanently saved to non-volatile memory, the MXG should always be powered
down either via the MXG's front panel power button or the appropriate SCPI command.
MXG's installed in rack systems and powered down with the system rack power switch
rather than the MXG's front panel switch display a Error -310 due to the MXG not being
powered down correctly.

2. SWEEP OUT
Connector female BNC Impedance <1 Q
Can drive 2 kQ.
Signal Voltage range: 0 to +10 V, regardless of sweep width

In swept mode: beginning of sweep = 0 V; end of sweep = +10 V
In CW mode: no output

This is a multiple use connector. For signal routing selections, see pages 49 and 123.

IThe N5161A and N5162A are only available with Option 1EM.
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3. AM

Connector
Signal

Damage Levels

4. FM

Connector
Signal

Damage Levels

5. PULSE

Connector
Signal

Damage Levels

6. TRIG IN

Connector

Signal

Damage Levels

female BNC Impedance nominally 50 Q
An externally supplied £1 vy signal that produces the indicated depth.

5 Vyms and 10 V,,

female BNC Impedance nominally 50 Q
An externally supplied £1 vy signal that produces the indicated deviation

5 Vips and 10 V,

female BNC
Externally supplied: +1 V = on; 0 V = off
5 Vips and 10 V,

Impedance nominally 50 Q

female BNC

An externally supplied TTL or CMOS signal for triggering operations, such as point to point
in manual sweep mode or an LF sweep in external sweep mode.
Triggering can occur on either the positive or negative edge.

<-0.5 and >2+5.5 V

Impedance high Z

7. TRIG OUT
Connector female BNC Impedance nominally 50 Q
Signal A TTL signal that is high at the start of a dwell sequence, or when waiting for the point trigger in

manual sweep mode.
It is low when the dwell is over, or when the point trigger is received.
The logic polarity can be reversed.

This is a multiple use connector. For signal routing selections, see pages 49 and 123.
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8. REFIN
Connector female BNC Impedance nominally 50 Q
Signal An externally supplied —3.5 to +20 dBm signal from a timebase reference that is within £1 ppm.

In its factory default mode, the signal generator can detect a valid reference signal at this connector
and automatically switch from internal to external reference operation. See “Presetting the Signal
Generator” on page 42. With Option 1ER (flexible reference input), you must explicitly tell the signal
generator the external reference frequency you wish to use; enter the information through the front
panel or over the remote interface.

9. 10 MHz OUT

Connector female BNC Impedance nominally 50 Q
Signal A nominal signal level greater than 4 dBm.
10. GPIB

This connector enables communication with compatible devices such as external controllers, and is
one of three connectors available to remotely control the signal generator (see also 11. LAN and
12. Device USB).

11. LAN

The signal generator supports local area network (LAN) based communication through this connector,
which enables a LAN-connected computer to remotely program the signal generator. The LAN

interface supports LXI; it does not support auto-MDIX. The signal generator is limited to 100 meters
on a single cable (100Base-T). For more information on the LAN, refer to the Programming Guide.

12. Device USB

Connector Mini-B
USB Protocol Version 2.0

Use this universal serial bus (USB) connector to connect a PC to remotely control the signal
generator.
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Digital Modulation Connectors (Vector Models Only)

1 0UT, @ OUT, | OUT, Q OUT

Connector Type: female BNC Impedance: 50 Q
DC-coupled
Signal
I OUT The analog, in-phase component of I/Q modulation from the internal baseband generator.
Q OuT The analog, quadrature-phase component of I/Q modulation from the internal baseband
generator.
| ouT Used in conjunction with the I OUT connector to provide a balanced® baseband stimulus.
C_J ouT Used in conjunction with the Q OUT connector to provide a balanced?® baseband stimulus.
Damage Levels > 1 Vrms DC Origin Offset typically <10 mV

Output Signal Levels into a 50 Q Load
* 0.5 Vpy, typical, corresponds to one unit length of the I/Q vector
* 0.69 Vok (2.84 dB), typical, maximum crest factor for peaks for n/4 DQPSK, alpha = 0.5
* 0.71 Vpk (3.08 dB), typical, maximum crest factor for peaks for ©/4 DQPSK, alpha = 0.35

* Typically 1 V,_, maximum

@Balanced signals are signals present in two separate conductors that are symmetrical relative to ground, and are opposite in polarity
(180 degrees out of phase).

EXT CLK
Connector female BNC Impedance nominally 50 Q
Signal An externally supplied TTL or CMOS bit clock signal where the rising edge aligns with the

beginning data bit.
The falling edge is used to clock external signals.
This signal is used with digital modulation applications.

Damage Levels < -4 and > +8 V. Maximum Clock Rate 50 MHz
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EVENT 1

Connector

Signal

Damage Levels

PAT TRIG

Connector

Signal

Damage Levels

Signal Generator Overview
Rear Panel Overview — N516TA/62A'/81A/82A MXG

female BNC Impedance: nominally 50

A pulse that can be used to trigger the start of a data pattern, frame, or timeslot.

Adjustable to * one timeslot; resolution = one bit

Markers

Each Arb-based waveform point has a marker on/off condition associated with it.

Marker 1 level = +3.3 V. CMOS high (positive polarity selected); -3.3 V CMOS low (negative polarity
selected).

Output on this connector occurs whenever Marker 1 is on in an Arb-based waveform (see “Using
Waveform Markers” on page 149).

<-4 and > +8 V

female BNC Impedance: nominally 50 €

A TTL/CMOS low to TTL/CMOS high, or TTL/CMOS high to TTL/CMOS low edge trigger.
The input to this connector triggers the internal digital modulation pattern generator to start
a single pattern output or to stop and re-synchronize a pattern that is being continuously
output. To synchronize the trigger with the data bit clock, the trigger edge is latched, then
sampled during the falling edge of the internal data bit clock.

This is the external trigger for all ARB waveform generator triggers.

Minimum Trigger Input Pulse (high or low) = 100 ns
Width

Minimum Trigger Delay (trigger edge to first bit of frame) = 1.5 to 2.5 bit clock periods
<-4 and > +8 V

DIGITALBUS 1/0

This is a proprietary bus used by Agilent Technologies signal creation software. This connector is not
operational for general purpose use. Signals are present only when a signal creation software option
is installed (for details, refer to http:;//www.agilent.com/find/signalcreation).

NOTE The MXG’s Digital BUS I/O connector can be used for enabling operation with the Agilent
Technologies N5106A PXB MIMO Receiver Tester.
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AUX 1/0

Pin 1 =Event 1
Pin 2 = Event 2
Pin 3 = Event 3
Pin4 = Event 4
25 1 Pin 5 = Sample Rate Clock Out

View looking into rear panel female 50—pin Pin 6 = Patt Trig 2

50 26 Pins 7-25 = Reserved*

Pins 26-50 = Ground
The AUX I/O connector is a shielded .050 series board mount connector.

Event 1, 2, 3, and 4 (pins 1 — 4)
A pulse that can be used to trigger the start of a data pattern, frame, or timeslot.
Adjustable to * one timeslot; resolution = one bit

*Future Capability

Markers

Each Arb-based waveform point has a marker on/off condition associated with it.

Marker level = +3.3 V CMOS high (positive polarity selected); -3.3 V CMOS low (negative polarity
selected).

Sample Rate Clock Out (pin 5)
This output is used with an internal baseband generator. This pin relays a CMOS bit clock signal for synchronizing serial data.
Damage levels:< -0.5 and > +5.5 V.

Patt Trig 2 (pin 6)

A TTL/CMOS low to TTL/CMOS high, or TTL/CMOS high to TTL/CMOS low edge trigger.

The input to this connector triggers the internal digital modulation pattern generator to start a single pattern output or to stop and
re—synchronize a pattern that is being continuously output.

To synchronize the trigger with the data bit clock, the trigger edge is latched, then sampled during the falling edge of the internal data bit
clock.

This is an external trigger for all ARB waveform generator triggers. Minimum pulse width = 100 ns. Damage levels: < -0.5 and > +5.5 V.
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Rear Panel Overview — N5183A MXG

13. Z AXIS OUTPUT
14. ALC INPUT

1. AC Power Receptacle

Option 1EM 4.FM 7.TRIGOUT 10.GPIB
only 3.AM 6. TRIGIN 9.10 MHz OUT 11. LAN
See page 7
2. SWEEP OUT 5.PULSE 8.REF IN 12. Device USB

1. AC Power Receptacle

The AC power cord receptacle accepts a three-pronged AC power cord that is supplied with the
signal generator. For details on line setting requirements and the power cord, refer to the
Installation Guide.

CAUTION To avoid the loss of data, GPIB settings, or current user instrument states that have not
been permanently saved to non-volatile memory, the MXG should always be powered
down either via the MXG's front panel power button or the appropriate SCPI command.
MXG's installed in rack systems and powered down with the system rack power switch
rather than the MXG's front panel switch display a Error -310 due to the MXG not being
powered down correctly.

2. SWEEP OUT
Connector female BNC Impedance <1 Q
Can drive 2 kQ.
Signal Voltage range: 0 to +10 V, regardless of sweep width

In swept mode: beginning of sweep = 0 V; end of sweep = +10 V
In CW mode: no output

This is a multiple use connector. For signal routing selections, see pages 49 and 123.
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3. AM

Connector
Signal

Damage Levels

4. FM

Connector
Signal

Damage Levels

5. PULSE

Connector
Signal

Damage Levels

6. TRIG IN

Connector

Signal

Damage Levels

female BNC Impedance nominally 50 Q
An externally supplied £1 vy signal that produces the indicated depth.

5 Vyms and 10 V,,

female BNC Impedance nominally 50 Q
An externally supplied £1 vy signal that produces the indicated deviation

5 Vips and 10 V,

female BNC
Externally supplied: +1 V = on; 0 V = off
5 Vips and 10 V,

Impedance nominally 50 Q

female BNC

An externally supplied TTL or CMOS signal for triggering operations, such as point to point
in manual sweep mode or an LF sweep in external sweep mode.
Triggering can occur on either the positive or negative edge.

<-0.5 and >2+5.5 V

Impedance high Z

7. TRIG OUT
Connector female BNC Impedance nominally 50 Q
Signal A TTL signal that is high at the start of a dwell sequence, or when waiting for the point trigger in

manual sweep mode.
It is low when the dwell is over, or when the point trigger is received.
The logic polarity can be reversed.

This is a multiple use connector. For signal routing selections, see pages 49 and 123.

8. REFIN

Connector

Signal

female BNC

An externally supplied —3.5 to +20 dBm signal from a timebase reference that is within =1 ppm.

Impedance nominally 50 Q

In its factory default mode, the signal generator can detect a valid reference signal at this connector
and automatically switch from internal to external reference operation. See “Presetting the Signal
Generator” on page 42. With Option 1ER (flexible reference input), you must explicitly tell the signal
generator the external reference frequency you wish to use; enter the information through the front
panel or over the remote interface.
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9. 10 MHz OUT

Connector female BNC Impedance nominally 50 Q
Signal A nominal signal level greater than 4 dBm.
10. GPIB

This connector enables communication with compatible devices such as external controllers, and is
one of three connectors available to remotely control the signal generator (see also 11. LAN and
12. Device USB).

11. LAN

The signal generator supports local area network (LAN) based communication through this connector,
which enables a LAN-connected computer to remotely program the signal generator. The LAN

interface supports LXI; it does not support auto-MDIX. The signal generator is limited to 100 meters
on a single cable (100Base-T). For more information on the LAN, refer to the Programming Guide.

12. Device USB

Connector Mini-B
USB Protocol Version 2.0

Use this universal serial bus (USB) connector to connect a PC to remotely control the signal
generator.

13. Z AXIS OUTPUT

This female BNC connector supplies a +5 V (nominal) level during retrace and band-switch intervals
of a step or list sweep. During step or list sweep, this female BNC connector supplies a -5 V
(nominal) level when the RF frequency is at a marker frequency and intensity marker mode is on.
This signal is derived from an operational amplifier output so the load impedance should be greater
than or equal to 5 kohms.
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14. ALC INPUT

This input connector is used for negative external detector leveling.
Connector female BNC Impedance nominally 100 kQ

Signal -0.2 mV to -0.5 V

Damage Levels -12to 1V
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2 Settin

g Preferences & Enabling Options

NOTE

For the N5161A/62A MXG ATE the softkey menus and features mentioned in this guide are

only available through the Web-Enabled MXG or SCPI commands. For information on the
Web- Enabled MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI
Command Reference.

The Utility menu provides access to both user and remote operation preferences, and to the menus in
which you can enable instrument options.

IIHIIIII

Utility 7

I/0 Configm

Remote Operation

GPIB Address and Remote Language on page 30

Configuring the LAN Interface on page 31

Enabling LAN Services: “Browser,” “Sockets,” “VXI-11" and “LX|-B” on page 32
Configuring the Remote Languages on page 33

1

User Preferences

Instrument

Ad justment.s®

Front Panel Knob Resolution on page 28

Setting Time and Date on page 28

Displaun

Reference Oscillator Tune on page 29

T

Fower On/,|
Freset

Display Settings on page 26

Instrument InfoM

fore 1 of 2

Y

Utility

L¥XI-EM

Power On and Preset on page 27

/]

Enabling an Option on page 37

Upgrading Firmware on page 29

Getting Started With LXI on page 117

Servicer

Hardware Assembly Installation and Removal Softkeys on page 39

e
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User Preferences

User Preferences

From the Utility menu, you can set the following user preferences:

¢ Display Settings, below

e Power On and Preset on page 27

¢ Front Panel Knob Resolution on page 28

Display Settings

Utility > Display

DisElag ?

Erightness -
100

See also, Using the Secure Display (Option 006 Only) on page

/Range:15 to 100

/Range: 35 to 55

Contrast”]
LS

Screen Saver
an

Light Only: turns the display light off, leaving the text visible at a low intensity.

Screen Saver
ode
(Light Onlu)

Light & Text: turns the display light and the text off.
If the display remains unchanged for long periods of time, use this mode to
prevent the text from burning the display.

Screen

Saver
Delau: 1 hr

fMore 1 of 2

Range: 1to 12 hours, in 1 hour increments

= Palette Select
___Display 7/ i Dark text on a light
Select EDlEr“ Bright Color §— background
ale M » .
(Bright Color) .
- When on, commands executed through Dark Color — Light text on a dark
Upaate IRFEMOte L —the remote control bus update the signal background.
_ generator display accordingly.
Act ivate Manochrome +—— Bright without color
Secure Display \page 306
Activate "““\/“‘\\
Restricted
Display

e

For details on each key, use key help
as described on page 42.

NOTE With both brightness and contrast set to minimum, the display may be too dark to see the
softkeys. If this happens, use the figure above to locate the brightness and contrast softkeys
and adjust their values so that you can see the display.
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Power On and Preset

Pouerup Type #
Utility > Power On/Preset >

Pouerup Preset s Last
Fouer Dn' >
(et Preset

Preset Language |
(5CPI

User

s T .

Festore Sustem
Settinas Lo
Default Values

Select the GPIB language desired after a preset.

R See also, the Programming Guide and the SCPI Command
estores persistent settings Reference.
Shng u?:g:ftgngiSI;)OWGF Available only when 8648 is either the selected preset language or
toytheiyr ?actor)‘/ defaults the selected remote language (see page 30).

' \i

Restore System

Confirm Restore
Sus Settings to
Default Values

\4“-*N‘-‘--

*Caution

To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to
non-volatile memory, the MXG should always be powered down either via the MXG's front panel power button or the
appropriate SCPI command.MXG's installed in rack systems and powered down with the system rack power switch
rather than the MXG's front panel switch display a Error -310 due to the MXG not being powered down correctly.

Note
To define a user preset, set the instrument up as desired and press User Preset > Save User Preset.
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Front Panel Knob Resolution

— Makes the increment value of the current function the active entry.

Utility >
| Adj > . . .
nstrument Adjustments The increment value and the step/knob ratio determine how much each

turn of the knob changes the active function value.

__Adjustments /| For example, if the increment value of the active function is 10 dB and the
( Step/Knob HEBH step/knob ratio is 50 to 1, each turn of the knob changes the active
\ function by 0.2 dB (1/50th of 10 dB).

Time/Dated—— page 28. i .
To change the amount for each turn of the knob, modify the increment

Ref Dscill%ﬁg__ page 29. value, the step/knob ratio, or both.
8]
Execute Executes the Alc Modulator Bias Adjustment. When using
ALC Modulat: F—,
Bias ﬂd?ugtﬁeﬁg the ALC in open loop mode, this compensates for open loop

power drift due to temperature and humidity.

SCPI Commands: .
. ibration: . . For details on each key, use key help
:ﬂore 1 of 2 :CALibration:ALC:MODulator:BIAS as described on page 42.

Setting Time and Date

Time Date
Time/Date
Utility > aff
CAUTION Changing the time or date can Instrument Adjustments > Ll 4
adversely affect the signal Step/Knob Ratio DoEﬁet
generator’s ability to use time—based 50/1
licenses, even if a time—based et Time
license is not installed. Time/Daterg—
Set Date
The signal generator’s firmware tracks the ——

time and date, and uses the latest time ‘\'\A\/\‘

and date as its time/date reference point.

Setting the Time or Date Forward

If you set the time or date forward, be aware that you are using up any installed time-based licenses,
and that you are resetting the signal generator’s time/date reference point. When you set a new time
or date that is later than the signal generator’s current reference point, that date becomes the new
reference point. If you then set the date back, you run the risk described in the next section.

Original time/date reference point New time/date reference point

—a

Time

Setting the Time or Date Backward

When you set the time back, the signal generator notes that the time has moved back from the
reference point. If you set the time back more a few hours, you disable the signal generator’s ability
to use time-based licenses, even if there is no license installed at the time that you set the time
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Upgrading Firmware

back. In this case, you can re-enable the signal generator’s ability to use time-based licenses by
moving the clock forward to the original time or simply waiting that length of time.

Reference Oscillator Tune
Utility > Instrument Adjustments >

Adjustments 7| Tunes the internal VCTXCO oscillator frequency.
SRR (g The user value offsets the factory tuned value (the value is added to the
factory calibrated DAC value). The tune value of 0 sets the factory
calibrated value.

Time/Dater .
The range; —8192 to 8192, can be set by using the front panel keypad,
" Ref usciu?tor\ knob or remote command.
une
N1/
For details on each key, use key help See also the SCPI Command Reference.

as described on page 42.

Upgrading Firmware

For information on new firmware releases, go to http:/www.agilent.com/find/upgradeassistant.
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Remote Operation Preferences

For details on operating the signal generator remotely, refer to the Programming Guide.

GPIB Address and Remote Language

IIIIiII'

Utility

GPTE Setup

GPIB Address
19

I1/0 Config

I/0 Configm

GPIE Setupm

-

Instrument
Ad.iustments® LAN SetupH page 31
Displau LER Sergégﬁgr page 32
Paower On/, Remote Language, | Select the desired language.
Freset (5CPID

Instrument Infow

This setting is not persistent and is cleared by performing a

Hore 1 of 2 %

NOTES

M

instrument Preset. In most cases, it is best to use Utility >
Power On/Preset > Language for a permanent language
change. See page 33.

USB is also available. It is not shown in the menu because it requires no configuration.

For details on using the instrument remotely, see the Programming Guide.

For details on each key, use key help as described on page 42.
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Setting Preferences & Enabling Options
Remote Operation Preferences

Utility > 1/0 Config LAH Config

> E 7 Auto
LAH Setu (DHCP /ALt a-IP )

E E Hostname

I1/0 Confi iy
GPIE Setups AP

Config Tupe

Lo
LAN Setups MBI

Manual Config

ettings”
LAM Services Manual

H— page 32.
SEER Advanced
el MM

Remote Language’
gsErm) Proceed With
Reconf iourat ion

M

Y

Manual Settings F

IP Address
141.121.95.170

Subnet Mask
0.0.0.0

Default Gatewau
141.121.88.1

OMS _ Serwver
255,255, 255,255

OWS Serwver
Qverride

Haming Services

0Off

Dunamic_OKS
\J OfF
Adv Settings -
y . NetBIOS Namin ICP Keep Alive
Apply Settings 7 Domain Name feF Ml TCP Keep Alive
E?HF%r‘m Ehanﬁ off
ELHOrK W1 i morkS /ONS=S0
restart) ESRTESHQH oFF TCP Kee?_ﬂliug
lﬁ 1menLl
L 0.0 sec
Ly btitn,, gttt Dunamic Hostname,
Services
NOTES
Use a 100Base-T LAN TCF Keep Alive,
cable to connect the signal generator to the LAN. Setup _
Confirm
Use a crossover cable to connect the signal DHEgzg.igeggié Adu_Setlings 7
generator directly to a PC. T or T — Ee%%qr‘e LﬁN _
ore 1 o > Sl 12 7| confirm Restore
For details on using the instrument remotely, Lefalilthvaltes LAN Settings Lo
Listed in the Default Values

refer to the Programming Guide and to
www.agilent.com and search on FAQs: Hardware
Configurations and Installation for the Agilent
MXG.

Programming Guide —

For details on each key, use key help as described on page 42.

-\fM
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Enabling LAN Services: “Browser,” “Sockets,” “VXI-11" and “LXI-B"1
Utility > I/O Config _
[T Services /] Enable remote

T/0 Config FTP Serusr (browser) access to the i
700 1 — lleb Services
GPIE Setups Off I instrument’s file system. Use a browser to control
Hebr Server the signal generator.
. | Off
Heb Servicesw L
LI =Bl SCPI Services 7 License Hgnager License Manager Server
eruver ——
LAN Services I o SCPI Servicesk > Sockets SCPI Off (On) allows updates of the
Setup*f ™) aOff instrument licenses, disable
for additional instrument
Femote Languaoe LHXI-B Enabled | page 117. _ w/-\m security.
(SCPIIY 0ff Al UHIDH S-I 4

Apply Settings .~

Confirm Chanoe

M Proceed With,
Reconf iourat ion W

(Instrument
Will Reboot)
N i A LA,
For details on each key, use key help For more information refer to
as described on page 42. the Programming Guide.

1Optior1 ALB LXI-B is only available on instruments with serial prefixes >US/MY/SG4818.
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Configuring the Remote Languages

Figure 2-1 N5161A/62A/81A/82A

Utility > I/O Config

IEI] Conf iE 7

GPIE Setups

LAN Setupw

LAM Services
Setup®

Femote Language
(SCPIIM

M

Setting Preferences & Enabling Options
Remote Operation Preferences

Select the desired Remote language.

Remote | anguage
SCPT

Remote | anguage

Remote | anguage

Remote | anguage

ELL23C ,ELL38C

EB2570,E8267D
ESBEZE

EB2L7C ,EB257C
ES267C

E22L 1A ,E82LLA
EB251A,EB250A

Hore 1 of 3 %

For details on each key, use key help

as described on page 42.

Hore 2 of 3~

ELLEE ELl3xE Fohde & Schuarzrl— R onco
Tt ferof LexH SHJ100A
R ta ity ST
sl

]

Refer to the SCPI Command Reference.

— 2410 Series

Remote | anguage
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Remote Operation Preferences

Figure 2-2 N5183A

Utility > I/O Config >

IEI] Conf iE 7

GPIB Setup Select the desired Remote language.

LAN Setupw

LAM Services
Setup®

FRemote L >
Bmnte Langiet > femote Language 7 Remote Language 7 femote Language 7 Remote Language 7
: 86620
M SCPI 8360 Series (GPIE onlu) StR
B663A
ELLZEC ,ELL3EC 837118 ,837128 (GPIE onla)
s «'/ "
EBES?D,EEEE;E 53731B,837328 Rohde & Schdarzs -
EBEWC,EEEE;E 837518 ,837526 Anritsu MG3E3xEM— [Remote Language
MGIEI1E
ESZ41A ,EZ24LA 2340883418 (GPIE only)
ESZ51A,ES25LA (GPIB only)
~Tore L of 3" MGIEIZE
fore 1 of 3 [_Hore 2 of 3 [_Hore 3 of 3 (GPIB onlg)
MGIEIZE
(GPIE only)
MGIEILE
(GPIE only)
For details on each key, use key help Refer to the SCPI Command Reference.

as described on page 42.
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Configuring the Preset Languages

Figure 2-3 N5161A/62A/81A/82A

Utility> Power On/Preset

Setting Preferences & Enabling Options
Remote Operation Preferences

Select the desired Remote language.

Pouer_On/Preset

Poner O,
(User)

Preset_lLanguage #
SCPT

Preset_lLanguage #

ELL2wB ,ELLExE

Preset_lLanguage #

Fohde & SchuarzF

j Preset Language
SHUZ008

SMATE200R

Preset. Language,|
(5CPI

ELL23C ,ELL38C

86L3A/B/C/D
(GPIB onlu)

Aerof Llexw

SMJ100A

EB2570,E8267D
ESBEZE

8BSER ,8657A/B
(GPIE onlu)

Festore Sustem
Settings toM
Default Walue

EB2L7C ,EB257C
ES267C

\ \ ES24 1A ES24LA
ESZ51A,EG25LA
\\ Hore 1 of 3 %
i
!
page 27

For details on each key, use key help

as described on page 42.

Hore 2 of 3~

Refer to the SCPI Command Reference.

SHMIn

SHL

Sy

—

Preset_lLanguage #

2410 Series
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Setting Preferences & Enabling Options
Remote Operation Preferences

Figure 2-4 N5183A

Utility > Power On/Preset Select the desired Remote language.
Pouer_On/Preset
Faower on, |
(Preset.1? -page 27
Preset. Language, L
(SCPL) f~—®[Preset_Language / Preset_Language 7 Preset_Language 7 Preset Language 7
: EEE2A
/ SCPI B3E0 Series D SR
Restare Sgster@ geb3A
o oo ELL28C ,ELL3a0 837118 ,837128 (GPIE only) A
Default Values/| . /‘
o s
SRS B3731E 637528 Fohde & Schuarz
Eos B 537518837528 ANritsu MG3EIxE »- Preset Language
MGIEI1E
ES241A ;EB2LLA 83408 63416 HEPIS Gt
ES251A ,ES25LA (GPIE only)
S MGIEIZE
Hore 1 of 3 % NMore 3 of 3 (GPIB onlu)
MGIEI3E
(GPIE onld}
MGIEILE
(GPIE only}
For details on each key, use key help Refer to the SCPI Command Reference.

as described on page 42.
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Setting Preferences & Enabling Options
Enabling an Option

Enabling an Option

There are two ways to enable an option:

¢ Use the License Manager software utility:
1. Run the utility and follow the prompts.

2. Download the utility from www.agilent.com/find/LicenseManager and select license (.lic) files
from an external USB Flash Drive (UFD).

¢ Use SCPI commands, as described in the Programming Guide.
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Enabling an Option

Viewing Options and Licenses

Utility > Tnstrunent_Info Options Info
Instrument Info Inst) t
Dimgnostic Infom nSuE%EERg’

Options Infor—:se SDFtuar‘guééﬂgEg' >

Aux Softuare Licenses

Haveform

Self Teste Lirensas™
NPTy Service Software Licenses
Installed
Board Info® appear here.

Front. Panel Testse

Haveform Licenses | —
Have ID Days Left Description

Waveform licenses from some
Instrument options appear Signal Studio applications appear here.

here. A check mark means that
an option is enabled.

Instrument Options
Option Expiratian Description
er [Oigitgl Out
0o& permanent. + Instrument security
019 permanent. + Increase baseband generator memory to BLHS
1EL permanent. + Differential IO outputs
1EQ permanent. ¥ Lol Power (<-110 dBm? ||
1ER permanent. Flexible reference input (1-50 MHz)
Lo3 permanent. + Calibrated AHGN
S0& permanent. ¥ b GHz freguency ranoe
B5L permanent. ¥ Internal baseband oenerator (125 MSa/s)
LINH permanent. + Standard front panel outputs

For details on each key, use key help
as described on page 42.
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Setting Preferences & Enabling Options
Hardware Assembly Installation and Removal Softkeys

Hardware Assembly Installation and Removal Softkeys

Utility > More 2 of 2 > Service For details on each key, use key help

as described on page 42.

- Remove Assy .~
service Prepare —————
CPU Azsembly
Remove AssembluM For Removal N5162A/82A only :
Confirm Removal
=R ﬂpreﬁgrie Prepare of CPU Assembly
SSemhly EBG Assembl!
Install Assemblur oo o Bomigl p—
ar
M\ Whethera softkey is available \ Bemova
depends on the model of MXG. = —
" _ R rEpaEre
VN MH Assembly
For Remowal
N5183A only /
Note: When pressed, a Confirm Removal menu (similar to the
one shown here for the CPU assembly) is opened for the RF,
BBG, and MW assemblies too.
Note: When pressed, a Confirm Install menu (similar to the one
shown here for the CPU assembly) is opened for the RF, BBG,
and MW assemblies too.
\
__Install Ass gonfirm Install X
Finalize ;
Confirm
CPU Assembly ;
Installation N5162A/82A only of %Bﬁtgéég#éﬂ
; ; Finalize
Finalize
BEG Assembly
FF Assembly 7 Abort.
Installation o istalilatin) Installatio ‘
< Whether a softkey is available
( depends on the model of MXG.
Finalize
M Assembly
Installation PP
/.‘/
N5183A only /

Note:

Each Remove Assembly softkey (CPU/RF/BBG/MW) when enabled will display a message in the lower left quadrant of display indicating
assembly prepared for removal or removal has been aborted.

Each Install Assembly softkey, when enabled will display a message in the lower left quadrant of display indicating assembly prepared for
installation or installation has been aborted.

Refer also, to the Service Guide.
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Hardware Assembly Installation and Removal Softkeys
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3 Basic Operation

NOTE For the N5161A/62A the softkey menus and features mentioned in this guide are only
available through the Web-Enabled MXG or SCPI commands. For information on the

Web-Enabled MXG, refer to the Installation Guide, the Programming Guide, and the SCPI

Command Reference.

This chapter introduces fundamental front panel operation. For information on remote operation,
refer to the Programming Guide.

* Presetting the Signal Generator on page 42

* Viewing Key Descriptions on page 42

* Entering and Editing Numbers and Text on page 43
e Setting Frequency and Power (Amplitude) on page 45
e Setting ALC Bandwidth Control on page 47

¢ Configuring a Swept Output on page 48

* Modulating the Carrier Signal on page 61

*  Working with Files on page 63

* Reading Error Messages on page 75
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Basic Operation
Presetting the Signal Generator

Presetting the Signal Generator

To return the signal generator to a known state, press either Preset or User Preset.

User

O Preset is the factory preset; User Preset is a custom preset** (see also, page 27).

To reset persistent settings (those unaffected by preset, user preset, or power cycle*),
press: Utility > Power On/Preset > Restore System Defaults.

*Caution

To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to
non-volatile memory, the MXG should always be powered down either via the MXG's front panel power button or the
appropriate SCPl command. MXG's installed in rack systems and powered down with the system rack power switch
rather than the MXG's front panel switch display a Error -310 due to the MXG not being powered down correctly.

**You can create more than one user preset by giving each saved state file a different name (see Figure 3-12 on page 73).

Viewing Key Descriptions

ﬁ The Help hardkey enables you to display a description of any hardkey or softkey.
To display help text:

1. Press Help.

2. Press the desired key.
The help displays and the key’s normal function does not execute.
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Entering and Editing Numbers and Text

Entering and Editing Numbers and Text

Entering Numbers and Moving the Cursor

Use the number keys and decimal point to enter numeric data.

Up/down arrow keys increase/decrease a selected (highlighted) numeric value, and move the cursor vertically.

Local
ancel/

)

EIEIEIS

00000
BlEIS
319

e

For details on each key, see page 42.

Entering Alpha Characters

Data entry softkeys appear in
various menus. If their meaning
is not clear in context, use the
help key (described on page 42)
to display an explanation. Use
the softkey next to the alpha
table for help on the table.

Selecting data that accepts
alpha characters, displays one of
the menus shown at right.

Use the arrow keys or knob to
highlight the desired letter, then
press the Select hardkey (or the
softkey next to the alpha table).
To correct errors, use Bk Sp or
Clear Text.

=) (0

-+ —

Use the Select hardkey to choose part of an entry, as when entering alpha
Incr
=

To specify a negative value, enter the
negative sign either before or after
the numeric value (this key is a toggle).

Backspace moves the cursor to the left,
deleting characters as it goes.

zaue Page up/down keys move tables of data up and down within the display area.
p

Left/right arrow keys move the cursor horizontally.

De

Page characters. In some menus, the Select key also acts as a terminator, and is
Down | equivalent to the Enter softkey.

Note: Rotating the knob increases or

decreases a numeric value, changes a

highlighted digit or character, or steps
s through lists or items in a row.

See also, Front Panel Knob Resolution on page 19

Note: File names are limited to 25 characters.

Text Entry 7 Text Entry Table Edit
Enter Enter
Clear Text Editing kKeussf—9 Clear Text
Displaded Case Editing Mode

Editing Mode
Ml Feplace

Lower

Feplace

L,-.Aw-

to move the cursor

Show ﬂlpla\ac Table Show Alpha Table

within the active value 0
| On | off IEl
¢ Lo rather than within the =
alpha table, turn the FBCDEFGHIJELH
ﬁgg“ﬁg?ﬂﬁﬂgbg alpha table off. HOPORSTUULRYZ
o w_$88+OIL1{37
0 #+L[1 T @*® -~

Add/edit comments for saved
instrument state files (see page 70).

To terminate the entry, press the Enter softkey.

A subset of this menu appears for hexadecimal characters. The character menu displays only the
letters A through F (use the numeric keypad for other values).
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Entering and Editing Numbers and Text

Example: Using a Table Editor

Table editors simplify configuration tasks. The following procedure describes basic table editor
functionality using the List Mode Values table editor.

1. Preset the signal generator: Press Preset.
2. Open the table editor: Press Sweep > More > Configure List Sweep.

The signal generator displays the editor shown in the following figure.
Active Function Area Cursor

Displays the active item as you edit it. Highlighting indicates the selected item. To make this the active (editable)
item, either press Select, or simply enter the desired value.

FREQUEHC PLLTUDE List Table
)
6.000 000 000 00 &+ 44.00 cen / R
_ Oalete Roud
List Hode Ualues
1/1) Frequency  Pouer Haveform
1 100000000000 GHz|-135.00| WFN1:RAMP_TEST_HFH =)
g 4 ]00000000000 GHz|-135.00|  (vector models only) 4< Insert Item
\ \ Oelete Item
\ Goto Roqe
| / / { Tore 1 of 2 )
Table Editor Name Table Items Table Editor Softkeys Indicates that
Table items are also Used to load, navigate, modify, and another menu
called data fields. store table item values. For details

Current / Total Number of Pages is available; to

on each key, use the key help:

display the
tF';rezs the (I;IEIP hardkey and then second menu,
e desired key. press More.

Highlight the desired item: use the arrow keys or the knob to move the cursor.
4. (Optional) Display the selected item in the active function area: Press Select.
Modify the value:

o If the value is displayed in the active function area, use the knob, arrow keys, or numeric
keypad to modify the value.

e If the value is not displayed in the active function area, use the numeric keypad to enter the
desired value (which then appears in the active function area).

6. Terminate the entry:

o If available, press the desired units.
e If units are not displayed, press either Enter (if available) or Select.

The modified item is displayed in the table.
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Setting Frequency and Power (Amplitude)

Setting Frequency and Power (Amplitude)

Figure 3-1 Frequency and Amplitude Softkeys

In Amplitude mode, this menu is
automatically displayed when entering
a numeric value with the front panel

In Frequency mode, this menu is
e—automatically displayed when entering
a numeric value with the front panel

¢ keypad. keypad.
___Frequency Frequency Units # Anplitude 7 Pouer _Units
Frea Ref Set Opensthe
0.00 Fz BHz Atten/All,l Atten/ALC dBm
Control
Freg Ref menu.
on' k—page 109 MHz T [ dBuY
Freq Offset
0.00 Hz kHz dELvemf
Freg Multiplier
1.000 = Hz iy
Freq Channelse TEmE
fore 1 of 2 More 1 of 3
Sets the current relative phase of
the RF output signal as the zero
___Frequency reference. Amplitude 7
All subsequent adjustments are a .
Phase Ref Set , . - metd FRef Set
relative to this adjustment. 0.00 dBm This So_ftkey Set§ auser
determined maximum
Adjust Phase ametd Fef power level on the
0.000 rad Treq Channels 7 &I on instrgment that is
Ref Freq Channels persistent.
EtEerence e
Oscillator’] P2ge 46 an e it
Amplitude i
Channel Humber
1 User Flatnesse—Page 90 LS SBHEE EE;
) Usar Pouer Enables the
DH%EUtDElﬁﬁ Maw Ernable T User Power
0ff Max softkey.
[_Tore 2 of 2 1\ Channel Band lore 2 of 3 > ALC B
(P-GSH Base RLto) T —Page 47
\’\..\__. Optimize S/N
an
To display the next menu, press More.
fMore 3 of 3 ™,
Enables the optimize signal-to-noise ratio state (Optimize S/N) On or Off.
The optimize signal-to—noise softkey changes the attenuator and alc setting to provide optimal
signal-to—noise performance; it does not change the RF output power.
Caution: When the optimize signal-to-noise ratio state is enabled, some increased levels of
harmonic distortion can occur. This increased harmonic distortion could degrade ACPR and EVM.
Note: This mode is mutually exclusive with attenuator hold (Atten Hold), and any modulation type. A
settings conflict error will be generated if attentuator hold or any modulation is activated when
optimize signal-to—noise is active (On).
For details on each key, use key help Refer to the SCPI Command

as described on page 42. Reference.
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Example: Configuring a 700 MHz, —20 dBm Continuous Wave Output
1. Preset the signal generator.

The signal generator displays its maximum specified frequency and minimum power level (the
front panel display areas are shown on page 11).

2. Set the frequency to 700 MHz: Press Freq > 700 > MHz.

The signal generator displays 700 MHz in both the FREQUENCY area of the display and the active
entry area.

3. Set the amplitude to —20 dBm: Press Amptd > —20 > dBm.

The display changes to —20 dBm in the AMPLITUDE area of the display, and the amplitude value
becomes the active entry. Amplitude remains the active function until you press another function
key.

4. Turn on the RF Output: Press RF On/O0ff.

The RF Output LED lights, and a 700 MHz, —20 dBm CW signal is available at the RF OUTPUT
connector.

Using an External Reference Oscillator

When using an external reference, you can select either narrow or wide bandwidth mode.
Freq > More
* Ref Oscillator

|—uses the signal generator’s internal reference oscillator.

Freguency Lt

uses the REF IN connector to get it's Frequency Reference. Note: An

Fhase Ref Set error screen is displayed if the reference is not connected or is tuned

e to the wrong frequency.
Adjust Phase . uses the signal generator’s internal reference unless a signal is
0.000 rad Ref Dscillator Auto present at the rear panel REF IN connector. If an external signal is
Ref Dscillator present, that signal is used as the reference.
Reference - QUrCceM
Oscillataor’] = (AULO)

Fef Oscillator

Wt Freq
10.0000000 MHz \:ange: 1 to 50 MHz
Ref Oscillstor or guaranteed operation below 2 MHz, select Narrow bandwidth; in Wide bandwidth,

E;EPEEH operation using frequencies below 2 MHz is not guaranteed.

IS el

Figure 3-2 illustrates the better close in phase noise of the wide bandwidth mode. If the
external reference you are using is noisy or spurious, use the narrow bandwidth mode.

Hore 2 of 2

With Wide bandwidth selected, If you select a frequency less than 2 MHz, the signal
generator displays a warning message.

For details on each key, use key help as described on page 42.
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Figure 3-2 Using an External Reference Oscillator

Setting ALC

Basic Operation
Bandwidth Control

MXG Close In Phase Noise @ 1 GHz
-4.00E+01 T
-4 50E+01 bt
o
smoesar LY MM
5 50E+1 i \
-5.00E+01 V"‘ - natrow bandwidth mode, H——F—————H
E.50E+401 \|L w‘\m external reference |1 | | | ]|
-7 O0E+11 r\w - M\M wide bandwidth mode, ||| | 11|
external reference
7 50E+01 H—t——H
-5.00E+01 WMW
0.50E+01 SR
& -9.00E01 e
3 -9.50E+01 )N
= 1.00E+02 ea
-1.05E+12 NN
-1 10E+12 MR
-1 15E+12
-1 20E+12 o | L]
-1.25E402
-1 30E+02
-1 356402
-1 40E+12
-1 46E+12
-1.50E+12
1.00E+10 1.00E+01 1 00E+02 1.00E+03 1 00E+04 1.00E+15 1.00E+16
Offset Frequency
Setting ALC Bandwidth Control
Figure 3-3 Amplitude Softkeys
Amplitude 7 Amplitude # Amplitude &
Atten/ALC, Amptd Ref Set User Power Maw
Control 0.00 dBm 30.00 dBm
User Power
AL fmptd Ref
5 Max Enable
0Ff NilEE O x B
Amptd Of fset ALC BH -
| Offsat L Bty - BIC Banduidth 7] aESt%?L?ti:;he
fauto [——ALC .
User FlatnessM bandwidth
mode
. 200 Hz — (Auto).
Output Blankin . .
B7 o I Disabling the
R — Auto ALC
fore 1 of 3 ™ Hore 2 of 3 % fMore 3 of 3 ™ mode. sets
the
bandwidth to
200 Hz.
For details on each key, use key help Refer to the SCPI Command To display the next menu, press
as described on page 42. Reference. More.
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Configuring a Swept Output

Configuring a Swept Output
The signal generator has two methods of sweeping through a set of frequency and amplitude points:

Step sweep (page 49) provides a linear or logarithmic progression from one selected frequency,
amplitude, or both, to another, pausing at linearly or logarithmically spaced points (steps) along the
sweep. The sweep can progress forward, backward, or manually.

List sweep (page 57) enables you to enter frequencies and amplitudes at unequal intervals, in
nonlinear ascending, descending, or random order. List sweep also enables you to copy the current
step sweep values, include an Arb waveform in a sweep (on a vector instrument), and save list sweep
data in the file catalog (page 68).
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Figure 3-4 Sweep Softkeys

Basic Operation

Configuring a Swept Output

During a sweep, the swept parameter (frequency, amplitude, or both) turns grey and changes as the parameter sweeps.

The selected sweep type determines the displayed parameter.
Selecting step sweep also displays the step spacing (Lin or Log).

Progress Bar: Note that very fast sweeps
can appear to sweep randomly or

backward.
FREQUEHCY AAPLITUDE SueepsLi
6.000 000,000 00 &z | -144.00 den Sueee, > ey Tioie
Sweep Tupe WAy
3 /List_Status Informatjion List
Freq
EMEED B (M2 Sweep Repeat On
Sleap Tupe (Step LIN Single ﬁ!
Manual Mode o OFfF fmetd
Sweep Direction: Up o
Sreep Repeat 1 Cont
Sweep Triooer @ FreeRun
Step Points 101 Point Triooer : FreeRun Confioure
Step Supentf— PA98 49
Step Duell 1 2.000msec
flore 1. of 3
Sweep without waiting for
_Trigger Setup trigger at each point. On vector models:
Point Trigger pauses for the dwell Available whe_n .
Free Run time prior to the first sweep. See Sweep Type = List
page 113.
SueeEZList F q
BN Trigger Key Trigger on a remote command.
List Sneep™f —Page 57

Sweep Trigoer
(Free Run)?|

Point Trigger
(Free Run)”|

page 61

N

More 2 of 3

Bus

Apply a TTL/CMOS signal to the

Ext ¥

/rigger In connector.

Periodically issue a trigger event to
~whatever selects it as a source.

Timer Trigger¥

Hore 1 of 2 %

Using timer trigger with single
sweep results in a delay prior to the

first sweep.

\i

Trigger Setup .~

LHI LAM

LHI ALARM

See page 113.

Sets the trigger
source to any
enabled LXI trigger.

[—input event.

Sets an LXI Alarm
during a sweep or
point trigger.
Configure the alarm
through SCPI only.

SueeEZList 7

Sweep Direction
Oovrn =N

Trigoer Out
Folarit!
Meg

Sweep Retrace
of

f I

p __flore 3 of 3 %

For details on each key, use key help as described on page 42.

Routing Signal

S

Sweep > More > More > Route Connectors

Step Sweep

Foute Connectorse

Down sweeps from
stop to start
frequency/amplitude.

Up sweeps from start
to stop
frequency/amplitude.

Does not effect
Sweep Out BNC
or TRig Out BNC
signals that are
routed as Source
Settled (See
page 49).

—page 49

Step sweep provides a linear or logarithmic progression from one selected frequency, or amplitude, or
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Basic Operation
Configuring a Swept Output

both, to another, pausing at linearly or logarithmically spaced points (steps) along the sweep. The
sweep can progress forward, backward, or be changed manually.
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Figure 3-5 Step Sweep Softkeys

Route Connectors

Foute To
Trig Out BKCw

(Sweep Trig Out)

Foute To
Sweep Out BHCH
(SWeep Out)

Route ToN
Event. 1 ENCH
(Marker 13

These softkeys are
only available for
the N5162A/82A
with a BBG.

Marker

Marker

Marker

Tri§ Out BHC 7

Sueep Trig Out

/Gour“ce Sett 1@4

Pulse Sunc

Pulze Wideo

N5161A"/62A"/81A/8
2A Only Sueeé Out_ BHC 7
-~ — Routes Step or
| L S
signals.
\ ﬁ
Source Settled f—Routes nol
tep or List
S Li
Sweep signals
\ Pulse Video (i.e. SCPI
command
\ development.

N5183A Only—]

Sueeé Out_BHC 7

C o)

ha s ea s

~]

EBG Markersy

fore 1 of 2

page 118 |

Trio Out BAC 7

LHI

——Routes Step or
List Sweep

N5183A only:
Optimizes the
N5183A 10V
Step Sweep
(Sweep Out)
BNC setup with

Sweep Ou
(Optimized for
87570 Suste

Source Settled)]

Routes non Step
or List Sweep
——signals (i.e. SCPI

command

the 8757D.*

Pulze Wideo

development.

* The N5183A
signal generator
does not support
the 8757 system
interface.

For details on each key, use key help

as described on page 42

L e

Basic Operation
Configuring a Swept Output

Source Settled
is not effected
by Trig Out
Polarity Neg
Pos softkey
selections (see
page 49).

These softkeys are
only available on a
N5162A/82A with a
BBG.

This softkey controls
the Event 2 marker
control
(N5162A1/82A only)
on the rear panel
TRIG OUT BNC
connector.

Marker 1

Marker 2

Marker 3

Marker L

-

" The N5161A and N5162A are identical to an MXG with a front panel display, except that the front
panel, hardkeys and softkeys functionality are only available through SCPI commands or the

Web—Enabled MXG. For information on the Web-Enabled MXG, refer to the Installation Guide, the
Programming Guide and the SCPI/ Command Reference.
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The N5183A allows you to use step sweep along with the frequency markers on instruments during
measurements (refer to “Using Frequency Markers (N5183A Only)” on page 55).

NOTE The N5183A does not support the 8757 system interface.

Figure 3-6 Sweep Softkeys
For details on each key, use key help
as described on page 42.

. Dwell Time = the time that the signal is settled and you can make

v a measurement before the sweep moves to the next point.
SueeEZList 7 E E 7| Steé Sueeé 7
Step Suee (Point to point time is the sum of the value set for the dwell plus
Sueepb Freq Start Step Ouell processing time, switching time, and settling time.)
(Off) &.00000000000GH=z 2.000 msec
Sweep Tupe Freq Stop Step Spacing Step Sweep and List Sweep dwell times are set independently.
List % &.00000000000GH=z LOG
Lin = steps equally spaced over the sweep; the output changes
Sweep HRepeat Amptd Start 4 Mark: \' linearly.
Sinole Mo -135.00 dBm SESIS - -
\ / Log = step spacing increases logarithmically over the sweep; the
output changes exponentially.
Amptd Stop
-135.00 dBm i
SESE%ESESr—» & Pm%? N5183A Only: Opens the frequency marker menu. See page 55.
(The N5183A does not support Agilent 8757 the system interface.)
fore 1 of 3 fMore 1 of 2

Example: Configuring a Continuous, Linear Step Sweep

Output: A signal that continuously sweeps from 500 to 600 MHz and from —20 to 0 dBm, with a dwell time
of 500 ms at each of six equally—spaced points.

1. Preset the instrument and open the Sweep/List menu: Press Preset > SWEEP.

Because continuous is the default sweep repeat selection, and linear is the default step spacing
selection, you do not need to set these parameters.

2. Open the step sweep menu: Press Configure Step Sweep.

3. Set the following parameters:

Start frequency 500 MHz: Press Freq Start > 500 > MHz

Stop frequency 600 MHz: Press Freq Stop > 600 > MHz
Amplitude at the beginning of the sweep, —20 dBm: Press Amptd Start > —20 > dBm
Amplitude at the end of the sweep, 0 dBm: Press Amptd Stop > 0 > dBm.

6 sweep points: Press # Points > 6 > Enter

Dwell time at each point, 500 milliseconds: Press More > Step Dwell > 500 > msec

4. Sweep both frequency and amplitude: Press Return > Return > Sweep > Freq Off On > Amptd Off On.

A continuous sweep begins, from the start frequency/amplitude to the stop frequency/amplitude.
The SWEEP annunciator displays, and sweep progress is shown in the frequency display, the
amplitude display, and the progress bar.

5. Turn the RF output on: Press RF On/Off.
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Configuring a Swept Output

The RF LED lights, and the continuous sweep is available at the RF Output connector.

Using Basic Step Sweep Functions
This procedure demonstrates the following task:

¢  “Configuring a Frequency Sweep (N5183A only)” on page 53

Configuring a Frequency Sweep (N5183A only)

For this example, we are going to set a step sweep using the N5183A, over a frequency range of 7.5
to 10.0 GHz, using a band-pass filter as our device under test, and display that response on a 8757D
Scalar Analyzer.

1. Set up the equipment as shown in Figure 3-7.

NOTE The N5183A signal generator does not support the 8757 system interface.

Scalar analyzer settings must match the signal generator’s settings.

Figure 3-7 Equipment Setup

BNC Cable
[ )
BNC Cable
i Sweep|| Pos
Z-Axis| Sweep n Z
Blank/Mkrs Out 0-10v | Blank
" -
AT Tinm. M
[ He
- S 4
RF
N5183A Output
i i 8757D
WXG Microwave Signal DUT Detector Scalar
I L ] Network

Analyzer*
*The N5183A signal generator is not compatible with the 8757 system interface.

2. Turn on both the 8757D and the N5183A.
3. On the 8757D:

a. Press SYSTEM > MORE > SWEEP MODE and verify that the SYSINTF softkey is set to OFF.
b. Press SYSTEM > MORE > DC
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c. Press SYSTEM > Freq LABELS > START FREQ > 7.5 GHz
d. Press SYSTEM > FREQ LABELS > STOP FREQ > 10.0 GHz
e. Press SYSTEM > TRACE # POINTS > 801

4. On the N5183A:

a. Change the connector routing to 8757D System, enabling the N5183A to provide a sweep out
to the 8757D during Step sweep operations. Press Sweep > More > More > Route Connectors >
Route to Sweep Out BNC > Sweep Out (Optimized for 8757D System).

b. Press Sweep > Configure Step Sweep > # Points > 801
c. Press Sweep > Configure Step Sweep > Freq Stop > 10.0 GHz
d. Press Sweep > Configure Step Sweep > Freq Start > 7.5 GHz

e. Press Sweep > Sweep > Freq On Off set to On

NOTE During swept RF output, the FREQUENCY and/or AMPLITUDE areas of the signal generator’s
display are greyed out, depending on what is being swept. In this case, since
frequency is being swept the FREQUENCY area of the display is greyed out.

5. On the 8757D: Adjust the settings for start and stop frequency response of the device under test
(DUT) so it is clearly seen on the 8757D display.

You may need to rescale the response on the 8757D for a more accurate evaluation of the
amplitude. Figure 3-8 on page 55 shows an example of a bandpass filter response.
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Figure 3-8 Bandpass Filter Response on 8757D

Using Frequency Markers (N5183A Only)
In step sweep mode, you can use the N5183A to create up to 20 frequency markers to display on
your measurement equipment.

NOTE The N5183A does nmot support the 8757 system interface.
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Figure 3-9 Frequency Marker Softkeys
Sweep > Configure Step Sweep >
More > Markers

FREQUEHCY

40.000 000 000 00 &z

ANPLITUDE

L0. 0000000000GH=z
L0. 0000000000GH=z

Frequency Start:
Frequency Stop :

Step Points: 101

Marker Marker Frequency On/0ff Ref
0 0
1 L0. 00000000000 GHz OFF ==
2 L0, 00000000000 GHz OFF ===
3 L0, 00000000000 GHz OFF ===
L L0, 00000000000 GHz OFF ===
5 L0, 00000000000 GHz OFF ===
6 L0, 00000000000 GHz OFF ===
? 40. 00000000000 GHz OFF ==

For details on each key, use key help
as described on page 42.

Sets the frequency for the

Narkers marker number highlighted.

—20 00 dem Marker Freq f«e——Up to 20 frequency markers
* can be set.

Enables the selected
frequency marker.

Marker On/O0ff

Selects the highlighted marker
~4—as the frequency reference
marker for the rest of the

Oelta Ref Set

Turn OFF frequency markers.

Markers
If the Delta Ref Set softkey

has been pressed, this softkey
-<t——~enables the Marker Delta
function and uses the Ref

fore 1 of 2

marker as the frequency
marker reference for the other
markers.

Markers

Sets the center frequency of
Marker->Center 44— the sweep to the value of the
Freg highlighted marker (row).

Mi->5tart Sets the start frequency of the
Mz-»5top ——sweep to the value of marker

1 (M1) and the stop frequency
to the value of marker 2 (M2).

Amplitude Markers
Off

Sets the marker’s amplitude
Marker Amplitude feg—Value displayed on the

2.00 d8 instrument (Range: —10 dB to
10 dB).

At
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List sweep enables you to enter frequencies and amplitudes at unequal intervals in nonlinear

ascending, descending, or random order. List sweep also enables you to copy the current step sweep
values, include a waveform in a sweep (on a vector instrument), and save list sweep data in the file
catalog (page 68). Dwell time is editable at each point. For fastest switching speeds, use list sweep.

Figure 3-10 List Sweep Configuration Softkeys and Display

Available only on vector models,
and
only when Sweep Type = List.

m Sueep lode
v off
T Frea
| OF ]
SuHeep -
(OffFa* >
. amptd
Displays the selected on
ﬁﬂsggge— sweep type parameters
(see page 58) Liaveform
—— an 1
Heep Repea
Sinole ﬁ!

Conf igure

Step SHesp?|

fore 1 of 3

SueeEZList F

Conf igure
List Sueep™

page 49

-

“‘\M

For details on each key, use key help
as described on page 42.

Available only when
waveform entry is selected

. >

Sweep Trigoer
(Free Run)®

Point Trigger
(Free Run)®

Sweep Direction
Doun

Each line defines the
corresponding point in
the sweep. For example,
line 1 defines point 1.

Trigoer Out
ari

oo Rzl

Sweep Retrace
0ff Il

sweep moves to the next point.

time, and settling time.

Foute Connectorss

—page 49

__Hore 3 of 3%

FREQUEHCY AAPLITUDE Table
6.000 000 000 00 &z | -144.00 den | /%iect voverorm
CH
List Mode Ualues (na rroclulatlon)/
1/ Frequency  Pouer Haveform Duell
% 5. 00000000000 GHz|-135. 00| s STy 2.000 ms T B
A Oelete Fou
Goto Fowe
fore 1 of 2
Vector models only
\J
List Table 7
Load/Storem
see page 58
~

The selected sweep determines which dwell time the signal generator uses. Step Sweep dwell
time is the same at each point; List Sweep dwell time can be different at each point.

Dwell Time = the time that the signal is settled and you can make a measurement before the

Point-to—Point Time = the sum of the value set for the dwell plus processing time, switching

Preset Listy

T~

Inzert Item

Delete Item

[uell Tupe
Step

__fHore 2 of 2%
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Example: Configuring a List Sweep Using Step Sweep Data

1. Set up the desired step sweep, but do not turn the sweep on. This example uses the step sweep
configured on page 52.
2. In the SWEEP menu, change the sweep type to list:
Press SWEEP > Sweep Type List Step to highlight List.
The display shows sweep list parameters, as shown below.
FREQUEHCY ANPLITUDE Sueep/List
6.000 000 000 00 sz | -144.00 cen Suen,
Speep Tupe
3 /List Status Information [ step
Sreep o OFfF Current Point : 0/1
SHeep Tupe :List Sweep Speed : Opts/sec ﬁhg?g %?.t
Manual Mode HE
SHeep Direction: Up
Sreep Repeat : Cont
Onell Points g i Sweep Triocger @ FreeRun
Ouell Tupe 1 List Foint Trigger @ FreeRun
Conf igure
Step SHesp?
[ Tore 1 of 3
Open the List Sweep menu: Press More > Configure List Sweep.
4. Clear any previously set values from the menu and load the points defined in the step sweep into
the list: Press More > Preset List > Preset with Step Sweep > Confirm Preset.
The display updates with the values loaded from the step sweep, as shown.
FREQUEHCY ANPLITUDE Tist Table Vector Models:

6.000 000 000 00 sz | -144.00 den Load/stores]  Presetting the list clears

any previously selected
Preset Liste waveforms.

List. Mode Ualues
1/

1) Frequency  Pouer Haveform Duell f
1 .00[— CH (no modulation) 500.000 ms Ineert. Tt For information on
2|520.00000000000 MHz| -16.00|—— CH (o modulation) 500.000 ms mSEre BEE selecting a list sweep
3|5L0.00000000000 MHz| -12.00|-- CH (o modulation) 500.000 me .
dmmmR L SRChemEn BB it adonsiiag
o = 4. - no modulat 1on o m= DOelete It it 1
6|600.00000000000 MHz|  +0.00|-- CH <no modulation) S00.000 ms miste ttem Ed!tlng List Sweep
v Points on page 59.
Waveforms are available Diell Tupe
only on vector models. step

flore 2 of 2

5. Sweep frequency and amplitude: Press SWEEP (hardkey) > Sweep > Freq Off On > Amptd Off On.
Setting the sweep turns on the sweep function; a continuous sweep begins. On the display, the
SWEEP annunciator appears, and the progress bar shows the progression of the sweep.

6. If not already on, turn the RF output on: Press RF On/Off.

The RF Output LED lights, and a continuous sweep is available at the RF OUTPUT connector.
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Example: Editing List Sweep Points

If you are not familiar with table editors, refer to page 44.

1. Create the desired list sweep. This example uses the list sweep created in the previous example.
2. If sweep is on, turn it off. Editing list sweep parameters with sweep on can generate an error.
3. Ensure that the sweep type is set to list: Press SWEEP > Sweep Type List Step to highlight List.
4. In the List Mode Values table editor, change the point 1 dwell time (defined in row 1) to 100 ms:
a. Press More > Configure List Sweep.
b. Highlight the point 1 dwell time.
c. Press 100 > msec.
The next item in the table (the frequency value for point 2) highlights.
Change the selected frequency value to 445 MHz: Press 445 > MHz.
6. Add a new point between points 4 and 5: Highlight any entry in row 4 and press Insert Row.
This places a copy of row 4 below row 4, creating a new point 5, and renumbers subsequent rows.
7. Shift frequency values down one row, beginning at point 5: Highlight the frequency entry in row
5, then press More > Insert Item.
This places a copy of the highlighted frequency value in row 6, shifting the original frequency
values for rows 6 and 7 down one row. The new row 8 contains only a frequency value (the
power and dwell time entries do not shift down).
8. Change the still active frequency value in row 5 to 590 MHz: Press 590 > MHz. The power in row 5
is now the active parameter.
9. Insert a new power value (—2.5 dBm) for point 5, and shift down the original power values for
points 5 and 6 by one row: Press Insertltem > -25 > dBm.
10. To complete the entry for point 8, insert a duplicate of the point 7 dwell time by shifting a copy
of the existing value down: Highlight the dwell time in row 7 and press Insert Item.
11. For an analog instrument, go to step 14. For a vector instrument, continue with step 12.
12. Select a waveform for point 2:
a. Highlight the waveform entry for point 2 and press the More > Select Waveform.
The signal generator displays the available waveforms, as shown in the following example.
FREQUEHCY ANPLITUDE Arb laveforn
6.000 000 000 00 &z | -144.00 den | seiect yaveforn] Either select a waveform,
Display uaueFDr“m’
Select Seament On ) Sequence On And Markers or
(1/1) BBG Hedia Points Int Hedia Segs
BAMP_TEST_WFH 200 A L Haveform
STNE TEST HFN Seoment.s*
LW select no modulation.
\wwm\m‘ (no modulation)
M A

b. Highlight the desired waveform (in this example, SINE TEST) and press either the Select
hardkey or the Select Waveform softkey.
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13. As desired, repeat step 12 for the remaining points for which you want to select a waveform. The
following figure shows an example of how this might look.

FREQUEHCY AAPLITUDE List Table
GHz | — dBm i
6-000 000 000 00 144°00 s 1B The empty entry is equivalent to
choosing CW (no modulation).

List. Mode Ualues
(1/1) Frequency  Pouer Haveform Duell

1|500.00000000000 MHz| -20.00{-— CH (no modulation? 100,000 ms 1 t R

2|L45.00000000000 MHz| -16.00|WFML:5INE_TEST_MFH 500.000 ms MEEG (R

3| 5L0. 00000000000 MHz| -12.00{-— CH (no modulation? 500, 000

4| 560, 00000000000 MHz|( -8.00{-— CH (no modulation? 500, ooy

9| 5590.00000000000 MHz| -2.S0({HFM1:RAMP_TEST_HFM =in] 0 ms Delete Row

6| 560.00000000000 MHz| -8.00(HFM1:RAMP_TEST_HFH

7|580.00000000000 MHz| -L4.00|-— CH (no modulation? / 500,000 ms

8| 500, 00000000000 MHz +0.00 500,000 ms

) Goto Fowe

fore 1 of 2

14. Turn sweep on:
Press Return > Return > Return > Sweep > Freq Off On > Amptd Off On > Waveform Off On.

15. If it is not already on, turn the RF output on:
Press RF On/Off.

The SWEEP annunciator appears on the display, indicating that the signal generator is sweeping,
and the progress bar shows the progression of the sweep.

NOTE If the instrument is in manual sweep (page 61), the active row (row 6 in the figure above) is
the selected (manual) point, and the signal generator outputs the settings for that selection
when the RF output is on.

Example: Using a Single Sweep
1. Set up either a step sweep (page 52) or a list sweep (page 58).

2. In the List/Sweep menu, set the sweep repeat to single:
Press Sweep Repeat Single Cont to highlight Single.

Sweep does not occur until you trigger it.

Note that the WINIT annunciator appears on the display, indicating that the sweep is waiting to
be initiated.

If not already on, turn the RF output on: Press RF On/Off.
4. Initiate the sweep: Press Single Sweep.
A single repetition of the configured sweep is available at the RF Output connector.

As the signal generator sweeps, the SWEEP annunciator replaces WINIT on the display, and the
progress bar shows the progression of the sweep.

At the end of the sweep, there is no progress bar, and the WINIT annunciator replaces SWEEP.
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Example: Manual Control of Sweep
1. Set up either a step sweep (page 52) or a list sweep (page 58).

Basic Operation
Modulating the Carrier Signal

2. In the Sweep/List menu, select a parameter to sweep: Press Sweep > parameter > Return.

3. Select manual mode: Press More > Manual Mode Off On.

When you select manual mode, the current sweep point becomes the selected manual point.

4. If it is not already on, turn the RF output on: Press RF On/Off.

Select the desired point to output: Press Manual Point > number > Enter.

The progress bar changes to indicate the selected point.

6. Use the knob or arrow keys to move from point to point. As you select each point, the RF output

changes to the settings in that selection.

The SWMAN annunciator
indicates that the sweep

is in manual mode.

FREQUEH

SunAH
Manual Point: 3

The currently sweeping
parameter stops and
displays the selected point.

ANPLITUDE

-144,00 den

fList Status Information

When you enter a manual point,
the progress bar moves to and
stops at the selected point.

Sreep
Sweep Tupe

Frequency Stop

Step Points

Freguency Start :
: 500.00000000MHz

1 Freg (Current Point @ 3/6 )
: Step LIM Sweep Speed 1 Opts/sec
500. 00000000MHz Manual Mode : On

The parameters of the selected sweep point (point 3
of 6 in this example) define the signal available at the

RF Output connector.

Su List

Conf igure
List Suesp®

Sweep Trigoer
(Free Run)®

Point Trigger
(Free Run)®

Manual Mode |

0ff Nl

When you turn manual mode on, the
current sweep point becomes the
manual point.

Manual Poin%

fore 2 of 3
T —

Modulating the Carrier Signal

To modulate the carrier signal, you must have both

e an active modulation format

and

¢ modulation of the RF output enabled

Example

1. Preset the signal generator.
2. Turn on AM modulation: Press AM > AM Off On (requires Option UNT).

You can turn on the modulation format before or after setting signal parameters.

The modulation format generates, but does not yet modulate the carrier signal.

Once the signal generates, an annunciator showing the name of the format appears, indicating
that a modulation format is active.
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3. Enable modulation of the RF output: Press the Mod On/0ff key until the LED lights.

If you enable modulation without an active modulation format, the carrier signal does not
modulate until you subsequently turn on a modulation format.

Annunciator indicates active AM modulation

ANPLITUDE

-144.00 den

A .
0ff M j«——AM modulation format on.

Al Tupe
L IH WS

Modulation Status Information

Hod State Depth/Dev Source Rate Uaveform AM Depth

an fod OFfF D.1% Internal LO0. 0Hz Sine 0.1 %
On/Off

AN Source

(Internal®

A _Rate

Loo.0 Hz

A lit LED indicates that any
active modulation format can
modulate the carrier.

NOTE To turn modulation off, press the Mod On/0ff key until the LED turns off.

When the Mod On/0ff key is off, the carrier signal is not modulated, even with an active
modulation format.

4. To make the modulated carrier available at the RF output connector, press the RF On/0ff key until
the LED lights.

See also: “Using Analog Modulation (Option UNT Only)” on page 77
“Using Pulse Modulation (Option UNU or UNW)” on page 123
“I/Q Modulation” on page 192
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Basic Operation
Working with Files

NOTE

The Agilent MXG is capable of simultaneous modulation. All modulation types (AM, FM, ¢M,
and Pulse) may be simultaneously enabled. But, there are some exceptions. Refer to

Table 3-1.

Table 3-1 Simultaneous Modulation Type Combinations

AM? FM oM Pulse®
AM -- X X X
FM X -- not applicable X
oM X not applicable -- X
Pulse X X X --

Linear AM and Exponential AM cannot be enabled simultaneously. Refer to Chapter 4.
bPulse modulation requires Option UNU or UNW. Refer to Chapter 6.

Working with Files

* File Softkeys on page 64

* Viewing a List of Stored Files on page 65

e Storing a File on page 66

¢ Loading (Recalling) a Stored File on page 68

¢ Moving a File from One Media to Another on page 69
¢  Working with Instrument State Files on page 70

¢ Selecting the Default Storage Media on page 74

The signal generator recognizes several types of files, such as instrument state files, license files, and
list sweep files. Files can be stored either in the signal generator’s internal storage or on the USB
media. This section provides an overview of how to navigate the signal generator’s file menus, and
how to view, store, load, and move files.

See also: Storing, Loading, and Playing a Waveform Segment on page 136.
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File Softkeys

Catalog &

Display internal or USB

Cataloo Tupe
(AL127]

Delete Filew

Copu File

Fename File

Delete ALl Filesk

Hore 1 of 2 %

Catalo

Goto Fowe

Securitum

For details on each key, use key help as described on page 42.

Note: Available file types depend on the installed options.

Instrument operating parameters (see page 70).

USE File Managerw

Internal/USBE

Storage Selectionm
USE if present)

flore 2 of 2

Shows the current directory

FREQUEHCY

Specifu Default
Storaoe Path for

' USE Media

\J

6.000 000 000 00 &z

ANPLITUDE

-144.00 den

/ Defau lt P

\@ e Directory

e |

USBE Nedia

T
PERSISTEMT

RAMP_TEST_WFM
RAMP_TEST_WFM
RAMP_TEST_WFM

USB(Dlrectorg JUSER ) T
(Thls path is the default path)

E
STATE
STATE
LIST

HWAVEFORMN

90.1MB Free

04/12/06
04 /12/06

04/12/06
04/12/06

800 B O4/12/06

OB/14/06 10:
OE/14/05 14
O/14 /05 14

files, depending on the Catalog Tupe 7
selected storage media. A1l Sweep data from the List Mode Values table editor.
User flatness calibration corrections.
Einary
State Catalog Tupe /page 65
Deletions require Catalog T s
i ui atalog Tupes ’ )
confirmation. List Displays 1Q Files
g tH?dul?tlon'
atalog Tupes
User Flatness D_lsplays FSK
Files
fore 1 of 2 > FIR \
Displays FIR
Files
-~
Default Storage e .
Automatically Use —
USB Nedia
If Present
74 Default Path
Use Only page
- page 304 Internal Storage DE?QCESFEBHE
Use Dnli Hefonitghath Available only with USB connected
u539n981§ (i.e. Without external USB connected,

/ softkeys are greyed out).

Recall
Instrument State

Copy File to
Instrument |

The signal generator does not
format USB media or change file
permissions. Use a computer to
perform these operations.

The display indicates when the current directory is the default storage path.
For information on setting the default storage path, see page 74.

This key changes, depending on
}—the selected file. See page 68.

page 69

Up Directory’|

Available only when the
current directory is not the
top level directory.

= Delete File or
Directory

M

Requires
confirmation

Create Directory

flore 1 of 2
T

——page 69

When you connect USB media to the instrument, the signal generator displays the USB Media menu and the message External USB Storage attached. When you
disconnect the USB media, the message External USB Storage detached displays. When you open the External Media menu without USB media connected, the
signal generator displays the message External Media Not Detected.

64
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ARB File Softkeys

Waveform files and their associated
marker and header information.

Arb [:atalo§ TQEB? Arb Catalog Tupe

- EBG Seoments

Stored
Seaments

Sequence

Oroo . . . .
Note: Available file types depend on the installed options.

MOMOD

_ _fore 1 of 2 &

For details on each key, use key help as described on page 42.

Viewing a List of Stored Files

The information in this section is provided with the assumption that default storage media is set to
Auto, as described on page 74.

Viewing a List of Files Stored in the Signal Generator
1. If USB media is connected, disconnect it. The signal generator’s storage media switches to
internal, so you can now use the file catalogs to see files stored in the signal generator.

2. Select the desired file catalog: Press > Catalog Type > desired catalog (in this example, All). The
selected files appear in alphabetical order by file name, as shown in the following figure.

FREQUEHCY ANPLITUDE Catalo

The selected file catalog and 6.000 000 000 00 GHz _144.00 dBm EatalDQ(FT‘ﬁ?’

the storage media

- - Oelete Filew
Catalog oF&nll Files in Int Storageg 30.5MB used  LEYME free
| File Hame — — — Tupe  Size  [MNodified |
&L ' S Copu File
3 10/31/06 09:
M 11/02/06 10:05
9 09/22/06 22:36 Fename File
6 10/09/06 1L:L1
7 BOGUSII 09/22/06 22:36
8  COMAZK_SCHAN_LFM SMULFH 1474752 09/22/06 22:36 )
9 COHAZK_PILOT_LFM SNLIFTH 1474752 09/22/06 22:36 Delete ALL Filesk
10 DISPLAY.BMP BINARY 76918 09/22/06 22:36
More 1 of 2
——
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Viewing a list of Files Stored on USB Media

With USB media connected, you can view files on USB media using either the file catalogs, which can
display only a selected type of file, or the USB File Manager, which displays all files.

Using the File Catalogs:

¢ With the USB media connected, select the desired file catalog: press > Catalog Type >
desired catalog. The selected files appear in alphabetical order by file name.

Using the USB File Manager:

¢ With USB media connected, open the USB File Manager: press File > More > USB File Manager.
The instrument displays the default directory on the USB Media, as shown in the following figure.
Note that when you attach USB media, the display goes directly to this menu.

Use the Page Up and Page Down
hardkeys to scroll through the
contents of the directory.

Storing a File

FREQUENCY ANPLITUDE USE Tiedia
6.000 000 000 00 sz | -144.00 den | ... .o Pec3l
Copy File to
USB Directoru: /USER 50, 118 Free Instrument

File Hame

5

N STATE 1EE B OL4/12/05 d )

LAST LIST 5.24kB  06/14/0B Deletg.FllE o
LAST USERFLAT 16 B 06/14/05 HrEEEE
PERSISTENT STATE 1.03kB  DE/1L /05
RAMP_TEST_WFHM HEADER 132 B OL4/12/05 )
RAMP_TEST_HFH MARKERS 200 B Ou/12/06 Create Directory
RAMP_TEST_WFHM WAVEFORM 800 B 04/12/08

(This path is the default path)
Tupe

Nodified .
STATE H Up Directory
STATE

flore 1 of 2
T

Several menus enable you to store instrument parameters. For example, you can store instrument

states, lists, and waveforms.

¢ An instrument state file contains instrument settings. For this type of file, use the Save hardkey
shown in Figure 3-11 on page 70.

¢ For other types of data, use the Load/Store softkey (shown below) that is available through the
menu used to create the file.
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File Type Save From

List Sweep menu
State Save menu
Waveform Mode menu

User Flatness ~ Amplitude menu
User Preset User Preset menu

Text Entry

Enter
Load From
Selected File Clear Text
Load/Stores—
Store Tog - Editing Mode
File - M Feplace

Show Alpha Table
Off

Use this menu to enter the file name,
as described on page 43.

File Length (including extension)
Internal Media: 25 characters
For details on each key, use key help as described on page 42. USB Media: 39 characters
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Loading (Recalling) a Stored File

There are several ways to load (recall) a stored file.
¢ For an instrument state file, use the Recall hardkey shown in Figure 3-11 on page 70.

* For other types of data, use the Load/Store softkey (shown below) that is available through the
menu used to create the file.

Eile Type Recall From
List Sweep menu
Load From | Confirm | oad State Save menu
Selected File | ™ —— Waveform Mode menu
Lomd/Storem—i From File User Flatness ~ Amplitude menu
StDPEiIg. User Preset User Preset menu
Loading a File From USB Media
To load a file from USB media, use the USB file manager shown below.
File Type Extension  Pressing Select with file highlighted...
List list loads list and starts sweep
File > Catalog Type > <type> > More > USB File Manager State state load instrument state
Waveform .waveform loads and plays waveform
O': . User Flatness .uflat loads and applies user flatness
File > More > USB File Manager User Preset .uprst loads and executes user preset
or License lic installs purchased license

Insert the USB media

If the signal generator does not recognize the
file, you must select how the file is to be used.

USE Nedia
Recall |\ Thiskey changes, depending
( Instrument. State Y on the selected file. | Copy & Select User Flatness —Gse File

Copy & Play Waveform Load Sweep List
Copy File to
Instrument. Copy & Play Sequence
Enter Directory Recall State
Up Directory Recall Instrument State
. Copy & Select
Delete File or Load List s
Directory® Install licenses CEARE S5
No action (USB disconnected) Copy & Plau
X Haveuform
Create Directory Use As >
fore 1 of 2 3 Eopgegugégg

For details on each key, use key help as described on page 42.
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Moving a File from One Media to Another

Use the USB Media Manager to move files between USB and internal media.

File > Catalog Type > <type> > More > USB File Manager

or

File > More > USB File Manager

or

Insert the USB Flash Drive (UFD)

USB Nedia 7

RecallT]
Instrument State

This key changes,
depending on the selected
file. See page 68

Whether a menu is available

Copy File to .}
Instrument

Up Directory

Delete File or
Diractoru™]

Create Directory

depends on the selected file.

Requires confirmation

fore 1 of 2

Moves up one directory level

USBE Nedia

Select
Internal Filelsiw
to Copy to USB

Selecting a waveform or
an unknown file type
displays this softkey.

Copu ALl Filesk

Copy File As ~|

Sweep List

Basic Operation
Working with Files

Instrument State

Copy to
i User Flatness
ED?HSE#EEEEEV —> Correct ions
EBG Memory
] / Have For“m \— >
ED%SE{&%%E Internal Storage
Seguence
If the file type is recognized w
the “Filename.xxx copied
to Internal Storage” is These Saftkeys only are

displayed.

Copy File As

available on the
N5162A"/82A with
BBG.

Eatal?%t;%g?, — Catalog Type Menu
page 64
Copy File
to USE

Oelete ALl Files,|
in Current Dir

b A

" The N5162A is identical to an MXG
with a front panel display, except that the front panel, hardkeys and softkeys functionality are only

available through SCPI commands or the Web—Enabled MXG. For information on the Web-Enabled

Requires confirmation

MXG, refer to the Installation Guide, the Programming Guide and the SCPI Command Reference.

For details on each key, use key help as described on page 42.

These softkeys
are only
available on
the N5182A
with BBG.

Copy All Files

Internal Storage
to USE

USE to
Internal Storage

=
\ n}

USE
? to BEG Memory
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Working with Instrument State Files

e Saving an Instrument State on page 71

e Saving a User Preset on page 71

¢ Recalling an Instrument State on page 71

¢ Recalling an Instrument State and Associated Waveform File on page 72
¢ Recalling an Instrument State and Associated List File on page 72

* Moving or Copying a Stored Instrument State on page 73

Figure 3-11 Save and Recall Softkeys

When saved to the signal generator, instrument settings
ﬂ m (states) save to instrument state memory*. Instrument
state memory is divided into 10 sequences (0 through 9);

+ each sequence comprises 100 registers (00 through 99).
_ Save State 7| Save State Recall State Delete softkeys in the Save and Recall menus enable you
SAVE Select Seq: RECALL Reg to delete the contents of a specific register, or the contents
Seqlbl Realood 0 == of all sequences in the state file catalog.
Caves1antes 00 Hegsnféeggq%%» EEliEsh ER The signal generator requires that you confirm a deletion.
Select Seqa Delete ALL Oelete, *Caution
Sequences SRl [REE To avoid the loss of data, GPIB settings, or current user
Delste ALl instrument states that have not been permanently saved
Reos in SeqfdIM to non-volatile memory, the MXG should always be
M powered down either via the MXG's front panel power
Delete ALl button or the appropriate SCPI command. MXG's installed
SERUEREES in rack systems and powered down with the system rack
_Hore 1 of 2 [_Tore 1 of 2 power switch rather than the MXG's front panel switch
display a Error -310 due to the MXG not being powered
For details on each key, use key help down correctly.

as described on page 42.

The following information is not stored in a state file:

System Security Level List Mode Freq Hostname Remote Language FM Deviation

System Security Level Display List Mode Power IP Address FTP Server PM Deviation

System Security Level State List Mode Dwell Subnet Mask Manual DHCP MAC

Web Server (HTTP) List Mode Sequence Default Gateway  VXI-11 SCPI User Power Correction
Sockets SCPI (TELNET) Display State On/Off  ARB Files List Files 1/Q Calibration Data
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Saving an Instrument State

1.

Preset the signal generator and set the following:
* Frequency: 800 MHz ¢ Amplitude: 0 dBm ¢ RF: on
(Optional, vector models only) Associate a waveform file with these settings:

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired file and press Select Waveform. If the file is not listed, you must first
move it from internal or external media to BBG media, see page 136.

Select the desired memory sequence (for this example, 1): Press Save > Select Seq > 1 > Enter.
Select the desired register (in this example, 01): Press Select Reg > 1 > Save Reg.

If a waveform is currently selected, saving the instrument state also saves a pointer to the
waveform file name.

Add a descriptive comment to sequence 1 register 01:

Press Add Comment to Seq[1] Reg[01], enter the comment and press Enter. The comment appears in
the Saved States list when you press Recall. If the instrument state has an associated waveform,
entering the waveform name in the comment makes it easy to identify which instrument state
applies to which waveform.

Saving a User Preset

A user preset is a special type of instrument state file.

1.
2.

Preset the signal generator and set as desired.
Press User Preset > Save User Preset.

This saves a state file named USER_PRESET, which the signal generator recognizes as containing
user preset information.

You can set up several preset conditions under different names:

1.
2.
3.

After you save a user preset, rename it to something other than USER_PRESET (see page 73).
Save as many user presets as you wish, renaming the USER_PRESET file each time.
Give the desired file the name USER_PRESET.

Recalling an Instrument State

1.
2.

Preset the signal generator.
Press Recall.

The Select Seq softkey shows the last sequence used, and the display lists any states stored in the
registers in that sequence; RECALL Reg is the active entry.

Select the desired instrument state:

If the desired state is listed in the currently selected sequence, press desired number > Enter.
If not, press Press Select Seq > desired number > Enter > RECALL Reg > desired number > Enter.
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Recalling an Instrument State and Associated Waveform File
1. Ensure that the desired waveform file exists, and that it is in BBG media (page 136).

If the waveform file is not in BBG media, this procedure generates an error.

Recalling an instrument state with an associated waveform file recalls only the waveform name. It
does not recreate the waveform file if it was deleted, or load the file into BBG media if it is in
internal or USB media.

Recall the desired instrument state (see previous example).

3. View the waveform file name recalled with the instrument state: press Mode > Dual ARB.
The name is displayed as the selected waveform.

4. Turn on the waveform file: Press Mode > Dual ARB > ARB Off On.

Recalling an Instrument State and Associated List File

Recalling an instrument state recalls only the list sweep setup. It does not recall the frequency
and/or amplitude values. Because you must load the list file from the file catalog, when you store a
list file, be sure to give it a descriptive name (up to 25 characters).

1. Recall the desired instrument state (see previous example).
2. Load the desired list file:
a. Press Sweep > More > Configure List Sweep > More > Load/Store.

b. Highlight the desired file and press Load From Selected File > Confirm Load From File.

Editing The Comment on an Instrument Comment

Use the following steps to change a comment on an instrument state saved using the Save key. This
is not the file name that appears in the State catalog (which is the file’s memory location).

1. Press Save

2. Highlight the desired register

3. Press Edit Comment In Seq[n] Reg [nn].
4. Press Re—SAVE Seq[n] Reg[nn].

This overwrites previously saved instrument state settings with the new comment.
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Moving or Copying a Stored Instrument State

Figure 3-12 Instrument State File Catalog

l Sequence Register

FREQUEHCY ANPLITUDE

6.000 000 000 00 &z | ~144.00 den

Basic Operation
Working with Files

Catalo:
Catalog Tupe
iStatei®

Delete Files

Copu File

of Atate Files in Int Storage ES.1MB used  L3EME free
Fi Hame upe Si dified
1 11/ i35
2 002 STATE 11/07 /08 16:329
3 PERSISTENT STATE 11/07 /06 12:23
L 1JSER_PRESET STATE 11/07 /06 16:36
5 SER_PRESETZ2 STATE 213 11/07/06 16:uL0

Fename File

Oelete ALl
State Files™

More 1 of 2 \

The signal generator recognizes only the file named USER_PRESET as user preset information (page 71).

A user-created state file’s default name is its memory location (sequence and register).

To move the file, rename it to the desired sequence and register; you can not give a file the same
name as an existing file. If you rename a state file to something other than a valid sequence/register
name, the file does not appear in either the Save or Recall menu.
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Selecting the Default Storage Media

You can configure the signal generator to store user files to either the internal storage or to external
USB media. To automatically switch between USB media and internal storage, depending on whether
USB media is attached, select Automatically Use USB Media If Present. To avoid storing any confidential
information in the instrument, select Use Only USB Media. To avoid storing any confidential information
to USB media, select Use Only Internal Storage.

This selection is unaffected by power—cycle or preset.

File > More > Tatalo

Goto Fowe

Securitus

USE File Managerw

Internal /USE
Current Storaoe Selec{ionp — - Default Storage This is the recommended selection. When USB media is attached to the
selection (USE if present) Automaticalluy Use front panel, it is the selected media; when USB media is not attached,
Hore 2 of 2 USE MNedia - internal storage is used.
S —— IF present
Use Only i i i i3 is i
Internal Storage ___ Memory in the instrument is used, and USB media is ignored.
Use Only
USE Media ]

\Media attached to the front panel USB connector is used, and no user
data is stored to internal storage.

Specifu Default
Storage Path form
IUSE Media |~ Select the directory on the USB media to be used for all file operations

when USB media is attached and enabled.

For details on each key, use key help as described on page 42.
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Reading Error Messages

If an error condition occurs, the signal generator reports it to both the front panel display error
queue and the SCPI (remote interface) error queue. These two queues are viewed and managed
separately; for information on the SCPI error queue, refer to the Programming Guide.

Characteristic Front Panel Display Error Queue
Capacity (#errors) 30
Overflow Handling Drops the oldest error as each new error comes in.
Viewing Entries Press: Error > View Next (or Previous) Error Page
Clearing the Queue Press: Error > Clear Error Queue(s)
Unresolved Errors? Re-reported after queue is cleared.
When the queue is empty (every error in the queue has been read, or the queue is cleared), the
No Errors following message appears in the queue:
No Error Message(s) in Queue 0of O

@Errors that must be resolved. For example, unlock.

Error Message Format Error Description
Error Number Error Message (May be truncated on the
N T
—-222 Data out of range; value clipped to lower limit.

Indicates that the user has entered a deviation, depth, or internal
source frequency that is beyond the specific limits

KW—_///
Explanation is provided in the Error Message file (see page 315)
(This is not displayed on the instrument)

The annunciator indicates an unviewed message.

new indicates a message generated
since messages were last viewed.

Modulation Status Information

Hod State Depth/Dev Source Rate
Fn On 1.0000kHz Internal L0D. 0Hz
[Error Tnfo 7|
View Previous
Error Page
View Next
Error_Oueue | 4 A Error Page

1, Settings conflict; Enabled modulation source conflicts (neu)
Slthhgrgumuslu enabled modulation source. Previous modulation 1 of 1
isabled.

Clear
Errar Queue(s)

Error messages appear in the lower left corner
of the display as they occur.

fxx= PROTO COOE == NOT FOR CUSTOMER USE === OL /062006 1012
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4 Using Analog Modulation (Option UNT Only)

NOTE
installed.

The Mod On/Off hardkey and LED functionality are only valid for MXGs with Option UNT

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting the power level and frequency, refer to
Chapter 3, “Basic Operation,” on page 41 and familiarize yourself with the information in that

chapter.
* The Basic Procedure on page 78

Using an External Modulation Source on page 79

* Removing a DC Offset on page 79

Figure 4-1 Analog Modulation Softkeys

oM
_ Y

[Tl | Fi/oH
AN @
on
A Tupe N
[RYW E-F an

Fr Dew
] (S 1.0000 KAz

FM Source
AhtarHngSs—Ppage 79 (Internal)*f—Page 79
FM_Rate
hDETDHaﬁg Loo0.0 Hz
Hore 1 of 2 __fore 1 of 2 —l
\J
i} [FiF]
A Hode
Mormal OCFM/OCHM Cal
\w

For details on each key, use key help
as described on see page 42.

FM/
oM
Y

I 57 T

Fri_ I
High BH

iyl
on

@M Dev
0.000 rad

M Source
tInternal)—Page 79

M _Rate
Loo.0 Hz

__fore 1 of 2 §—l

Fli700

DCFM/DC@N Cal

\w
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The Basic Procedure

The Basic Procedure

1. Preset the signal generator.

2. Set the carrier (RF) frequency.
3. Set the RF amplitude.
4

Configure the modulation:

AM

FM

OM

a. Press AM

b. Set the AM type (Linear or Exponential):

AMType to highlight desired type.
c. Set the AM Mode (Normal or Deep).

Default is Deep. To select Normal enable

More to highlight desired type.
d. Set the AM Depth:
Default 0.01%

Range 0.01 to 100%

e. Set the rate:
AM Rate > value > frequency unit

5. Turn on the modulation:

AM

AM Depth > value

a. Press FM/®M

b. Set the deviation:
FM Dev > value > frequency unit

c. Set the rate:
FM Rate > value > frequency unit

FM

a. Press FM/®M > FM ©®M
b. Set the BW (normal or high):

FM ®M to highlight desired type

c. Set the deviation:

®OM Dev > value > pirad

d. Set the rate:

©®M Rate > value > frequency unit

OM

AM Off On softkey to On

FM Off On softkey to On

OM 0ff On softkey to On

The appropriate modulation annunciator displays, indicating that you enabled modulation.

6. Turn on the RF output.

The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output”

on page 310.

See also “Modulating the Carrier Signal” on page 61.
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Using Analog Modulation (Option UNT Only)
Using an External Modulation Source

Using an External Modulation Source

Currently selected modulation.

Default
Source ; .
(Internal)™ Internal Select to use external modulation
Ext
Rear panel inputs are
described on page 15
AM input FM or ®M input

R;‘?#T o SWEER OUT LU M PULSE A TRIG IN TRIGOUT REF IW 10MHz QUT O
D@D
GRIA
I KN )= (

@] (OO = OSSO0 2 0 @:D:D@@Cﬁ

Removing a DC Offset

To eliminate an offset in an externally applied FM or ®M signal, perform a DCFM or DC®M
Calibration.

NOTE You can perform this calibration for internally generated signals, but DC offset is not usually
a characteristic of an internally generated signal.

1. Set up and turn on the desired modulation.
2. Press FM/®M > More > DCFM/DC®M Cal.

Performing the calibration with a DC signal applied removes any deviation caused by the DC signal,
and the applied DC level becomes the new zero reference point. When you disconnect the DC signal,
perform the calibration again to reset the carrier to the correct zero reference.
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B Optimizing Performance

NOTE For the N5161A/62A the softkey menus and features mentioned in this guide are only
available through the Web-Enabled MXG or through SCPI commands. For information on the
Web-Enabled MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI
Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting the power level and frequency, refer to
Chapter 3, “Basic Operation,” on page 41 and familiarize yourself with the information in that
chapter.

e Using the Dual Power Meter Display on page 82

* Using Flatness Correction on page 90

¢ Using External Leveling (N5183A Only) on page 99

* Using Unleveled Operating Modes on page 107

¢ Using an Output Offset, Reference, or Multiplier on page 109
* Using Free Run, Step Dwell, and Timer Trigger on page 113
e Using LXI (Option ALB only) (Option ALB) on page 115

* Using a USB Keyboard on page 121
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Using the Dual Power Meter Display

The dual power meter display can be used to display the current frequency and power of either one
or two power sensors. The display outputs the current frequency and power measured by the power
sensors in the larger center display and in the upper right corner of the display. Refer to Figure 5-2,
Figure 5-2, and Figure 5-3.

NOTE

The dual power meter display feature is only available on instruments with serial prefixes
>US/MY/SG4818.

To use two U2000 USB Series power sensors with the MXG, a USB hub (with power supply),
can be connected to the MXG’s front panel USB connector.

Figure 5-1 Dual Power Meter Display with Power Sensors A and B Calibrated

For details on each key, use key help as described on see page 42.

40.000 000 000 00 &Hz

ChA:—66.L4E dEm
ChE:-45.31 dBm

| Nouer Meter /7

Channel &
aOff

Chanoel Ay

[Palier Meter Measurements

Setup

ChA cuss: nuu7uo01L3)

-61.40 dBm

0 MHz

50.000 MHz

ChB ¢sck: 1u1.121.92.70)

-48.64 dBm

Once turned on, the
——_power meter
readings are always
visible, even if
another instrument
feature is selected
(i.e. Sweep, AM,
etc.).

Channel B
aOff

This area is the main

Channel B,
Setup

display for the dual
power meter
calibration frequency

=

and current power
easured.

If channel A or

channel B power
sensors or both are
displayed, and the
AMPTD or the FREQ
softkeys are pressed,
the large power
meter measurements
remains displayed.

After the first
connection, if the
connection is
successful, the
model number and
serial number of the
power sensor is
displayed.
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Figure 5-2 Dual Power Meter Display Menu

.—> Auxillary
Fouer Meter

Measurements’|

/\ M

FREQUEHCY

40.000 000 000 00 &z

RF_OFF

Pouer Heter

Pouer Heter Measurements

Chanoel Ay
Setup

TR On

Channel B |——

Channel B J=—
Setup

Optimizing Performance
Using the Dual Power Meter Display

Enables the power sensor on
channel A.

See
page 84

Enables the power sensor on
channel B.

Channel B is configured similarly to
channel A. See page 84

For details on each key, use key help
as described on see page 42.
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Figure 5-3 Configuring the Power Sensor Channels

AUX Fctn > Power Meter

Measurements

Note: This figure illustrates channel A, but channel B is similar.

Pouer Heter Channel A Setw J‘V P _Connection 7
Channel A Connect.ion Connect.ion Tupe ]
an Settings™ Sl - Enables the power meter
connection type: Sockets
Channel A Channel Power Meter Sackets LAN, VXI-11 LAN, or USB.
Satup® settings'[F] w1 120790 5o
— Note: The VXI-11 softkey is
Chanmel B Power Meter WHI-11 used to communicate
an IF Port remotely with a power meter
5025 / that has a GPIB connector
ia LAN-GPIB gateway.
Chanrel B use va
Setup® / Zero Sensor
- rd -
b, Al‘/

R S

USB U2000A Series Power
Sensors do not require the
sensor to be calibrated.

The MXG uses the USB
U2000A Series Power
Sensor’s “Internal” zero.
Refer to the USB U2000A
Series Power Sensor’s
documentation.

Zero Sensor and
Calibrate Sensor softkeys
are inactive during a
measurement.

Calibrate Sensor

Y

ChA Settings ~#

External Power

Meter Channel
H

Selects the channel on the
external power meter that the
" power sensor is connected to.

Channel Freg
50. 00000000MHz

. Selects the frequency that
channel A has been calibrated to.

Channel Offset
0.000 d&

___Enables a power offset in dB for
the current channel.

Averaoing,
(AULO)

. Enables averaging. Instrument
default is Auto with 1024 points.

Measurement.
Units
| cbm I

Sockets LAN: Sets the
IP port to 5025 (standard)

ChA Connection

Connection Tupe]

or 5023 (telnet)
programming.

(Sockets)
Sets the power meter’s IP

ddress or LAN-GPIB

P%Eegdggggg /gateway’s IP address (Sockets Power Meter
LAN and VXI-11 LAN only). IF Port

( Whether a softkey is available

depends on the selected
/ P . PM WHI-11
Connection Type. Device Name
ada, A gpibl,13
~ ./,,

For details on each key, use key help as
described on see page 42.

VXI-11 LAN: Opens a
menu for entering a
device name for the
power meter being used.
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Example: Dual Power Meter Calibration

In the following example a U2004A USB Power Sensor is connected to channel A and a N1912A
P-Series Power Meter and 8482A Power Sensor are connected to channel B and are zeroed and
calibrated, as required.

On the MXG:
1. Setup MXG for Step Sweep. “Configuring a Swept Output” on page 48.

CAUTION Verify RF Output power is off before continuing.

2. Connecting the Channel A power sensor: Connect USB sensor to MXG. The MXG should display a
message across the bottom that reads similar to:
USB TMC488 device (USB POWER SENSOR,MY47400143) connected

Figure 5-4 MXG Displays Connection to U2000 USB Power Sensor
FREQUEHCY

6.000 000 000 00 &z

‘USB THCL88 device (USB POUER SEHSOR.NYL7L00143) connected | >

3. Press Aux Fctn > Power Meter Measurements > Channel A Setup > Connection Settings > Connection Type >
USB Device (None) > USB POWER SENSOR (MY47400143)

4. Press Return > Zero Sensor

A diagnostic dialog box appears the initial time that a U2000 Series power sensor with a
different serial number is connected to the MXG (refer to Figure 5-5). After the U2000 has been
recognized by the MXG, the U2000 power sensor is saved as a softkey in the instrument and the
dialog box in Figure 5-5 won’t be displayed (press DONE, if you see this message).

Figure 5-5 Diagnostic Dialog Box for USB Sensor

| Dimgnostic Dialog
i

Verifu That the sensor is connected to the Power Meter
Reference or the MXG RF Out

A Running Calibration(s) bar is displayed on the MXG. Refer to Figure 5-6 on page 86.
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Figure 5-6 Running Calibration(s) Bar (Zeroing Sensor)

FREQUEHCY

40.000 000 000 00 &z

RF_OFF

Pouer Heter Measurements

Running Calibration¢s)
S0% complete

| '
For details on
each key, use key
help as described
1 on see page 42.
e
NOTE The U2000 Series USB Power Sensor, does not require a 50 MHz calibration. If a

calibration is attempted with the U2000 Series Power Sensors, the MXG displays a
message reading:

The U2000 series power sensor does not require a 50 MHz calibration. Refer to
Figure 5-7 on page 86.

Figure 5-7 Diagnostic Dialog Box Displayed for U2000 Power Sensor

40 00N NNn 0NN NN - exz

: Dimgnostic Dialog
Pouel

The U2000 series power sensor does not require a 50 MHz oK
calibration

For details on

each key, use key

| help as described
on see page 42.

5. Press Return > Return > Channel A to On

The current power meter sensor reading should be displayed in the ChA portion of the
instrument's display and in the upper right portion of the display under Power Meter. Refer to
Figure 5-8.
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Figure 5-8 Channel A Power Sensor Displayed on MXG

[RE_OFF_|/POYER NETER | Payer leter .~
40.000 000 000 00 &Hz oot gl ) ez )

Chanoel Ay
Setup

Pouer Heter Measurements

Channel B
| Off i

A cusB: nMyL7LODIL3)

-69.81 dBm

50.000 MHz
help as described

— — on see page 42.

6. On the N1912A P-Series Power Meter (Channel B power sensor). Connect the N1912A P-Series
Power Meter to the LAN.

7. Connect the power meter sensor to channel B of the power meter.

Channel B,
Setup

For details on

NOTE It is recommended, but not required to use the channel B on the N1912A. This provides
continuity with the MXG’s dual display. For this example, the U2004A has already used

up the channel A position on the MXG.

8. Connect the power sensor input to the 50 MHz reference of the power meter.
9. Press Channel B Setup
10. Press Connection Settings > Sockets

11. Press IP Address > IP address > Enter

NOTE The IP address of the power meter should be displayed in the ChB section of the display.

Figure 5-9 Channel B Power Sensor with IP Address Entered

FREQUEHCY RF_OFF |/POUER NETER

40.000 000 000 00 &Hz

ChA:—67.01 dEm Chanmel A

0ff iGN

Chanoel Ay
Setup

Pouer Heter Measurements

ChA cuse: nyu7u00113) (\) R O
Channel B,

-67.01 dBm i

50.000 MHz

each key, use key
I help as described
on see page 42.

12. Press Return > Channel Settings > External Power Meter Channel to B
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13. On the MXG: Press Channel B to On and then back to Off again. This initializes the MXG to the
external power meter.

14. Press Return > Zero Sensor

A diagnostic dialog box is displayed each time an external power meter is being used and the
Zero Sensor or Calibrate Sensor softkey is pressed (refer to Figure 5-10 on page 88).

Verify the power sensor is connected to the 50 MHz reference of the power meter.

Figure 5-10 Diagnostic Dialog Box for Channel B

FREQUEHCY RF_OFF |/POUER NETER

40.000 000 000 00 &Hz ENA: -60.80 dEm
: Dimgnostic Dialog
Pouer —

[: Werifu That the sensor is conmected to the Power Meter N

Reference or the MXG RF Out

For details on
each key, use key
50.000 HHz help as described
on see page 42.

15. Press Done
The Running Calibration(s) bar is displayed: Zeroing Sensor Please wait....
16. After Running Calibration(s) bar disappears: Press Calibrate Sensor
Diagnostic Dialog box is displayed that prompts for verifying the connection of the power sensor

to the power meter 50 MHz reference (refer to Figure 5-11 on page 88).

Figure 5-11 Diagnostic Dialog Box for Calibration

RF_OFF

40 00N NNn 0NN NN - exz

: Dimgnostic Dialog
Pouel

Verifu That the sensor is connected to the Power Meter DOME
Reference or the MXG RF Out

For details on
each key, use key

. help as described

T —_— on see page 42.
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17. Press Done

Calibration progress bar is displayed. Refer to Figure 5-12 on page 89.

Figure 5-12 Running Calibration(s) Bar (Calibrating Sensor)

"**%0.000 000 000 00 sz | - 20.00 w1 (.

Pouer Heter Measurements

Running Calibration¢s)
S0% complete
I

For details on
each key, use key
help as described
on see page 42.

18. Press Return > Channel B to On

19. The current power meter sensor reading should be displayed on the MXG in the ChB portion of
the display and in the upper right corner of the display under Power Meter and to the left of the
Power Meter power sensor reading.

Figure 5-13 Channel B Power Sensor Displayed on MXG
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20. The power sensors are now ready to be connected in a measurement setup.
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Using Flatness Correction

User flatness correction allows the digital adjustment of RF output amplitude for up to 1601
sequential linearly or arbitrarily spaced frequency points to compensate for external losses in cables,
switches, or other devices. Using an Agilent N1911A/12A, E4419A/B, or U2000 Series power
meter/sensor to calibrate the measurement system, a table of power level corrections can
automatically be created for frequencies where power level variations or losses occur. Supported
connection types to the power meter/sensor are Sockets LAN, VXI-11 LAN, USB, and GPIB via
VXI-11 LAN using a LAN-GPIB gateway (e.g. Eb810A Gateway or equivalent).

NOTE A power meter with GPIB requires using the Connection Type VXI-11 softkey, as well as a
LAN-GPIB gateway, to control a power meter. Refer to the Agilent Connectivity Guide
USB/LAN/GPIB Connectivity Guide (E2094-90009), Agilent MXG’s FAQs “How do I connect
to the LAN?”, and to the E5810A User’s Guide or equivalent, LAN/GPIB gateway device.

If you do not have an Agilent N1911A/12A or E4419A/B power meter, or U2000A/01A/02A/04A
power sensor, or if your power meter does not have a LAN, GPIB, or USB interface, the correction
values can be manually entered into the signal generator.

To allow different correction arrays for different test setups or different frequency ranges, you may
save individual user flatness correction tables to the signal generator’s memory catalog and recall
them on demand.

Follow the steps in the next sections to create and apply user flatness correction to the signal
generator’s RF output (see page 94).

Afterward, follow the steps in “Recalling and Applying a User Flatness Correction Array” on page 98
to recall a user flatness file from the memory catalog and apply it to the signal generator’s RF
output.
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Figure 5-14 User Flatness Correction Softkeys
For details on each key, use key help

m as described on see page 42.

\/
fAmplitude fAmplitude »["User Flatness
Atten/ALC Ametd Ref Set
Cantrol® 0.00 dBm ngﬁs
AL fmptd Ref i
off Nz O EOT AR
Starts the
Amptd Offset = user
0.00 dB 0o Cal flatness User Flalness
calibration. Freg Start
| » Configure . 00000000000GH=
== [FIEEn Poder MeterF~mSee
Output. Blankin pree o1 9 DDDDDEESSDSESD
. z
B on R
fore 1 of 2 1 p  Tore 2 of 2 # Pointg
\J
FREQUEHCY ANPLITUDE User Flatness /7
1.000 000 000 00 &z | -144.00 den Ineert. Ao
Delete Row
User Flatness: LAST User Flatness
Frequency Correction Confioure
% *0.00 %8 Goto Rode Step Arrau’]
Load Cal Arrad
Load /St.orem From Step Arrad
Preset Lists——Confirm

fore 1 of 2 —— m

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide 91



Optimizing Performance
Using Flatness Correction

Creating a User Flatness Correction Array

In this example, you will create a user flatness correction array. The flatness correction array
contains ten frequency correction pairs (amplitude correction values for each specified frequency),
from 500 MHz to 1 GHz.

An Agilent N1911A/12A or E4419A/B power meter and E4413A power sensor are used to measure
the RF output amplitude at the specified correction frequencies and transfer the results to the signal
generator. (A U2000 Series power meter/sensor could be used in lieu of the power meter and E4413A
power sensor.) The signal generator reads the power level data from the power meter, calculates the
correction values, and stores the correction pairs in the user flatness correction array.

If you do not have the required Agilent power meter, or if your power meter does not have a LAN,
GPIB, or USB interface, you can enter correction values manually.

NOTE On the N5183A, if the setup is using an external leveling configuration, the equipment setup
in “Required Equipment” on page 92 assumes that the steps necessary to correctly level the
RF output have been followed. If you have questions about external leveling, refer to “Using
External Leveling (N5183A Only)” on page 99.

Required Equipment

e Agilent N1911A/12A or E4419A/B power meter (a power meter is not required with the
U2000A/01A/02A/04A Power Sensor)

¢ Agilent E4413A E Series CW power sensor or U2000A/01A/02A/04A Power Sensor
* GPIB, LAN, or USB interface cables, as required

¢ adapters and cables, as required

NOTE For operating information on a particular power meter/sensor, refer to its operating guide.

Connect the Equipment

Connect the equipment as shown in “Connect the Equipment” on page 93.

NOTE During the process of creating the user flatness correction array, the power meter is
remotely controlled by the signal generator.
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Connect the Equipment

e Agilent N1911A/12A or E4419A/B power meter® °
e Agilent U2000A/01A/02A/04A power Sensor?®

LAN, GPIB, or USB interface cables,
as required
¢ adapters and cables, as required

E5810A
LAN/GPIB Gateway

Signal
Generator

RF Output

Input Port

USB port for connecting l
USB—compatible power <~ Cables >
meters/sensors (e.g.

N1911A/12A Power Meters aggv‘i’g;’ir
and U2000A Series USB ~ "
Power Sensors).
Flatness
Corrected
I Output
Out In Power Sensor

Device Under Test

The LAN, GPIB*, and USB connections are
for convenience. If your power meter does
not have LAN, GPIB, or USB, then manually
enter corrections as described in the
correction entry step in this section.

*GPIB control of a power meter requires a
LAN-GPIB gateway and use of the connection type
VXI-11. Refer to the Agilent Connectivity Guide
USB/LAN/GPIB Connectivity Guide (E2094-90009),
Agilent MXG’s FAQs “How do | connect to the
LAN?”, and to the E5810A User’s Guide or
equivalent LAN/GPIB gateway device.

Power Meter
(if applicable)

Note: Agilent U2000 Series
USB Power Sensors connect
directly to the signal generator’s
front panel USB port (i.e. the
power meter is not applicable).

For operating information, refer to the power meter/sensor documentation.
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Figure 5-15 Configure Power Meter Menu Softkeys
AMPTD > More > User

Flatness > Configure Power | Pll GConnection

Meter

\J
[ [:onFiE 7

Connect ion,
Settinas

Connection Tupe

(Sockets)’

Sets the power meter

Power Meter\
IF Address
141.121.16. 143/

gateway'’s |IP address

LAN only).

Fouer Meter
IF Port
S0z

on the selected

Fouer Meter
Channel
ElE

Zero Sensor

Calibrate Sensor

USB U2000A Series Power
Meters do not require the
sensor to be calibrated.

Basic Procedure

1. Create a user flatness array.

a. Configure the power meter/sensor

b. Connect the equipment

c. Configure the signal generator

Connection Type.

s IP
address or LAN-GPIB

" (Sockets LAN and VXI-11

—This softkey is dependant

Connection Tupe #

Sockets

WHI-11

RVt W

Enables the power meter
connection type: Sockets
LAN, VXI-11 LAN, or USB.

Note: The VXI-11 softkey is

used to communicate

remotely with a power meter

that has a GPIB connector
via LAN-GPIB gateway.

Pll_Connection 7

Connection Tupe,
(USE)

USE Device
(Mone

Sockets LAN: Sets the

Fouer Meter
IF Port

or 5023 (telnet)

programming.

PH WRI-11
Device Mame
opib0,13

I IP port to 5025 (standard)

VXI-11 LAN: Opens a

menu for entering a
device name for the
power meter being used.

d. Enter the user flatness correction values

2. Optionally, save the user flatness correction data.

3. Apply user flatness correction to the RF Output.

For details on

each key, use key
help as described

Open a menu
to enter the
USB device
name.

on see page 42.
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Configure the U2000A/01A/02A/04A Power Sensor

1.

Connect the power sensor to the signal generator’s front panel USB port. Refer to “Connect the
Equipment” on page 93.

2. Zero the power sensor using the signal generator softkeys.

CAUTION Verify the signal generator RF Output power is set to the desired amplitude before
performing the power meter zero. No RF Output amplitude check is done by the signal
generator during zero.

NOTE The signal generator’s RF Output LED remains unchanged during zeroing of the power

sensor (e.g. if the RF Output LED was on prior to starting the Zeroing of the power sensor,
the LED remains on throughout the zero/calibration). But, actually the instrument’s firmware
has turned off the RF Output’s power.

For operating information on your particular power sensor, refer to its operation guide.

Configure the E4419A/B and N1911A/12A Power Meter

1. Select SCPI as the remote language for the power meter.

2. Zero and calibrate the power sensor to the power meter, using the softkeys on the signal
generator or the front panel of the power meter.
Enter the power sensor calibration factors into the power meter as required.

4. Enable the power meter’s cal factor array.

NOTE The signal generator’s RF Output LED remains unchanged during zeroing of the power

sensor (e.g. if the RF Output LED was on prior to starting the Zeroing of the power sensor,
the LED remains on throughout the zero/calibration). But, actually the instrument’s firmware
has turned off the RF Output’s power.

For operating information on your particular power meter/sensor, refer to its operating
guide.

Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction Values

Create the User Flatness Array

1.

Configure the signal generator:

a. P

reset the signal generator.

b. Set the signal generator’s connection type to the power meter/sensor:

i

ii.

Press AMPTD > More > User Flatness > Configure Power Meter > Connection Type > connection
type.

If connection type is USB:
1. Zero Sensor

2. Go to step c.
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iii.

else

If Sockets LAN or VXI-11 LAN: Press Power Meter IP Address > power meter’s or LAN-GPIB
gateway IP address > Enter.

If Sockets LAN: Press Power Meter IP Port > IP port > Enter.
else
If VXI-11: Press PM VXI-11 Device Name > device name > Enter.

When connecting directly to the power meter, enter the device name as specified in the
power meter’s documentation. Typically, this is “inst0” and is case sensitive for some
power meters. Refer to your power meter’s documentation, the Agilent Connectivity Guide
USB/LAN/GPIB Connectivity Guide (E2094-90009), and Agilent MXG’s FAQs “How do I
connect to the LAN?”

When connecting via a LAN-GPIB gateway, enter the SICL address of the power meter.
Typically, this is “gpib0,13”, where “gpib0” is the GPIB SICL interface name of the
gateway and “13” is the GPIB address of the power meter. Refer to the Agilent
Connectivity Guide USB/LAN/GPIB Connectivity Guide (E2094-90009), Agilent MXG’s FAQs
“How do I connect to the LAN?”, and to the E56810A User’s Guide or equivalent, LAN/GPIB
gateway device.

Open the User Flatness table editor and preset the cal array:
Press Return > Configure Cal Array > More > Preset List > Confirm Preset with Defaults.

In the Step Array menu, enter the desired flatness—corrected start and stop frequencies, and
the number of points:

Press More > Configure Step Array >

Freq Start > 500 > MHz >
Freq Stop > 1 > GHz >
# of Points > 10 > Enter

Populate the user flatness correction array with the step array configured in the previous
step:

Press Return > Load Cal Array From Step Array > Confirm Load From Step Data.
Set the output amplitude to 0 dBm.

Turn on the RF output.
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2. Connect the power meter to the RF output and enter the correction values:

With a Power Meter Over LAN, GPIB, or USB

i. Create the correction values:
Press More > User Flatness > Do Cal.

The signal generator begins the user
flatness calibration, and displays a progress bar.

The amplitude correction values load
automatically into the
user flatness correction array.

ii. View the stored amplitude correction values:
Press Configure Cal Array.

The user flatness correction array title displays User Flatness:

ii.

iii.

iv.

Vi.

Manually

Open the User Flatness table editor and highlight
the frequency value in row 1:
Press More > User Flatness > Configure Cal Array.

The RF output changes to the frequency value of
the table row containing the cursor.

Note the value measured by the power meter.

Change the sign on the delta value (e.g. the delta
value of the 0 dBm reference value (step f), and the
measured value from i is -.34, change the value to
+.34).

Highlight the correction value in row 1.

Press
Select > enter the delta calculated in step iii > dB.

(e.g. For this example enter +.34)

The signal generator adjusts the output amplitude
based on the correction value entered.

Repeat steps ii — v until the power meter reads 0 dBm.

vii. Highlight the frequency value in the next row.

viii.Repeat steps ii through vii for the remaining rows.

(UNSTORED), without a name,

indicating that the current user flatness correction array data has not been saved to the file

catalog.

Optional: Save the User Flatness Correction Data

1. Press Load/Store > Store to File.

2. Enter a file name (for this example, FLATCAL1) and press Enter.

The user flatness correction array file is now stored in the file catalog as a USERFLAT file. Any
user flatness correction files saved to the catalog can be recalled, loaded into the correction array,
and applied to the RF output to satisfy specific RF output flatness requirements.

3. Press Return.

Enable the Flatness Correction at the RF Output

¢ Press Return > Flatness Off On.

The UF annunciator appears in the AMPLITUDE area of the display, and the correction data in the

array is applied to the RF output.
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Recalling and Applying a User Flatness Correction Array

The following example assumes that a user flatness correction array has been created and stored. If
not, perform the Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction
Values on page 95.

1. Preset the signal generator.
2. Recall the desired User Flatness Correction file:
a. Press AMPTD > More > User Flatness > Configure Cal Array > More > Preset List > Confirm Preset.
b. Press More > Load/Store.
Highlight the desired file.

d. Populate the user flatness correction array with the data contained in the selected file:
Press Load From Selected File > Confirm Load From File.

The user flatness correction array title displays User Flatness: Name of File.

3. Apply the correction data in the array to the RF output: Press Return > Flatness Off On to On.
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Using External Leveling (N5183A Only)

While operating in external leveling mode, if either the RF or the DC connection between
the signal generator and the detector is broken, maximum signal generator power can
occur. This maximum power may overstress a power-sensitive device under test.

Amplitude &

Atten/ALC,,

Atten Hold sets to On and grays out (inactive) with Ext Detector
selection. When re—selecting Internal, the softkey becomes

Control

ALC
Off

Leveling,|
Control

flore 1 of 2

Y

Amplitude V'

Amptd Ref Set
0.00 dem

ﬂﬁtd EEF

Amptd Offset
0.00 de

/

j:jjﬁifjiﬁfiiﬁi

External leveling lets you move the ALC feedback source closer to the device under test (DUT) so

Amptd

Offset
16.00 dB

[_ALC Control /| /
active, but attenuator hold remains on. If desired, manually set it
to off.

Option 1E1 feature—With the Ext Detector selection, Set Atten
> / has no effect on the output power level. During external detector
Sk e use, use the attenuator to keep the ALC power level at
approximately 0 dBm when using negative dBm power levels.
Set ALC Level See page 102.
0.00 dEm
Leveling Hode #
Internal
Leveling v
: Ext Detector
R R
Ext Leveling W

"~ This softkey works with only the Ext Detector selection. It uses
16 dB as its zero reference point.

These settings do not change the output power amplitude of the

MXG, they only let you modify the front panel display amplitude
value so it closely approximates the power level measured at the

output of the coupler/splitter. See page page 106.

that it accounts for most of the power uncertainties inherent to the cabling and components in a test

setup. Refer to Figure 5-16.
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Figure 5-16 ALC Circuity

Signal Generator

Opt 1E1 Output

Attenuator Leveled Output
ALC Modulator (see page 102).
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_ 1 OUTPUT Component orl(Epler_l
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§ [] External Detector

i (Negative output)
ALC Cabling

- \ ®——1 |nternal Detector
Driver

ALC INPUT

The external detector outputs a negative voltage to the signal generator’s rear panel ALC INPUT
connector based on the power level at the detector. As the RF power level at the coupler’s/power
splitter input changes, the external detector returns a compensating negative voltage. The ALC circuit
uses this negative voltage to level the RF output power by raising and lowering the signal’s power,
thus ensuring a constant power level at the point of detection (external detector). Since the point of
detection does not occur at the output of the device to which the detector is connected, there is
some power loss that is not compensated for by the external detector. For example on a coupler, the
coupled port siphons some of the signal’s energy to drive the external detector. In addition the
coupler experiences some insertion loss between the coupled port and the output.

Figure 5-18 on page 102 shows the input power versus output voltage characteristics for typical
Agilent Technologies diode detectors. Using this chart, you can determine the leveled power at the
diode detector input by measuring the external detector output voltage. For a coupler, you must then
add the coupling factor to determine the leveled output power.

When using an external detector, the signal generator’s power range may vary from the values shown
in the data sheet. This is primarily due to the efficiency of the detector. Always ensure that the
detector, coupler/power splitter are specified for the power and frequency range of interest. To
determine the signal generator’s actual power range during external leveling, see “Determining the
Signal Generator’s Amplitude Range” on page 104.

With external leveling, the displayed amplitude value can vary significantly from the actual output
power of the coupler/power splitter to which the external detector is connected (see Figure 5-17).
This is because the coupler/power splitter has it own signal characteristics (insertion loss, coupling
factor, and so forth), which are unknown to the signal generator, so it is typically unable to display
an accurate amplitude value. Also components between the signal generator and the external detector
can affect the output power of the coupler/power splitter. You can compensate for this power display
difference by using the

Ext Leveling Amptd Offset softkey or the Amptd Offset softkey. The difference between the two softkeys is
that the ExtLeveling Amptd Offset functions only while external leveling is active. For more information
on using the external leveling offset feature, see “Adjusting the Signal Generator Display’s Amplitude
Value” on page 106.
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Figure 5-17 Power Value Differences with External Leveling
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Figure 5-18 Typical Diode Detector Response at 25° C

1oV S=== = +20 dBV
==S5== ==+ +10dBV
= = +6 dBV

: S 7

1.0V 7 S=ss == 0dBV
LINEAR ASYMPTOTE = = =: =

7 ~10dBV
=S
I = A o
w =
m 7 |
< 100 mV SQUARE LAW ASYMPTOTE EEE 7 = —20dBY
- =S = == — === e : =
o
>
= S===s =
2 = =t -30dBV
E I EESs 855 Eomes
(o] =7
I 4
o " Es! Tt T T : s
5 10 mV === —— . L] "", -40 dBV
w
s
w
a
-50dBvV
=i §§ T il
1mV H=ee L SIICSTNEERED - -60dBV
i —66 dBV
| _70dBv
== = = === =
Amv i 1 -80dBV
—40 —30 —-20 —10 0 +10 420 +30

DETECTOR INPUT POWER, dBm

Option 1E1 OQutput Attenuator Behavior and Use

When using the internal detector, the Option 1E1 output attenuator enables signal generator power
levels down to —135 dBm at the RF Output connector. It accomplishes this by adding attenuation to
the output signal after the ALC detection circuit. The output power value (shown in the Amplitude
area of the display) is the resultant of the Set Atten and Set ALC Level values (see page 99). With the
external detector selected, the output attenuator no longer attenuates the output signal since the
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feedback for the detection circuit has been moved beyond the output attenuator. Because the
attenuator no longer affects the amplitude of the output signal, the output amplitude is determined
by only the Set ALC Level softkey.

With external leveling selected, the signal generator enables attenuator hold and the power range
approximates the range of a standard option (no attenuator) signal generator (see the Data Sheet).
As stated earlier, the actual output power may vary due to the external detector and the
coupler/power splitter performance characteristics.

NOTE When the internal detector (Internal selection) is reselected, the signal generator does not
turn the attenuator hold off.

Even though the output attenuator no longer affects the output power, it is still useful to drive the
ALC circuit to its mid—-power point of approximately 0 dBm, which is optimal for the internal leveling
circuitry and typically provides the best amplitude flatness results. This is useful with negative power
values of -5 dBm or less. For example, to drive the ALC to approximately mid-power with a —20
dBm power setting, add 25 dB of attenuation. This sets the ALC circuit to 5 dBm (20 + 25).

NOTE If there is too much attenuation, it will drive the ALC circuit too high and cause the signal
generator to go unleveled. Ensure that you decrease the attenuation as you increase the
power level.

Configure External Leveling

Basic Setup Process
¢ If working with a single frequency signal, perform Steps 1 through 5.

e If working with multiple frequencies:
a. Perform Steps 1 through 4.
b. Perform a user flatness correction, see “Using Flatness Correction” on page 90.
¢ If working with a sweep:
a. Perform Steps 1 through 4.
b. Setup the sweep, see “Configuring a Swept Output” on page 48.
Setup the equipment, see “Equipment Setup” on page 103
Configure the carrier signal, see “Configuring the Carrier” on page 104

Select external leveling, see “Selecting External Leveling” on page 104.

L

Determine the output amplitude range, see “Determining the Signal Generator’s Amplitude Range”
on page 104

5. Set the displayed power value, see “Adjusting the Signal Generator Display’s Amplitude Value” on
page 106
Equipment Setup

Set up the equipment as shown in Figure 5-19 on page 104. Place the external detector (detector and
coupler/power splitter) as close as possible to the DUT.
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Recommended Equipment
e Agilent 8474E negative detector
e Agilent 87301D directional coupler

e cables and adapters, as required

Figure 5-19 Typical External Leveling Setup using a Directional Coupler

Negative Detector

ALC INPUT qd P
i T
l shddublddon J .
HEEHAERARRERS RF OUTPUT Leveled Signal
. = ™
Signal Generator Amplifier Coupler

Configuring the Carrier
1. Press Preset.

2. Set the carrier frequency.
3. Set the power level to 0 dBm:

o If the signal generator has no output attenuator (no Option 1E1) or it has Options 1E1 and
532 or 540 installed:

Press AMPTD > 0 > dBm.
* If the signal generator has Options 1E1 and 520, set the output attenuator to zero dBm:
a. Press AMPTD > Atten/ALC Control > Atten Hold Off On to On.
b. Press SetAtten > 0 > dB.
c. Press SetALC Level > 0 > dBm.

Selecting External Leveling

Press AMPTD > Leveling Control > Leveling Mode > Ext Detector.

Determining the Signal Generator's Amplitude Range

The maximum output amplitude is frequency dependent. So if you are using multiple frequency
points and there is a need to know the maximum output amplitude for each frequency point, refer to
the “Amplitude” section of the MXG Data Sheet. Then use this procedure to determine the maximum
amplitude for each band.
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With external leveling and Option 1E1, the signal generator’s the power range approximates that of a
standard option instrument (no Option 1E1). But Option 1E1 does let you use the attenuator to drive
the ALC to its mid-power point when using negative amplitude values. However adding attenuation
does decrease the upper range limit. For more information, see “Option 1E1 Output Attenuator
Behavior and Use” on page 102.

1. If Option 1E1 is installed, adjust the attenuator to the desired level.

NOTE If the Option 1E1 output attenuator value is to high (approximately >55 dB), it will cause an
unlevel condition to occur when the RF output is turned on.

a. Press AMPTD > Atten/ALC Control > Set Atten.
b. Enter the attenuator value.
Turn on the RF output: Press RF On/0ff to On
3. Set the AMPTD step increment value to one dB.
¢ Press AMPTD > Incr Set > 1 > dB.
4. Determine the minimum amplitude value:
a. Set the amplitude to —25 dBM.
b. Using the down arrow key, decrease the amplitude until the UNLEVEL annunciator appears.
c. Using the up arrow key, increase the amplitude until the UNLEVEL annunciator is gone.

The value showing when the UNLEVEL annunciator is gone is the minimum amplitude range
value.

5. Determine the maximum amplitude value:
a. Set the amplitude to a value that does not cause the signal generator to go unleveled.

b. Using the up arrow key, increase the amplitude until it goes unleveled or an error message
indicating that the upper limit has been reached shows at the bottom of the display.

c. Decrease the amplitude value:

e If the unleveled annunciator appeared, decrease the amplitude until the annunciator is
gone. The value where the annunciator disappears is the maximum upper range value.

e If the signal generator displays Error: 501, Attenuator hold setting over range at
the bottom of the display, the value showing is the maximum upper range value.

To remove the error message, press the down arrow key until the message is gone. The
error appears when an attempt is made to increase the amplitude beyond the maximum
value as it relates to the current attenuator setting.
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Adjusting the Signal Generator Display’s Amplitude Value

When using external leveling, the signal generator’s displayed amplitude value will not match the
leveled power of the signal at the output of the coupler/splitter. To compensate for this difference,
the signal generator provides two methods for configuring the displayed power value so that it closely
matches the measured value at the output of the coupler/splitter.

1. Connect and configure a measurement instrument:

a. Connect the output of the coupler/splitter to either a power meter or a signal analyzer.

b. Configure the power meter/signal analyzer for measuring the power level of the signal.

2. Adjust the signal generator’s displayed amplitude value:
If using the ExtLeveling Amptd Offset Softkey:

This softkey uses 16 dB as its zero reference. The 16dB is the coupling factor of the internal
detector.

a.
b.

On the signal generator, press AMPTD > Leveling Control > Ext Leveling Amptd Offset.

While viewing the carrier amplitude value on the signal generator display, use the RPG
knob (detent knob) to adjust the offset value until the integer part of the displayed
amplitude value is the same as the integer portion of the measured value.

Each detent position adjusts the value by 1 dB.

Using the number keypad, make the necessary fractional adjustments to the display
amplitude value.

If using the Amptd Offset Softkey:

On the signal generator, press AMPTD > Leveling Control > More > Amptd Offset.

Calculate the difference between the signal generators displayed Amplitude value and the
measured value.

Using the numeric keypad, enter this difference as the Amptd Offset softkey value.
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Figure 5-20 Power Search and ALC Off Softkeys

Only available when
1/Qis on and I/Q
Source is set to

Pouer Search

Fouer Search
CALLD )|

Optimizing Performance

Using Unleveled Operating Modes

Pouer Search

Auto |

\i

— Auto: The calibration routine executes whenever

Span |

output frequency or amplitude changes.

— Span: Pressing Do Power Search executes the
power search calibration routine once over a

External.
Amplitude &
AttensALC, )| These
Control softkeys are
only active
ALC when an ARB
p— waveforms is
on playing in
memory.

Poner Search,|
(AuULo)

Available only when
ALC = Off

Do Power Search

Hore 1 of 3 ™

For details on each key, use key help
as described on see page 42.

ALC Off Mode

fanual

selected frequency range.
The corrections are stored and used whenever you

tune the signal generator to within the calibrated

Poner Search\
Feferenced
(HModulated)

FF Ouring
Fouwer Search
Minimum

User: Enables the
user to set the
signal generator
frequency settings.

Full: The signal
generator selects
its full frequency
range for the power
search.

Available only when
Power Search Reference 5
Manual

Available only when
Power Search = Span

Pouer Search

Span_Tupe
ﬁ Full

Start Freguency
250, 00000kHz

Stop Freguency
1.00000000000GHz

M‘

frequency range.

Manual: User must explicitly execute a power
search to calibrate the open loop ALC level.

Note:

1) This feature is not available on N5183A.
2) This feature is only available in instruments
beginning with serial number 4818 or greater or

and with Option 099.

Pouer Search

RMS

Fixzed

Manual

Modulated

RN

RMS: Value is a DC
bias equivalent to the
value derived from the
file header or the
calculated value from
the current 1/Q data.
Fixed: Uses a fixed 0.5
Vrms value (Same
value is used with Ext
1/Q data).

Manual: Allows user to
specify the DC bias
voltage value (0-14
Vrms).

Modulated: Uses the
AC bias from the actual
modulating signal.

Turning ALC off deactivates the signal generator’s automatic leveling circuitry, enabling you to
measure the output at a specific point in a test setup and adjust as required for the desired power
level at that point. Turning ALC off is useful when the modulation consists of very narrow pulses
that are below the pulse width specification of the ALC or when the modulation consists of slow
amplitude variations that the automatic leveling would remove.

Set the desired frequency.
Set the desired amplitude.

Turn the RF output on.

A

highlight Off.

Preset the signal generator.

Connect the power meter to the point at which you want a specific power level.

Deactivate the signal generator’s automatic leveling control: Press AMPTD > ALC Off On to
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7. Adjust the signal generator’s amplitude until the power meter measures the desired level.

Power Search Mode

Refer to Figure 5-20 on page 107. Power search executes a routine that temporarily activates the
ALC, calibrates the power of the current RF output, and then disconnects the ALC circuitry.

The four Power Search References control the power search function.

¢ Fixed - Reference level is 0.5 Vrms.

This reference functions with internal, external IQ and bursted signals. This is the instrument’s
default setting.

e RMS - User provided reference level 0-1.4 Vrms placed in the Waveform Header.
This reference functions with internal 1Q and bursted signals.

¢ Manual - User provided reference level 0-1.4 Vrms.
This reference functions with internal, external 1Q and bursted signals.

* Modulated - Uses the I/Q modulation signal as the reference level.

This reference functions with internal or external 1Q. It is not functional with bursted signals or
a signal with varying Vrms.

The RMS and MANUAL references are the most powerful selections. The user provides the reference
level. The IQ signal can be bursted (radar) or have different RMS levels (Wireless Signals). Once the
RMS level is set, the power search runs independent of the current Vrms value of the waveform.

The RMS and MANUAL references, with a reference level of 1.0 Vrms are equivalent to a FIXED
reference and is measured using SINE_TEST_WFM.

The FIXED, RMS, and MANUAL references use a DAC to apply the reference voltage and do not
require the 1Q signal to be present.

CAUTION The minimum reference level that results in a successful power search is dependent on
RF Frequency, RF Amplitude, and Temperature. An MXG power search using a reference
level of 0.1 Vrms for 0 dBm at 1 GHz may fail.

Power Search Settings

For the power search routine to execute, the instrument must be in the following conditions:
¢ The I/Q modulation enabled On.

¢ The RF output enabled On.

¢ The Automatic Leveling Circuitry deactivated (Off).

¢ The RF Blanking set to On.

This function prevents power spikes during the power search (refer to “Using the RF Blanking
Marker Function” on page 160.)

e  When using FIXED, RMS, or MANUAL send zeros (no signal) to the IQ modulator.
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Example: Automatic Power Search
1. Preset the signal generator.

2. Set the desired frequency.

3. Set the desired amplitude.

4. Turn the RF output on.

5. Deactivate the signal generator’s automatic leveling control:
Press AMPTD > ALC O0ff On to highlight Off

Deactivating the signal generator’s automatic leveling control is a significant instrument change
that automatically initiates a power search.

When set to Auto, power search automatically executes when a significant instrument setting changes.
The Do Power Search feature enables you decide when to execute a power search to compensate for
changes, such as temperature drift or a change in the external input.

Using an OQutput Offset, Reference, or Multiplier

Setting an Output Offset

Using an output offset, the signal generator can output a frequency or amplitude that is offset
(positive or negative) from the entered value.

RF Output = entered value — offset value

Displayed Value = output frequency + offset value

To set an offset:

e Frequency: Press Freq > Freq Offset > offset value > frequency unit.
e Amplitude: Press Amptd > More > Amptd Offset > offset value > dB.

Indicates that an offset is on

FREQUENCY ﬁ [
6.000 000 001 00 &z | -143.00 den ‘

Examples

Example | Example | Example

#1 #2 #3 Comments

Parameter

Entered (and displayed) Value: | 300 MHz | 300 MHz | 2 GHz The entered value must be positive.

Offset: 50 MHz | -50 MHz | -1 GHz An offset value can be positive or negative.

The signal generator alerts you if the

Output Frequency: 250 MHz | 350 MHz | 3 GHz output frequency or amplitude is out of range.
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When using the signal generator as a local oscillator (LO), you can use the offset to display the
frequency of interest, as illustrated below:

Antenna tuned to 1321 MHz

RF Amplifier Mixer Filter IF Amplifier

IF Output
IF = 321 MHz 321 MHz
-

&

T Output Frequency = 1000 MHz

Selected Offset Slanal Generator Display
321 MHz 1321 MHz (Antenna Frequency)

Signal Generator —679 MHz 321 MHz (IF Output)
(local oscillator)

Setting an Output Reference

Using an output reference, the signal generator can output a frequency or amplitude that is offset
(positive or negative) by the entered value from a chosen reference value.

RF Output = reference value + entered value

To set a reference:

1. Set the frequency or amplitude to the value you want as the output reference level.

2. Frequency: Press Frequency > Freq Ref Set
The frequency displays 0.00 Hz, indicating that this is the RF output frequency “zero level.”
All frequencies entered are interpreted as being relative to this reference frequency.

Amplitude: Press Amptd > More > Amptd Ref Set
The amplitude displays 0.00 dB, indicating that this is the RF output amplitude “zero level.”
All amplitudes entered are interpreted as being relative to this reference amplitude.

Indicates that a reference is on

FREQUEHCY REF ANPLITUDE REF

0.00 * | ~144.00 ‘
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Examples
Example | Example | Example
Parameter #1 #2 #3 Comments
Reference: 50 MHz 50 MHz 2 GHz A reference value must be positive.

Entered (and displayed) Value:

2 MHz —2 MHz -1 GHz The entered value can be positive or negative.

Output Frequency:

52 MHz 48 MHz 1 GHz The §1gnal .generator alerts you if the output frequency or
amplitude is out of range.

To set a new frequency or
steps above.

amplitude reference, turn the frequency reference off, and then follow the

Setting a Frequency Multiplier

Using a frequency multiplier, the signal generator can display a frequency that is the multiple
(positive or negative) of the output value.

Displayed Value = multiplier value X output frequency

Output Frequency = displayed value + multiplier value

To set a frequency multiplier:

1. Press Frequency > Freq Multiplier > multiplier value > x.

2. Set the desired frequency.

The display equals the

output frequency times the multiplier value.

Indicates that a frequency multiplier is on

FREQUEHCY NULT

600.000 000 00 mz | -144.00 den Frea fof oot
Freq: 600000 000 00 MHZ Incr: 100.00000kHz Fres EﬁF

ANPLITUDE Frequenc!

Freq Offset
0.00 Hz

Freg Multiplier
3.000 %

WWMW
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Examples
Example | Example | Example
Parameter #1 #2 #3 Comments
Frequency Multiplier: 3 -3 4 The multiplier range can be set from:

+0.001 to +1000
-1000 to -0.001

Entered (and displayed) Value: | 600 MHz | -600 MHz | 8 GHz

The signal generator alerts you if the output frequency is

Output Frequency: 200 MHz | 200 MHz 2 GHz out of range.

When using the signal generator as the input to a system, you can set the frequency multiplier so
that the signal generator displays the output of the system, as illustrated below using a doubler:

Signal Generator Doubler
= = Selected Entered/Displayed Signal Generator
Input = 2 GHz X2 Output = 4 GHz Multiplier Frequency Output
2 4 GHz 2 GHz

When measuring mixers, the frequency multiplier and frequency offset are often used together. In the
upconverter example below, the multiplier is set to —1 and the offset is set to 3 GHz so that the
signal generator displays frp.

Mixer

fre = 2200 — 2400 MHz fir = 3000 MHz

T fLo = 800 — 600 MHz

Selected Selected Entered/Displayed Signal Generator

Multiplier Offset Frequency Output (f o)
(fre)
Signal Generator -1 3000 MHz 2200 MHz 800 MHz
(local oscillator) -1 3000 MHz 2400 MHz 600 MHz

Using the Frequency and Phase Reference Softkeys

The MXG can be set to have either a user-determined frequency or phase reference.
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Figure 5-21 Frequency Reference and Frequency Offset Softkeys

FREQUEHCY Frequenc!
6.000 000 000 00 &= Frea Ref Set
HN:GDUOOUOUOUUOGHZ Incr: 1.00000kHZ Fres ﬁF
Freg Offset
0.00 Hz

Freg Multiplier
1.000 =

Freq Channelsk

16,700 22003 1613 Hore 1 of 2 %

Using Free Run, Step Dwell, and Timer Trigger

Free Run, Step Dwell (time), and Timer Trigger can be used to adjust the time spent at any point in
a Step Sweep or a List Sweep. There are two possible measurement combinations:

Free Run with Step Dwell time (Figure 5-22 on page 114) the signal generator waits for the signal to
settle and then waits for the Step Dwell time, then it jumps to the next frequency point. In addition,
the time to complete the entire sweep can vary. There is always a minimum value of Step Dwell for
each frequency point. The minimum Step Dwell timing for any point is fixed at a value of 100 us. The
time between frequency points is the sum of the settling time, plus the Step Dwell time. The settling
time is dependent on frequency, amplitude, band crossings, and other factors, so the time between
frequency points can vary.

Timer Trigger instead of Free Run (Figure 5-22 on page 114) the signal generator generates equally
spaced triggers, and it moves to the next point at each trigger. This has the advantage that the time
between points is consistent and the overall sweep time is consistent. But, if the trigger is too fast,
the signal may not have time to settle before jumping to the next point.

Understanding Free Run, Step Dwell, and Timer Trigger Setup

If the signal is to be settled for a minimum specific time at each point and it is not important if the
point to point time is consistent, use Free Run and SetDwell time.

If the signal’s point to point time requires consistency but the specific settling time at each point can
vary, then use the Timer Trigger. Avoid using too fast of a sweep which does not allow the signal
generator to settle.

If the signal needs to be settled for a specific minimum time and consistent point to point time is
required, then you should set the Timer Trigger to be the sum of the switching time (900 us or 5 ms,
depending on options) plus the minimum settled time that is needed to make the measurement.

If the measurement requires external equipment synchronization, consider using hardware triggers.
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Figure 5-22 Free Run, Set Dwell, and Timer Trigger Softkeys

Sweep > Configure Step

Sweep > More

Step Duell

Use Step Dwell with Free Run when additional measurement wait

2.000 msec

Step Spacin
i |

bt ittt nnin, |

Sweep > More

Sueep/sList &

Configure,
List Sueep

Skeep Trigoer)
(Free Fun)

(Free Fun)

Hore 2 of 3

time is desired after settling.

If the signal is to be settled for a minimum specific time at each point
and it is not important if the point to point time is consistent, use
Step Dwell and Free Run time.

Trigger Setu

Free Run

Trigger Ked If the signal’s point to point time
requires consistency but the

Point Trigger b

specific settling time at each point
Bus can vary, then use the Timer
Trigger. Avoid using too fast of a

sweep which does not allow the

=250 signal generator to settle.

Timer Trigger # If the signal needs to be settled for

Timer Trigger »Trig Timer Period a spegific minimum time and
e Sl e consistent point to point time is

required, then you should set the

Timer Trigger to be the sum of the
switching time (900 us (Option
Lot Nt UNZ) or 5 ms (Standard)) plus the
minimum settled time that is
needed to make the measurement.
Example: If you need the signal to
remain settled for 3 ms, and you
have Option UNZ which settles in
0.9 ms, then set the time trigger to

For details on each key, use key help as described on see page 42. the sum which is 3.9 ms.
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Using LXI (Option ALB only) (Option ALB)

NOTE LXI Class B Compliance Disclaimer

As of this product firmware release in June 2008, LXI Class B Compliance Tests, using the
new [EEE 1588-2008 Precision Time Protocol (PTP), were not available. This product
provides the features of an LXI Class B instrument by adding LAN Triggering and Time
Synchronization to its LXI Class C compliance. References to LXI Class B in the document,
instrument menus and web pages do not insure LXI Class B compliance. This product will
apply for LXI Class B Compliance when the LXI Consortium has approved its specification
changes and can provide certified testing. Refer to http./www.lxistandard.org/home.

LXI-B is only available on instruments with serial prefixes >US/MY/SG4818.

The LXI Standard (LAN eXtensions for Instruments) brings the connectivity of the internet to the
Test and Measurement industry. LXI adds a number of tools that a system integrator may use to
improve the efficiency of his measurements and improve his visibility into his system.

This section assumes the user is well acquainted with LXI terminology and use models. Also, this
section assumes that the user has read and understands the Chapter 3, “Basic Operation.” Refer to
the Programming Guide and to www.lxistandard.org.

Understanding LXI Clocks

In the simplest test system, one Personal Computer (PC) connects to one LXI instrument through
LAN. The PC has its own internal or browser clock and the LXI instrument has two clocks: the
Operating System Clock (MS Windows, Windows CE, VX Works, etc.) and the PTP clock. This is
shown in the following illustration.

Figure 5-23 LXI PC with Clock (Browser Clock) and MXG (Operating System Clock and PTP Clock)

Master Clock GrandMaster
Clock

[a[u]u]s]u]

PC with clock
(Browser clock) LXI Instrument includes Operating
System clock and PTP clock
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The PC browser clock shows the local civil time using a standard Date/Time representation. If the PC
is connected to a Network Time Protocol (NTP) server (through LAN), then its time will be relatively
accurate. However, because the PC may be in a different time zone or have a different Daylight
Savings Time offset (or both) than the instrument, it is possible for the PC Browser clock to have a
different time than the Instrument's Operating System (OS) clock.

The LXI instrument has two clocks. The instrument's Operating System clock, similar to a PC's
browser clock, shows civil time in a Date/Time format. The second clock is the instrument's PTP
clock. It is this clock that synchronizes to the Master Clock (if one is in the system). Typically, this
PTP clock shows time in elapsed seconds since its epoch.

As you create larger systems by adding more LXI instruments, the total number of system clocks
increases significantly. In addition to instrument clocks, you may have PTP Master clocks and a PTP
GrandMaster clock. Also, you may have one or more Boundary Clocks in your test system. Boundary
Clocks will have both Master and Slave clocks depending on the port.

NOTE The concept of local clock or local time can be confusing depending on your frame of
reference. For example, if you think of yourself in front of the PC, then local is the Browser
clock. If you think of yourself in front of the instrument, then local is the instrument. In
most test systems, the PC and the instrument are located close together. But, in some test
systems they may be located many miles apart, in different timezones, or even across an
ocean. Also note that the SCPI uses local in the context of the instrument OS clock.
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Getting Started With LXI

The following configurations provide the basic functionality of the LXI softkeys.

NOTE Enabling the LXI subsystem effects switching speed.

For optimal switching speed, disable the LXI subsystem when not in use.

Figure 5-24 Configuring the LXI subsystem

Utility > More ———»| Utility 7
LXI-EM
Serviced
\J
FREQUEHCY RE_OFF LATB Enables or disables the LXI
6.000 000 000 00 &z LKI-E Enabled subsystem. NOTE: LXI
. aff On/Off setting is persistent.
PTP Domain Sets the Precision Time
LXI Status Information \_ D Protocol Domain.
LHI-B State:  On SYERS (MK Sets the LXI Event Domain.
PTP Clock Domain: O
Event. Domain: u]
Grandmaster Clock: 016b0c000024% Conf igure
Master Clock: 016b0c000024 LHI Ewents’|
Route Connectorss—Page 49

Enabling the LXI-B subsystem (On) opens the Status Information window where the
PTP and Event Domain are configured. The Grandmaster and Master Clocks are
controlled by remote commands only.

\i

LXT-B Events

Configure LXI |8
Trioger Eventa*f— Pag9® "8

Confioure LKIWL  page 119
For details on each key, use key help Refer to the Programming Guide and the SCPI Command Reference. Output Events
as described on page 42.

Sny
—h
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Figure 5-25 Configuring LXI Trigger Input Events
Utility > More > LXI

v

LAT-B
LHXI-B Enabled
on

FTP DDrnaiB page 117 T7i-h Toenis

Configure LI

Event. Domain Trigoer Events

Configure LKI| page 119
Configure, _ Output. Events )
L¥I Events =

S,
Route Connectorsk—— Page 49
\J
FREQUEHCY RF_OFF Input Events

6.000 000 000 00 = e I v o

Input Events

These are the pre—defined default input LAN event identifiers and can not be deleted.
An incoming LAN event is treated as a trigger. The trigger event identifier must be
enabled (On) and the LXI LAN (page 49) selected as the source of the trigger.

For details on each key, use key help Refer to the Programming Guide and the SCPI Command Reference.
as described on page 42.
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Utility > More > LXI

v

LAT-B
LHXI-B Enabled
TN On
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Internal Status Events

Select Source

Operat ionCome lete

Indicates whether or
not a measurement
operation is underway.

Indicates that the

PTP Domain page 117 instrument is
0 settling.
Event. DDrnaiB : Settling>
= Sueeping Indicates whether
Comfioure )l 5 : ) or not the
L¥T Events] LAI-B Events \instrument is
Configure LXI Haiting sweeping the LO.
Foute Conmectorerl— Page 49 Trigger Events”| page 118 For Trigger
Configure LXI \Indicates the
Output Events” A instrument is
waiting for a
— o d trigger.
FREQUENCY Sl cibls Enables or
6 000 000 000 00 GHz Toogle disables the
Q Euent. State instrument event
] LANO — LAN7
Select Sourcek
Select Orivek
These are the pre—defined default outgoing LAN event identifiers and can not
be deleted.
The generation of an outgoing LAN event is dependant on the LAN event Y Disables the LAN

identifier being enabled (On) and the occurrence of one of the Internal Status

Events. The signal state of the outgoing LAN event can be the same as or
inverted from the source internal status event.

For details on each key, use key help

as described on page 42.

Select Drive

Off

Mormal

Hired-0r

i

event.

Typical operation
where both edges
of the instrument
event are
transmitted.

Only one edge of
the instrument
event is transmitted

Refer to the Programming Guide and the SCPI Command Reference.
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For More Information

For more information on using LXI see the Agilent website dedicated to LXI instrumentation:

www.agilent.com/find/lxt.

Agilent LXI Application Notes:

Using LXI to go beyond GPIB, PXI and VXI (AN 1465-20)

10 Good Reasons to Switch to LXI (AN 1465-21)

Transitioning from GPIB to LXI (AN 1465-22)

How to Use VXI and PXI in Your New LXI Test System (AN 1465-23)
Using Synthetic Instruments in Your Test System (AN 1465-24)
Migrating system software from GPIB to LAN/LXI (AN 1465-25)
Modifying a GPIB System to Include LAN/LXI (AN 1465-26)
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Using a USB Keyboard

You can use a USB keyboard to remotely control the RF output state, the modulation state, and to
select a memory sequence and register.

The register selection, RF output state, and modulation state are affected by power cycle or preset,
but the USB keyboard control state and the sequence selection are not.

CAUTION To avoid the loss of data, GPIB settings, or current user instrument states that have not
been permanently saved to non-volatile memory, the MXG should always be powered
down either via the MXG's front panel power button or the appropriate SCPI command.
MXG's installed in rack systems and powered down with the system rack power switch
rather than the MXG's front panel switch display a Error —-310 due to the MXG not being
powered down correctly.

USB Keyboard Key Signal Generator Function

Delete, Enter RF On/Off
¢ Insert Mod On/Off
fecall State Home, Up Arrow Next Sequence
RECALL Reg End, Down Arrow Previous Sequence
Page Up, Right Arrow, + Recall Next State Register
E=lEEE Seqé Page Down, Left Arrow, — Recall Previous State Register
Oelete
SeqC0] ReglO01*
Oelete All
Regs in SeqCO1”
——— FREQUEHCY AAPLITUDE Auto Recall
elete
Seainces" 6.000 000 000 00 &z | -144.00 e Next. SED
NMore 1 of 2
Y Prev SEQ
SEQ- REG——MOD RF
Auto Recallyp———
Prewv FREG
A“\“‘\“'\"‘h~ I . lE::'
USE keuboard
Control
on

Turning the USB keyboard control off disables the USB
keyboard; it has no effect on the Auto Recall softkeys.

For details on each key, use key help as described on see page 42.
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Using a USB Keyboard
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6 Using Pulse Modulation (Option UNU or UNW)

NOTE For the N5161A/62A the softkey menus and features mentioned in this guide are only
available through the Web-Enabled MXG or SCPI commands. For information on the

Web- Enabled MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI
Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting the power level and frequency, refer to

Chapter 3, “Basic Operation,” on page 41 and familiarize yourself with the information in that
chapter.

* Pulse Characteristics on page 125
e The Basic Procedure on page 127
* Example on page 127

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide 123



Using Pulse Modulation (Option UNU or UNW)

Figure 6-1 Pulse Softkeys

Pulse Source

Square
Pulse Source
¢ Free-Run Gated
Pulse page 127
— Triggered page 127 Ext Pulse
an
Adjustable
Fulse Sour“ce’ o Doublet
(Free-Fun) >
Pulse Period Trigger Doublet
L.00 usec
Bulse fore 1 of 2
Pulze Oelay = -
0.00000000  sec These softkeys are Trig Dut BHC Low = settled
only available when i
Pulse Width thet tP u'IAsg—Sthce Is Sueep Trig Out Latency from the external
2.00 usec Wi SDeout?Iet Justable pulse input to the pulse
e i ’ tput =~ 50— .
llore 1 of 2 - Ulégégpg%r?% Source Settled ‘S;II:;:U puP od 60ns
Irwert See also, page 15 50I ns >§I8°ns
Determines the type of signal and page 19 20 <50
transmitted out of the Trig Out BN&_ Ext Polarity | Pulse Sunc ns  <30ns
Normal = high state. Tnvert
Invert = low state. Rout.e{ Connectors Sueep Out BHC 7
» > Route To Pulze Wideo
Route Connector: > Trig Out ENCH - * Sueep Out
O T e (Sweep Trig Out)
Hore 2 of 2 %
Determines how the signal generatol 5 ng%eaﬁg B8 (iberen gl g Satt led
responds to an external pulse signal. Heep Ll L4 ——— > ource settle
Normal = high state. USEED @) fore 1 of 2 \
Invert = low state. Foute To
v W /(Euent 1 BrEY \ Pulse Video
(Marker 13 Trig Out BHC 7|
A“'-r
é Aux Pulse Gen \

These
softkeys are
only available
for the
N5182A.

Select which marker to

route to the Event 1 BNC.

For details on each key, use key help
as described on page 42.

farker 1

Marker 2

Marker 3

Marker L

"‘\.qu\/‘.

A SR
/ NV

This is the 2nd page of N

the Menu.

N

Marker 1

Marker 2

Marker 3

Marker L

M\

TTL signal

Select the signal
routed to each
output connector.

Select which
marker to
route to the
Trig out BNC.

These
oftkeys are

only available
for the
N5182A.
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Using Pulse Modulation (Option UNU or UNW)
Pulse Characteristics

Pulse Characteristics

NOTE When using very narrow pulses that are below the signal generator’s ALC pulse width
specification, or leveled pulses with an unusually long duty cycle, it is often useful to turn
ALC off (see page 107).

Pulse Source Type Period® Width & Delay® Uses Trigger Event®
Square Internal free run pulse train with Determined by . .
q 50% duty cycle. user defined rate.
Free Run Internal free run pulse train User Defined User Defined —
(default)
Triggered Internal pulse train — User Defined v
User Defined:
First pulse is relative to the
Adjustable Two internal pulse trains for each o rising edge of trigger signal. v
Doublet trigger event. Second pulse is relative to the
rising edge of first pulse.
See Figure 6-2 on page 126
The first pulse follows the
. . . trigger signal.
Trigger Two internal pulse trains for each - v/
Doublet trigger event. Second pulse is user defined.
See Figure 6-3 on page 126
Gated Internal gated pulse train — User Defined v
External External pulse signal at the rear - - -
panel Pulse connector

3All delays, widths, and periods have a resolution of 10 ns.
ba signal at the rear panel pulse connector must be held high for at least 20 ns to trigger an internally generated pulse.

Rear panel inputs are described on page 15

External pulse input

R;‘?#T O BWEEP QUT AM m PULSE TRIG IN TRIG QUT REFIN 10MHz OUT O
(e ] GhiE

@] DDCHJDICHJDQDDDDO ©0 @:D:D@@Cﬁ
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Pulse Characteristics

Figure 6-2 Adjustable Doublet

External
Trigger

RF Output

'<¢—— Delay —»-'<4—— Width —»

Pulse 1 ' Pulse 1

The delay of the first pulse is measured from ~

the leading edge of the external trigger signal.

Pulse 2

Pulse 2

'€«— Delay —————P'€—— Width ——»,

The delay of the second pulse is

measured from

the leading edge of the first pulse.

Figure 6-3 Trigger Doublet

External
Trigger

RF Output

The first pulse follows the
external trigger signal.

Pulse 1 . Pulse 1
~€—— Delay —p»-+—— Width ——P

The delay of the second pulse is measured from
the leading edge of the external trigger signal.
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Using Pulse Modulation (Option UNU or UNW)
The Basic Procedure

The Basic Procedure

1. Preset the signal generator.
2. Set the carrier (RF) frequency.
3. Set the RF amplitude.
4. Configure the modulation:
a. Set the pulse source: Press Pulse > Pulse Source > selection

b. Set the parameters for the selected pulse source:

Square Free Run (default) | Triggered | Adjustable Doublet | Trigger Doublet Gated External
Pulse Rate — — — — - _
— Pulse Period — — —_ Pulse Period —_
— Pulse Delay Pulse Delay | Pulse Delay Pulse Delay — —
— Pulse Width Pulse Width | Pulse Width Pulse Width Pulse Width —_
— — — Pulse 2 Delay — — —
— — — Pulse 2 Width —_ —_ —_

5. Turn on the modulation: Pulse Off On softkey to On.
The the PULSE annunciator lights, indicating that you enabled modulation.
6. Output the modulated signal from the signal generator: Press the front panel RF On Off key.
The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

See also, “Modulating the Carrier Signal” on page 61.

Example

The following example uses the factory preset pulse source and delay.
Output: A 2 GHz, 0 dBm carrier modulated by a 24 us pulse that has a period of 100 pus.

Preset the signal generator.

Set the frequency to 2 GHz.

Set the amplitude to 0 dBm.

Set the pulse period to 100 microseconds: Press Pulse > Pulse Period > 100 > usec.

Set the pulse width to 24 microseconds: Press Pulse > Pulse Width > 24 > usec

S o o

Turn on both the pulse modulation and the RF output.
The PULSE annunciator displays and the RF output LED lights.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output”
on page 310.
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Example
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1 Basic Digital Operation—No BBG Option Installed

NOTE For the N5162A the softkey menus and features mentioned in this guide are only available
through the Web-Enabled MXG or SCPI commands. For information on the Web- Enabled
MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI Command
Reference.

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting power level and frequency, refer to Chapter
3, “Basic Operation,” on page 41 and familiarize yourself with the information in that chapter.

See also “Adding Real-Time Noise to a Dual ARB Waveform” on page 243.
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1/Q Modulation

1/Q Modulation

The following factors contribute to the error vector magnitude:
¢ Differences in amplitude, phase, and delay between the I and Q channels
e DC offsets

The I/Q menu provides adjustments to compensate for some of the differences in the I and Q signals
or to add impairments.

See also “Modulating the Carrier Signal” on page 61.

Figure 7-1 1/Q Display and Softkeys

I/Q This panel displays the current status and settings
This panel displays the external of the 1/Q adjustments. Grey text indicates I/Q
1/Q signal routing. adjustments are off.
FREQUEHCY ANPLITUDE

6.000 000 000 00 &z | -144.00 e Ig;ﬂ

I/0 Adjustments
(134

I/0 Routing & Optimfzation I/0:  Off /
/

I1/0 Adjustments
I/0 Adjustments
0n

02/10/2006 1L:12

External Input
I Offset
0.000 W

External Input
0 Offset

Sets the dc offset

Quadrature
Anole ﬂdjustnﬁn%

For details on each key, use key help
as described on page 42.

Offsets the phase of the Q signal relative to the phase of the

| signal. The quadrature adjustment key is in units of
degrees. This adjustment is not calibrated.

The following table shows common uses for the adjustments.
Table 7-1 1/Q Adjustments Uses

I/Q Adjustment Effect Impairment
Offset Carrier Feedthrough dc offset
EVM error phase skew

Quadrature Angle

I/Q Images I/Q path delay
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Basic Digital Operation—No BBG Option Installed
1/Q Modulation

Configuring the Front Panel Inputs

The Agilent MXG accepts externally supplied analog I and Q signals through the front panel I Input
and Q Input for modulating onto the carrier.

1. Connect I and Q signals to the front panel connectors. For voltage levels, refer to “Front Panel
Overview — N5181A/82A MXG” on page 5.

a. Connect an analog I signal to the signal generator’s front panel I Input.
b. Connect an analog Q signal to the signal generator’s front panel Q Input.
Turn on the I/Q modulator: Press 1/Q 0ff On to On.

3. Configure the RF output:
a. Set the carrier frequency.
b. Set the carrier amplitude.
c. Turn the RF output on.

4. Make adjustments to the I/Q signals (page 130) as needed.
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1/Q Modulation
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8 Basic Digital Operation (Option 651/652/654)

NOTE For the N5162A the softkey menus and features mentioned in this guide are only available
through the Web-Enabled MXG or SCPI commands. For information on the Web- Enabled
MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI Command
Reference.

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting power level and frequency, refer to Chapter
3, “Basic Operation,” on page 41 and familiarize yourself with the information in that chapter.

The features described in this chapter are available only in vector signal generators with Option 651,
652, or 654.

* Waveform File Basics on page 134

* Storing, Loading, and Playing a Waveform Segment on page 136
*  Waveform Sequences on page 139

* Saving a Waveform’s Settings & Parameters on page 143
e Using Waveform Markers on page 149

e Triggering a Waveform on page 166

* C(Clipping a Waveform on page 173

* Scaling a Waveform on page 182

* Setting the Baseband Frequency Offset on page 188

* I/Q Modulation on page 192

* Using the Equalization Filter on page 198

e Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter on page
200

* Modifying a FIR Filter Using the FIR Table Editor on page 206
* Setting the Real-Time Modulation Filter on page 210
e Multiple Baseband Generator Synchronization on page 211

*  Understanding Option 012 (LO In/Out for Phase Coherency) with Multiple Baseband Generator
Synchronization on page 218

e  Waveform Licensing for Firmware Version 3 A.01.50 on page 222

e Waveform 5-Pack Licensing (Options 221-229) for Firmware Version < A.01.50 on page 230

See Also:
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Waveform File Basics

¢ Adding Real-Time Noise to a Dual ARB Waveform on page 243
¢ Real-Time Phase Noise Impairment on page 252

¢ Multitone and Two-Tone Waveforms (Option 430) on page 289

Waveform File Basics

There are two types of waveform files:
* A segment is a waveform file that you download to the signal generator.
For information on creating and downloading waveform files, refer to the Programming Guide.

* A sequence is a file you create in the signal generator that contains pointers to one or more
waveform files (segments, other sequences, or both).

For information on creating sequences, see page 139.

Signal Generator Memory

The signal generator has two types of memory:

* Volatile memory, baseband generator (BBG) media, where waveform files are played from or
edited.

*  Non-volatile memory, either internal (int) or external (USB) media, where waveform files are
stored.

Dual ARB Player

NOTE The MXG’s ARB Waveform File Cache is limited to 128 files. Consequently, once the 128 file
cache limit has been reached, the waveform switching speed will be much slower for
additional files loaded into the volatile waveform memory (BBG).

The dual ARB waveform player enables you to play, rename, delete, store, and load (external or
internal) waveform files in addition to building waveform sequences. The dual ARB waveform player
also provides markers (page 149), triggering (page 166), clipping (page 173), and scaling (page 182)
capabilities.

Most procedures in this section start from the Dual ARB menu, shown below.
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Basic Digital Operation (Option 651/652/654)

Waveform File Basics

If you set the ARB sample clock when the dual ARB

is off, the new setting is applied when the dual ARB

player is turned on; this setting survives toggling

Figure 8-1 Dual ARB Softkeys
Arb Setué &
Arb Note: This is the ) el (B
] b Sample Cloc
opp [ fiotoftwo 125 HB00000G0MAZ
D on rb menus. the Dual ARB player off and on.
Mode =
Feal-Time AWGM
Setup™ page 243
uastornr] P29 13 -
J‘ Friase Noﬁigg%&zﬁ' page 182
Nodulation Hode ARE Setupk >
- Funt.ime Scaling
Dual AREYE—P IEigger Tgpe' ( 70.00 % )— page 182
ont inuos ,
Free Run.
age 166 Modulator Atten
Eustom, pag 27.13 o8
ARBE Manual
__fore 1 of 2 %
Hore 1 of 2 These softkeys are
T only available in
the Dual ARB’s
T Arb Setup menu.
Homlene Arb Setup #
—
g requency )
Multitonew 0.000 be page 168
fore 1 of 2 \
Arb
Haveform, age 13
sequences"] o0 . page 191
Laveform, i
Utilities"| MLt BBGSE%BE;-» page 211
(OffD
Marker Real-Time
Utilities Modulation Filters— page 211
(Muguist.)
N L —
Note: This is second of Utiﬁ?i‘gg' — page 14 R
two Arb menus.

Arb_Markers

Marker Polaritus

Marker Routing

Set Markerss

Fioute Connectorss—page 49

For details on each key, use key help

as described on page 42.

age 14

IFN Utilities 7

Eég,t:v— page 17

Scale Haveform
ata'T— page 182

Clippin
(lIE?m%‘y— page 17

S-Pack

Licensingk— Page 230

waah a P

Available with

N5162A/82A opt 22x.
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Storing, Loading, and Playing a Waveform Segment

Storing, Loading, and Playing a Waveform Segment

NOTE The MXG’s ARB Waveform File Cache is limited to 128 files. Consequently, once the 128 file
cache limit has been reached, the waveform switching speed will be much slower for
additional files loaded into the volatile waveform memory (BBG).

Before using this information, you should be familiar with the signal generator’s file menus. If you
are not, refer to “Working with Files” on page 63 and familiarize yourself with that information.

See also: “Waveform Sequences” on page 139.

The signal generator has two types of waveform media: non-volatile (internal or USB), and volatile
(BBG). BBG media is also called “working” media, because before you can play, edit, or include a
waveform file in a sequence, the waveform file must be loaded into BBG media.

Figure 8-2 Waveform Segment Softkeys

Note: When a sequence is selected, this key name

Mode R page 149 ——changes to Show Waveform Sequence Contents.
Arb Select Haveform
GRE Gem=) Arb Segments .~
I On
Display Waveform Sty Arb Segments .~
And Markers”| = ore
Nodulation Hode Selact
Laveform® > Rername Seament.
Load Segment
Dual AREYE—S- Hovofor =1 From Irt Hedi
ARE Setupk Goto Fowe
EUSEQE' From Ihgaﬁegié Text Entry
Trigger Tupe
(Cont inuous , M M‘\‘ Enter
RS [V Goto Rode Delete Seoment
Oelete ALl Clear Text
Tho-TaneM —— Segments Onw
fore 1 of 2 Int Media
fore 1 of 2
Multitonek I Ml Replace
:ﬂore 1 of 2 ° These keys change to indicate the default media. Show Alpha Table
For information on selecting the default media, Off
see page 74.
FBCDEFGHIJKELR
For details on each key, use key hel Use the arrow keys or knob to HOPORSTUUHXEYZ
as described on page Zz. ynee highlight a letter or character. ————®fl u—$&8#+L1

Loading a Waveform Segment into BBG Media

Waveforms must reside in BBG media before they can be played, edited, or included in a sequence.
Cycling power or rebooting the signal generator deletes the files in BBG media.

NOTE Each time the instrument powers up, two factory-supplied segments are automatically
created in BBG media: RAMP_TEST WFM and SINE TEST WFM.

There are additional sample waveforms that are available in the internal storage and that
can be loaded into memory. Refer to www.agilent.com and search on “Factory Default
N5182A” and “waveforms”.

1. Press Mode > Dual ARB > Select Waveform > Waveform Segments.
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Storing, Loading, and Playing a Waveform Segment

2. Press Load Store to highlight Load, then, using the arrow keys, highlight the desired waveform
segment.

3. If there is already a copy of this segment in the currently selected media and you do not want to
overwrite it, rename the waveform segment before you load it (refer to the previous procedure).

4. Press Load Segment From currently selected Media.

To load all files from the currently selected media into BBG media, press
Load All From currently selected Media.

Storing/Renaming a Waveform Segment to Internal or USB Media

Use the following steps to store a copy of a file in BBG memory to the currently selected media
(page 74). If you have not downloaded a waveform segment, either refer to the Programming Guide,
or use one of the factory-supplied segments.

1. Press Mode > Dual ARB > Select Waveform > Waveform Segments.

2. Press Load Store to highlight Store.

3. Using the arrow keys, highlight the waveform segment you want to store.
4. Optionally, rename the segment.

If there is already a copy of this segment in the currently selected media and you do not want to
overwrite it, rename the waveform segment before you store it:

a. Press More > Rename Segment > Clear Text.

b. Enter a name for the waveform segment.

c. Press Enter > More.

d. Highlight the waveform segment that was renamed.

Press Store Segmentto currently selected Media.
6. Repeat Step 3 through Step 5 for all segments that you want to store.

To save all segments from BBG media to the currently selected media, press
Store All to currently selected Media.

Playing a Waveform Segment

1. Press Mode > Dual ARB > Select Waveform.

2. In the Segment on BBG Media column, highlight the waveform segment you want to play.
3. Press Select Waveform.

4. Set ARB 0ff On to On.

This plays the selected waveform segment. Both the I/Q and ARB annunciators turn on, and the
waveform modulates the RF carrier.
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Annunciators display with active waveform (ARB On)

[T/0] nRE |
~——

Select
ARB |Selected Laveforn: WFML:RANP_TEST_LFH | il
[]n e Eeck 25T ARE Setup

¥ L N

Current waveform selection

5. Configure the RF Output:
Set the RF carrier frequency and amplitude, and turn on the RF output.

The waveform segment is now available at the signal generator’s RF Output connector.
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Waveform Sequences

Figure 8-3 Waveform Sequence Softkeys

Sequence name
To display this softkey, select a waveform sequence.
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For details on each key, use key help
as described on page 42.

A waveform sequence is a file that contains pointers to one or more waveform segments or other
waveform sequences, or both. This lets the signal generator play multiple waveform segments, or
other sequences, or both thereby eliminating the need to stop waveform playback just to select
another waveform.

The segments that a waveform sequence points to are not automatically stored when you store the
sequence; you must also store the individual segments or they are lost when you turn off or reboot
the signal generator. If the segments are located in internal/external media, you must load them into
BBG media prior to selecting a waveform sequence (see page 136). If you attempt to play a sequence
without the segments loaded into BBG media, the signal generator reports: ERROR: 629, File
format invalid. If this happens and the segments are not stored in internal/external media, you
must recreate the segments using the same file names that the sequence points to before you can
play the sequence.
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Creating a Sequence

A waveform sequence can contain up to 1,024 segments and have both segments and other sequences
(nested sequences). The signal generator lets you set the number of times the segments and nested
sequences repeat during play back. But there is a difference between repeating a segment versus
repeating a nested sequence. Each segment can repeat up to 65,5635 times, but no matter how many
times a segment repeats, it counts as a single segment. However each repetition of a nested sequence
counts as additional segments.

—Segment 1
Sequence A — 2 segments
L Segment 2
Waveform 11 segments
Sequence __ Sequence AN\ , Segments
Sequence B —| repeated 4x 9 segments

L—Segment 3

The maximum number of times that a nested sequence can repeat is based on the number of
segments in the nested sequence and the remaining number of allowed segments (1,024). For
example, with a sequence that contains 24 segments and one nested sequence with 4 segments, the
nested sequence is limited to 250 repetitions:

24 + (4 x 250) = 1,024 maximum number of segments per sequence

Even though there is a limiting factor on the maximum number of times that a nested sequence can
repeat, each segment within the nested sequence can repeat up to 65,535 times.

Example

Use the following procedure to create and store a waveform sequence using one repetition each of
two different segments.

Assumption: The waveform segments are in BBG media (volatile memory). For information on loading
waveform segments into BBG media, see page 136.

1. Select the first segment:

a. Press Mode > Dual ARB > More > Waveform Sequences > Build New Waveform Sequence > Insert
Waveform.

b. Highlight the desired waveform segment and press Insert.
2. Select the second segment:
a. Highlight the next desired waveform segment and press Insert.

b. Press Done Inserting
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3. Name and store the waveform sequence to the Seq file catalog:
a. Press More > Name and Store.

b. Enter a file name and press Enter.

See also, “Viewing the Contents of a Sequence” on page 141 and “Setting Marker Points in a
Waveform Segment” on page 156.

Viewing the Contents of a Sequence

There are two ways to view the contents of a waveform sequence:

Through the Waveform Sequences Softkey
1. Press Mode > Dual ARB > More > Waveform Sequences.

2. Highlight the desired sequence.

3. Press Show Waveform Sequence Contents.

Using the Select Waveform Softkey
1. Press Mode > Dual ARB > Select Waveform.

2. In the Sequence On column, highlight the desired waveform sequence.

3. Press Show Waveform Sequence Contents.

Editing a Sequence

When editing a waveform sequence, you can:

* change the number of times each segment or nested sequence plays

¢ delete segments or nested sequences from the sequence

* add segments or nested sequences to the sequence

* toggle markers on and off (described on page 162)

e save changes either to the current waveform sequence or as a new sequence

If you exit the sequence editing menu before saving changes, the changes are lost.

Sequences save to the Seq file catalog.

CAUTION If you edit and resave a segment used in a sequence, the sequence does not
automatically update the RMS value in its header. You must select and update the
sequence header information (page 143).

Use the following steps to edit a sequence that has two different segments so that the first segment
repeats 100 times and the second segment repeats 200 times, then save the changes.

Assumption: A waveform sequence that has two different segments has been created and stored (see
previous example on page 140).

1. Select the sequence:
Press Mode > Dual ARB > More > Waveform Sequences > highlight the desired sequence >
Edit Selected Waveform Sequence.
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2. Change the first segment so that it repeats 100 times:
Highlight the first segment entry and press Edit Repetitions > 100 > Enter.

The cursor moves to the next entry.

3. Change the repetition for the selected entry to 200:
Press Edit Repetitions > 200 > Enter.

4. Save the changes made in the previous steps:
Press More > Name and Store > Enter.

To save the changes as a new sequence:

a. Press More > Name and Store > Clear Text.
b. Enter a file name (for example, SINE100+RMP200).
c. Press Enter.

The edited sequence saves as a new waveform sequence.

Playing a Sequence

If you have not created a waveform sequence, refer to “Creating a Sequence” on page 140.

NOTE To play a waveform segment individually or as part of a waveform sequence, the segment
must reside in BBG media. See also, “Loading a Waveform Segment into BBG Media” on
page 136.

1. Select a waveform sequence:
a. Press Mode > Dual ARB > Select Waveform.

b. Highlight a waveform sequence (for this example, SINE100+RMP200) from the Sequence On
column.

c. Press Select Waveform.

The display shows the currently selected waveform (for example, Selected Waveform:
SEQ:SINE100+RMP200).

Annunciators display with active waveform (ARB On)

FREQUEHCY DE
2000 000 000 'A!_‘ Off
[T/0] nRE |
Select
HaveFarm®
ARE Setupw

Ir‘igger W

Current waveform selection

2. Generate the waveform:
Press ARB Off On to On.

This plays the selected waveform sequence. During the waveform sequence generation, both the
I/Q and ARB annunciators turn on, and the waveform modulates the RF carrier.
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3. Configure the RF output:

a. Set the RF carrier frequency.
b. Set the RF output amplitude.
c. Turn on the RF output.

The waveform sequence is now available at the signal generator’s RF OUTPUT connector.

Saving a Waveform'’s Settings & Parameters

This section describes how to edit and save a file header. When you download only a waveform file
(I/Q data, which the signal generator treats as a waveform segment), the signal generator
automatically generates a file header and a marker file with the same name as the waveform file.
Initially the file header has no signal generator settings saved to it, and the marker file consists of all
zeros. For a given waveform, you can save signal generator settings and parameters in its file header
and marker settings in its marker file (page 149); when you load a stored waveform file into BBG
media, the file header and marker file settings automatically apply to the signal generator so that the
dual ARB player sets up the same way each time the waveform file plays.

Figure 8-4 Header Utilities Softkeys

Mode > Dual ARB > = |_Edit Header
More > -
ier Edit._Header
Header Utilities Edit_Header Enter
Edit Enter
Description®] page 146 Unspecified
Edit Unspecified
Frs?] M"‘\\w Calculate
Edit AHGN 4 Header File
FMS Owverride”
Edit Header S R
Clear Header Header File
e, e Sequence
elect Header
Save Setup Select
To Header DiFﬁer‘gnt. >
eader
For details on each key, | _MNore 1 of 2 Eatalog Tupe (120 e

use key help
as described on
page 42.

WS

(BEG Seoments)P|

“\M_.

e S

When you create a waveform sequence (as described on page 140), the signal generator automatically
creates a waveform sequence header that takes priority over the individual waveform segment
headers. During a waveform sequence playback, the segment headers are ignored, except to verify
that all required options are installed. Storing a waveform sequence also stores its file header.

Some of the current signal generator settings shown in the file header appear as part of the softkey
labels, and others appear in the dual ARB summary display, shown in the following example.
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All settings in this menu can be stored to
the file header (Table 8-1 on page 144 lists

FREQUENCY ANPLITUDE all settings stored in a file header)
6.000 000 000 00 s 0.00 den . —
Softkey label,
Arb Sample Clock | — file header
125, 000000000MHz setting
ARB Selected Waveform: LFM1:RAMP_TEST_LFN
Uff Sample Clock: 125.000000000MHz Feal-Time HLJGN’
Setup
Trig Tupe: Continuous (Free Run) _ .
Trig Source: Ext (Patt Trig In 1) Egig;?tgé . Meg — Noﬁiggléééﬂﬁ' The Runtime

Moise: OfFf

Carrier Bandwidth: 1.000Hz
FF Flat Woise Banduwidth: 1.000H=

Scaling softkey is
only available under
the Dual ARB menu.

Carrier to Moise: 0.00dB

Funt ime Scaling§
78.78 //

ARB summary, file
header settings

Table 8-1

File Header Entries

I/0 Attenuator

9.:58 dB

Manual
More 1 of 2

Softkey labels,
file header
settings

Arb Setup v
Easeband
Freguency Offset
0.000 Hz

see page 188 ——

32-Character Description A description entered for the header, such as a the waveform’s function (saved/edited with the Edit

Sample Rate

Runtime Scaling

RMS

Marker 1...4 Polarity

ALC Hold Routing

RF Blank Routing

Mod Attenuation

BB Freq Offset

AWGN:

State

Description softkey, see Figure 8-4).

The waveform playback rate. This is the ARB sample clock rate, set in the Arb Setup menu (shown
in Figure 8-1 on page 135).

The Runtime scaling value is applied in real-time while the waveform is playing. This setting can be
changed only for files playing in the dual ARB player (see page 185).

When the modulator attenuation setting (see page 135) is set to Auto, this value is used to calculate
the I/Q modulator attenuation setting to optimize ACPR. Value: 0 to 1.414213562

Marker polarity can be positive or negative (described on page 162).

Which marker, if any, implements the ALC hold function (described on page 151), which holds the
ALC at its current level when the marker signal is low. All waveforms generated in the signal
generator have a marker on the first sample point. To see the results from the three routing
selections, you may need to select a range of sample (marker) points (see “Setting Marker Points in
a Waveform Segment” on page 156).

Which marker, if any, implements the RF blanking function (described on page 160) when the
marker signal is low. RF blanking also uses ALC hold. There is no need to select the ALC Hold
Routing for the same marker when you are using the RF Blank Routing function. When the marker
signal goes high, RF blanking discontinues.

The I/Q modulator attenuation setting (set in the Arb Setup menu shown in Figure 8-1 on
page 135).

The baseband frequency offset, in Hz (see page 188).

Indicated whether real-time noise is on (1) or off (0) (see page 243).
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Table 8-1 File Header Entries (Continued)

AWGN: C/N Ratio Carrier to noise ration, in dB (see page 248).

AWGN: Carrier BW Bandwidth over which the noise power is integrated, in Hz (see page 248).
AWGN: Noise BW Bandwidth of the noise, in Hz (see page 248).

AWGN: Carrier RMS The carrier RMS across the carrier bandwidth (see page 248).

Phase Noise State Indicated whether phase noise is on (1) or off (0) (see page 252).

Phase Noise F1 The start frequency for the level mid—frequency characteristics (see page 252).
Phase Noise F2 The end frequency for the level mid-frequency characteristics (see page 252).
Phase Noise Lmid The amplitude for the level mid—frequency characteristics (see page 252).
Modulation Filter The real-time modulation filter type selected (see page 210).

Over-Range Protect Indicated whether DAC Over-Range Protection is on (1) or off (0) (see page 256).
Unique Waveform Id 0 = no Id; once an Id is assigned, it cannot be changed.

License Required Indicates whether a license is required to play the waveform. See also: “Viewing Options and

Licenses” on page 38

Can be Read Out Indicates whether the waveform can be queried through SCPI or FTP.

Viewing and Modifying Header Information

The following example uses the factory-supplied waveform file RAMP TEST WFM.
1. From BBG media, select the waveform RAMP TEST WFM:

a. Press Mode > Dual ARB > Select Waveform.

b. In the Segment On column, highlight the waveform RAMP TEST WFM.

c. Press Select Waveform.
2. Open the Header Utilities menu:

Press More > Header Utilities

The Figure 8-5 shows the default file header for the factory-supplied waveform RAMP TEST WFM.
The Header Field column lists the file header parameters; use the Page Down key to see them all.

The Saved Header Settings column shows that most of the settings are Unspecified.
Unspecified means that there is no setting saved for that particular parameter.

The Current Inst. Settings column shows the current signal generator settings. In this
example, these are the settings that you will save to the file header.

NOTE If a setting is unspecified in the file header, the signal generator uses its current value for
that setting when you select and play the waveform.
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Figure 8-5 Example File Header

. The name of the waveform file.
Mode > Dual ARB > More > Header Utilities

-FFIEIIIUEN[:'|I ANPLITUDE | Edit Wéader
; The description can be up to
-— Edit
6. 000 000 000 00 GHz 1 44. 00 dBm escr'j_ptj_gn' . 32—characters.
Eclit.
File Header InFormation:UENL-EAND_TEST I - RHE*l  Opens a menu for manually
Header Field Saved Header Settings Current Inst. Settings defining the carrier RMS value
Description Edit ALGN | to use for calculating the
N AMS Ouerride AWGN: Carrier RMS value
Samp le Hggglina Unspecified %gE%SDQDDDDDDHHZ | in the Header Field.
ﬁr‘ISk Iy B Fl1hﬂ'$?7_‘ﬂ§ D Ex’ﬂ Clear Header +— Resets the saved
arker olarity nspecifie 0s ;
Marker 2 Polaritu | Unspecified Fos hef\fiertse;tlr}gs“
Marker 3 Polarity | Unspecified Pos Save Setup eniries to detau
Marker L Polarity | Unspecified Pos To Header settings
LT Hold Routing | Unspecified Mone \
10:18 More 1 of 2 Edit Header
Default header settings Current signal generator settings Enter
To calculate the RMS waveform voltage: .
Press Calculate Unspecified
Then refer to Header Field information.
Note: For greater accuracy, if the waveform has long rise/fall times, a DC Calculate
offset, or noise* already added to the waveform (for a bursted signal), it
is recommended that the Edit RMS and Edit AWGN RMS Override
softkeys are used for the best measurement accuracy.
*Option 403 Real-time AWGN does not affect the Header Field RMS Y GV

value. But, noise added to the waveform prior to downloading and
playing in the signal generator does affect the Header Field RMS value.

3. Save the information in the Current Inst. Settings column to the file header:

Press Save Setup To Header.

Both the Saved Header Settings column and the Current Inst. Settings column now display
the same values; the Saved Header Settings column lists the settings saved in the file header.

Edit and Update Settings

a.

Return to the ARB Setup menu:
Press Return > More > ARB Setup.

From this menu you can access some of the signal generator settings that are saved to the file
header. Figure 8-1 on page 135 shows the ARB Setup softkeys used in the following steps.

Set the ARB sample clock to 56 MHz:
Press ARB Sample Clock > 5 > MHz.

Set waveform runtime scaling to 60%:
Press Waveform Runtime Scaling > 60 > %.

Return to the Header Utilities menu:
Press Return > More > Header Utilities.

As shown in the following figure, the Current Inst. Settings column now reflects the
changes to the current signal generator setup, but the saved header values have not changed.
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Edit._Header

Edit
Description®

Edit.

File Heade{dInFormation: HFH1 :RANP_TEST_UFN

Header Fie

Saved Header Settings

Description

Sample Rate
Funt.ime Scaling

Marker 1 Polarity
Marker 2 Polarity
Marker 3 Polarity
Marker L Polarity
ALC Hold Routing

Current Inst. Settings

125, 000000000MHz
8,78 >

RHS®
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— the two columns
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AMS Override®

5. 000000000 Hz /
B0.00 > -

0.81L852207
Fos

Fos
Fos
Fos
Mone

M/A
Fos
Fos
Fos
Fos
Mone

Clear Header

Save Setup
To Header

10:22

More 1 of 2

e. Save the current settings to the file header:
Press the Save Setup To Header softkey.

The settings from the Current Inst. Settings column now appear in the Saved Header
Settings column. This saves the new current instrument settings to the file header.

If you change any of the signal generator settings listed in the file header after you select the
waveform file, the changed setting(s) appear in the file header’s Current Inst. Settings column
and are used instead of the saved header settings. To reapply the saved header settings, reselect the

waveform for playback.

Viewing & Editing a Header without Selecting the Waveform

As described on page 145, you can view and edit a waveform’s header information after you select
the waveform; you can also edit waveform header information without selecting a waveform, or for
another waveform than the one that is currently selected.

1. Access the file header utilities menu:
Press Mode > Dual ARB > More > Header Utilities > More > Select Different Header.

The signal generator displays an alphabetical list of the waveform files in the media that was last
selected. The following figure shows an example of the factory-supplied waveforms in BBG media.
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Active catalog Active media

6.000 000 000|00 &z

FREQUEHCY

ANPLITUDE

-144.00 den

Header File
Active waveform catalog
Select Header

Cataloo of BBG Seoment Files) in(BBG_Hemor
1I€ Hame

i FPAME_TEST LIFM
2 SIME_TEST_LFM

LB used  25EME free
Size NModified

200

Catalog Tupe ]
BEG Seamentsi®)

Type:

WFM1 = Volatile Segment
NVWFM = Non-Volatile Segment
SEQ = Sequence

For details on each key, use key help
as described on page 42.

2.
3.

Files in BBG media — |

\
Header File
Catalogs that enable you to
Segﬁgggg view files in the active media.
For details on selecting the
active media, see page 65.
Sequence

| — BBG Segments

e S

If the desired catalog is not displayed, select it.
Highlight the desired waveform file and press Select Header.

The signal generator displays the file header for the selected waveform file.

Modifying Header Information section).

To edit the header, press More, and proceed as described in Step 4 on page 146 (Viewing and
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Using Waveform Markers

The signal generator provides four waveform markers to mark specific points on a waveform segment.
When the signal generator encounters an enabled marker, an auxiliary signal is routed to a rear
panel event output that corresponds to the marker number.

* Event 1 is available at both the EVENT 1 BNC connector (see page 19), and a pin on the
AUXILIARY I/O connector (see page 20).

e Event 2 is available at both the TRIG OUT BNC connector (see page 16), and a pin on the
AUXILIARY I/O connector (see page 20).

e Events 3 and 4 are available at pins on the AUXILIARY I/O connector (see page 20).

You can use an auxiliary output signal to synchronize another instrument with the waveform, or as a
trigger signal to start a measurement at a given point on a waveform.

You can also configure markers to initiate ALC hold or RF Blanking (which includes ALC hold). Refer
to “Using Waveform Markers” on page 149 for details.

When you download a waveform file that does not have a marker file associated with it, the signal
generator creates a marker file without any marker points. Factory-supplied segments
(RAMP_TEST WFM and SINE TEST WFM) have a marker point on the first sample for all four markers.

The following procedures demonstrate how to use markers while working in the dual ARB player.
These procedures also discuss two types of points: a marker point and a sample point. A marker
point is a point at which a given marker is set on a waveform; you can set one or more marker
points for each marker. A sample point is one of the many points that compose a waveform.

There are three basic steps to using waveform markers:
Clearing Marker Points from a Waveform Segment on page 155
Setting Marker Points in a Waveform Segment on page 156

Controlling Markers in a Waveform Sequence on page 162

This section also provides the following information:

¢ Waveform Marker Concepts on page 150

¢ Accessing Marker Utilities on page 154

e Viewing Waveform Segment Markers on page 155

¢ Viewing a Marker Pulse on page 159

¢ Using the RF Blanking Marker Function on page 160
¢ Setting Marker Polarity on page 162
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Waveform Marker Concepts

The signal generator’s Dual ARB provides four waveform markers for use on a waveform segment.
You can set each marker’s polarity and marker points (on a single sample point or over a range of
sample points). Each marker can also perform ALC hold, or RF Blanking and ALC hold.

J—L Positive 43 EVENT N

Marker N

Marker

e > O | U RF Blank Off On
Set Marker Marker A /O Blarl'n\f(zrlg% vl\\/’hen
- On Off Polarity Negative Marker i
— = Markeris Low
When the signal generator encounters an enabled marker (described on page 162), an :RF Blank Only: includes ALC Hold
auxiliary output signal is generated and routed to the rear panel. :
Event 1 is available at the EVENT 1 BNC 19), and at a pin on th /o' - Holoarker
vent 1 is available at the connector (see page 19), and at a pin on the Holds ALC when
AUXILIARY 1/O connector (see page 20). Marker is Low
Events 2 through 4 are available at pins on the AUXILIARY I/O connector (see page 20). Marker N

ALC Hold Off On

Marker Signal Response

The signal generator aligns the marker signals with the I and Q signals at the baseband generator.
However some settings such as amplitude, filters, and so forth within the RF output path can create
delays between the marker EVENT output signal and the modulated RF output. When using the
marker EVENT output signal, observe the signals (marker relative to modulated RF) for any latency,
and if needed, reset the marker point positions, include delay (page 195), or both.

Marker File Generation

Downloading a waveform file (as described in the Programming Guide) that does not have a marker
file associated with it causes the signal generator to automatically create a marker file, but does not
place any marker points.

Marker Point Edit Requirements

Before you can modify a waveform segment’s marker points, the segment must reside in BBG media
(see “Loading a Waveform Segment into BBG Media” on page 136).

Saving Marker Polarity and Routing Settings

Marker polarity and routing settings remain until you reconfigure them, preset the signal generator,
or cycle power. To ensure that a waveform uses the correct settings when it is played, set the marker
polarities or routing (RF Blanking and ALC Hold) and save the information to the file header

(page 143).

NOTE When you use a waveform that does not have marker routings and polarity settings stored in
the file header, and the previously played waveform used RF Blanking, ensure that you set
RF Blanking to None. Failure to do so can result in no RF output or a distorted waveform.
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ALC Hold Marker Function

While you can set a marker function (described as Marker Routing on the softkey label) either before
or after you set marker points (page 156), setting a marker function before setting marker points may
cause power spikes or loss of power at the RF output.

Use the ALC hold function by itself when you have a waveform signal that incorporates idle periods,
burst ramps, or when the increased dynamic range encountered with RF blanking (page 160) is not
desired.

The ALC hold marker function holds the ALC circuitry at the average value of the sampled points
set by the marker(s). For both positive and negative marker polarity, the ALC samples the RF output
signal (the carrier plus any modulating signal) when the marker signal goes high:

Positive: The signal is sampled during the on marker points.
Negative The signal is sampled during the off marker points.

NOTE Because it can affect the waveform’s output amplitude, do not use the ALC hold for longer
than 100 ms. For longer time intervals, refer to “Power Search Mode” on page 108.

Markers set to account for marker
response relative to RF output

RF OUTPUT | : >>

ek
-"-

<
Mark = ”
arkKer _I—! == :
Positive Polarity : :
¢ 100 ms »:
. Max ALC hold time .
CAUTION Incorrect ALC sampling can create a sudden unleveled condition that may create a spike

in the RF output, potentially damaging a DUT or connected instrument. To prevent this
condition, ensure that you set markers to let the ALC sample over an amplitude that
accounts for the higher power levels encountered within the signal.
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Example of Correct Use

Waveform: 1022 points
Marker range: 95-97
Marker polarity: Positive

This example shows a marker set to sample the waveform’s area of
highest amplitude. Note that the marker is set well before the

waveform’s area of lowest amplitude. This takes into account any

response difference between the marker and the waveform signal.
I
I

|
i (H\ il

TR LT R TIN

Mw\‘\' |

1
\

(\‘\"\ﬂ\'ﬂ\\'\ﬂ\'wﬂﬂ'\ﬂ\‘W\”\(\‘\"W\”\MM

Close-up of averaging

The ALC samples the waveform when the marker signal goes
high, and uses the average of the sampled waveform to set the
ALC circuitry. ()

Here the ALC samples during the on marker points (positive
polarity).

Example of Incorrect Use

Waveform: 1022 points
Marker range: 110-1022
Marker polarity: Positive

=

Pulse Unleveled

This example shows a marker set to sample the low part of the
same waveform, which sets the ALC modulator circuitry for
that level; this usually results in an unleveled condition for the
signal generator when it encounters the high amplitude of the
pulse.

152 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Basic Digital Operation (Option 651/652/654)
Using Waveform Markers

Example of Incorrect Use

Waveform: 1022 points
Marker range: 110-1022
Marker polarity: Negative

This figure shows that a negative polarity marker goes low during
the marker on points; the marker signal goes high during the off | Marker On . Marker | erOn -
points. The ALC samples the waveform during the off marker off

points.

Sample range begins on first point of signal

Sampling both on and off time sets the modulator circuitry
incorrectly for higher signal levels. Note the increased amplitude
at the beginning of the pulse.

<« Marker On _A -

Negative range set between signal and
off time
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Accessing Marker Utilities

Mode > Dual ARB > More > Marker Utilities

Arb_MNarkers

Marker Polaritub————————————®

Note: This is the
second Arb menu.

Narker Polarity #
Marker 1 Polarit
Heg IEEEH

Marker Routingm

Set Markersk

page 49— p»|

Foute Connectorsk

BN

Arb_Markers 7

Marker
EH: 3 u

Set Marker On
First Point

Range Of Paints"]

Set Marker Off

Set Marker On >

Narker Range .~
First Mkr Poin%

Marker 3 Polarit
Heg IEEEH

Marker L Polarit
Heg IEEEH

T

Harker 2 Polarity f€——
Heg IEEEH

For details on each key, use key help
as described on page 42.

The settings in these menus

Narker Routing
Pulse/RF Blank

\j

(Hane )]
ALC Hold

(Hone ) "]

Last Mkr Point
200

# Skipped Pointg

APply To Hawveform

Narker Range .~
First Mkr Poin%

Last Mkr Point
200

\j

Range Of Points®|

Display Waveform
And Markers®|

APply To Hawveform

RV VY

The display below shows the | and Q components of the waveform, and
the marker points set in a factory—supplied segment.

FREQUEHCY ANPLITUDE Narker
6.000 000 000 00 &=z | -144.00 den
Zoom In
Arb uavefur‘m And Markers
HFH1 :RANP_TEST_UFN

I Zoom Out

Q

1 Zoom In Max

2
Marker points
on first Il / $ il Sample Point = Zoom Out. Max
sample point 570272006 10118

Narker Routing F

can be stored to the file
header, see page 143

Hone

Marker 1

Marker 2

Marker 3

Marker L

First sample point

First r,,//’/ghownondspMy
Sample Point

These softkeys change
the range of waveform
sample points shown

on the marker display.

Each press of the
softkey changes the
sample range by
approximately a factor
of two.
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Viewing Waveform Segment Markers

Markers are applied to waveform segments. Use the following steps to view the markers set for a
segment (this example uses the factory-supplied segment, SINE TEST WFM).

1. In the second Arb menu (page 154), press Marker Utilities > Set Markers.
2. Highlight the desired waveform segment (in this example, SINE TEST WFM).
3. Press Display Waveform and Markers > Zoom in Max.

The maximum zoom in range is 28 points.

Experiment with the Zoom functions to see how they display the markers.

The display can show a maximum of 460 points; displayed waveforms with a sample point range
greater than 460 points may not show the marker locations.

Clearing Marker Points from a Waveform Segment

When you set marker points they do not replace points that already exist, but are set in addition to
existing points. Because markers are cumulative, before you set points, view the segment (page 155)
and remove any unwanted points. With all markers cleared, the level of the event output signal is OV.
To clear marker points on a segment, the segment must reside in BBG media (page 136).

Clearing All Marker Points
1. In the second Arb menu (page 154), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment (in this example, SINE TEST WFM).

3. Highlight the desired marker number: Press Marker 12 34.

4. For the selected marker number, remove all marker points in the selected segment:
a. Press Set Marker Off Range of Points.

Notice that the softkeys for the first and last marker points correspond with the length of the
waveform. The factory-supplied waveform (SINE TEST WFM) contains 200 samples. To clear all
set marker points, the range must equal to the length of the waveform.

b. Press Apply To Waveform > Return.

5. Repeat from Step 3 for any remaining marker points that you want to remove from the other
markers.

Clearing a Range of Marker Points

The following example uses a waveform with marker points (Marker 1) set across points 10—20. This
makes it easy to see the affected marker points. The same process applies whether the existing points
are set over a range or as a single point (page 156).°

1. In the second Arb menu (page 154), press Marker Utilities > Set Markers, then select Marker 1.

2. Set the first sample point that you want off (for this example, 13):
Press Set Marker Off Range Of Points > First Mkr Point > 13 > Enter.

3. Set the last marker point in the range that you want off to a value less than or equal to the
number of points in the waveform, and greater than or equal to the value set in Step 2 (for this
example, 17):
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Press Last Mkr Point > 17 > Enter > Apply To Waveform > Return.

. . Arb Uaveform And Markers
This turns off all marker points for UFI1 :STHE_TEST_UFN
the active marker within the range I
set in Steps 2 and 3, as shown at 0
right. %
How to view markers is described E
on page 155. 1 Sample Point 28

Clearing a Single Marker Point

Use the steps described in “Clearing a Range of Marker Points” on page 155, but set both the first
and last marker point to the value of the point you want to clear. For example, if you want to clear
a marker on point 5, set both the first and last value to 5.

Setting Marker Points in a Waveform Segment

To set marker points on a segment, the segment must reside in BBG media (page 136).

When you set marker points, they do not replace points that already exist, but are set in addition to
existing points. Because markers are cumulative, before you set marker points within a segment, view
the segment (page 155) and remove any unwanted points (page 155).

Placing a Marker Across a Range of Points
1. In the second Arb menu (page 154), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment.

3. Select the desired marker number: Press Marker1234

4. Set the first sample point in the range (in this example, 10):
Press Set Marker On Range Of Points > First Mkr Point > 10 > Enter.

5. Set the last marker point in the range to a value less than or equal to the number of points in
the waveform, and greater than or equal to the first marker point (in this example, 20):

Press Last Mkr Point > 20 > Enter.
6. Press Apply To Waveform > Return.

This sets a range of waveform marker points. The marker signal starts on sample point 10, and ends
on sample point 20, as shown in the following figure.

Arb Waveform And Markers
UFN1:STHE_TEST_UFNI

FwMe O H

1 Sample Point 28

How to view markers is described on
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Placing a Marker on a Single Point

On the First Point

1. In the second Arb menu (page 154), press Marker Utilities > Set Markers.
2. Highlight the desired waveform segment.

3. Select the desired marker number:
Press Marker1234.

4. Press Set Marker On First Point.
This sets a marker on the first point in the segment for the marker number selected in Step 3.
On Any Point

Use the steps described in “Placing a Marker Across a Range of Points” on page 156, but set both the
first and last marker point to the value of the point you want to set. For example, if you want to set
a marker on point 5, set both the first and last value to 5.

Placing Repetitively Spaced Markers

The following example sets markers across a range of points and specifies the spacing (skipped
points) between each marker. You must set the spacing before you apply the marker settings; you
cannot apply skipped points to a previously set range of points.

NOTE The skipped points value is limited to the size of the range of points.

1. Remove any existing marker points (page 150).

2. In the second Arb menu (page 154), press Marker Utilities > Set Markers.
3. Highlight the desired waveform segment.
4

Select the desired marker number:
Press Marker1234.

5. Set the first sample point in the range (in this example, 5):
Press Set Marker On Range Of Points > First Mkr Point > 5 > Enter.

6. Set the last marker point in the range. (The last marker point value must always be less than or
equal to the number of points in the waveform, and greater than or equal to the first marker
point, in this example, 25):

Press Last Mkr Point > 25 > Enter.

7. Enter the number of sample points that you want skipped (in this example, 1):
Press # Skipped Points > 1 > Enter.

8. Press Apply To Waveform > Return.
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This causes the marker to occur on ArD Liaverorn And fiarkars
every other point (one sample point is UFI =STHE_TEST_LFN
skipped) within the marker point range, I
as shown at right. o
How to view markers is described on %
page 155. P
1 Sample Point 28

One application of the skipped point
feature is the creation of a clock signal
as the EVENT output.
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Viewing a Marker Pulse

When a waveform plays (page 142), you can detect a set and enabled marker’s pulse at the rear
panel event connector/Aux I/O pin that corresponds to that marker number. This example
demonstrates how to view a marker pulse generated by a waveform segment that has at least one
marker point set (page 156). The process is the same for a waveform sequence.

This example uses the factory-supplied segment, SINE_TEST WFM in the dual ARB Player.
Factory-supplied segments have a marker point on the first sample point for all four markers, as
shown.

Arb Waveform And Markers
Marker points on UFN1 :SIHE_TEST_UFH
first sample point of I

waveform segment

FLrde

3

1 Sample Point 28

How to view markers is described on page 155
In the first Arb menu (page 135), press Select Waveform.
Highlight the SINE TEST WFM segment and press Select Waveform.
Press ARB 0ff On to On.
Connect the Agilent MXG’s rear panel Q OUT output to the oscilloscope’s channel 1 input.

A e

Connect the signal generator’s rear panel EVENT 1 output to the oscilloscope’s channel 2 input.

When marker 1 is present, the Agilent MXG outputs a signal through EVENT 1 as shown in the
following example.

QOouT

Marker pulse on the Event 1 signal.

T [eem  HIE
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Using the RF Blanking Marker Function

While you can set a marker function (described as Marker Routing on the softkey label in the Marker
Utilities menu) either before or after setting the marker points (page 156), setting a marker function
before you set marker points may change the RF output. RF Blanking includes ALC hold (described
on page 151, note Caution regarding unleveled power). The signal generator blanks the RF output
when the marker signal goes low. This example is a continuation of the previous example, Viewing a
Marker Pulse.

1. Using the factory-supplied segment SINE TEST WFM, set Marker 1 across points 1-180 (page 156).
2. From the Marker Routing softkey menu, assign RF Blanking to Marker 1:

In the second Arb menu (page 154), press Marker Utilities > Marker Routing > Pulse/RF Blank > Marker
1.
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Marker Polarity = Positive

When marker polarity is positive (the default
setting), the RF output is blanked during the off
marker points.

oV

Marker Polarity = Negative

When marker polarity is negative, the

RF output is blanked during the on marker
points

ov
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Setting Marker Polarity

Setting a negative marker polarity inverts the marker signal.
1. In second Arb menu (page 154), press Marker Utilities > Marker Polarity.
2. For each marker, set the marker polarity as desired.

e The default marker polarity is positive.

* Each marker polarity is set independently.

See also, “Saving Marker Polarity and Routing Settings” on page 150.

As shown on page 160:
Positive Polarity: On marker points are high (=3.3V).
Negative Polarity: On marker points are low (0OV).

RF blanking always occurs on the low part of the signal regardless of the polarity setting.

Controlling Markers in a Waveform Sequence

In a waveform segment, an enabled marker point generates an auxiliary output signal that is routed
to the rear panel EVENT output (described in “Rear Panel Overview — N5161A/62A1/81A/82A MXG”
on page 15) corresponding to that marker number. For a waveform sequence, you enable or disable
markers on a segment-by-segment basis; this enables you to output markers for some segments in a
sequence, but not for others. Unless you change the sequence marker settings or cycle the power, the
marker setting for the last segment edited in the sequence applies to all segments in the next
sequence that you build. For information on building a waveform sequence, see “Creating a Sequence”
on page 140.
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Figure 8-6 Waveform Sequence Menus for Enabling/Disabling Segment Markers

-
_Arb Sequences /]
Mode > Dual ARB > Insert.
More HaveFarm®
Note: This is the second Arb menu. Delete Selected
Haveform
______Arb -_—
Delete ALl
iy FveForms
. - Enable/Disable markers while
(e Arb Sequences el (RS creating a waveform sequence
Build Mew
llaveform Sequence” Enable/Disable
uedTETE rerkers?)
Edit Selected Arb_Sequences
—— laveform Sequencel ™ — fiore 1 of
nSer
Utilities® Laveform®
b Show HaugFD{m’
equence Contents Arb_Sequences .~
ANk amn™ Delete Eele%tecl
Delete verorm MName And Store
laveform Sequence® olete ALL Arb Narkers
elete
Haveforms Tooale Marker 1
Goto Fowe
Edit Repetitions
Tooole Marker 2

Enablefﬁisable'
arkers

Edit a sequence to UEEES [eFER &
For details on each key, use key help [ Hore I of 2 Sl enable/disable markers
as described on page 42.

Togole Marker L

Goto Fowe
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Enabling and Disabling Markers in a Waveform Sequence

Select the waveform segments within a waveform sequence to enable or disable each segment’s
markers independently. You can enable or disable the markers either at the time of creating the
sequence or after the sequence has been created and stored. If the sequence has already been stored,
you must store the sequence again after making any changes. Enabling a marker that has no marker
points has no effect on the auxiliary outputs. To set marker points on a segment, see “Setting Marker
Points in a Waveform Segment” on page 156. This example assumes that a waveform sequence exists.

1. Ensure that all waveform segments for the sequence reside in BBG media (see page 136).
2. From the second Arb menu, press Waveform Sequences.
3. Highlight the desired waveform sequence.
4. Press Edit Selected Waveform Sequence > Enable/Disable Markers.
5. Toggle the markers:
a. Highlight the first waveform segment.
b. As desired, press Toggle Marker 1, Toggle Marker 2, Toggle Marker 3, and Toggle Marker 4.

An entry in the Mkr column (see figure below) indicates that the marker is enabled for that
segment; no entry in the column means that all markers are disabled for that segment.

c. In turn, highlight each of the remaining segments and repeat Step b.
Press Return > More > Name and Store.

Either rename the sequence using the text entry keys (see page 137) or just press Enter to save
the sequence with the existing name.

The markers are enabled or disabled per the selections, and the changes saved to the sequence file.

The following figure shows a sequence built using one of the factory-supplied waveform segments; a
factory—-supplied segment has a marker point on the first sample for all four markers. In this
example, marker 1 is enabled for the first segment, marker 2 is enable for the second segment, and
markers 3 and 4 are enabled for the third segment.

rossiE e e
Seament On Sequence On |(UNSTORED) UHTIT
(1/1) BBG Media Int fiedia [(1/1) llaveform _Reps Sequence marker column
RAMP_TEST_HFH SEQ1 HFML:SINE_TEST_LIFT
STHE_TESTUFH  SINE100+RHP200 LF11: STNE_TEST_LFM UEEES [P &

This entry shows that markers
3 and 4 are enabled for this
segment.

LIFM1:SINE _TEST LIF

For each segment, only the markers enabled for that segment produce a rear panel auxiliary output
signal. In this example, the marker 1 auxiliary signal appears only for the first segment, because it is
disabled for the remaining segments. The marker 2 auxiliary signal appears only for the second
segment, and the marker 3 and 4 auxiliary signals appear only for the third segment.
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Using the EVENT Output Signal as an Instrument Trigger

For details on each key, use key help as described on page 42.

One of the uses for the EVENT
output signal (marker signal) is to Mode

trigger a measurement instrument. The settings in this menu

You can set up the markers to start J‘ = ﬁi; db; s:;;ed ato eth1e4 2|e

the measurement at the beginning TR ETTE T » 866 page 149

of the waveform, at any single point on #

in the waveform, or on multiple Dual AREFE—> Arb Setup 7

points in the waveform. To optimize Lmvatorn? ARB Sample Clock L sample
the use of the EVENT signal for RE e
measurements, you may also need ARE Setupe—m= [ . i oise setting
to adjust the sample rate. The —— Setup?
location of the sample rate setting . Feal-t.i

is shown in the figure at right. Tuo-Tanek N i

The EVENT output signal can exhibit jitter of up to #4 ns on the rising and falling edge. This jitter
can be minimized in either of two ways.

Method 1: Use a sample clock of 125 MHz/N where N is a positive integer and where 125 MHz/N can
be represented exactly on the display.
For example: 125 MHz, 62.5 MHz, 31.25 MHz, 25 MHz, and so on.

If the result cannot be represented exactly on the display, jitter will be present.
For example: N = 6 will result in jitter, because 125 MHz/6 = 20.833 Mhz, which is truncated when
displayed.

Method 2: Select a sample clock and waveform length that spaces the markers by a multiple of 8 ns.
For example: A 200 point waveform with a marker on the first point and a sample clock of 50 MHz
provides a marker every 4 us. Because 4 us is a multiple of 8 ns, the jitter is minimized.

When the EVENT output signal exhibits jitter and it is used as a measurement trigger, it can cause
the waveform to falsely appear as having jitter. If this condition occurs, you can adjust the sample

rate to a value (see above) that does not cause the jitter appearance. To maintain the integrity of the
original waveform with a sample rate change, you will have to also recalculate the sample values. The
following figures illustrate the marker signal jitter and its affect on the waveform.

EVENT output signal exhibits jitter Waveform appears to exhibit jitter when The jitter is gone with
due to a non—optimal sample rate triggered using EVENT signal with jitter. an optimal sample rate

Oscilloscope triggering on waveform Oscilloscope triggering on EVENT signal Oscilloscope triggering on EVENT signal
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Triggering a Waveform

Figure 8-7 Triggering Softkeys

Mode > Dual ARB ArD

ARE
[ OFf Q]

Select
Haveform

ARE Setupk

Trigoer Tupe
cCont inuons  H—Page 167

Free Run.

4 page 168
fMore 1 of 2 N

For details on each key, use key help
as described on page 42.

Triggers control data transmission by controlling when the signal generator transmits the modulating
signal. You can configure trigger settings so that data transmission occurs once (Single mode),
continuously (Continuous mode), or starts and stops repeatedly (Gated and Segment Advance modes).

A trigger signal contains both positive and negative states; you can use either for triggering.

When you initially select a trigger mode or when you change from one triggering mode to another,
you may lose the carrier signal at the RF output until the modulating signal is triggered. This is
because the signal generator sets the I and Q signals to zero volts prior to the first trigger event. To
maintain the carrier signal at the RF output, create a data pattern with the initial I and Q voltages
set to values other than zero.

When you initially turn the Arb ON or select a trigger mode or when you change from one triggering
mode to another, you may temporarily lose the carrier signal for a few tens of milliseconds at the RF
output. The Arb will present the idle IQrms value of the next Arb waveform to the I1Q modulator.
This ensures that the RF carrier output is at the correct amplitude level while the Arb waits for a
trigger. When that trigger is received, the Arb begins playing the waveform and the modulated RF
carrier exhibits no undesirable transients.

There are two parts to configuring a waveform trigger:
* Type determines the behavior of the waveform when it plays (see Trigger Type on page 167).

¢ Source determines how the signal generator receives the trigger that starts the modulating
waveform playing (see Trigger Source on page 168).
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Trigger Type

Type defines the trigger mode: how the waveform plays when triggered.

Mode > = Immediately triggers and plays the waveform; triggers
Dual ARB > Lontinuous fode received while the waveform is playing are ignored.
Trigger Type fArb_irigoer 7 Free Run
Continuous - ) . .
(Free Runl”| - . Plays the waveform when a trigger is received;
Trigger & Run F=——0 subsequent triggers are ignored.
Singlew
Feset. & Run
Segment. AdvanceM Plays the waveform when a trigger is received; subsequent
\W triggers restart the waveform.
GatedM Ignores an early trigger
* received while a
W A segment in a sequence plays waveform is playing.
once, ignoring the repetition Single Mode
setting, after which the dual ARB
Gated Hode pl_ayer stops and walt_s for a Mo Retrigger An early trigger received
trigger before advancing to the while a waveform is
Active Low - . B
Seqg Advance fode Pﬁ’d sTgme{nt. The lnet_xt segment Buffered Tri playing waits until the
en plays to completion. uffered Trio $—— ot waveform
i i Single . . . . completes, then plays
Active High If a trigger is received while a ] the waveform once
segment is playing, the segment Festart on Trig
Cont inuous plays to completion. The dual A Iy tri ived
ARB player then advances to the @ S sl Wﬂi;atrhye C\g%zrfg?;e;\s/e
next segment and plays that - .
The waveform stops during the inactive segmer?t to comple‘:iox. playing immediately
state of the trigger source, and plays restarts the waveform.

during the active state.
A segment in a sequence plays continuously until the waveform receives another trigger.

If a trigger is received while a segment is playing, the segment plays to completion. The
dual ARB player then advances to the next segment and plays that segment continuously.

For details on each key, use key help
as described on page 42.

¢ Continuous mode repeats the waveform until you turn the signal off or select a different waveform,
trigger mode, or response (Free Run, Trigger & Run, Reset & Run).

¢ Single mode plays the waveform once.

NOTE  In Single No Retrigger, do not use Continuous Reset & Run mode due to the variable latency of
this setup.

No Retrigger: If a trigger is received early it will be ignored. The gap in your playback is dependant
on the trigger period, after which time the RF will start up again where it is expected.

Buffered Trigger: An early trigger will cause the waveform to play to the end and then start again.
The RF will not be aligned with this early trigger.

Restart on Trigger: The ARB will reset itself and trigger again but there will some gap in the
playback while this is occurring. It will reset itself for every trigger it receives.

¢ Segment Advance mode plays a segment in a sequence only if triggered. The trigger source controls
segment-to-segment playing (see Example: Segment Advance Triggering on page 169). A trigger
received during the last segment loops play to the first segment in the sequence.
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¢ Gated mode triggers the waveform at the first active triggering state, then repeatedly starts and
stops playing the waveform in response to an externally applied gating signal. See Example: Gated
Triggering on page 170.

Trigger Source

Mode >
Dual ARB >
Trigger Source

!

Arb Trigger #

Trigger Source »
(Ext 7]

#1__farb Trigger ~#

Ext. Source,l - Trigoer Key
(Patt Trig In 12 Neg = the signal generator " [Ext Trig Source
responds during the trigger signal ) i
Ext Polaritu | lowstate, Patt Trig In 1+ Z?;ngéng’)\‘c connector Bus
Pas t ' pag
Pos = the signal generator . Ext
Ext Oelau ; : : Patt Trio In 2 4 Aux I/O connector (see
oo responds during the trigger signal page 20)

high state.

Key inactive until Ext W ’Nﬁo
’Delay is enabled On.

For details on each key, use key help
as described on page 42.

External Trigger Polarity
¢ In Continuous, Single, and Segment Advance modes, use the ExtPolarity softkey to set the external
trigger polarity.

* In Gated mode, the Active Low and Active High softkeys (page 167) determine the external
trigger polarity.

168 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Basic Digital Operation (Option 651/652/654)
Triggering a Waveform

Example: Segment Advance Triggering

Segment advance triggering enables you to control the segment playback within a waveform sequence.
This type of triggering ignores the repetition value (page 141). For example if a segment has
repetition value of 50 and you select Single as the segment advance triggering mode, the segment still
plays only once. The following example uses a waveform sequence that has two segments.

If you have not created and stored a waveform sequence, refer to “Creating a Sequence” on page 140.

1.
2.

Preset the signal generator.

Configure the RF output:

e Set the desired frequency.

¢ Set the desired amplitude.

* Turn on the RF output.

Select a waveform sequence for playback:

a. Press Mode > Dual ARB > Select Waveform.

b. In the Sequence On column, highlight a waveform sequence file.
c. Press Select Waveform.

Set the triggering as follows:

e Trigger Type: continuous Segment Advance
Press Trigger Type > Segment Advance > Continuous.

e Trigger source: Trigger hardkey
Press Trigger Source > Trigger Key.

Generate the waveform sequence:
Press ARB Off On until On highlights.

(Optional) Monitor the waveform:

Connect the RF OUTPUT of the signal generator to the input of an oscilloscope, and configure the
oscilloscope so that you can see the signal.

Trigger the first waveform segment to begin playing continuously:
Press the Trigger hardkey.

Trigger the second segment:
Press the Trigger hardkey.

Pressing the Trigger hardkey causes the currently playing segment to finish and the next segment
to start.

If the last segment in the sequence is playing, pressing the Trigger hardkey causes the first
segment in the waveform sequence to start when the last segment finishes.
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Example: Gated Triggering

Gated triggering enables you to define the on and off states of a modulating waveform.

1. Connect the output of a function generator to the signal generator’s rear panel PAT TRIG IN
connector, as shown in the following figure. This connection is applicable to all external triggering
methods. The optional oscilloscope connection enables you to see the effect that the trigger signal
has on the RF output.

Function Generator
E—c)
o58EsaE0E o
Signal Generator ( PAT TRIG Oscilloscope
ﬁJ ¥‘ / \
=l oooo o [——] oooo o——]
[=[=]
@°°ooo:j
® ® @ O
opoococo ®
RF OUTPUT § 0 0 0 °
i © Q0B 0406 ® ©® ©® ¢
E Channel 1 E Channel 2
i i
2. Preset the signal generator.
Configure the RF output:
* Set the desired frequency.
* Set the desired amplitude.
e Turn on the RF output.
4. Select a waveform for playback (sequence or segment):
a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On or Sequence On column, highlight a waveform.
c. Press Select Waveform.
5. Set the triggering as follows:
e Trigger type: Gated
Press Trigger Type > Gated.
* Active state: Low
Press Active Low.
* Trigger source: External
Press Trigger Source > Ext.
* Input connector: Rear panel Patt Trig In BNC
Press Ext Source > PattTrigin 1.
6. Generate the waveform: Press Return > ARB Off On until On highlights.
170
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7. On the function generator, configure a TTL signal for the external gating trigger.
8. (Optional) Monitor the waveform:

Configure the oscilloscope to display both the output of the signal generator, and the external
triggering signal. You will see the waveform modulating the output during the gate active periods
(low in this example).

The following figure shows an example display.

Modulating Waveform RF Output

B
MW~ -

-

Externally Applied Gating Signal
Gate Active = Low
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Example: External Triggering

Use the following example to set the signal generator to output a modulated RF signal
100 milliseconds after a change in TTL state from low to high occurs at the PATT TRIG IN rear panel

BNC connector

FUNCTION
GENERATOR
Y A
I €]

poooooood ©
ooooooog

PAT TRIG

OUTPUT

SIGNAL GENERATOR

1. Connect the signal generator to the function generator as shown above.
2. Configure the RF output:
* Set the desired frequency.
* Set the desired amplitude.
* Turn on the RF output.
3. Select a waveform for playback (sequence or segment):
a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On or Sequence On column, highlight a waveform.
c. Press Select Waveform.
4. Generate the waveform:
Press ARB Off On until On highlights.
5. Set the waveform trigger as follows:
a. Trigger Type: single
Press Trigger Type > Single > No Retrigger
b. Trigger Source: external
Press Trigger Source > Ext
c. Input connector: Rear panel Patt Trig In BNC
Press Ext Source > PattTrigin 1.
d. External Trigger Polarity: positive
Press Ext Polarity until Pos highlights
e. External Delay: 100 ms
Press More > Ext Delay until On highlights
Press Ext Delay Time > 100 > msec
6. Configure the Function Generator:
* Waveform: 0.1 Hz square wave
¢ QOutput Level: 3.5V to 5V.
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Clipping a Waveform

Digitally modulated signals with high power peaks can cause intermodulation distortion, resulting in
spectral regrowth that can interfere with signals in adjacent frequency bands. The clipping function
enables you to reduce high power peaks by clipping the I and Q data to a selected percentage of its
highest peak, thereby reducing spectral regrowth.

¢ How Power Peaks Develop on page 174

* How Peaks Cause Spectral Regrowth on page 176

¢ How Clipping Reduces Peak-to—Average Power on page 177

¢ Configuring Circular Clipping on page 180

¢ Configuring Rectangular Clipping on page 181

Figure 8-8 Clipping Softkeys

Mode > Dual ARB > More —p»

For details on each key, use key help

as described on page 42.
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How Power Peaks Develop

To see how clipping reduces high power peaks, it is important to understand how the peaks develop
as you construct a signal.

Multiple Channel Summing

1I/Q waveforms can be the summation of multiple channels, as shown in the following figure. If a bit
in the same state (high or low) occurs simultaneously in several individual channel waveforms, an
unusually high power peak (positive or negative) occurs in the summed waveform.

Because the high and low states of the bits in channel waveforms are random and generally result in
a cancelling effect, high power peaks occur infrequently with multiple channel summing,.

Uy

Multiple Channels to be
Summed Into One Tor Q
Waveform

i

Summed Ior Q Waveform
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Combining the | and @ Waveforms
When the I and Q waveforms combine in the I/Q modulator to create an RF waveform, the magnitude

of the RF envelope is f12+Q2, where the squaring of I and Q always results in a positive value.

As shown in the following figure, simultaneous positive and negative peaks in the I and Q waveforms
do not cancel each other, but combine to create an even greater peak.

4V

I Ia

Iand Q Waveforms
to be Combined

Q — Q
4V 4
——t— +—t— i I
] 4 1
1
-+ 566V]I4V
1
4 1
566V "
Resultant Baseband Y SV
Waveform Determined Vector Representation
by A/ 12 O2
YNT*Q of High Peak
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How Peaks Cause Spectral Regrowth

In a waveform, high power peaks that occur infrequently cause the waveform to have a high
peak-to-average power ratio, as illustrated in the following figure.

———————————————— Peak Power

Average Power

Because the gain of a transmitter’s power amplifier is set to provide a specific average power, high
peaks can cause the power amplifier to move toward saturation. This causes the intermodulation
distortion that generates spectral regrowth. Spectral regrowth is a range of frequencies that develops
on each side of the carrier (similar to sidebands) and extends into the adjacent frequency bands (see
the following figure). Clipping provides a solution to this problem by reducing the peak-to-average
power ratio.

Spectral
Regrowth

RF Signal Adjacent Band
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Clipping a Waveform

How Clipping Reduces Peak-to—Average Power

You can reduce peak-to-average power, and consequently spectral regrowth, by clipping the
waveform. Clipping limits waveform power peaks by clipping the I and Q data to a selected
percentage of its highest peak. The Signal Generator provides two methods of clipping:

e (Circular clipping is applied to the composite I/Q data (I and Q data are equally clipped).

As shown in Figure 8-9, the clipping level is constant for all phases of the vector and appears as
a circle in the vector representation.

* Rectangular clipping is independently applied the I and Q data.

As shown in Figure 8-10 on page 178, the clipping level is different for I and Q, and appears as
a rectangle in the vector representation.

In both circular and rectangular clipping, the objective is to clip the waveform to a level that reduces
spectral regrowth but does not compromise the integrity of the signal. The two complementary
cumulative distribution plots in Figure 8-11 on page 179 show the reduction in peak-to-average
power that occurs after applying circular clipping to a waveform.

The lower the clipping value, the lower the peak power that is passed (the more the signal is
clipped). The peaks can often be clipped without substantially interfering with the rest of the
waveform. In many cases, data that might otherwise be lost in the clipping process is retained
because of the error correction inherent in the coded systems. If you apply excessive clipping,
however, lost data cannot be recovered. Experiment with clipping settings to find a percentage that
reduces spectral regrowth while retaining needed data.

Figure 8-9 Circular Clipping
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Figure 8-10 Rectangular Clipping
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Figure 8-11 Reduction of Peak—to—Average Power

Complementary Cumulative Distribution
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Basic Digital Operation (Option 651/652/654)
Clipping a Waveform

Configuring Circular Clipping

Use this example to configure circular clipping and observe its affect on the peak-to-average power
ratio of a waveform. Circular clipping clips the composite I/Q data (I and Q data are clipped equally).
For more information about circular clipping, refer to “How Clipping Reduces Peak-to—Average
Power” on page 177.

CAUTION Clipping is non-reversible and cumulative. Save a copy of the waveform file before you
apply clipping.

Copy a Waveform File
1. Display the signal generator’s files: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP TEST WFM.
3. Press Copy File.
4. Name the copy (in this example, the name is MY TEST CIRC) and press Enter.

Apply Circular Clipping to the Copied Waveform File
1. Open the DUAL ARB Waveform Utilities menu: Press Mode > Dual ARB > More > Waveform Utilities.

2. In the list of files, highlight the copied file (in this example, MY TEST CIRC).
3. Create the CCDF plot: Press Plot CCDF.
4

Observe the shape and pOSitiOIl of Example waveform curve before clipping

the waveform’s curve (the dark line /
I:IJHPLEHEHTFIR'.-I CUMULA IUE IJISTRIBUTIEIN

in the example at right). p w00z EFORA: /T
L2_50% 0 dB
5. Activate circular clipping: Press AT ELE (T o 10
Return > Clipping > Clipping Type until 0 i; == dg p 12
[1+jQ| highlights. u'.]f]gi% - ; 0_1:4
6. Set circular clipping to 80%: Peak  L.7 dB ! l]ul-]gi;
Press Clip |1+jQ| To > 80 > %. T PERK/AUG_dB 10.0

7. Apply 80% clipping to the I and Q
data: Press Apply to Waveform.

8. Create the CCDF plot (see the Example waveform curve after circular clipping
example at right): Press Plot CCDF.

I:IJNPLENEHTFIR'.-I UNMULATIVE DISTRIBUTION
9. Ol.)sel'fve the waveform’s curve after 1S, 003 0 d8 E 1003 RUEFRN: ¥ TEST_CIRC
clipping. 10% g 10%
17 .
Note the reduction in ikE d 0 i:
peak-to-average power relative to the =001 & u.l-]ﬁ
previous plot. ¥ oo
0 PEAK/AUG_dB 10.0

180 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Basic Digital Operation (Option 651/652/654)
Clipping a Waveform

Configuring Rectangular Clipping

Use this example to configure rectangular clipping. Rectangular clipping clips the I and Q data
independently. For more information about rectangular clipping, refer to “How Clipping Reduces
Peak-to—Average Power” on page 177.

CAUTION Clipping is non-reversible and cumulative. Save a copy of the waveform file before you
apply clipping.

Copy a Waveform File
1. Display the signal generator’s files: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP TEST WFM.
3. Press Copy File.
4

Name the copy (in this example, the name is MY TEST REC) and press Enter.

Apply Rectangular Clipping to the Copied Waveform File
1. Open the DUAL ARB Waveform Utilities menu: Press Mode > Dual ARB > More > Waveform Utilities.

2. In the list of files, highlight the copied file (in this example, MY TEST REC).
3. Create the CCDF plot: Press Plot CCDF.
4

Observe the shape and pOSitiOIl of Example waveform curve before clipping

the waveform’s curve (the dark line

/
in the example at right). . fDnPLEnENLIgﬁ'EIFE%IthH_TZ[EUSIET DISTRIBUTION
L2507 0 dB %
5. Activate rectangular clipping: Press AT ELE (T o T
Return > Clipping > Clipping Type until 0 if == dg p 13
[11.1Q@] highlights. u'.]f]gi% - d8 ; 0.17
6. Set 80% clipping for the I data: Press Peak  L.7 dB I l]ul-]gi;
Clip |1] To > 80 > %. ] PERR/AUG_dB 10.0

7. Set 40% clipping for the Q data: Press
Clip |Q]| To > 40 > %.

Apply the rectangular clipping to the waveform: Press Apply to Waveform.

Create the CCDF plot (see the Example waveform curve after rectangular clipping
example at right): Press Plot CCDF.
COMPLEMENTARY/CUNULAT IVE DISTRIBUTION
10. Ol.)se?ve the waveform’s curve after 49, 503 0 d8 E 1003 UAUFFORN: M¥_TEST_REC
Chpplng- 109 =---—-dB | B 10%
. . 1z --—-di | A 1%
Note the reduction in dkE =85 017
. = tr] ——— L - e
peak.—to—average power relative to the e o @ I oow
previous plot. Y 0.001%
0 PEAK/AVG _dB 10.0
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Scaling a Waveform

Scaling a Waveform

The signal generator uses an interpolation algorithm (sampling between the I/Q data points) when
reconstructing a waveform. For common waveforms, this interpolation can cause overshoots, which
may create a DAC over-range error condition. This chapter describes how DAC over-range errors
occur and how you can use waveform scaling to eliminate these errors.

¢ How DAC Over-Range Errors Occur on page 183

e How Scaling Eliminates DAC Over-Range Errors on page 184

¢ Agilent MXG waveform scaling on page 185 and page 186:

— Waveform runtime scaling to scale a currently-playing waveform

— Waveform scaling to permanently scale either the currently playing waveform, or a
non-playing waveform file in BBG media

Figure 8-12 Scaling Softkeys
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How DAC Over—Range Errors Occur

The signal generator uses an interpolator
filter when it converts digital I and Q
baseband waveforms to analog
waveforms. Because the clock rate of the
interpolator is four times that of the
baseband clock, the interpolator
calculates sample points between the
incoming baseband samples and smooths
the waveform as shown in the figure at
the right.

The interpolation filters in the DACs
overshoot the baseband waveform. If a
baseband waveform has a fast-rising
edge, the interpolator filter’s overshoot
becomes a component of the interpolated
baseband waveform. This response
causes a ripple or ringing effect at the
peak of the rising edge. If this ripple
overshoots the upper limit of the DAC
range, the interpolator calculates
erroneous sample points and is unable
to replicate the true form of the ripple
(see the figure at the right). As a result,
the signal generator reports a DAC
over-range error.

Basic Digital Operation (Option 651/652/654)
Scaling a Waveform

INTERPOLATED SAMPLES

N/

BASEBAND SAMPLES

OVER-RANGE SAMPLES CANNOT
BE INTERPOLATED CORRECTLY

DAC RANGE N

ya

BASEBAND SAMPLES
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Scaling a Waveform

How Scaling Eliminates DAC Over—Range Errors

Scaling reduces the amplitude of the baseband
waveform while maintaining its basic shape and
characteristics, such as peak-to-average power
ratio. If the fast-rising baseband waveform is
scaled enough to allow an adequate margin for
the interpolator filter overshoot, the interpolator
filter can calculate sample points that include
the ripple effect and eliminate the over-range
error (see the figure at the right).

Although scaling maintains the basic shape of
the waveform, excessive scaling can compromise
waveform integrity. For example, if the bit
resolution becomes too low the waveform
becomes corrupted with quantization noise. To
achieve maximum accuracy and optimize
dynamic range, scale the waveform no more
than is required to remove the DAC over-range
error. Optimum scaling varies with waveform
content.

SAMPLES WITHIN DAC RANGE
INTERPOLATED CORRECTLY

DAC RANGE

<

N/

BASEBAND SAMPLES
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Scaling a Waveform

Setting Waveform Runtime Scaling

Runtime scaling scales the waveform data during playback; it does not affect the stored data. You can
apply runtime scaling to either a segment or sequence, and set the scaling value either while the ARB
is on or off. This type of scaling is well suited for eliminating DAC over-range errors. Runtime scaling
adjustments are not cumulative; the scaling value is applied to the original amplitude of the
waveform file. There are two ways to save the runtime scaling setting: by using the save function
(page 71) and by saving the setting to the file header (page 145). Saving to the file header saves the
value with the waveform file, saving with the Save function stores the value as the current
instrument setting.

Use this example to learn how to scale the currently selected waveform.
1. Select the waveform to which you want to apply scaling:

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired waveform (segment or sequence).
c. Press Select Waveform.

2. Play the selected waveform: Press ARB 0ff On until On highlights.
Set the Waveform Runtime Scaling value:
a. Press ARB Setup > Waveform Runtime Scaling.
b. Enter a scaling value.

The signal generator automatically applies the new scaling value to the waveform. There is no
single value that is optimal for all waveforms. To achieve the maximum dynamic range, use
the largest scaling value that does not result in a DAC over-range error.

c. Press Return.
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Setting Waveform Scaling

Waveform scaling differs from waveform runtime scaling in that it permanently affects waveform data
and only applies to waveform segments stored in BBG media. You scale the waveform either up or

down as a percentage of the DAC full scale (100%). If you scale your waveforms using this method,

you may also need to change the waveform runtime scaling value to accommodate this scaling.

When you scale, the signal generator permanently modifies the waveform file’s sample values so that
they conform to the desired scaling value. When you initiate scaling, the signal generator performs
the following actions:

¢ locates the waveform file’s absolute peak sample value

* determines its current percentage of full scale

e calculates the ratio of the desired scale value to the determined absolute peak sample scale value
¢ multiplies each sample in the waveform file by this ratio

Peak sample

DAC full scale 100%

. .‘../. ....................... 85% of full scale—Prescaling
¢ = Samples L
L :

. . .4 = =+ 60% of full scale-Post scaling
o : L
e : e *
L * L H
. : UEL *
‘ Original ramp waveform : POt - Scaled ramp waveform :
- [} v *

Scaled sample value = scaling ratio x prescale sample val

Scaling ratio = desired scale val / current scale val
=60/85
=0.70588

Each sample in the waveform is multiplied by 0.70588 to
reach the 60% post scaling waveform amplitude.

When you scale a waveform, you can create fractional data, lose data, or both. Fractional data occurs
almost every time you reduce or increase the scaling value, and causes quantization errors.
Quantization errors are more noticeable when scaling down, since you are closer to the noise floor.
You lose data when either the signal generator rounds fractional data down or the scaling value is
derived using the results from a power of two. This means that scaling a waveform in half (power of

two: 21 = 2) causes each waveform sample to lose one bit. The waveform data modifications are not
correctable and may cause waveform distortion. It is always best to make a copy of the original file
prior to applying scaling.

Use the following examples to apply waveform scaling to a waveform file. While this process uses the
factory-supplied waveform RAMP TEST WFM, it is the same for any waveform file.

Copy a Waveform File
1. Display the waveform files in BBG media: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP TEST WFM.
3. Press Copy File.
4

Name the copy (this example uses the name MY TEST SCAL) and press Enter.
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Scaling a Waveform

Apply Scaling to the Copied Waveform File

CAUTION This type of scaling is non-reversible. Any data lost in the scaling operation cannot be
restored. Save a copy of the waveform file before scaling.

1. Open the DUAL ARB Waveform Utilities menu:
Press Mode > Dual ARB > More > Waveform Utilities.

2. In the list of BBG Media segment files, highlight the copied file (in this example, MY TEST SCAL).
Set and apply a scaling value (in this example 70% scaling is applied):
Press Scale Waveform Data > Scaling > 70 > % > Apply to Waveform.
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Setting the Baseband Frequency Offset

The baseband frequency offset specifies a value to shift the baseband frequency up to +50 MHz
within the BBG 100 MHz signal bandwidth, depending on the signal generator’s baseband generator
option. While the following figure shows how to access the control using the Dual ARB player, the
location of the Baseband Frequency Offset softkey within each ARB format, through the ARB Setup
softkey, is the same as for the Dual ARB player.

When the Baseband Frequency Offset is non-zero, the hardware rotator accumulates phase-shift of
the baseband signal. This residual phase remains even after the offset value is returned to zero. To
remove this phase accumulation, either restart the personality or select the Baseband Frequency Offset
Phase Reset softkey. This softkey will grey out whenever the phase, due to the frequency offset, is
zero. In addition, while there is a non-zero residual phase present in the signal, the DAC Over-Range
Protection feature will automatically ensure that the reduced internal scaling is applied. This reduced
scaling will be removed when both the frequency offset is returned to zero and the phase is reset.

Figure 8-13 Baseband Frequency Offset Softkey for the Dual ARB Player

Mode The settings in this menu
can be stored to the file
header, see page 143.

Arb
Nodulation Mode ____ ARB Arb Setu
WA On Arb Sample Clock
b Sample Clocl
Dual ARBH—I 12E. 000000000rH=
Select
Haveform e —
eal-Time
Cuskamy ookM—— page 243
ARE Setupk >
Feal-Time
TP T Prizse Moise Setup™ page 243
(EDEtinuausi. gets the Bagifband |
ree Fun i i requency Offset value
Funt.ime Scalin
THo-Tanek 70.00 3 |—page 182 entered in the signal to
baseband.
Hodulatgg ?gtgg
Multitonew o
Hore 1 of 2 ™ e— = Arb Setup # lears the phase
- R ——m—m—e————omoou accumulation and so zeros
lore 1 of 2 lore 1 of 2 the phase shift. Causes a
sudden phase shift
discontinuity of the
baseband signal.
Q—page e
For details on each key, use key help HUltl_BBGSg%BE; page 212
as described on page 42. (OffD
Feal-Time
Modulation Filbers——pPage 212
(Mugquist)
__llore 2 of 2 %

Common uses for the offset feature include:

o offsetting the carrier from any LO feedthrough (carrier signal spur at the carrier frequency)
* sum the baseband signal with external I and Q inputs to create a multicarrier signal
* use the signal generator’s I/Q signal as an IF

188 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Basic Digital Operation (Option 651/652/654)
Setting the Baseband Frequency Offset

NOTE Changing the baseband frequency offset may cause a DAC over range condition that
generates error 628, Baseband Generator DAC over range. The signal generator
incorporates an automatic scaling feature to minimize this occurrence. For more information,
see “DAC Over-Range Conditions and Scaling” on page 190.

The baseband frequency offset value is one of the file header parameters (page 143), which means
you can store this value with the waveform. When you select a waveform with a stored frequency
offset value, the signal generator changes the current value to match the stored file header value. If
there is no stored baseband offset frequency value for the current waveform, the signal generator
uses the last set frequency offset value.

You can also use the Save function (page 71) to store this value as part of the signal generator setup.
When you Recall a setup stored with the Save function, the baseband frequency offset value becomes
the current instrument setting value, disregarding the stored file header value.

Use the following steps to offset the carrier from LO/carrier feedthrough. This example uses the
factory supplied waveform, SINE_TEST WFM available in the Dual ARB Player. To view the output for
this example, connect the RF OUTPUT of the signal generator to the input of a spectrum analyzer.

1. Select and play the waveform.

a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On BBG Media column, select SINE TEST WFM.
c. Press Select Waveform.

Generate the waveform: Press ARB Off On to On.
3. Configure the carrier signal:

a. Set the carrier signal to 1 GHz.
b. Set the amplitude to 0 dBm.
c. Turn on the RF OUTPUT.

4. Press Mode > Dual Arb > ARB Setup > More > Baseband Frequency Offset > 20 MHz.

The modulated RF signal is now offset from the carrier frequency by 20 MHz as shown in the
following figures.
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Modulated carrier with 0 Hz Modulated carrier with 20 MHz

baseband frequency offset baseband frequency offset Modulated RF signal

.

LO/carrier feedthrough

LRV e e MWM\WMWMM\M\MN\MJN\WAWNNWMWM it

Spectrum analyzer set to a span of 100 MHz

DAC Over—Range Conditions and Scaling

When using the baseband frequency offset (at a setting other than 0 Hz), it is possible to create a
DAC over-range condition, which causes the Agilent MXG to generate an error. To minimize this
condition with the frequency offset feature, the Agilent MXG incorporates an automatic DAC
over-range protection feature that scales down the 1I/Q data by 1/square root of 2 when the offset is
something other than zero. Because it can scale the data by more than what is actually need, it
typically decreases the dynamic range of the waveform. This is especially noticeable when using a
constant amplitude signal such as GSM.

For the Dual ARB Player, this automatic over-range feature can be turned off. When on, it is active
for the Dual ARB signal only when the offset is something other than 0 Hz. The control for the Dual
ARB DAC over-range protection feature is located in the key path as shown in Figure 8- 14.
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Figure 8-14 Dual ARB DAC Over—Range Protection Softkey Location
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Setting the Baseband Frequency Offset

When the DAC over—range protection is off,
g—~climinate over—range conditions by
decreasing the scaling value (see “Setting
Waveform Runtime Scaling” on page 185).

Arb_Setup &

Easeband
Freguency Of fset
0.000 Hz

Hulti—BBGSSgnc
(Master)

Default setting is On. Available only
when Real-Time Phase Noise is on
(see page 251)

Turn off when you want to manually
control scaling while using the
baseband frequency offset feature.
Manually adjust the scaling using the
Waveform Runtime Scaling softkey
above.

ctupMi——Ppage 212

In the Dual ARB Player, to avoid excessive scaling or to just perform scaling manually, turn the
feature off and use the Waveform Runtime Scaling softkey to eliminate DAC over-range conditions.
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1/Q Modulation

1/Q Modulation

The following factors contribute to the error vector magnitude:

¢ Differences in amplitude, phase, and delay between the I and Q channels

e DC offsets

The I/Q menu not only enables you to select the I/Q signal source and output, it also provides

adjustments and calibrations to compensate for differences in the I and Q signals.

See also, “Modulating the Carrier Signal” on page 61.

Figure 8-15 1/Q Display and Softkeys
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EVM is an 80% nyquist filter (100Mhz wide) with a wide transition band.
When an equalization filter is active, this filter is not active.

*&—Selects between optimizing the internal I/Q channel for EVM (in channel
performance) at the expense of ACP (out of channel performance) or
optimizing for ACP at the expense of EVM.

1/0
Int Phase . .
Folar ity Inverts an internally generated Q signal, so that the | component lags the
Invert Q component by 90 degrees.
BUPStlBﬁB +~¢—Used only with internally generated, bursted modulation

formats. Enables/disables the RF burst modulator.

-«—Opens the internal I/Q Equalization Filter which can be used
to correct and/or impair the RF and External I/Q outputs for
the internal I/Q source.

the unselected path.

ACP is also an 80% nyquist filter (100Mhz wide), but the transition band
is very narrow, thus reducing images for wide-band signals. This filter will
be convolved with the active equalization filter, the result of which will be

truncated to the center 256 taps.

SCPI Commands :

[:SOURce] :DM: INTernal : CHANnel :OPTimization EVM|ACP
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s
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These selections are
reflected in the

1/Q Routing &
Optimization graphic.

Optimization

RF Outpu

Ext I/0 Outpu

Each path requires different optimization values;
when you select a path, you are selecting the
unique optimization values required by that path.

The signal generator applies the selected
optimization values to both paths, which impairs

For details on each key, use key help
as described on page 42.
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1/Q Modulation

Using the Rear Panel | and Q Qutputs

NOTE The rear panel I and Q connectors only output a signal while using the internal BBG.

In addition to modulating the carrier, the signal generator also routes the internally generated I and
Q signals to the rear panel I and Q connectors. These output signals are post DAC, so they are in
analog form. You can use these rear panel I and Q signals to:

e drive a system’s transmitter stage
¢ test individual analog I and Q components such as an I/Q modulator
¢ route the I and Q signals into another signal generator

The factory default setting routes the internally generated I and Q signals to the I/Q modulator and
the rear panel I and Q output connectors. However to optimize (apply calibration factors) the rear
panel signals, you need to select the external I/Q output path.

Select and Play a Waveform

1. Press Mode > Dual ARB > Select Waveform.
2. Highlight the desired waveform.
3. Press Select Waveform > ARB Off On to On.

Optimize the Signal Path

1. Connect cables from the rear panel I and Q connectors to either a DUT or another signal
generator.

When you turn the ARB on, the signal generator automatically outputs the I and Q signals to the
rear panel connectors. You can use the rear panel I and Q signals as I and Q inputs to another
signal generator. The MXG has front panel connectors, I Input and Q Input, for this purpose.

2. Press 1/Q > 1/Q Correction Optimized Path > Ext 1/Q Output.

When you optimize a path, the path indicator turns green.

Factory default setting—RF Output path optimized T/0
T/0 Routing & Optimization - ﬁ
BB GEN | $ I/0 0UT HE:—,E?HEE?'
I/0 Correction
EXT IN RF_OUT Opt.imized Pathn
(RF Output)
E Optimized Path B
1/0 Optimization /| (O F 2
RF Output
Rear panel 1/Q path optimized <
I/0 Routing & Optimization Ext I/0 Output
— e / Lo aatta i)
EXT IN RF OUT
E Optimized Path
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1/Q Modulation

Configuring the Front Panel Inputs

The signal generator accepts externally supplied analog I and Q signals through the front panel I
Input and Q Input. You can use the external signals as the modulating source, or sum the external
signals with the internal baseband generator signals.

1. Connect I and Q signals to the front panel connectors.
a. Connect an analog I signal to the signal generator’s front panel I Input.
b. Connect an analog Q signal to the signal generator’s front panel Q Input.
2. Set the signal generator to recognize the front panel input signals:
e To Modulate onto the Carrier

Press 1/Q > 1/Q Source > External.

I/0 Routing & Optimization

Signal generator display: both paths are calibrated
when the 1/Q Correction Optimized Path is set to

Ext I/Q Output (see page 193) —

Note: when the optimized path is set to RF, only the
RF Out path is calibrated. [ Optimized Path

¢ To Sum and Modulate onto the Carrier
Press 1/Q > 1/Q Source > Sum.
To select and play a waveform for the BB GEN path, see page 137.

I/0 Routing & Optimization

Signal generator display: both RF paths are calibrated
when the I/Q Correction Optimized Path is set to
RF Output (see page 193)

[ Optimized Path

Notice that only the internal BBG (BB GEN) routes I and Q signals to the rear panel I and Q
outputs.

3. If you are using only the external I and Q signals (no summing), turn on the I/Q modulator:
Press 1/Q 0ff On to On.

4. Configure the RF output:
a. Set the carrier frequency.
b. Set the carrier amplitude.

c. Turn the RF output on.
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1/Q Adjustments
1/Q Adjustments
Use the I/Q Adjustments to compensate for or add impairments to the I/Q signal.
The DC offset values are calibrated relative to
the RMS waveform voltage being played out of
the ARB. See page 146. BB I/0 Adj
Xy
. Adjusts the | signal amplitude relative to the Q . ‘
I/Q > 1/Q Adjustments signal amplitude. Use this as an internal
. impairment, or to compensate for differences in 0 _Dffeet
1/0 Adjustments signal path loss that occur due to path 0.000 %
1/0 Adjustments irregularities in the external | and Q output -
B N gen
0.000 de
Internal Baseband
; ¥ L Quadrature
Ad.justments Anole Adjustment
Offsets the phase of the Q signal y 0.00 deg
External Input - relative to the phase of the | signal.
3 —————————————— P
Ad justments® Ext In 1/0 Ad The baseband quadrature
Exter‘n?lD\%l\ggg% adjustment key is calibrated in units
External Dutput' g.000 W of degrees. The external input Hore 1 of 2
djustments — T quadrature adjustment is not
wternal Inpu i
W 0 OFfast calibrated.
0.0o0 W

The function provided by this key is

' ] Jyadrature / not the same as the function
. i provided by the I/Q Skew key.
E%U DUt 170 AdJ Angle ﬂdJustrrgl?B

I/0 Attenuator Skew is typically used either to create
12,57 dB ‘,\A‘“\ impairments, or to reduce error vectors on
Manual it

large bandwidth signals.

Common_HMode : - .
1/0 Offset Eange Provides a relative time delay correction
@ ine

. between the | and Q signals. The different
he 1/Q Attenuator softkey affects the 1/Q signal to the RF signal paths traveled by the | and Q signals
Common Mode Output and the External I/Q Outputs.

result in time delay differences that show
IS%SEESEE up as an EVM errv)s,r in large bandwidth
- This softkey is active when the I/Q optimized path is set modulated signals.
DlEFﬁF?ggE to Ext I/Q Output and a digital modulation personality is Adding an equal and opposite time delay
Available only 0.0000 on. This attenuation is also adjustable using the Mod (skew) in the 1/Q signals during baseband
with Option 1EL Diff. Mode Attenuator key located in the Arb Setup menus in each generation eliminates the time delay error,
0 Offset personality. This adjustment is not affected by the 1/Q correcting for any delays in signals that are
0.0000 v Adjustments On/Off key. generated in the internal baseband

generator.

When Auto mode is selected, the signal generator
automatically optimizes 1/Q attenuation for the current
conditions. When the Manual mode is selected, 1/Q
Attenuation is the active function. The value you enter

Availabl ly wh
sets the attenuation level of the 1/Q signal. valiable only when a

waveform is playing.

SCPI Commands (Refer to the commands for each

personality):
[:SOURce] :RADio: <personalitys>:IQ:MODulatio

n:ATTen

Changes the absolute phase of
Offsets are typically used to either reduce carrier leakage, or to create an impairment that simulates carrier leakage. both the | and Q signals with

respect to triggers and markers.
Common Mode I/Q Offset Range Positive values add delay and
This changes the adjustment range of the Common Mode 1/Q Offset from Coarse (Default) to fine or vice versa. The Coarse  negative values advance the
range corresponds to the default value of + 2.5V. The Fine range corresponds to a value of + 100 mV. signals. This value affects both
Common Mode 1/Q Offset the baseband signal modulated
This adjusts the DC offset of both | and Q signals simultaneously. onto the RF and the external
Diff Mode | Offset output signals (I and Q). This
This adjusts the DC offset level of the | and I-bar output signal. | and I-bar cannot be adjusted independently. setting cannot be used with

constant envelope modulation
and it does not affect external |
and Q inputs.

Diff Mode Q Offset
This adjusts the DC offset level of the | and I-bar output signal. | and |-bar cannot be adjusted independently.
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1/Q Calibration

Table 8-2 1/Q Adjustments Uses

I/Q Adjustment Effect Impairment
Offset Carrier feedthrough dc offset
EVM error phase skew
Quadrature Angle
I/Q Images I/Q path delay
1/Q Skew EVM error high sample rate phase

skew or I/Q path delay

I/Q Gain Balance I/Q amplitude difference I/Q gain ratio

The I/Q adjustment, I/Q Delay, is not for adding impairments; its function is to compensate for any
latency between the EVENT output signals (marker signals) and the RF output.

17Q Calibration

Use the I/Q calibration for I and Q signal corrections. What aspects of the I and Q signal is corrected
depends on whether the signal is internally or externally generated.

Correction Internal I and Q | External I and Q
Offset X X
Gain Balance X --
Quadrature Error X X

When you perform an I/Q calibration, that calibration data takes precedence over the
factory-supplied calibration data. The calibration routines improves performance that may degrade
over time or due to temperature changes.
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1/Q Calibration

C optimizes the 1/Q performance for the current
instrument settings, and typically completes in several
. . . . seconds. Changing any instrument setting except for 1/Q
I/Q > 1/Q Calibration /0 Calibration /| adjustments after performing a DC calibration voids the DC
calibration and causes the signal generator to revert to the

E te Cal
HERULE L8 factory—supplied calibration data.

Calibration Tupe | Presgtting the instrument or cycling power is equivalent to
User  Full pressing Revert to Default Cal Setting.

) User provides a quicker calibration when a full calibration
Available only when is not required. You can limit the calibration by specifying
Calibration type = User the calibration start and stop frequencies.

When you limit the calibration to less than the instrument’s

Rewvert to full frequency range, the factory—supplied calibration data
R e is used for the rest of the range.

Deletes any user—generated Information is retained through a preset or power cycle*.

calibration data and restores
the factory—supplied Full takes 5 minutes, executing measurements over the
calibration data. instrument’s entire frequency range.

Information is retained through a preset or power cycle*.

*Caution:

To avoid the loss of data, GPIB settings, or current user
instrument states that have not been permanently saved to
non-volatile memory, the MXG should always be powered

Note i . . . . down either via the MXG's front panel power button or the
A DC calibration requires the following settings: appropriate SCPI command. MXG's installed in rack
«1/Q: On systems and powered down with the system rack power

. . . switch rather than the MXG's front panel switch display a
Optimized Path: RF Output Error -310 due to the MXG not being powered down
« Source: Internal correctly.

For details on each key, use key help
as described on page 42.
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Using the Equalization Filter

Using the Equalization Filter

An equalization FIR file can be created externally, uploaded via SCPI, and subsequently selected from
the file system (refer to “Working with Files” on page 63). For information related to downloading
FIR file coefficients, refer to the Programming Guide. For information regarding working with FIR
file coefficients manually, refer to “Modifying a FIR Filter Using the FIR Table Editor” on page 206.

This filter can be used to correct and/or impair the RF and External I/Q outputs for the internal 1/Q
source. This filter will be convolved with the ACP Internal I/Q Channel Optimization filter if that
filter is selected, the result of which will be truncated to the center 256 taps. The equalization filter
operates at 1256MHz, so all equalization filters must be resampled to 125MHz prior to selection, if
they are sampled at some other rate.

The MXG supports equalization filters—either Complex or Real—that are programmable FIR filters
with two inputs (I, Q) and two outputs (I, Q) per sample. This 256-tap filter has two modes of
operation:

NOTE The maximum number of taps is 256 (with 2 coefficients per tap for a complex filter) for
equalization filters. The minimum number of taps is 2.

Equalization filters can also be referred to as predistortion filters or correction filters.

Type of Description

Filter

Real The I and Q samples are independently filtered by a single set of real coefficients.
Complex The samples are treated as complex (I + jQ) and convolved with the filter coefficients which

are specified as (I + jQ) in the time domain.

The equalization filter can be turned on and off.
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Figure 8-16 Int Equalization Filter Softkeys

Basic Digital Operation (Option 651/652/654)
Using the Equalization Filter

For details on each key, use key help
as described on page 42.

Enables the internal
—— equalization filter.

Opens a file catalog of FIR filters to select as the equalization filter. Equalization filters are
typically complex and must have an oversample ratio of 1. The filter must not have more than

—— 256 taps (512 coefficients for a complex filter). The equalization filter operates at 125MHz, so
all equalization filters must be resampled to 125MHz prior to being placed in the MXG.

page 201

1/Q > More

1/0 & Int Eg Filter 7
Int Phase Int Equalization |
Folarity Filter

Invert on
Burst, 2lope Select Filter S
on C=hOME= 3

Int Equalization i

Pt — pee

Optimize Int 1,0 « .A...«/ .

Channel For
ACP

o

Note:

page 192

Use the FIR Table editor to view the filter’s coefficients.

Refer to page 206.

For more information on the SCPI commands,
refer to the SCP/ Command Reference.

SCPI commands:

Equalization filter state:
[:SOURce] :DM: INTernal :EQUalization
[:SOURce] :DM: INTernal :EQUalization
Equalization filter selection:

[:SOURce] :DM: INTernal : EQUalization
[:SOURce] :DM: INTernal : EQUalization

To add a real filter to the file system:

:FILTer:
:FILTer:

STATe { OFF }
STATe?

| on

SELect "filename"
SELect?

:FILTer:
:FILTer:

:MEMory:DATA:FIR "filename", [REAL,] osr, coeffl [,coeff2 [..,
coeffN] ]

:MEMory:DATA:FIR? "filename"

To add complex filter to the file system:

:MEMory:DATA:FIR "filename", COMPlex, osr, hIRe0O, hQImO [, hIRel,

hQIml [.., hIReN, hQImN]]
:MEMory:DATA:FIR? "filename"

To add 1/Q symbol data to the file system:
:MEMory:DATA “WFM1:filename", <blockdata>
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Basic Digital Operation (Option 651/652/654)
Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter

Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation
Filter

Finite Impulse Response filters can be used to compress single carrier I/Q waveforms down to just
the 1I/Q constellation points and then define the transitions similar to the modulation filter in Arb
Custom (refer to “Using Finite Impulse Response (FIR) Filters in ARB Custom Modulation” on
page 273). The key difference for dual ARB real-time modulation is that a filter is applied as the
waveform plays, rather than in the waveform data itself.

Figure 8-17  Filter Menu

Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter >
Enables or disables the Modulation Filter. This filter is typically applied to an Arb Waveform
containing just the 1/Q symbol decision points. The Modulation Filter then effectively

defines the transitions between the symbol decision points. This means that the filter must
have an oversample ratio of 2 or more. When this feature is active, the Sample Clock Rate

is actually the Symbol Rate. Also, the filter must be real (refer to page 210). Filter Select /7|

Root. Hyquist
| Filters 7 u

Modulation Filter
| Of+ ]

Muguist

Available only when the filter selected =
Root Nyquist or Nyquist

Select

(Nuguist) Gaussian

Def ine, f———page 201 Opens the 1S-95
User FIR® Filter Alpha I5-35M—filter selection
0.350 menu.

This softkey changes, depending

T oﬁhe?eleaedﬁer—Type._ Uzer FIRM
Filter BbT
0.500

Filter Alpha |—
0.350 =_page 206

fore 1 of 2

Optimize FIR For
ACP

page 198

Available only when the

filter selected = Gaussian Filter Select
HEOMA

Fectangole

EOGE

EDGE Wide

EOGE HSR

fore 2 of 3

_Filter Select 7

APCO 25 CLFM

For details on each key, use key help as described on page 42.

P T
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Creating a User—Defined FIR Filter Using the FIR Table Editor

Basic Digital Operation (Option 651/652/654)
Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter

In this procedure, you use the FIR Values table editor to create and store an 8-symbol, windowed
sync function filter with an oversample ratio of 4.

Accessing the Table Editor

1.
2.
3.
4.

Press Preset.

Press Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter > Select > Nyquist.
Press Define User FIR.

Press More 1 0of 2 > Delete All Rows > Confirm Delete of All Rows.

This will initialize the table editor as shown in Figure 8-18.

Figure 8-18 Creating a User—Defined FIR Filter Using the FIR Filter Table Editor

Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter > Define
User FIR > More 1 of 2 > Delete All Rows > Confirm Delete of All Rows

'

For details on each key, use key help as described on page 42.

FREQUEHCY RF_OFF User Filter
6.000 000 000 00 GHz Load/Storem
ALC OFF
Lomd Default |
FIR Values Due/r‘iaamlE_BaLiD;_LL\Length In Sumbols: O FIR
Coeff. Real Value magi
o Delete ALL Rowsk
Convert To |
Feal Filter
Display Filterw
fore 2 of 2
17
Active only when:
FIR filter coefficient table
has minimum of two
values visible.
Note:

Modulation filters must be real and have an oversample ratio (OSR) of 2 or greater.
Equalization filers are typically complex and must have an oversample ratio (OSR) of 1.

Entering the Coefficient Values
1.

Press the Return softkey to get to the first page of the table editor.

2. Use the cursor to highlight the value field for coefficient 0.

Opens a menu that
enables you to select
and load a saved file
into volatile memory.
See page 43.

page 207

Adds a column for
specifying the imaginary
coefficients of the filter.*
(All of the imaginary
coefficients will be 0
initially.) If the Convert to
Complex Filter softkey
has been selected the
Convert to Real Filter
softkey becomes
available.

Caution: Selecting the
Convert to Real Filter
softkey removes the
Imaginary Values column
and the imaginary values
are lost.
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Basic Digital Operation (Option 651/652/654)
Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter

3. Use the numeric keypad to type the first value (—0.000076) from Table 8-3. As you press the
numeric keys, the numbers are displayed in the active entry area. (If you make a mistake, you can
correct it using the backspace key.)

4. Continue entering the coefficient values from the table in step 1 until all 16 values have been

entered.
Table 8-3

Coefficient Value Coefficient Value

0 —0.000076 8 —0.035667
1 —-0.001747 9 —0.116753
2 —0.005144 10 —0.157348
3 —0.004424 11 —0.088484
4 0.007745 12 0.123414
5 0.029610 13 0.442748
6 0.043940 14 0.767329
7 0.025852 15 0.972149
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Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter

Duplicating the First 16 Coefficients Using Mirror Table

In a windowed sinc function filter, the second half of the coefficients are identical to the first half in
reverse order. The signal generator provides a mirror table function that automatically duplicates the
existing coefficient values in the reverse order.

1. Press Mirror Table. The last 16 coefficients (16 through 31) are automatically generated and the
first of these coefficients (number 16) highlights, as shown in Figure 8-19 on page 203.

Figure 8-19

FIR table coefficient
values, may be from the
factory default values or
entered by the user.

TREQUENCY 6.000 000 000 00 st n“p—LTuanEZIUU den

User Filter

Inzert Roud

_ Oelete Rod

FIR Values (UHSTORED) Oversample Ratio: L
Coeff. Ualue Length In Sumbols: 8

10 -0.1573487>

11 -0.088k8k0 ( Coteliony

12 0.123414 f
| 13 0.4L2745 J

14 0.767329 Mirror Table
| 15 0.9721L5

16 0.9721L5

17 0.767329 0 1= Rati
\ 18 0.LL4Z748 versamkie Fatin

13 0. 123414

02,/20/2007 X2:28 More 1 of 2

For details on each key, use key help as described on page 42.

Use the Goto Row
menu to move around
and make changes to
the FIR Values
coefficient table.
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Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter

Setting the Oversample Ratio

NOTE Modulation filters are real and have an oversample ratio (OSR) of two or greater.

Equalization filters are typically complex and must have an OSR of one (refer to “Using the
Equalization Filter” on page 198 and to “Setting the Real-Time Modulation Filter” on
page 210).

The oversample ratio (OSR) is the number of filter coefficients per symbol. Acceptable values range
from 1 through 32; the maximum number of taps allowed by the table editor is 1024.

The actual limits on OSR, number of coefficients, and number of symbols depends on the feature
with which the FIR is used. Refer to Table 8-4.

Table 8-4
Filter Type Oversampling Ratio Number of Taps Symbols/Coefficients
(OSR) (Maximum) (Maximum)
Equalization® 1 256 -
ARB Custom >2 -- 512/1024
Modulation®
Dual ARB >2 -- 32/1024
Real-Time
Modulation®

3When I/Q timing skew, I/Q delay, or the ACP internal 1/Q channel optimization features are active, the
effective number of taps for the equalization filter are reduced.

bThe filter may be sampled to a higher or lower OSR.
The filter will be decimated to a 16 or lower OSR depending on the symbol rate.

For modulation filters, if the oversample ratio is different from the internal, optimally selected one,
then the filter is automatically resampled to an optimal oversample ratio.

For this example, the desired OSR is 4, which is the default, so no action is necessary.

Displaying a Graphical Representation of the Filter

The signal generator has the capability of graphically displaying the filter in both time and frequency
dimensions.

1. Press More 10f2 > Display FFT (fast Fourier transform).
Refer to Figure 8-20 on page 205.
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Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter

Figure 8-20

FREQUEHCY ANPLITUDE

6.000 000 000 00 &z | -144.00 den

FFT
0
d
B
For details on each key, use key
help as described on page 42. =100 5 Sumbol Rate 2
T7/20/2007 12:37
2. Press Return.
3. Press Display Impulse Response.
Refer to Figure 8-21.
Figure 8-21
FREQUENCY ANPLITUDE

6.000 000 000 00 &z | ~144.00 den

. Impulse Response

1 Length In Sumbols: Oversample Ratio: L

For details on each key, use key
help as described on page 42.

-0-5 g Coefficient

31
02‘20‘200? 12:40

4. Press Returnto return to the menu keys.

Storing the Filter to Memory
Use the following steps to store the file.

1. Press Load/Store > Store To File. The catalog of FIR files appears along with the amount of memory
available.

2. As described in Storing, Loading, and Playing a Waveform Segment on page 136, name and store
this file as FIR 1.

The FIR_1 file is the first file name listed. (If you have previously stored other FIR files, additional
file names are listed below FIR_1.) The file type is FIR and the size of the file is 260 bytes. The
amount of memory used is also displayed. The number of files that can be saved depends on the size
of the files and the amount of memory used. Refer to Figure 8-22.
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Modifying a FIR Filter Using the FIR Table Editor

Figure 8-22

FREQUEHCY ANPLITUDE

6.000 000 000 00 &z | -144.00 den

List Load/store

Load From
Selected File

Store To
FileM

Catalog of FIR Files in Int Storage 30MB used LGSME free
File Hame Tupe Size Hodified
1 FIR_1 FIR 260 02/20/07 12:LE
2 I 20 ‘07 1245

Delete Files
These keys manage the table

of DMOD files in internal

Goto Roue storage.

02/20/2007 12:4L7

Catalog displays FIR files that
have been previously saved by
the user.

For details on each key, use key help as described on page 42.

Memory is also shared by instrument state files and list sweep files.

This filter can now be used to customize a modulation format or it can be used as a basis for a new

filter design.

Modifying a FIR Filter Using the FIR Table Editor

FIR filters stored in signal generator memory can easily be modified using the FIR table editor. You
can load the FIR table editor with coefficient values from user-defined FIR files stored in

non-volatile memory or from one of the default FIR filters.
the new files.

Then you can modify the values and store

206

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Basic Digital Operation (Option 651/652/654)
Modifying a FIR Filter Using the FIR Table Editor

Loading the Default Gaussian FIR File

Figure 8-23  Loading the Default Gaussian FIR File
Mode > Dual ARB > Arb Setup > More > Real-Time

Modulation Filter For details on each key, use key help as described on page 42.
_Filters  # User Filter User Filter Load Def FIR Gaussian BbT
Select, )
(Root. Muguist) Insert. Ao Load/Storer Root Muguists] Gererate
USEEFé?E' Delete Row ’ Load DeFaE%E’ Nuquists
Filter Alpha g
l].gl]l] Goto Rodw Delete ALl Housb—|_> Gaussianm FllteE %85
Dptimize”EIH For : Conwvert To Filter Sumbols
ACP Mirror Table Feal Fiiter Rectanales g
Festore Default i g
Filter ENEREEITERS REEA Display Filters e Hindou, |
(None)
Nore 1 of 2 | “ore 2 or 2% -

|

Default Filter

Hone
These softkeys select a
window function Hamming
(apodization function) for
a filter.
Hann
Kaizer#

__f_;ZT“‘““““KI

Press Preset.
Press Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter > Define User FIR > Gaussian.
Press Filter BbT > 0.300 > Enter.

Press Filter Symbols > 8 > Enter.

or o o o=

Press Generate.

NOTE The actual oversample ratio during modulation is automatically selected by the instrument. A
value between 4 and 16 is chosen dependent on the symbol rate, the number of bits per
symbol of the modulation type, and the number of symbols.

6. Press Display Impulse Response (refer to Figure 8-24).
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Modifying a FIR Filter Using the FIR Table Editor

Figure 8-24
FREQUEHCY AAPLITUDE
6.000 000 000 00 &z | -144.00 den
Impulse Response A
1.2 Lenoth In Sumbols: 8 Oversample Ratio: L
U
a
1
u
e
For details on each key, use key 0.2 -
help as described on page 42. 0 Coefficient VT 1:_?_13?

7.

Press Return.

Modifying the Coefficients

1.
2.
3.

For details on each key, use key
help as described on page 42. =0.9 Coefficient 31

Using the front panel arrow keys, highlight coefficient 15.
Press 0 > Enter.

Press Display Impulse Response.

Figure 8-25
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6.000 000 000 00 &z | ~144.00 den

Impulse Response A
1.5 Lenath In Sumbols: 8 Oversample Ratio: L
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Refer to Figure 8-25 on page 208. The graphic display can provide a useful troubleshooting tool
(in this case, it indicates that a coefficient value is missing, resulting in an improper Gaussian
response).

4. Press Return.
Highlight coefficient 15.
Press 1 > Enter.
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Storing the Filter to Memory

The maximum file name length is 23 characters (alphanumeric and special characters).
1. Press Load/Store > Store To File.

2. Name the file NEWFIR2.

3. Press Enter.

The contents of the current FIR table editor are stored to a file in non-volatile memory and the
catalog of FIR files is updated to show the new file.
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Setting the Real-Time Modulation Filter

The real-time modulation filter effectively compresses a single carrier I/Q waveform down to just the
I/Q constellation points and then controls the transitions similar to the modulation filter in Arb
Custom modulation. The key difference is that this filter is applied as the waveform plays, rather
than in the waveform data itself. The real-time modulation filter is only available for Dual ARB
waveforms.

When the real-time modulation filter is on, the sample clock rate acts as the symbol rate. The sample
clock rate must be set to one half of the sample rate for the real-time Arb modulation filter feature
to be turned on. The sample rate is determined by the Option 65x loaded in

CAUTION Because the Arb format only supports rectangular I/Q data for defining the symbol
decision points, constant envelope modulation, which should be specified as magnitude
and phase, are not supported. (Examples of constant envelope modulation are MSK and
FSK.)

The carrier frequency must be the same for all frequencies used (i.e. only single carrier
applications work with arb real-time modulation filters).

Figure 8-26 Real-Time Modulation Filter Softkey for the Dual ARB Player

Mode > Dual ARB > Arb . oo
Setup > More The settings in this menu

can be stored to the file

header, see page 143. —>
— I5-95
Arb Setup 7 ] Filters r —» _Ailter Select
Easeband ; .
Freauency Dffset flodulat ign fgtter Root. Hyquist 15-95 w/Eq
Easeband
Select ;
IRREEEIEE) (oRacie | (Root Nuauist)® Nuguist 15-95 Hod
Define ;
User FIRY Gaussian 15-95 Mod W/EQ
Multi-BBG Sunc .
Filter Alpha _acb |
izl 0400 [e7en
Feal-Time i
i i | S Optimize FIR For
Modulat ion F%é%\%f)“’ ACP page 200
fMore 2 of 2
These are the available
lter Select real-time modulation filters that
can be applied to a waveform.
HCOMA
<
Filtér Select
Fectangle
APCO 25 CLEM
EDGE
EOGE Wide R WV
For details on each key, use key help APCO 25 CLF
as described on page 42.
Ore 2 o ——|
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Common uses for the real-time modulation feature include:

*  Where the single carrier rectangular ideal I/Q symbol decision points are known and are to have
an over-sampled filter applied.

¢  Where greater effective MXG memory size is required.

*  When you have a low rate waveform that could benefit from a higher OSR that does not make the
waveform longer.

The real-time modulation filter setup is one of the file header parameters (page 143), which means
you can store this setup with the waveform. When you select a waveform with a stored modulation
filter setup, the signal generator changes the current setup to match the stored file header setup. If
there is no stored modulation filter setup for the current waveform, the signal generator uses the last
set modulation filter setup.

You can also use the Save function (page 71) to store this value as part of the signal generator setup.
When you Recall a setup stored with the Save function, the modulation filter value becomes the
current instrument setting value, disregarding the stored file header value.

Use the following steps to apply a real-time modulation filter to the current waveform loaded into
volatile memory. This example uses the factory supplied waveform, SINE TEST WFM available in the
Dual ARB Player. To view the output for this example, connect the RF OUTPUT of the signal
generator to the input of a spectrum analyzer.

NOTE The following setup assumes you have completed the setup in “Setting the Baseband
Frequency Offset” on page 188 for creating a modulated RF signal that is offset from the
carrier frequency by 20 MHz.

1. Configure the modulation filter:
Press Mode > Dual ARB > Arb setup > More > Real-Time Modulation Filter > Select > Root Nyquist
2. Press Filter Alpha > .4 > Enter.

The modulated RF signal now has a real-time modulation filter of type root nyquist, with a filter
alpha of 0.400.

Multiple Baseband Generator Synchronization

Available in the Dual ARB menu, this feature lets you set up a master/slave system of up to sixteen
Agilent MXGs so that the baseband generators (BBG) synchronize the playing of waveforms. The
system count includes one Agilent MXG to function as the master (see “Equipment Setup” on

page 215).

The MXG with Option 012, enables 2x2, 3x3, or 4x4 MIMO configurations to share a common external
LO signal to create phase coherent system. Refer to “Understanding Option 012 (LO In/Out for Phase
Coherency) with Multiple Baseband Generator Synchronization” on page 218 and the Data Sheet.
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Figure 8-27 Multiple Baseband Generator Synchronization (BBG Synchronization) Trigger Softkeys and Menu Location

Note: The BBG sync feature automatically configures the trigger settings shown below. To avoid a settings conflict error in this
process, manually configure the trigger settings prior to setting the BBG sync parameters shown on page 213.
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Figure 8-28 Multiple BBG Synchronization Front Panel Displays

Master Display and Available Softkeys

FREQUEHCY ANPLITUDE Multi-BBG Sunc
Multi-BEG Sunc
2.000 000 000 00 GHz 0.00 dBm Uper=g—— Select Off, Master, or Slave
EXTREE L/ (Master)
Humber of Slaves: 2 Humber of Slaves [M&——Tis is a persistent setting that
NMultiple BBG Sunchronization Settings and Status / / 2 ts;rvwes both preset and cycling
7 e e power.
‘. ulti-BBG Sunc Tupe : Master «—— Grayed—out on master, active for
Euentl ﬁ 10MHz Out  (Mumber of Slaves @ 2 slaves.
to to STATUS:
Fat Tri D . REF IN Out OFf Sunc
At ris Ensure all slaves are listening i
before pressing "Sunc Slaves" unc S lmves [ Synchronizes the baseband
/ on this Master instrument = generators for all instruments in the
// —\ﬂ system.
Note: Press only after pressing
Master/slave indicator and setup Listen for Sync on all slave
diagram. instruments and the slaves show
Master shows one of the following messages: “Waiting For Sync” as the status.
» Out of Sync

* In Sync
Shows after pressing Sync Slaves

Slave Display and Available Softkeys

FREQUEHCY ARPLITUDE
2.000 000 000 00 GHz HUltl_BTEl%Bg)y «—Sclect Off, Master, or Slave
EXIREF ik

HTRE!
MWumber of Slauves . .
- - - - T=—These are persistent settings that
2 p g
NMultiple BBG Synchronization Settings and Status // / survive both preset and cycling the
it power.
ulti-BBG Sunc Tupe : Slaue SIS [Resfielen |
Event.1 Slave Position D #1of 2 —
e STATUS:
Pat Trig ' REF IN Out of Sunc
s Select "Listen for Sunc" on this . )
/ i Slave instrument Lo G Sgnc"_Aﬂer pressing, the slave waits for the
synchronization signal initiated by
- the master.

Note: Press before pressing Sync

Master/slave indicator and setup diagram. Slaves on the master instrument.

The bottom slave indicator is green on the
last slave in the system. Slave shows one of the following messages:
« Out of Sync
« Waiting for Sync
Shows after pressing Listen for Sync
« In Sync
Shows after pressing Sync Slaves on the master

For details on each key, use key help
as described on page 42.
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Understanding the Master/Slave System

System Delay

The multiple BBG synchronization feature provides a system for synchronizing the waveform
generation capability of up to 16 signal generators to within a characteristic value of + 8 ns between
the master and the last slave. This minor amount of delay (*+ 8 ns) can be reduced further to
picosecond resolution by using the 1/Q Delay softkey located in the I/Q menu. To reduce the delay,
check and adjust the BBG signal alignment for each signal generator in the system. For more
information on adjusting the delay, see “I/Q Adjustments” on page 195.

The delay value includes compensation for cables that have less than 1 ns of propagation delay
between the EVENT1 and PAT TRIG connectors (see Equipment Setup). The recommended cable is an
Agilent BNC cable, part number 10502A. The use of cables with greater propagation delay may not
allow the signal generators to properly synchronize.

System Synchronization

Synchronization occurs after the master signal generator sends a one-time event pulse that
propagates through and to each slave in the system. Prior to this event, each slave must recognize
that it is waiting for this event pulse, which occurs during the system configuration (see “Configuring
the Setup” on page 215). In order to properly send the synchronization pulse, the trigger source and
the Dual ARB Player for each signal generator must be turned off.

The master/slave setup does mot incorporate a feedback system between the slaves and the signal
generator selected as the master. After synchronization, if changes occur to the Multi-BBG Sync
Setup menu or a signal generator is added to the system, the master does not automatically
resynchronize the setup. This may cause the signal generators in the system to incorrectly report
their status as In Sync.

The system can also misinterpret other signals as the synchronization pulse, which results in an
incorrect In Sync status. These types of signals include a continuous trigger or an active Marker
routed to the EVENT 1 connector. Improperly connected rear panel cables can also create a false
status.

You must resynchronize the entire system after making any change in one or all of the Multi-BBG
Sync Setup menus, after adding a signal generator to the system, or in doubt as to the true status of
a signal generator. Changes to parameters that are outside of the Multi-BBG Sync Setup menu such
as waveform files, Dual ARB state, sample rate, scaling, carrier frequency or amplitude have no effect
on the system synchronization. To resynchronize a system, see “Making Changes to the Multiple
Synchronization Setup and Resynchronizing the Master/Slave System” on page 217.

System Trigger Setup

The multiple BBG synchronization feature restricts the trigger selections (see page 212) for each
signal generator. For signal generators selected as slaves, you can only modify the trigger type (with
restrictions). The trigger source is fixed and set to receive a trigger through the rear panel PAT TRIG
connector. On the master, you can change both the trigger type (with restrictions) and the trigger
source. The trigger source provides three options for triggering the waveforms: external trigger, front
panel Trigger key, or the GPIB trigger.

If the trigger settings are other than what the BBG synchronization feature supports, the feature
changes the trigger settings to what is shown on page 212. When this change occurs, the Agilent MXG
generates a settings conflict error to alert you to the changes. To avoid the error generation,
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appropriately configure the trigger settings prior to selecting
slave.

Basic Digital Operation (Option 651/652/654)
Multiple Baseband Generator Synchronization

a signal generator as the master or

The system trigger propagates in the same manner as the synchronization pulse initiated by the
master (see System Synchronization). So if it is not turned off during changes to the synchronization

parameters, it can cause a false In Sync status.

The signal generator does not reset the trigger parameters when the multiple BBG synchronization
feature is turned off. To play waveforms after disabling the feature, you must either set the trigger
type to Free Run or provide a trigger to start the waveform play back.

Equipment Setup

Figure 8-29 Multiple Baseband Synchronization Setup

Note: To minimize synchronization delay, the Agilent BNC cable 10502A is the recommended
cable for the rear panel daisy chain connections (see page 214).
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There can be 1 to 15
slaves in a setup.

3

.
Configuring the Setup

Set the Common Parameters

Perform the following steps on all signal generators:
1.
2.
3.

Set the frequency of the carrier signal.

Set the power level of the carrier signal.
Select the desired waveform (see page 136).
Do not turn the Dual ARB on.

If not using the Trigger key, provide an external trigger
source. For information on the PAT TRIG connector,
see page 19.
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4. Except for triggering, set the desired waveform parameters such as markers and sample clock.

The baseband synchronization feature limits the trigger selections for both the master and slaves.
If the current trigger settings include unsupported BBG synchronization parameters, the Agilent
MXG generates a settings conflict error and changes the trigger settings. To avoid the settings
conflict error, manually set the trigger parameters as shown on page 212 prior to setting the
multiple BBG synchronization parameters.

5. Turn on the RF Output.

Set the BBG Synchronization Master Parameters
1. Press Mode > Dual ARB > ARB Setup > More > Multi-BBG Sync Setup > Multi-Bbg Sync Type > Master.

2. Set the number of slaves using the Number of Slaves softkey.
3. If desired, modify the trigger parameters (see page 212).

The master signal generator allows the modifications of both the trigger type and the trigger
source.

a. Return to the Dual ARB menu (see page 212).
b. Set the desired trigger type and source.
c. Return to the Multi-BBG Sync Setup menu.

Set the BBG Synchronization Slave Parameters
1. Press Mode > Dual ARB > ARB Setup > More > Multi-BBG Sync Setup > Multi-BBG Sync Type > Slave.

2. Set the number of Slaves using the Number of Slaves softkey.
3. Set the slave position that the signal generator occupies.
There can be up to fifteen slaves in a system.

4. Press the Listenfor Sync softkey and verify that Waiting for Sync appears in the Status area of
the display.

5. If desired, select a different trigger type parameter:
a. Return to the Dual ARB menu (see page 212).
b. Set the desired trigger type.
c. Return to the Multi-BBG Sync Setup menu.

6. Repeat for each slave signal generator in the system.

Synchronize the System

Perform this procedure only after setting the parameters for both the master and slave signal
generators. If resynchronizing a system, use the procedure “Making Changes to the Multiple
Synchronization Setup and Resynchronizing the Master/Slave System” on page 217.
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1. On the master, press the Sync Slaves softkey.

NOTE All of the signal generators in the master/slave system must be resynchronized when any
changes are made to the master/slave settings or with the addition of a slave instrument,
even if In Sync appears after pressing the Listen for Sync softkey on the slave instruments.

2. On the front panel displays, ensure that all of the signal generators show In Sync as the Status.

Trigger and Play the Waveform
1. On all Agilent MXGs, press Mode > Dual ARB > ARB 0ff On to On.

2. Start the trigger signal going to the master signal generator.

Making Changes to the Multiple Synchronization Setup and Resynchronizing the Master/Slave
System

If any changes are made to the master/slave parameters or a signal generator (slave unit) is added to
the system, the system must be resynchronized even if In Sync appears in the Status portion of the
display.

1. Turn off the trigger source. If using the Trigger key, there is nothing to turn off.

If the trigger source is on and provides a continuous pulse stream, it may cause the signal
generators to incorrectly display In Sync as the status after pressing the Listen for Sync softkey.

2. On each of the signal generators, press Mode > Dual ARB > ARB Off On to Off.

If a signal generator(s) has the Dual ARB on during changes, signal generators further in the
chain may incorrectly display In Sync after pressing the Listen for Sync softkey.

On each of the signal generators, press ARB Setup > More > Multi-BBG Sync Setup.
4. Make the changes in the Multi-BBG Sync Setup menu.

Out Of Sync appears as the status message.

On each of the slave signal generators, press Listen for Sync.

6. Ensure that all of the slaves’ Status show Waiting for Sync. If In Sync shows as the status,
perform the following steps:

a. Check that the PATTTRIG to EVENT 1 cables are properly connected on the rear panel.
A disconnected cable can cause a false In Sync status.

b. If the cables are connected, perform steps 1 and 2.

c. Press Listenfor Sync and ensure that Waiting for Sync appears as the status.

On the master signal generator, press Sync Slaves.

Verify that In Sync appears as the status on all master/slave signal generators.

9. Perform the process “Trigger and Play the Waveform” on page 217.
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Understanding Option 012 (LO In/Out for Phase Coherency) with Multiple
Baseband Generator Synchronization

NOTE This section assumes that the previous section on Multiple Baseband Generator
Synchronization has been read and understood. If not, refer to “Multiple Baseband Generator
Synchronization” on page 211 before continuing.

The MXG with Option 012, enables 2x2, 3x3, or 4x4 MIMO configurations to share a common external
LO signal to create a phase coherent system (refer also, to “Multiple Baseband Generator
Synchronization” on page 211).

RF phase coherency may not be needed for general STC/MIMO receiver testing, since a MIMO receiver
perceives any phase differences between the sources as part of the channel conditions and correct for
them. But, RF phase coherency might be desirable for certain applications such as R&D on
beamforming systems.

Configuring the Option 012 (LO In/Out for Phase Coherency) with MIMO

The Agilent BNC cable, part number 105024, is the recommended cable for the standard multi-BBG
synchronization setup, and is recommended for Option 012 too (see also Figure 8-29 on page 215).
Additionally, for the 2x2, 3x3, and 4x4 MIMO connections from the LO IN and LO OUT to the splitter,
additional cables are required (refer to Table 8-5, Figure 8-30 on page 220, and Figure 8-31 on
page 221).

NOTE Agilent recommends the LO Output be covered when not in use.

When the LO In/Out jumper cable is removed and the instrument is in Dual ARB mode, the
instrument is unleveled and the instrument displays an Unlevel error message.

All test equipment requires a 12 hour warm-up period to ensure accurate performance.

The phase coherent configuration requires the following:

* The recommended LO input drive level should be in the 0 to 6 dBm range.

NOTE The 0 to 6 dBm LO input drive level ensures the instruments will operate over the full
frequency and over the full 0 to 55 ambient temperature rangel.

e The I/Q calibration and the self-test must be performed with the LO In/Out jumper cable in
place. Where the I/Q calibration cannot be run, the baseband offset can be manually adjusted to
minimize the I/Q offsets.

* The phase coherency feature only applies to the Dual ARB modulation mode.

¢ All cables from the splitter output to the instrument inputs should be of equal lengths.

Lo input power requirements vary with temperature; power <0 dBm may work at 20-30 degree ambient
temperature conditions. Refer to the Data Sheet.
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Table 8-5 Option 012 (LO In/Out for Phase Coherency) Equipment

Basic Digital Operation (Option 651/652/654)
Understanding Option 012 (LO In/Out for Phase Coherency) with Multiple Baseband Generator Synchronization

MIMO Configuration

Part?

Cable Length

Notes

2x2

n/a

11636A

As required

n/a

SMA flexible cables are connected from
the power splitter outputs to the LO
inputs on the rear panel of both the
master and the slave MXGs. Refer to
Figure 8-30 on page 220.

Power Divider, DC to 18 GHz. Refer to
www.agilent.com.

3x3

n/a

PS3-20-451/12
S

As required

n/a

SMA flexible cables are connected from
the power splitter outputs to the LO
inputs on the rear panel of the slave
MXGs. Refer to Figure 8-31 on

page 221.

3-Way Pulser Microwave Corp., 3-Way
Wilkinson Dividers

4x4

n/a

PS4-16-452/10
S

As required

n/a

The SMA flexible cables are connected
to the power splitter output to the LO
inputs on the rear panel of the slave
MXGs. Refer to Figure 8-31 on

page 221.

4-Way Pulser Microwave Corp., 4-Way
Wilkinson Dividers

All

10502A

22.86 cm (9 inches)

Refer to Figure 8-30 on page 220 and
Figure 8-31 on page 221. See also
“Multiple Baseband Generator
Synchronization” on page 211.

@0n all of the MIMO configurations, the same length of SMA flexible

cables are connected from the splitter

output to the inputs on the master and slave instruments. Refer to Figure 8-30 on page 220 and to Figure 8-31 on

page 221.
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2x2 MIMO (LO In/OQut for Phase Coherency) Configuration

For the 2x2 MIMO (LO In/Out for phase coherency) setup, the LO from the master MXG can be ran
through a power splitter and used as the LO input to both the master and the slave MXGs. No
external source is required.

To generate phase coherent signals for a 2x2 MIMO configuration, the master MXG LO OUT is
connected via a power splitter to the slave LO IN. The LO OUT provides a sufficient amplitude LO
signal when connected directly, to drive the Slave MXG(s), thus providing phase coherency for the RF
output signals. In this example, we show two MXG signal generators with Option 012 connected for a
phase coherent 2x2 MIMO solution. Refer to Figure 8-30.

Figure 8-30 2x2 MIMO (LO In/OQut for Phase Coherency) Equipment Setup

Master
M5182 Option 012 IiEVENTNDut)
e - RF Output
Lo DUTl LOIN 10 MHz OUT
GPIB/LAN o
REF IN
Signal Studio Software
LOIN I—
M7E158 or NTE178 FAT TRIG (In)
. = “a BERS8-"
I = 2 olsmnosmss
o — =18 was ot — |
RF Output

Slave
MN51228 Option 012

Note:
To optimize the phase coherence, the same length SMA flexible cable is recommended for the output of the 2—way splitter
connections to the LO IN of the MXGs with Option 012 (see page 218).

To minimize synchronization delay, the Agilent BNC cable 10502A is the recommended cable for the rear panel daisy chain

3x3 and 4x4 MIMO (LO In/Out for Phase Coherency) Configurations

For a 3x3 and 4x4 MIMO (LO In/Out for phase coherency) setups, an additional analog source is
needed to provide the higher LO power required by the power splitter and the additional
instruments.

Splitting the LO output four ways causes too much loss to drive the LO input of the N5162/82As in
the system. Also, there is no amplitude adjustment to the LO output of the N5162A/82A. To generate
phase coherent signals for a 3x3 and 4x4 configurations with the MXG, an external Master LO is
needed to provide a sufficient amplitude LO input signal to the vector MXGs (refer to Figure 8-31 on

page 221).

NOTE The Master LO is not controlled by any of the Signal Studio software, but must be set
manually—via the RF frequency settings on the master MXG—by the user to the desired

frequency and amplitude.
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Figure 8-31 3x3 and 4x4 MIMO (LO In/Out for Phase Coherency) Equipment Setup
Note:
A SMA flexible cable is recommended for the input to the 4—way splitter connections to the LO IN and LO OUT of the MXGs with
Option 012 (see page 218).

To optimize the phase coherence, the same length SMA flexible cable is recommended for the output of the 4—way splitter
connections to the LO IN of the MXGs with Option 012 (see page 218).

To minimize synchronization delay, the Agilent BNC cable 10502A is the recommended cable for the rear panel daisy chain
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Waveform Licensing for Firmware Version > A.01.50

Waveform licensing enables you to license waveforms that you generate and download from any
Signal Studio application for unlimited playback in a signal generator. Each licensing option (221-229)
allows you to permanently license up to five waveforms or (250-259) allows you to permanently
license up to 50 waveforms of your choice (i.e. Waveform Option 22x or Option 25x are perpetual
fixed waveform licenses).

Waveforms licensed with Options 221-229 or Options 250-259 cannot be exchanged for different
waveforms. Once a waveform is licensed, that license is permanent and cannot be revoked or
replaced. Option 22x and 25x waveform licenses are signal generator specific (i.e. signal generator serial
number specific). If a licensed Option 22x or Option 25x waveform file is transferred to another signal
generator, the file must be licensed by a separate Option 22x or Option 25x that is in the other signal
generator before it can be played.

To redeem Option 22x or Option 25x, refer to the N5182A-2xx Entitlement Certificate that comes
with the N5182A-2xx order. For more information on extracting and downloading waveform files,
refer to the Programming Guide.

Understanding Waveform Licensing

Use any N76xxB Signal Studio software to build and download waveforms to the signal generator.
Each license option provides 50 available slots where you can add and play waveforms for a trial
period of 48 hours per slot. During this time, you can replace the waveform any number of times
until you are satisfied with it. After the trial period expires, the waveform in the slot is no longer
playable until the slot is locked for permanent playback; however, you can replace the waveform in
the slot with another waveform of your choice before locking the slot.

To license additional waveforms that exceed the number permitted by an Option 22x or Option 25x,
you must purchase another Option 22x or Option 25x that you do nmot already own. For example, if
you already own Option 250, purchase Option 251 to add an additional 50 slots. Adding all options,
250-259, provides a maximum of 500 slots. Adding all options, 221-229, provides a maximum of 45
slots. (Repurchasing the same option for the same signal generator, gives you no additional Waveform
licenses.)

Installing an Option N5182-22x or Option N5182A—25x

Load a Waveform License, Option N5182-22x or Option N5182A-25%, into the signal generator using
License Manager or a USB media. For more information on loading the Waveform License, refer to
the N5182A-2xx Entitlement Certificate included with your order.

Licensing a Signal Generator Waveform

Create and download a waveform using any of the N76xxB Signal Studio software to the signal
generator. Refer to your Signal Studio software help if you need assistance using the application.

Refer to page 227 for steps in adding the waveform to a license slot for a 48-hour trial period.
During the trial period, the waveform can be played and replaced any number of times. When the
trial time expires, the slot can no longer be used for playback until the slot is locked for permanent
playback capability.
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Waveform Licensing Softkeys Overview

Figure 8-32 Waveform Licensing Softkeys
Mode > Dual ARB > More

Arb
Wawe form Note: Waveforms licensed with Option 2xx cannot be exchanged for other waveforms.
SequUENCES Once a waveform is locked into a license slot, that license is permanent and cannot be
revoked or replaced.
Haveform
Utilities
Utlﬁﬁgg This softkey is only available if there is an Option 2xx license installed on the instrument.
—Pressing this softkey displays the licensing status and associated filename for each slot and
Header accesses the waveform licensing menu selections.
Utilities
Hawe form,|
Licensing
Note: When Waveform Licensing is first accessed, all slots appear as
Available. For licensing status descriptions after waveforms have been

added to a slot, refer to Table 8-6 on page 226.

This softkey allows you to add
a waveform that you select to
the first available slot. Refer
to page 224.

S “E'”eéﬁr;rt". This softkey allows you to

a
Available Slot replace a waveform in the

v — selected slot. Refer to
14
Uaveform Licensing i Licenses Used: &/S00 In Slot page 225.
Sloi Etatug 11/03/2008 ?51323% 7 e e
ocke - Clear Wawveform
2 Lock Reddired T0-SCOMAL Fram Slot _V‘fa;'eform from the selected
3 Locked 12/02/2008 slot.
L Lock Reguired
5 Femaining Trial Time LE: h2 Lock Haueformylh This softkey allows you to
6 Remaining Trisl Time L In Slot h
7 Auvallable ' |~ I\ lock a waveform into a slot.
8 Auvailable After the trial period has
13 Eggﬂggig Goto SlotMy | expired, the waveform must
- be locked in order to be able
LA AS Liss Nore 1 of 2 to play the waveform. Refer

to page 225.

This softkey allows you to
select a specific slot where
you want to add, replace, or
clear a waveform. You can
also select a slot by using
the front panel arrow keys or
by scrolling to the slot. Refer

Refer to the SCPI Command Reference
for related license commands.

Play Waveform

page 225 to page 224.
Locate Wawvefarm
inkdemary
For details on each key, use key help
as described on page 42. fore 2 of 2
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Figure 8-33 Waveform Licensing Softkeys

Mode > Dual ARB > More >
Waveform Licensing > Add
Waveform to First Available Slot

or

Mode > Dual ARB > More >
Waveform Licensing > Replace
Waveform in S‘ot

FREQUENCY
6.000 000 000 00 s+

Add To Slot

Add Haveform

Catalog Tupe
(5t

|[:atalog of BBG Segment Files in BBG Hemory Licenses Used: E/S00
Haveform Stat.

oredy
Seaments)

aLus
12TOME_HFH

AUTOGER_LAYEFORI M50
CDHMAZK_SCHAN_HFT I

Haveform Licensed

COMAZK_PILOT_LFM
EDGE_BURST_LIFM
G ST_LFM

] 1
N7E02E_2
M7E1SE_1
N7E1SE_2

01/07/2005 10:05

The waveform to be added or replaced can be selected from BBG memory, internal storage, or a

USB device.

FREQUENCY
6.000 000 000 00 &+

Catalog Type

Stored
Seoments

Catalog of Stored Seament Files i|S1tI{|t Storage Licenses Used: G/500
atus

IFM
GSM_COMT_LFM
IDEN_IMBOUND_A
QAM16_LIFM
OPSk_LFM
HCOMA_10PCH_LFM

Haveform License Mot Reguired

HCOMA_THM1_6LOPCH_1C_HFHM

HCOMA_THY_LFH
W IMAK_10MHZ_GLOAM_HFM

IICOMA_TH1_ELDPCH_LC_WFM HWaveform License Mot Required -

BEG Seoments

01,/07//2009 13:37

Note: Waveforms licensed with Option 2xx cannot be “exchanged”. Once
a slot is locked, that license for the waveform in the locked slot is
permanent and cannot be revoked or replaced.

The softkey is greyed out, if a
waveform is already licensed or
does not require licensing.

———__To select a waveform,

use the arrow keys to
[ highlight the waveform

and then press Add

Waveform.

y

Refer to the SCPI Command
Reference for related License
Commands.

This softkey displays a
catalog of the waveform
segments stored in the Int
Storage or USB Media.

This softkey displays a

atalog of the waveforms
stored in the BBG
memory.

For details on each key,
use key help as described
on page 42.
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icensing Softkeys

Mode > Dual ARB > More > Waveform Licensing
> Lock Waveform in Slot

Lock In Slot

Confirm
Locking Haweform

Press this softkey to confirm that you want to lock the waveform into the slot for
— permanent licensing. If the waveform has not been saved to internal storage, a
warning message appears. Refer to Step 4 on page 228.

Backup Haveform
To Int Storage

This softkey is displayed if the waveform is not found in the internal storage
memory of the signal generator. Press this softkey to store the waveform into the
Internal Storage and to activate the Confirm Locking Waveform softkey. Refer to

s T

Step 4 on page 228.

Mode > Dual ARB > More > Refer to the SCPI Command Reference
Waveform Licensing > Goto Slot —for related license commands.
Goto Slot

Enter

___ Press this softkey after entering a specific slot number using the front panel
numeric pad.

Goto First Slot

—Press this softkey to go to the first slot.

Goto First
Available Slot

. Press this softkey to go to the first slot whose status is available.

Goto Last Slot

. Press this softkey to go to the last slot. The number of slots depends on the number of
licensing options installed on the instrument.

b

Mode > Dual ARB > More > Waveform
Licensing > More > More

FREQUENCY Press thi? softkey to play
6.000 000 000 00 s+ Play Waveform || highighted Sot.

Locate Waveform Press this softkey to

T T - — locate the waveform in
Haveform Licensing Licenses Used: §/500 inkemory
Slot. status Filename memory that was added
1 Locked 11/03/2008 TO-SCOMAD = to this slot regardless of
2 Lock Required TO-5COMAL the name. If the search
3 Locked 12/02/2008 returms no results, the
L Lock Reguired original waveform has
H] Femaining Trial Time Lb been deleted from
g . Trigl Time L7 memory and cannot be
8 fvailable found.
9 Available
10 Available
01412 ‘2009 03:28 Hore 2 of 2 A

For details on each key,
use key help as described
on page 42.
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Table 8-6 Waveform Licensing Slot Status Messages

Status Column

Meaning

Notes

Available

The slot has never had a waveform
added to it.

50 slots are initially available for
each Option 25x.

5 slots are initially available for
each Option 22x.

Locked MM/DD/YY

The slot is locked and can no
longer be modified.

The waveform in this slot is
licensed to this signal generator
for unlimited playback.

Remaining Trial Time HH:MM

The slot is in a trial period that is
available for 48 hours that begins
when a waveform is added.

During the trial period, the
waveform in this slot can be
played, cleared, or replaced with
another waveform.

Lock Required

The trial period for the slot has
expired but the slot has not been
locked.

The slot can be cleared or
replaced with a different waveform
but the waveform cannot be played
until the slot is locked. A trial
period is no longer available.
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Example: Licensing a Signal Studio Waveform
The following steps add a waveform file to a license slot and lock the slot for permanent playback.
1. Press Mode > Dual ARB > More > Waveform Utilities > Waveform Licensing

The signal generator displays a catalog of files labeled: Catalog of BBG Segment Files in BBG
Memory.

2. Use the arrow keys to highlight and select the file to be licensed.

Press Add Waveform to add the selected waveform to the first available slot.

Figure 8-35 Add Waveform

Mode > Dual ARB > More > Waveform Licensing> Status area for the )
Add Waveform to First Available Slot waveform N7602B-WFM1 is
empty and the Add

Waveform softkey is active,
indicating the waveform is
licensable.

FREQUEHCY ANPLITUDE Add To Slot

935.200 000 00 rtz | -10.00 /e P —

Cakaloo Tupegk —page 224

Catalog of BBG Seoment Files in BBG Hemory Cicenses Jsed:f/c00)  'BBG| Seaments)
laveform Stotus

RAMP_TEST_FM ICErsE Mot Regquirent

SINE_TEST_MFH License Not Required

\
The selected
waveform is added to
the first available slot.
The trial time for the

Add Hawveform
To Firste
Available Slot

slot begins as soon as
Replace Hgweform,) the waveform is
llaveform Licensing ) Cicendes Used: E/500 In Slot added
Slot atus Filename .
1 Locked 11,/03/2003 TO-SCOMAD N ciear vawverorm During the 48 hour
2 Lock Required TD-SCOMAL From Slot trial period, the
1[3' ll:DCtEHd 125’0252009 = waveform can be
ac Equ 1re
5  Femoining Trisl Time LE: Y Lock Uaveform played and repiaced
6 Remaining Irial ime L7:33 N7ECZE—LF M1 In Slot Y :
g Eﬂgﬂggig When the trial time
: expires, the licensing
d pre-lable Gotelslty status of the slot
changes to Lock
Required after which
m the waveform can no
longer be played until

the slot is locked.
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4.

License the waveform:

a. Press Lock Waveform in Slot.
A warning is displayed: *** Waveform Lock Warning!!! ***_[f necessary, verify you have
selected the correct waveform you want for licensing by pressing Return.
Figure 8-36 Waveform Lock Warning

FREQUEHCY RF_OFF Lock In Slot

6.000 000 000 00 = s

4% Waveform Lock Warning!l |1 s

Once a waveform is locked it will use up an
avallable license slot and it can not be un-locked.
Be sure that wou want to lock this waveform.

NN NI Gl T S o~

b. Press Confirm Locking Waveform.
The licensing status of the slot will be changed to Locked MM/DD/YY.

c. If the waveform has not been previously backed up in internal storage, a warning is displayed:
*** Waveform Backup Required!!! ***,

d. Make a backup copy of this waveform on a USB media or a computer before pressing Backup
Waveform to Int Storage. (If the waveform is lost or deleted on the signal generator, it cannot be
recovered).

Figure 8-37 Backup Waveform To Int Storage softkey

The Confirm Locking
Waveform softkey remains
inactive until the waveform is
stored in internal storage.

FREQUEHCY ANPLITUDE Lock In Slot

935.20000000 wz | -10.00 cen_["cccrc

A

dCkUP HEVetor
To Int Storace

aveform Backup Required! ! | #+x

ress this softkey to store
the waveform into the internal
storage and to activate the Confirm
Locking Waveform softkey.

CAUTION It is important that you make a backup copy of any waveforms that you are licensing.

Do not store the backup copy on the signal generator. If all copies of the waveforms
are deleted or lost, there is no way to recover the waveform or reassign the license.
Refer to “Working with Files” on page 63.
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Waveform Licensing Warning Messages

Figure 8-38
This standard warning is
FREQUENCY Lock In Slot displayed every time a
6 000 000 000 00 GHz Confirm waveform is selected to be
2 Locking Hawveform locked. This notification
indicates that one of the
available “license slots” is
about to be used from
. Option 2xx.
%% Waveform Lock Warning! | ##x ALWAYS make
Once a waveform is locked it will use up an azfllgf'grﬁspi'ﬁs:f
gvallable license slot and it can not be un-locked. separate
Be sure that uou want to lock this waveform. non-volatile memory
i file is
Inportant! Keep a backup copy of the waveform elseuhere Ih case a
in raca unil rdolato All filos in Tnt Stnraoo. :lhe;eitr‘esc:rzzrllzﬁtt’fsrom
FREQUENCY AMPLITUDE Lock In Slot internal storage.
935.20000000 mz| -10.00 cen
I ARB This warning is displayed
hen an attempt is made
Backup Haveform ;Ac’) lock a waveform that
o Int Storage has not been saved to
i internal st B
+4x Waveform Backup Required! || #x* g Ty s
Waveform backup required. The waveform can not be fﬁé‘y"ﬁtae: jocked unless
licensed until it is copied to non—volatile memory. non-volatile memory).
Press the Backup
Waveform To Int Storage
You must back up the waveform to non-volatile memory softkey.
FREQUEHCY AMPLITUDE Lock In Slot

[ 6.000 000 000 0[1] EHEHB -144.00 den This wamning is displayed

when there is insufficient
memory or other problems
with the internal storage,
or USB media
(non-volatile memory) and

¥+ WaveformBackup Failed! | | ®¥% the waveform could not be

. saved to non-volatile
Laveform backup failed. The waveform could nob be memory.

copied to non—volatile memory. There may not be
enough free memory.

You must free enough non-volatile memory to copy
the uaveform before you can license it.

FREQUEHCY Lock In Slot This warning is displayed
6 000 000 000 00 GHz when the waveform file
+ cannot be found in BBG or
internal storage. You must
ensure that the waveform
still resides in the
instrument before you can

*+x Haveform File is Missing! | | #xx lock it

The waveform file in the selected slot is no longer
in instrument memory .

You must either clear or replace the waveform for
this slot or load the missing file into instrument
memory before you can license it.
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Waveform 5—Pack Licensing (Options 221-229) for Firmware Version < A.01.50

Waveform 5-Pack licensing enables you to create, generate, and permanently license up to 45 Signal
Studio waveforms (e.g. Each Option 22x enables licensing of five waveforms (Option 221, 222, 223,
229).

Use the signal generator to manage the licensing of these waveforms. For example, you can use the
signal generator to select individual waveforms for licensing and you can view a list of all currently
licensed waveforms.

Understanding Waveform 5—Pack Licensing

Waveforms licensed with 5-Pack cannot be exchanged. Once a waveform is licensed, that license is
permanent and cannot be revoked or replaced. Option 22x waveform licenses are signal generator
specific (i.e. signal generator serial number specific).

Waveform 5-Pack licensing enables you to create and generate signals which can be saved for
unlimited use in a signal generator (i.e. Waveform 5-Pack Option 22x is a perpetual firxed waveform
license).

Use the Signal Studio software to build and download waveforms to the signal generator’s volatile
memory to be played. When you are satisfied with the waveform, it must be stored to non-volatile
memory before it can be licensed.

If a licensed Option 22x waveform file is transferred to another signal generator, the file must be
licensed by a separate Option 22x that is in the other signal generator before it can be played. For
more information on extracting and downloading waveform files, refer to the Programming Guide.

To license additional waveforms that exceed the number permitted by an Option 22x, you must
purchase an Option 22x that you do not already own. For example if you already own Option 221
with only two remaining licenses and you need ten more waveforms, purchase Options 222 and 223
to have enough licenses to license ten more waveforms. This would leave two remaining licenses on
Option 223. (Repurchasing Option 221 a second time, for the same signal generator, gives you no
additional Waveform 5-Pack licenses.)

After licensing a waveform, you can make copies of the waveform using different file names for use
on the same signal generator and even rename the original file without affecting the waveform
license.

You can also use the Option 22x to license waveforms from N76xxB Signal Studio software
downloaded during its 14-day free trial license. All of the N76xxB Signal Studio software products
provide a 14-day trial period (trial license). This 14-day trial license lets you download and play
back waveforms during the trial period. These waveforms are denoted by the TRL in the status
message area of the waveform segment catalog. After the trial period expires, the TRL message is
removed but the waveform remains. You can license these waveforms after the TRL message is gone.

Waveform 5-Pack requires firmware version =A.01.20.

Installing an Option N5182A-22x Waveform 5—Pack Licensing

* Load a Waveform 5-Pack license, Option N5182A-22x, into the signal generator using License
Manager or a USB media. For more information on loading the Waveform 5-Pack License, refer to
the N5182A-22x Entitlement Certificate.
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Licensing a Signal Generator Waveform File

1. Create the waveform:

a.

Download any of the N76xxB Signal Studio software that interest you. For downloading
N76xxB Signal Studio software, refer to the N5182A-22x Entitlement Certificate.

Create and download a waveform to a signal generator using any of the N76xxB Signal Studio
software. Refer to your Signal Studio software Help.

Waveform 5—Pack Licensing Softkeys Overview

Figure 8-39 Waveform 5—Pack licensing Softkeys

Mode > Dual ARB >
Waveform Utilities >

HFR Utigities 7

Plot,
CCOF

More >

Note: Waveforms licensed with 5-Pack cannot be “exchanged”. Once a waveform is
licensed, that license is permanent and cannot be revoked or replaced.

Scale Waveform,)
ata

Clipping,
CT+ja 13

b-Pack Licensing

S-Pack Historu

— page 238

S5-Fack Licensingh
| - T4

J This softkey is only

._____available if there is an

AM‘./“‘"M

Option 22x installed on the
instrument.

Add Hawveforms,|
To 5-Pack

— page 232

s nat p pt

For details on each key, use key help
as described on page 42.
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Figure 8-40 Add a Waveform to 5—Pack Softkeys

Mode > Dual ARB > More >
Waveform Utilities > 5-Pack
Licensing > Add Waveforms to

v

5-Pack revoked or replaced.

Note: Waveforms licensed with 5-Pack cannot
be “exchanged”. Once a waveform is licensed,
that license is permanent and cannot be

FREQUEHCY REF] AAPLITUDE Add To S-Pack
935.200 000 00 mz | -10.00 aen q
Catalog Tupe
(Storedey
Catalog of Stored Seament Files in Int Storage Licenses Used: 1/UL5 Seqment.s)
Haveform Status
12TOME_FM S-Pack License Mot Reguired
AUTOGEN_HAVEFORM_$KH 5-Pack License Mot Required
COMAZK _SCHAN_LIFM 5-Pack License Mot Required
EDHHEK_PILDT_HFH 5-Fack License Mot Required -
EDGE_BURST ck License Fequired
GSH_BUHST_HFH License Feguired
M7E02E_2
M7E15E_1 License Mot Required
N7E15B_2 License Wot Required
\ 09:13
Displays the name of the Mrm file and status. Refer to
Table 8-7 on page 233.
\J
FREQUEHCY  REF] AAPLITUDE Catalog Tupe
-— Stored
935.200 000 Q0 e _10.00 B seSLared

Catalog of Stored Seoment Files in Int Storage Licenses Used: 1/45
Haveform Status

EBG Seaments

12TOME_FM E-Pack License Mot Reguired
AUTOGEN_HAVEFORM_$KH 5-Pack License Mot Required
COMAZK _SCHAN_LIFM 5-Pack License Mot Required
COMAzK_PILOT_HFH 5-Pack License Mot Required -
EDGE_BURST_HFM E-Pack License Mot Reguired
UH?T_HFH S—Pack License Mot Reguired
N7E02E_2
M7E15E_1 E-Pack License Mot Reguired
M7E158_2 5-Pack License Not Required
03:13

This softkey is only active when
there are secure waveforms that
can be added and a Waveform
5—Pack license with available
slots (i.e. if a waveform is already
licensed or does not require
licensing the softkey is greyed
out). Refer to page 236.

To select a waveform
to receive one of your
Waveform 5—Pack
licenses, use the
arrow keys to highlight
the waveform and
then press Add
Waveform.

Refer to the SCPI Command
Reference for related 5-Pack
License Commands.

This softkey
displays a catalog
of the waveform
segments stored
in the Int Storage
or USB Media.

This softkey
displays a catalog
of the waveforms
stored in the BBG
memory.

For details on each
key, use key help
as described on
page 42.
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Table 8-7 Waveform 5—Pack Licensing Status Messages for the “Catalog of Segment Files in Int Storage [or USB Media]”

Status Message

Meaning

Notes

Empty field

If no status message, then the waveform is
licensable.

Once a Trial (TRL)
license expires, the
waveform becomes
licensable (i.e. the status
message for the TRL
waveform becomes an
empty field).

If a licensed Option 22x
waveform file is
downloaded to another
N5182A signal generator,
the waveform becomes
licensable on that other
signal generator (i.e. the
status message field is
empty).

5-Pack Licensed

This waveform is licensed by Option 22x.

5-Pack License Not Required

This status message applies to:

Any free waveforms provided with the
Agilent MXG (e.g. RAMP_TEST WFM, and
SINE_TEST WFM, etc.)

Any customer created waveform

Any waveforms that have a valid license (e.g.
Trial (TRL) licenses, Advanced Design System
(ADS), etc.).

Once a Trial (TRL)
license expires, the
waveform becomes
licensable (i.e. the status
message for the TRL
waveform becomes an
empty field).

If a licensed Option 22x
waveform file is
downloaded to another
Nb5182A signal generator,
the waveform becomes
licensable on that other
signal generator (i.e. the
status message field is
empty).
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Example: Licensing a Signal Studio Waveform

The following steps add a single waveform file, to a Waveform 5-Pack license. Refer to Figure 8-42 on
page 236.

2. There are two methods to save a waveform to the internal memory:

NOTE Before you can license a waveform with the Waveform 5-Pack licensing, the waveform must
be saved in either the internal storage or the USB media.

a. Save the file to internal storage using the Backup Waveform To Int Storage softkey:
1. Press Return > Return > More > Waveform Utilities > 5—Pack Licensing > Add Waveforms to 5-Pack.

2. Press Backup Waveform To Int Storage (refer to Figure 8-41).

Figure 8-41Backup Waveform To Int Storage softkey

The Confirm Adding
FREQUEHCY ANPLITUDE Add To 5-Pack Waveform To 5-Pack

935.200 000 00 rz | -10.00 den the wavelorm fs Stored n
I ARB

internal storage.

/
B?Ckup e o Press this softkey to store the
waveform into the Internal

o Int Storaoe
erfor‘m Backup Required! | | ##x Storage and to activate the
“ - st et Confirm Adding Waveform

To 5-Pack softkey.

For details on each key, use key help
as described on page 42.

3. Go to 3 Step d.

b. If the waveform has already been stored in the signal generator using the Backup Waveform to
Int Storage softkey then proceed to Step d.

1. Otherwise use the ARB Segments menu Load Store softkey to store the waveform to
internal storage. Refer to “Working with Files” on page 63.

2. Proceed to Step 3 once you've stored the waveform to internal storage (internal media).

3. License the waveform:
a. Press Return > Return > More > Waveform Utilities > 5-Pack Licensing > Add Waveforms to 5-Pack.

The signal generator displays a catalog of files labeled: Catalog of BBG Segment Files in
BBG Memory.

b. Use the arrow keys to highlight and select the file to be licensed.
c. Press Add Waveform.

A warning is displayed: *** Waveform Licensing Warning!!! *** [f necessary, verify you
have selected the correct waveform you want for licensing by pressing Return. Otherwise
continue to the next step (refer to Figure 8-42 on page 236).

d. Press Confirm Adding Waveform to 5—Pack.

The display returns to the Catalog of BBG Segment Files in BBG Memory and the file’s
Status column is now labeled 5-Pack Licensed (refer to Figure 8-42 on page 236).
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e. Make a backup copy of this waveform on a USB media or a computer (If the waveform is lost
or deleted on the signal generator it cannot be recovered).

CAUTION It is important that a backup copy is made of any 5-Pack waveforms; the backup copy
must be stored on a computer or other media. Do not store the backup copy on the
stgnal generator. If all of the copies of the waveforms are deleted or lost, then there is
no way to recover the waveform or reassign the license. Refer to “Working with Files”
on page 63.
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Figure 8-42  Add Waveform to 5-Pack Softkey

Mode > Dual ARB > More > Status area for the ) Important! Always
Waveform Utilities > 5-Pack waveform N7602B-WFM1 is backup licensed
Licensing > Add Waveforms to empty and the Add ) waveforms in a separate
5-Pack Waveform softkey is active, place from the

FREQUEHCY ANPLITUDE A | _Add To 5-Pack - If tlhe tWg\?eform
935.200 000 00 MHz _10.00 m Add Hawveforme ﬁge?’lcsi?'lg I'?;s
[1/0]_ARB |

indicating the waveform is instrument (e.g.

licensable. computer, USB media,
etc.).

been verified as
Catalon Tups, b page 232 the waveform
Catalog of BBG Seonent Files in BB iCenees)/Usedy 7/o5|  (BEG Seoments)” ﬁggngggf :)?ebses
N BOZE—LIFT - Confirm
RAMP_TEST_HFT E-Fack License Mot Required Adding
SIME_TEST_LFM S-Pack License Mot Regquired Waveform To
5-Pack.
Caution! This
step cannot be
Y undone.
. " FREQUENCY ANPLITUDE Add To 5-Pack
This warning
message 035.200 000 00 m: -10.00 den Adding Heverorm I
indicates that 1 AR To S-Pack
this is the last
chance for
verifying that
the waveform W\ "k WaveformLicensing Warning! 1 #xx )
licensed is the Once a waveform is 5-Pack licensed it will use up an
one you want. avallable license slot and it can not be un-licensed.
If the Be sure that uyou wert to license this waveform.
waveform
selected has Important! Keep a backup copy of the waveform elseuhere
not been in case you delete all files in Int Storage.
verified, press
Return and 15716
verify the \J
selection. FREQUENCY ANPLITUDE Add To 5-Pack

935.200 000 00 mz| _-10.00 _cen (:

For details on each key, use key
help

Catalog Tupe,
(HEG Seoments)

icenses Used: B/uS

Note that N7602B-WFM1 has a Status of “5-Pack Licensed’
and the Add Waveform softkey is no longer active.
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Using Waveform 5—Pack History

The Waveform 5-Pack History softkeys can be used to manage the Waveform 5-Pack files on your
signal generator. The 5-Pack History softkeys can be used to:

* Create a list for a specific Waveform 5-Pack licensed waveform including any renamed files that
have been leveraged from that licensed waveform

¢ Create a list of all licensed and unlicensed waveforms on the signal generator
Refer to Figure 8-43 on page 238, for a description of the Waveform 5-Pack History softkeys.

The 5—Pack History softkey is only active, if you have previously stored a Waveform 5-Pack file in
non-volatile memory (internal storage, or USB media). But, the softkey 5—Pack History tracks the
history of licensed waveform files that may no longer be available in non-volatile memory (e.g. if the
waveform file has been deleted from internal storage or is located on a USB media that is not
attached to the instrument, the 5-Pack History softkey remains active). b—Pack History retains a
catalog of the Redemption Date, Waveform ID, and the Original Filename.

NOTE You can display either a catalog of the Internal storage or of the USB media but not both at
the same time.

If you switch from the internal storage to the USB media, and the instrument displays an
“Error -230, Data corrupt or stale” this is typically because a file (or files) was found
with the same name, but the file is a different waveform file (has a different Waveform ID)
than the original 5-Pack licensed internal storage file.
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Figure 8-43 Waveform 5—Pack History Softkeys

Mode > Dual ARB > More >
Waveform Utilities > 5-Pack
Licensing > 5-Pack History

FREQUEHCY

6.000 000 000 00 &z

Only available when there have
been waveforms with Waveform

5—Pack licenses previously stored.
W\

\

ANPLITUDE o]

-144.00 den

Haveform 5-Pack License History
Redemption Date

Haveform ID

I 1
N7E028_2
N7E028_3

05,/03./2007
05,/03./2007

dfab2eed
df37hesd

Original Filename

Licenses Used: 3/ULS

Pressing this softkey searches for
every copy of the highlighted
waveform regardless of the current
filename. If the search returns no
results, then the original waveform has
been deleted and cannot be found.

/

Pack Histor!

Find Haweforme

Find ALL,

Haveforms" | 1

10:238

Displays the number of
\waveform licenses used
and the number of total
waveform license ‘slots’
available (e.g. For this
| example 3 of the 45

This area displays the date the waveform was licensed, the unique Waveform ID, and
Original filename at the time the waveform was first redeemed.

licenses have been
| used).

This screen displays all
waveforms that are
licensed by Option 22x.

"

nt Storag
Int Storage
Int Storage
Int Storage

N7E02B_1_COPY1
N7E028_1_COFY2
N7BE028_1_COFY3
N7E028_2
N7E028_3
W7BE028_1_COFY3

All Haveforms

For details on each key,
use key help
as described on page 42.

13: 2L

Location is the memory location:
*Int Storage

*BBG Memory, Or

*USB Media

Note:

/

1) In this example, the waveform N7602B_1_COPY3 is stored in the Int Storage and playing in the BBG Memory:

2) In this example, the Int Storage has been selected as the non—volatile storage location. To view any 5—Pasz< waveforms stored on the USB media, the
USB media must be selected as the default storage. Refer to page 63.

FREQUENCY 935.200 000 00 = n“pLI—TTBOUU dBn

Haveform 5-Pack Search Results
Location

Int Storage

Int Storage

Int Storage

EBG Memory

/Current. Filenamd\
N76026_1_COPY1
N7E026_1_COPY2
N76026_1_COPY3

( H7602B_1

¥

Find Haveform

When you press Find Waveform,
any copies of the originally saved
waveform are displayed on the
instrument (e.g.
N7602B_1_COPY1,
N7602B_1_COPY2, and
N7602B_1_COPY3). In this
example, the original filename
N7602B_1 was not found because

the original file was deleted or the
name was changed. But three
copies were found
(N7602B_1_COPY3 was found in
both the Int Storage and the
BBG Memory).
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Example: Finding the History of a Waveform 5—Pack License

Use the following procedure to create a catalog of licensed Waveform 5-Pack files in the internal
storage or USB media. Refer to Figure 8-44 on page 239, for the following procedure.

The following procedure generates a catalog for a Waveform 5-Pack file labeled: N7602B-WFM1.

1. On the signal generator:

a. Press Mode > Dual ARB > More > Waveform Utilities > 5—Pack Licensing > 5—Pack History

b. Use the arrow keys to highlight the cataloged file N7602B-WFM1.

c. Press Find Waveform

The instrument displays a catalog titled “Waveform 5-Pack Search Results”. This catalog
displays a list of all of the files that are copies of the original file that was licensed with the
Waveform 5-Pack licensing, named N7602B-WFM1. For this example, the copies are currently
in the BBG memory and the Internal storage and named N7602B-WFM1 and
N7602B-WFM1_COPY (respectively). Refer to Figure 8-44 on page 239.

NOTE If no files are found, you can reload the backup copies that were made in Step e on
page 235.
Figure 8-44  Using Waveform 5-Pack History “Find Waveform” Softkey

Mode > Dual ARB > More >
Waveform Utilities > 5—Pack
Licensing > 5—Pack History

The highlighted file
N7602B-WFML is the
waveform created in this
example. (Notice the unique
Waveform ID displayed for
each licensed waveform.)

For details on each key,
use key help
as described on page 42.

6,000 000 000 00 o | ~144.00 & |

9-Pack Histor

Find Haweforme

Find ALL,

Haveform 5-Pack License History

Licenses Used:\ 8/U5
Redemption Date Haveform ID

Haveforms

-

Original Filename

05 /03,2007 dfabbesd N7E02E_1

05 /03,2007 2c15a2ca N7E02E8_2
05/10/2007 fabsbclc UNWTITLEO-HFML
05/10/2007 L250b52e UNWTITLEO-HFML
05/10/2007 0f2037d0 UNWTITLEO-HFML
05 /14 /2007 2feebib2 UWTITLEO-HFML
0 EA200 bi7Ea7da WNZEO2E-LIFM1

bbakDbla

Haveform 5-Pack Search Results

Location Current. Filename \

TREQUERCY 6.000 000 000 00 st n“p—LTuanEZIUU den

( H7602B-LFN1

I e

Int Storage
EBG Memory

N7E02B-HFM1_COFY
N7BE02B-HFM1_COPY

— see page 240.

Notice that the originally
5-Pack licensed waveform,
N7602B-WFM1, has been
changed to
N7602B-WFM1_COPY and
is saved in the Internal
Storage and playing in the
BBG Memory.

If no waveforms are listed
when Find Waveform is
pressed, then the waveform
cannot be found in BBG
Memory, Internal
Storage, or USB Media
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Finding All Waveforms Associated with 5-Pack Licenses

The following procedure displays a catalog of all of the Waveform 5-Pack files in the BBG memory
and the internal storage:

1. On the signal generator:
a. Press Mode > Dual ARB > More > Waveform Utilities > 5—Pack Licensing > Find All Waveforms

The instrument displays a catalog titled: Waveform 5-Pack Search Results. Refer to Figure
8-45.

NOTE If no files are found, you can reload the backup copies that were made in Step e on
page 235.

Figure 8-45  Using Waveform 5-Pack History “Find All Waveforms” Softkey

Mode > Dual ARB > More > Waveform Utilities >
5—Pack Licensing > 5-Pack History > Find All

l

Waveforms

Haveform 5-Pack Search Results All Haveforms
Location Current Filename
Int Storage W7EO2B_1_COPY
Int Storage WFEDZB_2
Int Storage N7E0ZE_1_MHHHK
Int Storage UNTITLED-HFM_ZEB
Int Storage N7E026_1
Int Storage N7E02E8_2_COPY
Int Storage N7E02B_2_COPY_AR
Int Storage UNTITLEO-HFM1_COPYH
Int Storage W7E02B-HFH1_COPY
EEG Memory N7E02B-HFH1_COPY
16:23
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Waveform 5—Pack Warning Messages

Figure 8-46
FREQUEHCY AAPLITUDE Add To 5-Pack.
935.200 000 00 mz | -10.00 B0 | ecoin usieisrn
T ARE To 5-Pack

I

*xx HaveformLicensing Warning! | | #xx <

Once a waveform is 5-Pack licensed it will use up an
avallable license slot and it can not be un-licensed.
Be sure that uou want to license this waveform.

Important! Keep a backup copy of the uaveform elseuhere

This standard warning is
displayed every time a
waveform is selected to be
licensed. This notification
indiﬁa{)els }Pat one (I)ftt[h?‘ )
available “license slot[s]" is
- about to be used from
Option 22x.
ALWAYS make
backup copies of
waveforms in a
separate
non-volatile memory
in case a file is

in case you delete all files in Int Storage.
- [FREQUEHCY ANPLITUDE

) 935.200 00000 mz| _-10.00 _cen

Add To 5-Pack

deleted or lost from
the instrument’s

This warning is displayed

Backup Haveform
To Int Storage

when an attempt is made
to license a waveform that
has not been saved to

*xx Wavef orm Backup Required! ! | #kx

laveform backup required. The waveform can not be
licensed until it is copied to non-volatile memDrgn‘V””

You must back up the waveform to non-volatile memory
before you can license it.

——

internal storage or USB
media (i.e. waveforms
cannot be licensed unless
they have been stored to
non-volatile memory).
Press the Backup
Waveform To Int Storage
softkey.

- (|FREQUEHCY

ANPLITUDE

6.000 000 000 00 &= -144.00 _cn

Add To 5-Pack

xxx WaveformBackup Failed! ] %

Waveform backup failed. The waveform could not be
copied to non—volatile memory. There may not be
enough free memory.

You must free enough non-volatile memory to copy
the uaveform before you can license it.

[ |FREQUEHCY

ANPLITUDE

935.200 000 00 mz| _-10.00 _cen

*xx Wavef orm Renaming Required! | | sk «—|

The file you are truing to license is not backed up
in non—volatile memory, but & file in non-volatile
memory has the same name.

You must rename one of the files before adding the
uaveform to the 5-Pack license list.

15:12

P

Add To 5-Pack

/

This warning is displayed
when there is insufficient
memory or other problems

with the internal storage,
— or USB media
(non-volatile memory) and
the waveform could not be
saved to non—-volatile
memory.

This warning is displayed
when the file being
licensed is not backed up
_—in internal storage or the
USB media (non—volatile
memory), but there is a file
already in the internal
storage or USB media,
with the same name.
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9 Adding Real-Time Noise to a Signal (Option 403)

NOTE For the N5162A the softkey menus and features mentioned in this guide are only available
through the Web-Enabled MXG or SCPI commands. For information on the Web- Enabled
MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI Command
Reference.

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting the power level and frequency, refer to
Chapter 3, “Basic Operation,” on page 41 and familiarize yourself with the information in that
chapter.

This feature is available only in N5162A/82A Agilent MXG Vector Signal Generators with Option 431.
Option 431 requires Option 651, 652, or 654.

This chapter contains examples of using the additive white gaussian noise (AWGN) waveform
generator, which is available only in vector signal generators with Option 403.

e Adding Real-Time Noise to a Dual ARB Waveform on page 243
* Using Real Time I/Q Baseband AWGN on page 249

Adding Real-Time Noise to a Dual ARB Waveform

NOTE The procedures in this section that pertain specifically to adding Real-Time Noise (AWGN) to
a waveform, are applicable to the Custom ARB, Multitone, and Two-Tone modulation
standards too.

A vector signal generator with option 403 enables you to apply additive white gaussian noise (AWGN)
to a carrier in real time while the modulating waveform plays in the dual ARB waveform player. This
feature appears in each of the arb formats and as a stand-alone menu (Refer to Figure 9-7 on
page 249).
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Adding Real-Time Noise to a Dual ARB Waveform

Figure 9-1

Real Time 1/Q Baseband AWGN Softkeys

Arb Setué &

Arb Sample Clock
125, 000000000MHz

For details on each key, use key help
as described on page 42.

Arb
ARE
| Off [l
Nodulation Hode
Select,
Oual ARBM— Haveform
Eusgag, ARE Setupk
Trigoer Tupe
(Cont inuous , M
Free Run.
THo-Tanek
fMore 1 of 2 N
Multitonew

fore 1 of 2 E

Nodulat.i

Feal-Time
Fhase Moises
Impairment

W NI

Real-Time ALGN,
Setup

Real-Time,
Fhase Moise Setup

Funt.ime Scaling
70.00 X

This is the stand—alone

Heal—g&gﬁr | — Real-Time AWGN and the 2nd

page of the Modulation Mode
menu (see page 249).

The state of the noise (on or off)
is shown on the display.

ARB Real-Time ALGH

s )

Modulator Atten
27.13 dB
Manual

__fore 1 of 2 %

AUGH Setup

Carrier to Molse
tig—— see page 245

Real-Time ALIGN
on

Power Control

Figure 9-6 on page 248
provides additional
details on these settings.

Mode#— see page 245

(Total)

Carrier To Moise

Fatio Formgt—— see page 245

IVl Eb/Mo

=]
0.00 dB

fore 1 of 2

Static graphic representation of
ARB Real-Noise AWGN (i.e.
graphic does not update as

values change).

N\
The relationship of the values are displayed in the

static graphic of ARB Real-Time AWGN.

The Total Noise Power is the Noise Power over the
occupied noise bandwidth (NBW * 1.25).

AUGH Setup  #
Carrier Bandwidth
1.000 Hz

For the selected carrier to noise ratio,
the bandwidth over which the noise is
integrated. Typically, Carrier
Bandwidth (CBW) is the occupied

. bandwidth of the carrier.

The Carrier Bit Rate softkey sets the
carrier bit rate. (The default carrier bit

rate is 1 bps.)

Moize Bandwidth
1.000 Hz

. Flat Noise Bandwidth (NBW): The
actual flat noise bandwidth (NBW),

—

Carrier Bit Rate
1.000 bps

which should be slightly wider than
the carrier bandwidth (typically 1.6
times wider). The occupied

The Carrier Bit Rate softkey is only

available when the Carrier to Noise
Ratio Format Softkey is set to E,/N,,.
See also page 247.

Output M
(Carrier+Hoise)

bandwidth is =
(1.25 * the Flat Noise Bandwidth)

w

- =

L -

ee page 246
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Adding Real-Time Noise to a Signal (Option 403)
Adding Real-Time Noise to a Dual ARB Waveform

Figure 9-2 Real Time 1/Q Baseband AWGN - Power Control Mode Softkeys
Mode > Dual ARB > Arb Setup > For details on each key, use key help
Real-Time AWGN Setup

as described on page 42.

Figure 9-6 on page 248

ALGH Setup

RE_OFF

provides additional
6 000 000 000 00 GHz Real-Time AMGN details on these settings.
. On
Foner Control
T ode
ARB Real-Time ALGH (Total)
Carrier To Moise
p f—CBU-—+ Ratin Format — —| — —Seepage 246
Eb/No
1} e e
u [H i i
e BEiE O Hgéig Selecting Total as the power
r 0.00 dB control mode makes the total
H L - - power and C/N independent
variables while making the
E 4 carrier power and total noise
HBL Freq power dependent variables. The
dependent variables carrier
power and total noise power are
fiore 1 of 2 set by the total power, C/N, and
the rest of the Noise settings.
The carrier power and total

noise power change as any
noise parameter is adjusted to
keep the total power and the

Pouer Control 7| CIN at their last specified
values.
Total

Selecting Carrier as the power
control mode makes the carrier
power and C/N independent
\variables while making the total
power and total noise power
dependent variables. The

Carrier

Total Moise dependent variables total power
and total noise power are set by
N the carrier power, C/N, and the
- / - rest of the Noise settings. The

total power and total noise
power change as any noise
parameter is adjusted to keep
the carrier power and the C/N at
their last specified values.

Selecting Total Noise as the
power control mode makes the
total noise power and C/N
independent variables while
making the total power and
carrier power dependent
variables. The dependent
variables total power and carrier
power are set by the total noise
power, C/N, and the rest of the
Noise settings. The total power
and carrier power change as
any noise parameter is adjusted
to keep the total noise power
and the C/N at their last
specified values.
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Figure 9-3 Real Time 1/Q Baseband AWGN - Noise Mux Menu Softkeys
Mode > Dual ARB > Arb Setup >
Real-Time AWGN Setup > More

The Carrier Bit
Rate softkey is
only available
when the Carrier
to Noise softkey
is set to Ep/N,,.

AUGH Setup &

Carrier Bandwidth
1.000 Hz

Moize Bandwidth
1.000 Hz

4<

Carrier Bit Rate
1.000 bps

OULPLIE Pl
(Carrier+Noise)

w

- =

L -

Hoise Hux

Carrier+Hoise

Carrier

MNoise

Enables diagnostic control of
additive noise, so that only the
noise, only the carrier, or the
sum of both the noise and the
carrier are output from the
internal baseband generator.
With the ALC off, this feature
enables direct measurement of
the carrier or the noise
contributions independently
from the total power. The system
still behaves as if both the noise
and the carrier are present on
the output when it comes to
determining the Auto Modulation
Attenuation and the RMS level
for RMS Power Search.

E,/N, Adjustment Softkeys for Real Time 1/Q Baseband AWGN

Figure 9-6 on page 248
provides additional
details on these settings.

For details on each key, use key help
as described on page 42.

This feature allows the AWGN C/N to be set using the E,/N, (energy per bit over noise power density

at the receiver or signal to noise ratio per bit) form. This requires the carrier bit rate to be known.
Refer to Figure 9-4, “Eb/No Carrier Bit Equation.”

Figure 9-4 E,/N, Carrier Bit Equation

bitRate )

E
?) (
— |dB + 101 e
dB+10 °£10 carrierBandwidth

i:(
Np Nog
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Adding Real-Time Noise to a Dual ARB Waveform

Figure 9-5 Real Time 1/Q Baseband AWGN - E,,/Nj Adjustment Softkeys

Mode > Dual ARB > Arb Setup > Real-Time AWGN Setup
Figure 9-6 on page 248
provides additional

FREQUEHCY |, AlIGH Setup details on these settings.
6.000 000 000 00 s

Lff | Selects either the Carrier to
Noise Ratio (C/N) or energy per

| = ——— bit over noise power density at
Fower Eunﬁggé'l the receiver (Ep/N,) as the
=Ti variable controlling the ratio of
AR Feal-Time AUGH (Total) the carrier power to noise power
; ; in the carrier bandwidth. When
=Rl | Earréez ) TDFNDJ-SE | E,/N, is selected, the second
p | aLlo Eg?ﬁg page of the AWGN Setup menu
o ) shows the Carrier Bit Rate
u [H N ; ; softkey to enable the E,/N,
e | Carrier 40 HD%SB value to be calculated.
g \ VA atio |—
0.00 d& ~~The active
H \ softkey changes
with the Carrier to
k—HBI—! Freq r——— Noise Ratio
\ / Format selected
7 \ flore 1 of 2 ggtz lfv';/ No)-
Display remains grayed out until Ey/N, is displayed when Carrier to Noise Katio
real-time AWGN is enabled. Format softkey is set to Ep/N,,.

C i)

AUGH Setup  #
Carrier Bandwidth
1.000 Hz

The Carrier Bit Rate softkey sets the Moise Bandwidth
carrier bit rate. (The default carrier bit 1.000 Hz
rate is 1 bps.)

Carrier Bit Rate
The Carrier Bit Rate softkey is only 1.000 bps
available when the Carrier to Noise
Ratio Format Softkey is set to E,/N,. Output Mu,

(Carrier+Noise)

To view the carrier bit rate equation, e P e

refer to page 42.

v
iGN Setup 7|

eal-Time AHGN
aon

Fower Control
odek

(Total)

Carrier To Moise
Eatio Format

o

CIN selected

Carrier to MNoise
Ratio
0.00 dB

Whether a softkey is available
L _¥ depends on the Carrier to ——————

e Noise Ratio Format softkey o Ega’ﬁg
"I setting (e.g. CIN or Eg/N,). i )

Ep/N, selected

—

For details on each key, use key help
as described on page 42.
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Adding Real-Time Noise to a Dual ARB Waveform

Figure 9-6 Carrier to Noise Ratio Components

Carrier Bandwidth (CBW) is typically the

occupied bandwidth of the carrier and the Noise

Bandwidth is the flat noise bandwidth (NBW).
The carrier now appears
larger because of the

Noise BW added noise power.

(NBW) =
* Carrier BW ' 1 flat noise )
(CBW) bandwidth

(CBW)

' 1
RMS ' * Carrier BW ' '
(total carrier power) ' :

Carrier

Example

Use the following steps to modulate a 1 GHz, —-10 dBm carrier with the factory-supplied waveform
SINE_TEST_WFM, and then apply noise with a 456 MHz bandwidth signal that has a 30 dB
carrier-to—noise ratio across a 40 MHz carrier bandwidth.

1. Preset the signal generator and set the following:

* Frequency: 1 GHz
¢ Amplitude: —10 dBm
* RF output: on

2. Select the factory-supplied waveform SINE TEST WFM:

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight SINE TEST WFM and press Select Waveform.

Turn on the dual ARB player: press ARB Off On to highlight On.
4. Set the ARB sample clock to 50 MHz: Press ARB Setup > ARB Sample Clock > 50 > MHz.
Press Real-time Noise Setup and set the following:

e Carrier to Noise Ratio: 30 dB
¢ Carrier Bandwidth: 40 MHz

¢ Noise Bandwidth: 45 MHz

¢ Real-time Noise: on

The signal generator’s displayed power level (-10 dBm) 4ncludes the noise power.
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Adding Real-Time Noise to a Signal (Option 403)
Using Real Time 1/Q Baseband AWGN

Using Real Time 1/Q Baseband AWGN

Figure 9-7 Real Time 1/Q Baseband AWGN Softkeys

lodulation lode —®[Todulation Mode
Dual AREP Real-lim,] o Heal=tine AUGH /|
Real-Time Real-LLIe RGN
- Off
Eusgagb Phase Moises Qe JEx
Impairment
Eandwidth
\‘»NM\\_ 1.000000000MHz

Modulator Atten

E.00 dB
Tho-TaneM Manual
i ¥
fultitone For details on each key, use key help
More 1 of 2 Sﬁl— as described on page 42.

Use the following steps to apply 10 MHz bandwidth noise to a 500 MHz, -10 dBm carrier.

1.

Configure the noise:

a. Preset the signal generator.

b. Press Mode >More > Real Time I/Q Baseband AWGN
c. Press Bandwidth > 10 > MHz.

Generate the noise:

Press AWGN Off On until On highlights.

During generation, the AWGN and I/Q [Frcquency ATPLITODE
right). AWGN is now available to 6.000 000 000 0 144.00 _den

modulate the RF carrier.

Configure the RF output:

*  Frequency: 500 MHz

* Amplitude: —10 dBm

* RF output: on

The carrier with AWGN is now available at the signal generator’s RF OUTPUT connector.
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Adding Real-Time Noise to a Signal (Option 403)
Using Real Time 1/Q Baseband AWGN
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10 Real-Time Phase Noise Impairments (Option 432)

NOTE For the N5162A the softkey menus and features mentioned in this guide are only available
through the Web-Enabled MXG or SCPI commands. For information on the Web- Enabled
MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI Command
Reference.

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting the power level and frequency, refer to

Chapter 3, “Basic Operation,” on page 41 and familiarize yourself with the information in that
chapter.

This feature is available only in N5162A/82A Agilent MXG Vector Signal Generators with Option 431.
Option 431 requires Option 651, 652, or 654.

This chapter contains the softkey maps to locate the Phase Noise Impairment option functions and
information on the use of this feature.

* Real-Time Phase Noise Impairment on page 252

e The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments on page 253
* Understanding the Phase Noise Adjustments on page 255

* DAC Over-Range Conditions and Scaling on page 256
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Real-Time Phase Noise Impairments (Option 432)
Real-Time Phase Noise Impairment

Real-Time Phase Noise Impairment

This feature lets you degrade the phase noise performance of the signal generator by controlling two
frequency points and an amplitude value. The signal generator adds this phase noise to the phase
noise normally produced by the Agilent MXG. This feature appears in each of the arb formats and as
a stand-alone menu. While the following figure shows how to access the controls using both the
stand-alone menu and the Dual ARB player, the location and softkeys within each arb format is the
same as for the Dual ARB player.

Figure 10-1 Stand—Alone and Dual ARB Player Real-Time Phase Noise Softkeys

Mode

This softkey is

| llodulation lode available in all arb
formats.
Dusl aresf—- A0
ARE Arb_Setu
an
Lustom, Arb Sample Clock
e— 125, 000000000MHz
elec
uaueFor?’ K
Real-Time ALGN,
7 Setup
ARE Setupsf—P
THo-Tonew Feal-Time
Trigoer Tupe Fhase Moise Setup”|—
(Cont inuous , M
Mult itoned Free Aun) Rurt.ime Scaling
70.00 X
Hore 1 of 2
Hodulatgg ?gtgg
[ _Hore 1 of 2 Manual
fore 1 of 2

Nodulation Hode

Feal Time I/0Q
Easebande
AHGH

Phase Moise
Inpairment?

I\\‘A‘\_‘_

FREQUEHCY

2.000 000 000 00 s+

ERXTREF

Desired f2: 30000 000 KHZ

Stand-alone menu

Use to add phase noise to the
CW output without having to
play a waveform.

The display updates even
when the feature is off.

ANPLITUDE

-10.00 den

-u0

LCF)
dBc/Hz

=110

ARB Additive Phase Hoise Impairyent
£1 2

\J

Phase Hoise

Fhaze Moise
an

s ired

De
Start Fregifl) £ —

1.000000kHz

For an explanation on these
settings see

“The Agilent MXG Phase Noise
Shape and Additive Phase Noise
Impairments” on page 253.

The start frequency for the flat
mid—frequency characteristics.

F'Iat Mid-Frequency Area
Denoted by f1 and f2

Desired
Stop Freq(f2) |
30. 000000kHz

The end frequency for the flat
mid—frequency characteristics.

————————————— Lmid

Desired Flat
Amplitude(lmid)
=70.00 dBc/Hz

The amplitude for the flat
T~ mid—frequency characteristics.

100Hz

Frequency, Loo Scale

1hHz

(Lmid stands for the level
amplitude of the mid—frequency
characteristic.)

For details on each key, use key help

as described on

page 42.

NOTE: The phase noise impairment is added to the base phase noise of

the signal generator.
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Real-Time Phase Noise Impairments (Option 432)
The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments

The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments

Phase Noise Plots Without Phase Noise Impairment

—-50 dBc/Hz — -50 dBc/Hz

The Agilent MXG demonstrates a definitive
shape to its phase noise plot. The
mid—frequency offsets are characterized by a
leveling (flattening) of the phase noise
amplitude from approximately a 3 kHz offset

to approximately a 70 kHz offset.
Close in and far out offsets demonstrate
slopping characteristics (areas before and

<t after the mid—frequency offsets).

il

Frequency Offset

The signal generator degrades the phase noise by moving the mid-frequency characteristics and/or
changing its amplitude using the following settings:

e Start frequency (f1) of the mid-frequency characteristics
* Stop frequency (f2) of the mid-frequency characteristics
e Amplitude (Lmid) of the mid-frequency characteristics

-50 dBc/Hz -50 dBc/Hz

This is a plot of the unmodified phase noise
shape that shows the location that each

value alters.
Amplitude

(Lmid)

ha

Mid—frequency characteristics

Frequency Offset
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Real-Time Phase Noise Impairments (Option 432)
The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments

Phase Noise Plots With Phase Noise Impairments

Flat mid—frequency offset

50 dBo/Hz characteristics (Lmid)

-50 dBc/Hz

When turned on, this phase noise is added

Re_sultaln: phase to the base phase noise of the signal
/ no'se 0o generator.
T

N Even though it is only the mid—frequency

T characteristics placement that are modified,
these changes affect the entire phase noise
shape. The close in and far out offset
. - characteristics change by exhibiting
approximately a 20 dBc/Hz slope for each

No additive Ny
phase noise Flat mid—frequency offset L octave of frequency offset.
characteristics (Lmid)

14 Hz Frequency Offset 16

—-50 dBc/Hz -50 dBc/Hz

1100 Hz 1/ kHz

The resultant phase noise plot shown on
the left has the following settings:

e f1=100Hz
e f2=1kHz
* Amplitude (Lmid) =-70 dBc

Ensure that the f1 value is less than or
—20 dBc/Hz equal to f2. If not, f2 changes its value to
match f1. Conversely if 2 is set to a value
that is less than f1, f1 changes its value to
match f2.

Frequency Offset

The frequency values entered for the impairments may not be the exact values when viewed on the
RF output. The entered values are guidelines that the signal generator uses to calculate the real
values. See “Understanding the Phase Noise Adjustments” on page 255 for more information.

To view the results of the settings (fl, f2, and Lmid), use the front panel graph (below and on

page 252) or view the phase noise plot on a measurement instrument (shown above—Agilent E4440A
PSA with Option 226).

ARB Additive Phase Noise Impairment .
T £1 £2 Signal generator front panel plot:
. 12100 Hz
Leey | T — N R Lmid e f2=1kHz
TR : ™ *  Lmid = -70 dBc
-90 K
10Hz Frequency, Loo Scale 10kHz
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Real-Time Phase Noise Impairments (Option 432)
Understanding the Phase Noise Adjustments

Understanding the Phase Noise Adjustments

The signal generator bases the resultant phase noise shape on three settings, Lmid (amplitude), f1
(start frequency), and f2 (stop frequency).

The range for Lmid is coupled to f2, so as f2 increases in value, Lmid’s upper boundary decreases. If
the current Lmid setting is too high for the new f2 setting, the signal generator changes the Lmid
value and generates an error to alert you to the change. In addition, the actual Lmid value can vary
by 0.28 dBc/Hz from the entered value.

The frequency settings (f1 and f2) are really guidelines that the signal generator uses to calculate the
real frequency offset values seen on the RF OUTPUT. This means that the entered start and stop
frequency values are an approximation and may not be the values seen on a measurement
instrument, however they will be close.

The effects of the f1 and f2 parameters are based on a varying logarithmic scale. This scale is
determined by the f2 value. The higher the f2 value the larger the scale, which makes this behavior
more noticeable at higher frequency settings. This becomes apparent when a change in the fl or f2
value causes little to no change in the fl1 or f2 position. This is easy to view using the signal
generator’s front panel phase noise graph and demonstrated in Figure 10-2. This behavior makes the
frequency adjustments coarser as the f2 frequency value increases.

Figure 10-2 f1 and f2 Frequency Setting Behavior

iti i i Desired
ARB Additive PhESEF{ilJl se Inpal r;rgent 13?255055335%; f1 and f2 softkey settings for the front
=60 i panel phase noise graph.
H Desired
Stop Fregqif2)
30.000000000HHz
LCFY Desired Flat
dBc/Hz ﬂ!TDl?ELlJESELmlSJ
Lmid -80.50 dBc/Hz
-a0 i W
1MHz Frequency, Loo Scale ! 100MHz
L ey s Ll
' l
ARB Additive Phase Noise Inpairment Desiced | f1 did not change frequency unti
A Start Freg(fl) 12.1 MHz was set. This means that it
-60 £l - f2 A2 M T T took an increase of 1.6 MHz to change
' ' Desired its frequency offset.
' Stop Freq(f2)
! Ll v L40. 00DD00D00NHZ
CLE) : : : Desired Flat 2 did not change frequency until 40
dBc/Hz \ LD MHz was set. This means that it took an
“““““““““ ) =il 2 increase of 10 MHz to change its
/. \ N frequency offset.
=4l

0 » e
1% Frequengl, Loo Scale 1ﬂﬂﬂz

f1—original 10.5 MHz f2—40 MHz setting that
setting - moved the offset position
f2—original 30 MHz

1—12.1 MHz setting that setting
moved the offset position

For details on each key, use key help
as described on page 42.

The only way to make an accurate determination of the effect of the f1 and f2 values is by viewing
the front panel graph or making a measurement. You can view the front panel graph remotely by
using the LXI interface. For more information on the LXI interface, see the Programming Guide.
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Real-Time Phase Noise Impairments (Option 432)
DAC Over—Range Conditions and Scaling

DAC Over—Range Conditions and Scaling

When using phase noise impairment, it is possible to create a DAC over-range condition, which
causes the Agilent MXG to generate an error. To minimize this condition with the phase noise
impairment feature, the Agilent MXG incorporates an automatic DAC over-range protection feature
that scales down the I/Q data. Because it can scale the data by more than what is actually need, it
typically decreases the dynamic range of the waveform. This is especially noticeable when using a
constant amplitude signal such as GSM.

For the Dual ARB Player, the automatic over-range protection can be turned off (on is the factory
default). The control for the Dual ARB DAC over-range protection feature is located in the key path
as shown in Figure 10-3.

Figure 10-3 Dual ARB DAC Over—Range Protection Softkey Location

Mode -
> lodulation Hode Arb
Dual ARB»—p ARE ] Arb Setué 7
0n
58 BRI
Custom o 4
ion* Select
Modulat ion Laneform®
Real-Tima ALIGM,|
Setup
ARE Setupk >
Real-Time |
Tho-Tanes Trigger Tupe Fhase Moise Setup
(Eopﬁéguaﬂﬁib When the DAC over—range protection is off,
Runt ime Sc:alj_ngA‘/ eliminate over—range conditions by
Multitonew FO.00 2 decreasing the scaling value (see “Setting
Waveform Runtime Scaling” on page 185).
Madulator Atten
flore 1 of 2 Tore Tor 2 oC fLteR
e Manual
_ MHore 1,0f 2 %
Arb Setup A
Bageband
Freguency Of fset.
0.000 Hz
Default setting is On.
MUlti—BEG Sunc Turn off to manually control scaling while
Fetuny using the phase noise impairment option.
Roal-Time Manually adjust the scaling using the
For details on each key, use key help UEELRETEAC, F e Waveform Runtime Scaling softkey
as described on page 42. —_Tore 2 of 2w shown above.

In the Dual ARB Player, to avoid excessive scaling or to just perform scaling manually, turn the
over-range protection off and use the Waveform Runtime Scaling softkey to eliminate DAC over-range
conditions.

When the automatic feature is disabled, the other options to eliminate a DAC over-range condition
are to reduce the f2 value, or the Lmid value, or both until the condition corrects itself.
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11 Custom Digital Modulation (Option 431)

NOTE For the N5162A, the softkey menus and features mentioned in this guide are only available
through the Web-Enabled MXG or SCPI commands. For information on the Web-Enabled

MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI Command
Reference.

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting the power level and frequency, refer to

Chapter 3, “Basic Operation,” on page 41 and familiarize yourself with the information in that
chapter.

This feature is available only in N5162A/82A Agilent MXG Vector Signal Generators with Option 431.
Option 431 requires Option 651, 652, or 654.

¢ Custom Modulation on page 258

¢ Using the Arbitrary Waveform Generator on page 263

¢ Using Finite Impulse Response (FIR) Filters in ARB Custom Modulation on page 273
* Modifying a FIR Filter Using the FIR Table Editor on page 278

¢ Differential Encoding on page 281
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Custom Digital Modulation (Option 431)
Custom Modulation

Custom Modulation

Custom Modulation has built-in modulation standards such as TETRA and DECT; and pre-defined
modulation types such as BPSK and 16QAM that can be used to create a signal in addition, it
provides the flexibility to modify the digital format’s attributes.

ARB Custom Modulation Waveform Generator

The signal generator’s ARB Waveform Generator mode is designed for out-of-channel test
applications. This mode can be used to generate data formats that simulate random communication
traffic and can be used as a stimulus for component testing. Other capabilities of the ARB Waveform
Generator mode include:

¢ configuring single or multicarrier signals. Up to 100 carriers can be configured.
* creating waveform files using the signal generator’s front panel interface.

The waveform files, when created as random data, can be used as a stimulus for component testing
where device performance such as adjacent channel power (ACP) can be measured. The

AUTOGEN WAVEFORM file, that is automatically created when you turn the ARB Waveform Generator
on, can be renamed and stored in the signal generator’s non-volatile memory. This file can later be
loaded into volatile memory and played using the dual ARB waveform player.

For more information, refer to “Waveform File Basics” on page 134 and “Modes of Operation” on
page 4.
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Custom Digital Modulation (Option 431)
Custom Modulation

Figure 11-1 ARB Custom Modulation Softkeys

Nodulation Hode 7
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Mult itones—=page 296
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_Hore 1 of 2 - Custom ARE
Trigoer Tupe
(Cont inuous , M
Free Run) page 166
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For details on each key, use key help as described on page 42.
Hore 2 of 2 ™
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Custom Digital Modulation (Option 431)
Custom Modulation

Figure 11-2 Quick Setup Softkeys

Mode > ARB Custom Modulation > Single Carrier Setup
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Figure 11-3 Mode Type Softkeys

Mode > ARB Custom Modulation > Single Carrier
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Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide

261



Custom Digital Modulation (Option 431)
Custom Modulation

Figure 11-4 Store Custom Dig Mod State Softkeys
Mode > ARB Custom Modulation > Single Carrier Setup > Store Custom Dig Mod State

page 268
FREQUEHCY AAPLITUDE Store State
6.000 000 000 00 &z | -144.00 den storg, To Confirn Delete
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For details on each key, use key help as described on page 42. M
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Custom Digital Modulation (Option 431)
Using the Arbitrary Waveform Generator

Using the Arbitrary Waveform Generator

This section teaches you how to build dual arbitrary (ARB) waveform files containing custom TDMA,
digital modulation for testing component designs.

Figure 11-5 Adding Custom Modulation to a Waveform

Mode > ARB Custom Modulation > Single Carrier Setup

" __Ouick Setup 7
This softkey label updates to reflect HlE S8 u -
the current modulation type. CUStDﬁDglg%gﬁé, ~ »page 269
GSH
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Surbol Fate | Tore 1 of 3
1.000000 Hsps
Store Custom,
Dio Hod State'] > Page 262

For details on each key, use key help as described on page 42.

Using Predefined Custom TDMA Digital Modulation

This section teaches you how to perform the following tasks:
¢ Selecting a Predefined EDGE Setup on page 263
¢ Generating the Waveform on page 263

¢ Configuring the RF Output on page 264

Selecting a Predefined EDGE Setup
1. Press Preset.

2. In the ARB Custom Modulation menu (page 263), press Single Carrier Setup > Quick Setup > EDGE.

Generating the Waveform
Press Digital Modulation Off On.

This generates a waveform with the pre-defined EDGE state selected in the step. The display changes
to Dig Mod Setup: EDGE. During waveform generation, the DIGMOD and I/Q annunciators appear and
the pre-defined digital modulation state is stored in volatile memory (BBG). The waveform is now
modulating the RF carrier.
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Custom Digital Modulation (Option 431)
Using the Arbitrary Waveform Generator

Configuring the RF Qutput

1. Set the RF output frequency to 891 MHz.

2. Set the output amplitude to —5 dBm.
3. Press RF On/O0ff.

The predefined EDGE signal is now available at the signal generator’s RF OUTPUT connector.

264
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Creating a Custom TDMA Digital Modulation State

Custom Digital Modulation (Option 431)
Using the Arbitrary Waveform Generator

In this procedure, you learn how to set up a single-carrier NADC digital modulation with customized
modulation type, symbol rate, and filtering.

Figure 11-6 Setting a Digital Modulation Filter

Mode > ARB Custom Modulation > Single Carrier Setup

This softkey label updates to reflect
the current modulation standard.

This softkey sets
the filter shape.

This softkey
sets the filter
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For details on each key, use key help as described on page 42.

Opens a menu to select a
1S-95 filter.

mapping can be specified.
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Custom Digital Modulation (Option 431)
Using the Arbitrary Waveform Generator

Figure 11-7 Modifying a Digital Modulation Type
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This section teaches you how to perform the following tasks:
¢ Selecting a Digital Modulation Setup on page 266

¢ Configuring the RF Output on page 264

¢ Selecting the Filter on page 267

¢ Configuring the RF Output on page 264

Selecting a Digital Modulation Setup
1. Press Preset.

2. In the ARB Custom Modulation menu (page 265), press Single Carrier Setup > Quick Setup > NADC.

Modifying the Modulation Type and Symbol Rate
1. In the ARB Custom Modulation menu (page 265), press Single Carrier Setup > Modulation Type > Select
> PSK > QPSK and 0QPSK > QPSK.

2. Press Return > Symbol Rate > 56 > ksps.
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Custom Digital Modulation (Option 431)
Using the Arbitrary Waveform Generator

Selecting the Filter
1. In the Setup Mod menu (page 265), press Filter > Select > Nyquist.

2. Press Return > Return.

Generating the Waveform
Press Digital Modulation Off On.

This generates a waveform with the custom, single-carrier NADC, digital modulation state created in
the previous sections. The display changes to Dig Mod Setup: NADC (Modified). During waveform
generation, the DIGMOD and I/Q annunciators appear and the custom single-carrier digital
modulation state is stored in volatile memory. The waveform is now modulating the RF carrier.

For instructions on storing this custom, single-carrier NADC, digital modulation state to the
non-volatile memory catalog, see Storing a Custom TDMA Digital Modulation State on page 267.

Configuring the RF Qutput
1. Set the RF output frequency to 835 MHz.

2. Set the output amplitude to 0 dBm.
3. Press RF On/0ff.
The user-defined NADC signal is now available at the RF OUTPUT connector.

Storing a Custom TDMA Digital Modulation State

Using this procedure, you learn how to store a custom digital modulation state and a custom
multicarrier digital modulation state to non-volatile memory.

If you have not created a custom, single-carrier, digital modulation state, complete the steps in the
previous section, Creating a Custom TDMA Digital Modulation State on page 265.
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Figure 11-8 Storing a Custom Digital Modulation State
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Goto Raoue storage.
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have been previously saved by For details on each key, use key help as described on page 42.

the user.

1. Return to the top-level ARB Custom Modulation menu, where Digital Modulation Off On is the first
softkey.

2. In the ARB Custom Modulation menu (page 268), press Single Carrier Setup > Store Custom Dig Mod
State > Store To File.

If there is already a file name from the Catalog of DMOD Files occupying the active entry
area, press the following key: Clear Text

3. Enter a file name (for example, NADCQPSK) using the alpha keys and the numeric keypad with a
maximum length of 23 characters.

4. Press Enter.

The user—defined, single-carrier, digital modulation state is now stored in non-volatile memory.

NOTE The RF output amplitude, frequency, and operating state settings are not stored as part of a
user—defined, digital modulation state file.
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Recalling a Custom TDMA Digital Modulation State

Using this procedure, you will learn how to recall a custom digital modulation state from signal
non-volatile memory.

If you have not created and stored a user-defined, single-carrier, digital modulation state, complete
the steps in the previous sections, Creating a Custom TDMA Digital Modulation State on page 265
and Storing a Custom TDMA Digital Modulation State on page 267, then preset the signal generator
to clear the stored user—defined, digital modulation waveform from volatile ARB memory.

Figure 11-9 Recalling a Custom TDMA Digital Modulation State
Mode > ARB Custom Modulation > Single Carrier Setup>__,

__Quick Setup 7~ For details on each key, use key
Custom Digital help as described on page 42.

ate®
G5H

EDGE

MAOC
POC

Hore 1 of 3 ™ Loads the highlighted file
into the instrument
memory.

FREQUEHCY ANPLITUDE 5e,

6.000 000 000 00 &z | -144.00 den B

Catalog of DNOD Files in Int Storage 30MB used LGSME free
File Hame Tupe Size Hodified

00

Delete Filem
These keys manage the table
of DMOD files in internal
storage.

Goto Fowe

02/07/2007 16:04

1. In the Quick Setup menu, press Custom Digital Mod State.
2. Highlight the desired file (for example, NADCQPSK).

3. Press SelectFile > Return.

4. Press Digital Modulation 0ff On until On is highlighted.

The instrument regenerates the custom, digital modulation waveform in volatile memory. After
waveform generation, the custom, digital modulation waveform is available to be modulated on the
RF output.

For instruction on configuring the RF output, see Configuring the RF Output on page 264.
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Creating a Custom Multicarrier TDMA Digital Modulation State

In this procedure, you learn how to customize a predefined, multicarrier, digital modulation setup by
creating a custom, 3-carrier EDGE, digital modulation state.

This section teaches you how to perform the following tasks:

¢ Creating a Multicarrier Digital Modulation Setup on page 271
¢ Modifying Carrier Frequency Offset on page 271

* Modifying Carrier Power on page 271

* Generating the Waveform on page 271

¢ Configuring the RF Output on page 271
Figure 11-10Creating a Multicarrier Digital Modulation Setup
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For details on each key, use key help as described on page 42.

270 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Custom Digital Modulation (Option 431)
Using the Arbitrary Waveform Generator

Creating a Multicarrier Digital Modulation Setup
1. Press Preset.

2. Press Mode > ARB Custom Modulation > Multicarrier 0ff On to On.

3. Press Multicarrier Setup > Select Carrier and Initialize Table > Carrier Setup > EDGE > Done.

Modifying Carrier Frequency Offset
1. Highlight the Freq Offset value (500.000 kHz) for the carrier in row 2.

2. Press —625 > kHz.

Modifying Carrier Power
1. Highlight the Power value (0.00 dB) for the carrier in row 2.

2. Press -10 > dB.

You now have a custom 2-carrier EDGE waveform with a carrier at a frequency offset of
—625 kHz and a power level of —10.00 dBm, as shown in the following figure.

™"*"6.000 000 000 00 stz | ~144.00 an |

Initialize
Table®

For details on each key, use key
help as described on page 42.

= - - — Inzert Rou
NMulticarrier Setup: EDGE Carriers (fodified)
Carrier Phases: Fixed
arrier Fhases e Carrier Freq Offset Pouer
1 EOGE ~500.000 kHz 0.00 dB Oelete Rou
2 EOGE —B25.000 kHz —10.00 dB
3 | ——————— |
Goto Rodw If Digital Modulation is already on, you
must press Apply Multicarrier to apply
the changes and generate a new
_Aepply b custom multicarrier digital modulation
Multicarrier waveform based on the updated
02,/Z1/2007 16:0d | Nore 1 _of 2 values.
—

Generating the Waveform
Press Return > Digital Modulation Off On.

This generates a waveform with the custom, multicarrier, EDGE state created in the previous
sections. The display changes to Dig Mod Setup: Multicarrier (Modified). During waveform
generation, the DIGMOD and I/Q annunciators appear and the new custom, multicarrier, EDGE state
is stored in volatile memory. The waveform is now modulating the RF carrier.

For instructions on storing this custom, multicarrier, EDGE state to non-volatile memory, see
“Storing a Custom Multicarrier TDMA Digital Modulation State” on page 272.

Configuring the RF Qutput
1. Set the RF output frequency to 890.01 MHz.

2. Set the output amplitude to —10 dBm.
3. Press RF On/O0ff.

The custom multicarrier EDGE signal is now available at the RF OUTPUT connector.
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Storing a Custom Multicarrier TDMA Digital Modulation State

Using this procedure, you learn how to store a custom, multicarrier, TDMA, digital modulation state
to non-volatile memory.

If you have not created a custom, multicarrier, digital modulation state, complete the steps in the
previous section, “Creating a Custom Multicarrier TDMA Digital Modulation State” on page 270.

Figure 11-11 Storing a Custom Multicarrier Softkeys
Fixed: All the carriers are set to a

lCarrier Define phase of 0.

Carrier Phases |—pe-Random: All of the carriers are
[FREEl Fandom set to a random phase value.

ANPLITUDE

-144.00 den

FREQUEHCY

6.000 000 000 00 &z

Load/Storer—seDage 43
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Carrier Phases: Fixed
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2 EDBE —E25.000 kHz -10.00 oB
3 | —————— |

For details on each key, use key help as
described on page 42.

02/21/2007 17:22 Hore 2 of 2
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1. Return to the top-level Digital Modulation menu, where Digital Modulation Off On is the first softkey.
2. Press Multicarrier Setup > More > Load/ Store > Store To File.

If there is already a file name from the Catalog of MDMOD Files occupying the active entry
area, press the following key: Clear Text

3. Enter a file name (for example, EDGEM1) using the alpha keys and the numeric keypad with a
maximum length of 23 characters.

4. Press Enter.

The user-defined, multicarrier, digital modulation state is now stored in non-volatile memory.

NOTE The RF output amplitude, frequency, and operating state settings are not stored as part of a
user—defined, digital modulation state file.

Applying Changes to an Active Multicarrier TDMA Digital Modulation State

If the digital modulation format is currently in use (Digital Modulation Off On set to On) while changes
are made in the Multicarrier Setup table editor, you must apply the changes before the updated
waveform will be generated.

From the Multicarrier Setup table editor, press Apply Multicarrier to apply the changes and generate
a new custom multicarrier digital modulation waveform based on the updated values.
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Using Finite Impulse Response (FIR) Filters in ARB Custom Modulation

Finite Impulse Response filters can be used to refine the transitions between symbol decision points
of the generated waveforms.

Figure 11-12  Filter Menu
Mode > ARB Custom Modulation > Single Carrier Setup > Filter
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More 2 of 3 3

Creating a User—Defined FIR Filter Using the FIR Table Editor

In this procedure, you use the FIR Values table editor to create and store an 8-symbol, windowed
sync function filter with an oversample ratio of 4.

Accessing the Table Editor
1. Press Preset.

2. Press Mode > ARB Custom Modulation > Single Carrier Setup > Select > Nyquist.
3. Press Filter > Define User FIR.
4. Press More 10f2 > Delete All Rows > Confirm Delete of All Rows.

This will initialize the table editor as shown in Figure 11-13.
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Figure 11-13Creating a User—Defined FIR Filter Using the FIR Filter Table Editor

Mode > ARB Custom Modulation> Single Carrier Setup > Filter > Define i i
User FIR > More 1 of 2 > Delete All Rows > Confirm Delete of All Rows For details on each key, use key help as described on page 42.

¢ Opens a menu that
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Lomd Default,
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Active only when:

FIR filter coefficient table
has minimum of two
values visible.

Note: M“/M

Modulation filters are typically real and have an oversample ratio (OSR) of two or greater.
Equalization filers are typically complex and have an oversample ratio (OSR) of one (Dual ARB only).

Entering the Coefficient Values
1. Press the Return softkey to get to the first page of the table editor.

2. Use the cursor to highlight the Value field for coefficient O.

3. Use the numeric keypad to type the first value (—0.000076) from Table 11-1. As you press the
numeric keys, the numbers are displayed in the active entry area. (If you make a mistake, you can
correct it using the backspace key.)

4. Continue entering the coefficient values from the table in step 1 until all 16 values have been

entered.
Table 11-1
Coefficient Value Coefficient Value
0 —0.000076 8 —-0.035667
1 —-0.001747 9 —0.116753
2 —-0.005144 10 —0.157348
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Table 11-1
Coefficient Value Coefficient Value
3 —0.004424 11 —0.088484
4 0.007745 12 0.123414
5 0.029610 13 0.442748
6 0.043940 14 0.767329
7 0.025852 15 0.972149
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Duplicating the First 16 Coefficients Using Mirror Table

In a windowed sinc function filter, the second half of the coefficients are identical to the first half in
reverse order. The signal generator provides a mirror table function that automatically duplicates the
existing coefficient values in the reverse order.

1. Press Mirror Table. The last 16 coefficients (16 through 31) are automatically generated and the
first of these coefficients (number 16) highlights, as shown in Figure 11-14 on page 276.

TREQUENCY 6.000 000 000 00 st n“p—LTuanEZIUU den

Figure 11-14
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For details on each key, use key help as described on page 42. coefficient table.

Setting the Oversample Ratio

NOTE Modulation filters must be real and have an oversample ratio (OSR) of two or greater.

The oversample ratio (OSR) is the number of filter coefficients per symbol. Acceptable values range
from 1 through 32; the maximum combination of symbols and oversampling ratio allowed by the table
editor is 1024. The instrument hardware, however, is actually limited to 32 symbols, an oversample
ratio between 4 and 16, and 512 coefficients. So if you enter more than 32 symbols or 512
coefficients, the instrument is unable to use the filter. If the oversample ratio is different from the
internal, optimally selected one, then the filter is automatically resampled to an optimal oversample
ratio.

For this example, the desired OSR is 4, which is the default, so no action is necessary.

Displaying a Graphical Representation of the Filter

The signal generator has the capability of graphically displaying the filter in both time and frequency
dimensions.

1. Press More 10f2 > Display FFT (fast Fourier transform).
Refer to Figure 11-15 on page 277.
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Figure 11-15
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2. Press Return.
3. Press Display Impulse Response.
Refer to Figure 11-16.
Figure 11-16
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4. Press Returnto return to the menu keys.

Storing the Filter to Memory
Use the following steps to store the file.

1. Press Load/Store > Store To File. The catalog of FIR files appears along with the amount of memory
available.

2. As described in Storing, Loading, and Playing a Waveform Segment on page 136, name and store
this file as FIR 1.

The FIR_1 file is the first file name listed. (If you have previously stored other FIR files, additional
file names are listed below FIR_1.) The file type is FIR and the size of the file is 260 bytes. The
amount of memory used is also displayed. The number of files that can be saved depends on the size
of the files and the amount of memory used. Refer to Figure 11-17.
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Figure 11-17

FREQUEHCY

6.000 000 000 00 Gz

ANPLITUDE

-144.00 den

List Load/store

Load From
Selected File

Store To
FileM

Catalog of FIR Files in Int Storage 30MB used LGSME free
File Hame Tupe Size Hodified
1 FIR_1 FIR 260 07 12:LE
2 I 23

Delete Files
These keys manage the table

of DMOD files in internal

Goto Roue storage.

02/20/2007 12:4L7

Catalog displays FIR files that
have been previously saved by
the user.

For details on each key, use key help as described on page 42.

Memory is also shared by instrument state files and list sweep files.

This filter can now be used to customize a modulation format or it can be used as a basis for a new

filter design.

Modifying a FIR Filter Using the FIR Table Editor

FIR filters stored in signal generator memory can easily be modified using the FIR table editor. You
can load the FIR table editor with coefficient values from user-defined FIR files stored in

non-volatile memory or from one of the default FIR filters.
the new files.

Then you can modify the values and store
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Loading the Default Gaussian FIR File

Figure 11-18 Loading the Default Gaussian FIR File
Mode > ARB Custom Modulation > Single Carrier

Setup For details on each key, use key help as described on page 42.
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Press Preset.

Press Mode > ARB Custom Modulation > Single Carrier Setup > Quick Setup > NADC.
Press Filter > Define User FIR > More 1 of 2 > Load Default FIR > Gaussian.

Press Filter BbT > 0.300 > Enter.

W o
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5. Press Filter Symbols > 8 > Enter.

6. Press Generate.

NOTE The actual oversample ratio during modulation is automatically selected by the instrument. A
value between 4 and 16 is chosen dependent on the symbol rate, the number of bits per
symbol of the modulation type, and the number of symbols.

7. Press Display Impulse Response (refer to Figure 11-19).

Figure 11-19
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8. Press Return.

Modifying the Coefficients
1. Using the front panel arrow keys, highlight coefficient 15.
2. Press 0 > Enter.

3. Press Display Impulse Response.

Figure 11-20
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Refer to Figure 11-20 on page 280. The graphic display can provide a useful troubleshooting tool
(in this case, it indicates that a coefficient value is missing, resulting in an improper Gaussian
response).

4. Press Return.
Highlight coefficient 15.

6. Press 1 > Enter.

Storing the Filter to Memory

The maximum file name length is 23 characters (alphanumeric and special characters).
1. Press Load/Store > Store To File.

2. Name the file NEWFIR2.

3. Press Enter.

The contents of the current FIR table editor are stored to a file in non-volatile memory and the
catalog of FIR files is updated to show the new file.

Differential Encoding

Differential encoding is a digital-encoding technique whereby a binary value is denoted by a signal
change rather than a particular signal state. Using differential encoding, binary data in any
user—defined I/Q or FSK modulation can be encoded during the modulation process via symbol table
offsets defined in the Differential State Map.

For example, consider the signal generator’s default 4QAM I/Q modulation. With a user-defined
modulation based on the default 4QAM template, the I/Q Values table editor contains data that
represent four symbols (00, 01, 10, and 11) mapped into the I/Q plane using two distinct values,
1.000000 and —1.000000. The following illustration shows the 4QAM modulation in the I/Q Values
table editor.

FREQUEHCY RF_OFF User Mod Tupe

6.000 000 000 00 &k Load/Stare

Lomd Default,
I/0 Ualues 1/0 Map
Data I Value 0 Value
00000000 1.000000
00000001 -1.000000 1.000000 Delete ALL Rousk
00000010 —1.000000 —1.000000
00000011 1.000000 —1.000000 i i
oooooi00 0 -———— 2l oot 1oL
0n
Configure
Differentiale
Encoding
zxz [EMO COOE = More 2 of 2
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The following illustration shows a 4QAM modulation I/Q State Map.

2nd Symbol

Data = 00000001
Distinct values: -1, +1

3rd Symbol

Data = 00000010
Distinct values: -1, -1

1st Symbol
Data = 00000000
Distinct values: +1, +1

I/0 State Ma

. 'm I/0 Statesl:! yp/
+1 1@ 0!
0

)

a

1

u

e

) o,
k_i I Ualue M

4th Symbol
Data = 00000011
Distinct values: +1, -1

Differential encoding employs relative offsets between the states in the symbol table to encode
user—-defined modulation schemes. The Differential State Map table editor is used to introduce
symbol table offset values which in turn cause transitions through the I/Q State Map based on their
associated data value. Whenever a data value is modulated, the offset value stored in the Differential
State Map is used to encode the data by transitioning through the I/Q State Map in a direction and
distance defined by the symbol table offset value.

Entering a value of +1 will cause a 1-state forward transition through the I/Q State Map, as shown
in the following illustration.

NOTE The following I/Q State Map illustrations show all of the possible state transitions using a
particular symbol table offset value. The actual state-to-state transition would depend upon
the state in which the modulation had started.

As an example, consider the following data/symbol table offset values.

Table 11-2
Data Offset Value
00000000 +1
00000001 -1
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Table 11-2
Data Offset Value
00000010 +2
00000011 0

NOTE

The number of bits per symbol can be expressed using the following formula. Because the

equation is a ceiling function, if the value of x contains a fraction, x is rounded up to the
next whole number.

x= Logzor)

Where x = bits per symbol, and y = the number of differential states.
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These symbol table offsets will result in one of the transitions, as shown.

Data Value 00000000 Data Value 00000001
with Symbol Table Offset +1 with Symbol Table Offset —1
transition 1 state forward transition 1 state backward
I/0 State Map I/0 State Map
I/0 States: L

I/0 States: h

+1 [¢ > +1 4

__./\ Il

-1 T Ualue +1 -1 T Ualue

1
= mERas o

1

= mERas o
+1@

%]

Data Value 00000010 Data Value 00000011
with Symbol Table Offset +2 with Symbol Table Offset 0
transition 2 states forward no transition
I/0 State Map I/0 State Map
. I/0 States: L , I/0 States: L
+1 g 1 +1 [ g al
] ] : ) < ;
u u
d d
1 1
u u
E V2
-1 19 L3} 119 b
=1 I Ualue +1 -1 I Value +1

When applied to the user-defined default 4QAM I/Q map, starting from the 1st symbol (data 00), the
differential encoding transitions for the data stream (in 2-bit symbols) 0011100001 appear in the
following illustration.
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1st Symbol 5th Symbol
+1 y 3rd Symbol Y
0 Data = 0011100001
1] 2nd Symbol 4th Symbol
d
1 Data Value Symbol Table Offset
u 00 +1
01 -1
e 10 +2
11 +0
-1

-1 I Value +1

As you can see from the previous illustration, the 1st and 4th symbols, having the same data value
(00), produce the same state transition (forward 1 state). In differential encoding, symbol values do
not define location; they define the direction and distance of a transition through the 1/Q State Map.

Using Differential Encoding

The signal generator’s Differential State Map table editor enables you to modify the differential
state map associated with user-defined I/Q and user-defined FSK modulations. In this procedure,
you create a user—defined I/Q modulation and then configure, activate, and apply differential
encoding to the user-defined modulation. For more information, see “Differential Encoding” on
page 281.

Configuring User—Defined 1/Q Modulation
1. Press Preset.

2. Perform the following keypress sequence required for your format type.

For Custom Format

Press Mode > ARB Custom Modulation > Single Carrier Setup > Modulation Type > Define User 1/Q >
More 1 of 2> Load Default1/Q Map > QAM > 40AM
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For TMDA Formats

Press Mode > ARB Custom Modulation > Single Carrier Setup > Quick Setup (desired format) >
Modulation Type > Define User1/Q > More 10f2 > Load Default1/Q Map > QAM > 4QAM

This loads a default 4QAM I/Q modulation and displays it in the I/Q table editor.

The default 4QAM I/Q modulation contains data that represent 4 symbols (00, 01, 10, and 11)
mapped into the I/Q plane using 2 distinct values (1.000000 and —1.000000). These 4 symbols will be
traversed during the modulation process by the symbol table offset values associated with each
symbol of data. Refer to Figure 11-21.

Figure 11-21
FREQUEHCY RE_OFF User fod Tupe

6.000 000 000 00 &k Load/Stare

Lomd Default,
I/0 Ualues 1/0 Map
Data I Value 0 Value
00000000 1.000000
00000001 -1.000000 1.000000 Delete ALL Rousk
00000010 —1.000000 —1.000000
00000011 1.000000 —1.000000 i i
poooo100 - -l Diffgrential
on
Configure
Differentiale
Encoding
. fore 2 of 2

Accessing the Differential State Map Table Editor
Press Configure Differential Encoding.

This opens the Differential State Map table editor, as shown. At this point, you see the data for
the 1st symbol (00000000) and the cursor prepared to accept an offset value.You are now prepared to
create a custom differential encoding for the user-defined default 4QAM I/Q modulation. Refer to
Figure 11-22 on page 286.

Figure 11-22

Data Symbol Table Offset Values Entry Area

FREQUEHCY RE_OFF Diff Encode
6.000 000 000,00 & | Edit Ttem
NFFerential State Nap (UNSTORGD) M= (X
Data Suymbol Table Offset
[LUIEL Oelete Row
Goto Rowk

Delete ALl Rowsk
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Editing the Differential State Map

1.

Press 1 > Enter.

This encodes the first symbol by adding a symbol table offset of 1. The symbol rotates forward
through the state map by 1 value when a data value of 0 is modulated.

Press +/— > 1 > Enter.

This encodes the second symbol by adding a symbol table offset of —1. The symbol rotates
backward through the state map by 1 value when a data value of 1 is modulated.

NOTE At this point, the modulation has one bit per symbol. For the first two data values (00000000

and 00000001) only the last bits (the 0 and the 1, respectively) are significant.

Press 2 > Enter.

This encodes the third symbol by adding a symbol table offset of 2. The symbol rotates forward
through the state map by 2 values when a data value of 10 is modulated.

Press 0 > Enter.

This encodes the fourth symbol by adding a symbol table offset of 0. The symbol does not rotate
through the state map when a data value of 11 is modulated.

NOTE At this point, the modulation has two bits per symbol. For the data values 00000000,

00000001, 00000010, 00000011, the symbol values are 00, 01, 10, and 11 respectively.

Applying Custom Differential Encoding

Press Return > Differential Encoding Off On.

This applies the custom differential encoding to a user—-defined modulation.

NOTE Notice that (UNSTORED) appears next to Differential State Map on the signal generator’s

display. Differential state maps are associated with the user-defined modulation for which
they were created.

In order to save a custom differential state map, you must store the user-defined modulation
for which it was designed. Otherwise the symbol table offset data is purged when you press
the Confirm Exit From Table Without Saving softkey when exiting from the I/Q or FSK table editor.
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12 Multitone and Two-Tone Waveforms (Option 430)

NOTE For the N5162A the softkey menus and features mentioned in this guide are only available
through the Web-Enabled MXG or SCPI commands. For information on the Web-Enabled
MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI Command
Reference.

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting the power level and frequency, refer to
Basic Operation on page 41 and familiarize yourself with the information in that chapter.

This feature is available only in N5162A/82A Agilent MXG Vector Signal Generators with Option 430.
Option 430 requires Option 651, 652, or 654.

Creating a Custom Two—Tone Waveform

Using the Two-Tone menu, you can define, and modify user-defined Two-Tone waveforms. Two-Tone
waveforms are generated by the dual arbitrary waveform generator.

The section Using Two-Tone Modulation on page 290 teaches you how to perform the following tasks:
¢ Creating a Two-Tone Waveform on page 291

¢ Viewing a Two-Tone Waveform on page 292

¢ Minimizing Carrier Feedthrough on page 293

¢ Changing the Alignment of a Two-Tone Waveform on page 294

Creating a Custom Multitone Waveform

Using the Multitone Setup table editor, you can define, modify and store user—-defined multitone
waveforms. Multitone waveforms are generated by the dual arbitrary waveform generator.

The Using Multitone Modulation on page 296 teaches you how to perform the following tasks:
e Initializing the Multitone Setup Table Editor on page 296

¢ Configuring Tone Powers and Tone Phases on page 297

* Removing a Tone on page 297

* Generating the Waveform on page 297

¢ Configuring the RF Output on page 298
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Using Two—Tone Modulation

In the following sections, this chapter describes the two-tone mode, which is available only in
N5162A/82A Agilent MXG Vector signal generators with Option 430:

¢ Creating a Two-Tone Waveform on page 291
¢ Viewing a Two-Tone Waveform on page 292
¢ Minimizing Carrier Feedthrough on page 293
¢ Changing the Alignment of a Two-Tone Waveform on page 294

See also: Saving a Waveform’s Settings & Parameters on page 143

NOTE For more information about two-tone waveform characteristics, and the two-tone standard,
download Application Note 1410 from our website by going to htip://www.agilent.com and
searching for “AN 1410” in Test & Measurement.
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Multitone and Two—Tone Waveforms (Option 430)
Using Two—Tone Modulation
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Creating a Two—Tone Waveform
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page 252

This procedure describes how to create a basic, centered, two-tone waveform.

S o o

Turn on the RF output.

Preset the signal generator.

Press Mode > Two-Tone > Freq Separation > 10 > MHz.
Press Two Tone Off On to On.

Set the signal generator RF output frequency to 6 GHz.
Set the signal generator RF output amplitude to -10 dBm.

page 243

The two-tone signal is now available at the signal generator RF OUTPUT connector. Figure 12-1 on

page 292 shows what the signal generator display should look like after all steps have been

completed. Notice that the T-TONE, I/Q, annunciators are displayed; the RF ON, MOD ON are on; and
the parameter settings for the signal are shown in the status area of the signal generator display.
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Figure 12-1
Mode > Two-Tone
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6.000 000 000 00 &= 0.00 den 5
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on Alignment: Center e EE{IMETSR%
For details on
each key, use
key help as ARE Setup
described on
page 42. 022772007 11:23| Hore 1 of 2

Viewing a Two—Tone Waveform

This procedure describes how to configure the spectrum analyzer to view a two-tone waveform and
its IMD products. Actual key presses will vary, depending on the model of spectrum analyzer you are
using.

1. Preset the spectrum analyzer.

2. Set the carrier frequency to 6 GHz.

3. Set the frequency span to 60 MHz.

4. Set the amplitude for a 10 dB scale with a —-10 dBm reference.
5

Adjust the resolution bandwidth to sufficiently reduce the noise floor to expose the IMD products.
A 9.1 kHz setting was used in our example.

6. Turn on the peak detector.
7. Set the attenuation to 4 dB, so you're not overdriving the input mixer on the spectrum analyzer.

You should now see a two-tone waveform with a 6 GHz center carrier frequency that is similar to
the one shown in Figure 12-2 on page 293. You will also see IMD products at 10 MHz intervals above
and below the generated tones, and a carrier feedthrough spike at the center frequency with carrier
feedthrough distortion products at 10 MHz intervals above and below the center carrier frequency.
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Figure 12-2
Channels
Intermodulation Carrier
Distortion Feedthrough
For details on each key, use key help as described on page 42. Carrier Feedthrough

Distortion

Minimizing Carrier Feedthrough

This procedure describes how to minimize carrier feedthrough and measure the difference in power
between the tones and their intermodulation distortion products. Before beginning this procedure, it
is important that a recent I/Q calibration has been performed on the instrument. The procedure for
performing an I/Q calibration (refer to “I/Q Calibration” on page 196).

This procedure builds upon the previous procedure.

1.

w®

NS o e

On the spectrum analyzer, set the resolution bandwidth for a sweep rate of about
100 to 200 ms. This will allow you to dynamically view the carrier feedthrough spike as you make
adjustments.

On the signal generator, press 1/Q> 1/Q Adjustments > 1/Q Adjustments 0ff On to On.

Press Internal Baseband Adjustments > | Offset and turn the rotary knob while observing the carrier
feedthrough with the spectrum analyzer. Changing the I offset in the proper direction will reduce
the feedthrough level. Adjust the level as low as possible.

Press Q@ Offset and turn the rotary knob to further reduce the carrier feedthrough level.
Repeat steps 3 and 4 until you have reached the lowest possible carrier feedthrough level.
On the spectrum analyzer, return the resolution bandwidth to its previous setting.

Turn on waveform averaging.
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8. Create a marker and place it on the peak of one of the two tones.

9. Create a delta marker and place it on the peak of the adjacent intermodulation product, which
should be spaced 10 MHz from the marked tone.

10. Measure the power difference between the tone and its distortion product.

You should now see a display that is similar to the one shown in Figure 12-3 on page 294. Your
optimized two-tone signal can now be used to measure the IMD products generated by a
device-under-test.

Note that carrier feedthrough changes with time and temperature. Therefore, you will need to
periodically readjust your I and Q offsets to keep your signal optimized.

Figure 12-3
Main Marker

Minimized
Carrier
Feedthrough

Marker a
10.200000 MHz
-68.939 dB Delta Marker

| |
'w"n'rh'?v’ bty k""*‘.‘ﬁ" et I |"'-’-ﬁ1,"'|,I'i,"r'q«'}fi.\"l‘r-,l"f»ih'*ﬁlf'

)
A f.'.-'n’ﬁ.-.«‘ i

For details on each
key, use key help as
described on page 42.

1 kHz

Changing the Alignment of a Two—Tone Waveform

This procedure describes how to align a two-tone waveform left or right, relative to the center
carrier frequency. Because the frequency of one of the tones is the same as the carrier frequency,
this alignment typically hides any carrier feedthrough. However, image frequency interference caused
by left or right alignment may cause minor distortion of the two-tone signal. This procedure builds
upon the previous procedure.

1. On the signal generator, press Mode > Two Tone > Alignment Left Cent Right to Left.
2. Press Apply Settings to regenerate the waveform.
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NOTE Whenever a change is made to a setting while the two-tone generator is operating
(Two Tone Off On set to On), you must apply the change by pressing the Apply Settings softkey
before the updated waveform will be generated. When you apply a change, the baseband
generator creates a two-tone waveform using the new settings and replaces the existing
waveform in ARB memory.

3. On the spectrum analyzer, temporarily turn off waveform averaging to refresh your view more
quickly. You should now see a left-aligned two-tone waveform that is similar to the one shown in
Figure 12-4.

Figure 12-4
Upper Tone
Aligned with
Carrier
Channels Frequency
Intermodulation
Distortion
For details on each key, use key help as described on page 42. Carrier

Frequency
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Using Multitone Modulation

Multitone Modulation Softkeys

This softkey is active if changes have been
made to the current Multitone waveform in
the table editor. The softkey must be

pressed to apply those changes.
\

— Nultitone A
¢ Mult itone
| on
Nodulation Hode \
Initialize
Dual ARB» \ Tab1eM page 296
Edit.
Hodugg%gm’ Table page 297
( ¥ page 208 Arb Setu » frb Setup 7 \
AFE Sample Clock Baseband
1.0000000 HHz FrequencH ngsﬁt
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NMultitone
ARE Setupk -
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For softkey usage, Marker
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see page 135
A (Multitone’s ARB Setup is similar to Dual Arb Setup.)

Exceptions:
m > No Waveform Runtime Scaling softkey,
> No Multi-BBG Sync Setup softkey, and
> No DAC Over-Range Protection softkey

For details on each key, use key help as
described on page 42.

Initializing the Multitone Setup Table Editor

1. Press Preset.

2. Press Mode > Multitone

3. Press Initialize Table > Number of Tones > 5 > Enter.
4

Press Freq Spacing > 20 > kHz.
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Figure 12-5
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For details on each key, use key help as described on page 42. W

Press Done.

You now have a multitone setup with five tones spaced 20 kHz apart. The center tone is placed at
the carrier frequency, while the other four tones are spaced in 20 kHz increments from the center
tone.

Configuring Tone Powers and Tone Phases

1.

2.
3.
4

Highlight the value (0 dB) in the Power column for the tone in row 2.
Press Edit Table > Edit ltem > —4.5 > dB.

Highlight the value (0) in the Phase column for the tone in row 2.
Press Editltem > 123 > deg.

Removing a Tone

1.
2.

Highlight the value (On) in the State column for the tone in row 4.
Press Toggle State.

Generating the Waveform

Press Return > Multitone Off On until On is highlighted.

This generates the multitone waveform with the parameters defined in the previous sections. During
waveform generation, the M-TONE and I/Q annunciators activate and the multitone waveform is
stored in volatile ARB memory. The waveform is now modulating the RF carrier.
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Configuring the RF Output

1. Set the RF output frequency to 100 MHz.
2. Set the output amplitude to 0 dBm.

3. Press RF On/0ff.

The multitone waveform is now available at the signal generator’s RF OUTPUT connector.

Applying Changes to an Active Multitone Signal

If the multitone generator is currently in use (Multitone Off On set to On) while changes are made in
the Multitone Setup table editor, you must apply the changes before the updated waveform will be
generated.

From the Multitone Setup table editor, press the following key to apply the changes and generate a
multitone waveform based on the updated values: Apply Multitone

Storing a Multitone Waveform

In this example, you learn how to store a multitone waveform. If you have not created a multitone
waveform, complete the steps in the previous section, Creating a Custom Multitone Waveform on page
289.

1. Press Load/Store > Store To File.

If there is already a file name from the Catalog of MTONE Files occupying the active entry
area, press the following keys (see page 43):

Edit Keys > Clear Text

2. Enter a file name (for example, STONE) using the alpha keys and the numeric keypad with a
maximum length of 23 characters (see page 43).

3. Press Enter.

The multitone waveform is now stored in the Catalog of MTONE Files.

NOTE The RF output amplitude, frequency, and operating state settings are not stored as part of a
multitone waveform file. Similarly, the multitone settings are not stored as part of the
instrument state. Therefore, in most cases you should save both the instrument states and
the multitone settings to be able to restore all of your settings later.
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Recalling a Multitone Waveform

Using this procedure, you learn how to recall a multitone waveform from the signal generator’s
memory catalog.

If you have not created and stored a multitone waveform, complete the steps in the previous
sections, Creating a Custom Multitone Waveform on page 289 and Storing a Multitone Waveform on
page 298, then preset the signal generator to clear the stored multitone waveform from volatile ARB
memory.

1.

2
3.
4.
5

Press Mode > Multitone.

Press Load/Store.

Highlight the desired file (for example, STONE).
Press Load From Selected File > Confirm Load From File.
Press Multitone Off On until On is highlighted.

The firmware generates the multitone waveform in ARB memory. After waveform generation, the
multitone waveform is available to be modulated on the RF output.

For instruction on configuring the RF output, see Configuring the RF Output on page 298.
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13 Working in a Secure Environment

NOTE For the N5161A/62A the softkey menus and features mentioned in this guide are only
available through the Web-Enabled MXG or SCPI commands. For information on the
Web-Enabled MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI
Command Reference.

* Understanding Memory Types on page 301

* Removing Data from Memory (Option 006 Only) on page 304

* Using the Secure Display (Option 006 Only) on page 307

Understanding Memory Types

The signal generator has several memory types, and each is used to store a specific type of data.
Before removing sensitive data, you should to understand how each memory type is used. The
following tables describe each memory type used in the base instrument, and optional baseband

generator.

Table 13-1 Base Instrument Memory

includes flatness calibration,
instrument states, and sweep
lists

| E
) o

.=

£R| =%
Memory Eg g &
Type and [=] 81 = g Purpose/Contents Data Input Method | Location in Instrument and Remarks
Size 9 S8

23| &

SEE|=aF

E8|5E

BEZ|AE
Main Yes No firmware operating memory operating system CPU board, not battery backed.
Memory .
(RAM) no user data
32 MB
Main Yes Yes factory firmware upgrades CPU board (same chip as firmware memory,
Memory calibration/configuration data | and user-saved but managed separately)
(Flash) data? . . .

2user file system, which Because this memory chip contains 8 MB of

8 MB user data (described here) and 8 MB of

firmware memory, a full-chip erase is not

desirable. User data areas are selectively and

completely sanitized when you perform the
Erase and Sanitize function.
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Table 13-1 Base Instrument Memory (Continued)

=| &
=) =]
= =
Memory El g TE
Type and a g 5 dg" Purpose/Contents Data Input Method | Location in Instrument and Remarks
Size ) ol
23|~
EE| =%
28| 8&
BEzZ|AB
Firmware No Yes main firmware image factory installed or | CPU board (same chip as main flash memory,
Memory firmware upgrade but managed separately)
(Flash)

During normal operation, this memory cannot
8 MB be overwritten. It is only overwritten during
the firmware installation or upgrade process.

Because this memory chip contains 8 MB of
user data and 8 MB of firmware memory
(described here), a full-chip erase is not
desirable. User data areas are selectively and
completely sanitized when you perform the
Erase and Sanitize function.

Bootrom No Yes CPU bootup parameters factory programmed | CPU board
Memor;
(EEPRgM) no user data During normal operation, this memory cannot
Yes Yes LAN configuration Front panel entry or be overwritten or erased except for LAN
8 kB 8 pane ¥ configuration. This read-only data is
remotely
programmed at the factory.
Calibration | No Yes factory factory or service RF Board
Data calibration/configuration data | only
(Flash) backup
256 kB no user data
LCD No No display buffer operating system RF board, not battery backed.
Display
Memory
(RAM)
160 kB
Front Panel | No No front panel keyboard operating system Front Panel board
Memory controller firmware
(Flash)
no user data
32 kB

@Analog instruments only
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Table 13-2 Baseband Generator Memory (Options 651,652, 654)

| E
.S ©
=

23 |=7%
Memory 55 g g
Type and a 81 = g Purpose/Contents Data Input Method |Remarks
Size 3 S8

2% | &

EE| =%

R

EZ|Aas
Waveform Yes No waveforms (including normal user Not battery backed.
Memory header and marker data) operation
(RAM)
<320 MB
Persistent Yes Yes all user data normal user User data is completely sanitized when you
Memory operation perform the Erase and Sanitize function.
(Flash)®
4 GB
Calibration No Yes no user data factory or service
Data Memory only
(Flash)
128 kB

For serial numbers <MY4818xxxx, US4818xxxx, and SG4818xxxx, the persistent memory value = 512 MB.

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide 303



Working in a Secure Environment
Removing Data from Memory (Option 006 Only)

Removing Data from Memory (Option 006 Only)

When moving the signal generator from a secure development environment, there are several security
functions you can use to remove classified proprietary information from the instrument. Security
functions also have equivalent SCPI commands for remote operation (“System Subsystem (:SYSTem)”
commands; refer to the SCPI Command Reference)

CAUTION The signal generator has several memory types (described in Table 13-1 on page 301,
and Table 13-2 on page 303), and each is used to store a specific type of data. Before
removing sensitive data, understand how each memory type is used.

v

Catalog &
Catalog Tupe S
(ALY Page 65 Confirm Delete __ Security
—® |Confirm Delete Of Erase ALLM Below
Oelete Filew All Files Security Level
W Erase and Hone
3 M
Copu File Overwrite AlL
Catalo
Erase and
PO Sanitize ALLY page 305 SrEss See
Gota Rokqe Secure Mode on
. age 306
_ Erter Secure Modew Querdrite pag
Oelete ALl Filesk Securitum] >
Tore 1 of 2S¢ Security Level > Sanitize
X (Mone ) ® Ll
USE File Managerw
For details on each key, \\'\\A‘\‘
use key help as described on T L/USE
nLerna
page 42. Storage Selectionm
USE if present)
More 2 of 2
Erase All
Removes: All user files, user flatness calibrations, user I/Q calibrations
Resets: All table editors with original factory values, ensuring that user data and
configurations are not accessible or viewable
Does Not: Sanitize memory
Time to Erase: typically < 1 minute, depending on the number of files.
To Start: Press File > More > Security > Erase All > Confirm Erase

NOTE This is not File > Delete All Files, which deletes all user files but does not reset table editors.

304 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Working in a Secure Environment
Removing Data from Memory (Option 006 Only)

Erase and Overwrite All

This performs the same actions as Erase All, plus it clears and overwrites the various memory types
in compliance with the National Industry Security Program Operating Manual (NISPOM) DoD
5220.22-M.

CPU Flash Overwrites all addressable locations with random characters and then erases the
flash blocks. This accomplishes the same purpose as a chip erase. System files are
restored after erase.

To Start: Press File > More > Security > Erase and Overwrite All > Confirm Erase

Erase and Sanitize All

This performs the same actions as Erase and Overwrite All and then adds more overwriting actions.
After executing this function, you must manually perform the additional steps described below for the
sanitization to comply with the National Industry Security Program Operating Manual (NISPOM) DoD
5220.22-M.

CPU Flash Overwrites all addressable locations with random characters and then erases the flash
blocks. This accomplishes the same purpose as a chip erase. System files are restored after
erase.

BBG Persistent (Vector instruments only) Overwrites all addressable locations with random characters and

Memory (Flash) then erases the flash blocks. This accomplishes the same purpose as a chip erase. System

files are restored after erase.

To Start: Press File > More > Security > Erase and Sanitize All > Confirm Sanitize
Removing Persistent State Information Not Removed During Erase

Persistent State

The persistent state settings contain instrument setup information that can be toggled within
predefined limits such as display intensity, contrast and the GPIB address. In vector models, the user
1Q cal is also saved in this area.

The following key presses or SCPI commands can be used to clear the IQ cal file and to set the
operating states that are not affected by a signal generator power-on, preset, or *RST command to
their factory default:

Instrument Setup

¢ On the Agilent MXG front panel, press: Utility > Power On/Preset > Restore System Settings to Default
Values > Confirm Restore Sys Settings to Default Values

* Or send this command to the Agilent MXG: :SYSTem:PRESet:PERSistent
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Working in a Secure Environment
Removing Data from Memory (Option 006 Only)

LAN Setup

The LAN setup (hostname, IP address, subnet mask, and default gateway) information is not
defaulted with a signal generator power-on or *RST command. This information can only be changed
or cleared by entering new data.

User 1Q Cal File (Vector Models Only)

When a user-defined 1Q calibration has been performed, the cal file data is removed by setting the
cal file to default, as follows:

¢ On the front panel, press: 1/Q > 1/Q Calibration > Revert to Default Cal Settings
* Or send this command to the Agilent MXG: :CAL:IQ:DEF

Secure Mode

CAUTION Once you activate secure mode (by pressing Confirm), you cannot deactivate or decrease
the security level; the erasure actions for that security level execute at the next power
cycle. Once you activate secure mode, you can only increase the security level until you
cycle power. For example, you can change Erase to Overwrite, but not the reverse.

After the power cycle, the security level selection remains the same, but secure mode is
not activated.

To avoid the loss of data, GPIB settings, or current user instrument states that have not
been permanently saved to non-volatile memory, the MXG should always be powered
down either via the MXG's front panel power button or the appropriate SCPI command.
MXG's installed in rack systems and powered down with the system rack power switch
rather than the MXG's front panel switch display a Error —-310 due to the MXG not being
powered down correctly.

Secure mode automatically applies the selected Security Level action the next time the instrument’s
power cycles.

To Set the Level: Press File > More > Security > Security Level and choose from the following:

— None = factory preset, no user information is lost
— Erase =Erase All

— Overwrite = Erase and Overwrite All

— Sanitize = Erase and Sanitize All

To Activate: Press File > More > Security > Enter Secure Mode > Confirm

The softkey changes to Secure Mode Activated.

Securing a Nonfunctioning Instrument

If the instrument is not functioning and you are unable to use the security functions, you must
physically remove the processor board and, for vector instruments, the A4 Memory Chip from the
instrument. Once these assemblies are removed, choose one of the following options:

¢ Discard the board (or boards) and send the instrument to a repair facility. A new board (or
boards) will be installed and the instrument will be repaired and calibrated. If the instrument is
still under warranty, you will not be charged for new boards.

306 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Working in a Secure Environment
Using the Secure Display (Option 006 Only)

e If you have another working instrument, install the board (or boards) into that instrument and
erase the memory. Then reinstall the board (or boards) back into the nonworking instrument and
send it to a repair facility for repair and calibration. If you discover that one or both of the
boards do not function in the working instrument, discard the nonfunctioning board and note on
the repair order that it caused the instrument failure. If the instrument is still under warranty,
you will not be charged for new boards.

For instructions on how to remove and replace boards, refer to the Service Guide.

Using the Secure Display (Option 006 Only)

This function prevents unauthorized personnel from reading the instrument display and tampering
with the current configuration through the front panel. The display blanks, except for the message
shown in the following figure, and the front panel keys are disabled.

To re-enable the display and front panel keys, cycle the power.
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Working in a Secure Environment
Using the Secure Display (Option 006 Only)

Figure 13-1 Secure Display Softkeys

For details on each key, use key help

Utility as described on page 42.
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14 Troubleshooting

NOTE

For the N5161A/62A the softkey menus and features mentioned in this guide are only
available through the Web-Enabled MXG or SCPI commands. For information on the
Web-Enabled MXG, refer to the Installation Guide, the Programming Guide, and to the SCPI
Command Reference.

* Display on page 310

e Signal Generator Lock-Up on page 310

* RF Output on page 310

No RF Output

Power Supply Shuts Down

No Modulation at the RF Output

RF Output Power too Low

Distortion

Signal Loss While Working with a Spectrum Analyzer
Signal Loss While Working with a Mixer

* Sweep on page 313

Cannot Turn Off Sweep

Sweep Appears Stalled

Incorrect List Sweep Dwell Time

List Sweep Information is Missing from a Recalled Register
Amplitude Does Not Change in List or Step Sweep

* Internal Media Data Storage on page 314

Instrument State Saved but the Register is Empty or Contains the Wrong State

e USB Media Data Storage on page 314

Instrument Recognizes USB Media Connection, but Does Not Display Files

* Preset on page 314

The Signal Generator Does Not Respond
Pressing Preset Performs a User Preset

* Error Messages on page 315

* Front Panel Tests on page 316

e Self Test Overview on page 317

* Licenses on page 319

* Contacting Agilent Technologies on page 319

Returning a Signal Generator to Agilent
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Troubleshooting
Display

Display

The Display is Too Dark to Read

Both brightness and contrast may be set to minimum. Use the figure in “Display Settings” on page 26
to locate the brightness and contrast softkeys and adjust their values so that you can see the display.

The Display Turns Black when Using USB Media

Removing the USB media when the instrument begins to use it can cause the screen to go black.
Cycle instrument power.

Signal Generator Lock—Up

* Ensure that the signal generator is not in remote mode (the R annunciator shows on the display).
To exit remote mode and unlock the front panel, press Local Cancel/(Esc).

¢ Ensure that the signal generator is not in local lockout, which prevents front panel operation. For
information on local lockout, refer to the Programming Guide.

e If a progress bar appears on the signal generator display, an operation is in progress.
* Preset the signal generator.

¢ Cycle power on the signal generator.

RF Output

No RF Qutput
¢ Check the RF ON/OFF LED (shown on page 5). If it is off, press RF On/Off to turn the output on.
¢ Ensure that the amplitude is set within the signal generator’s range.

e If the instrument is playing a waveform, ensure that marker polarity and routing settings are
correct (see “Saving Marker Polarity and Routing Settings” on page 150).

Power Supply Shuts Down

If the power supply does not work, it requires repair or replacement. If you are unable to service the
instrument, send the signal generator to an Agilent service center for repair (see “Contacting Agilent
Technologies” on page 319).

No Modulation at the RF Qutput

Check both the Mod On/Off LED and the <modulation> Off On softkey, and ensure that both are on.
See also “Modulating the Carrier Signal” on page 61.

For digital modulation on a vector signal generator, ensure that the internal I/Q modulator is on (the
I/Q annunciator displays).

If using an external modulation source, ensure that the external source is on and that it is operating
within the signal generator’s specified limits.
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Troubleshooting
RF Output

RF OQutput Power too Low
¢ If the AMPLITUDE area of the display shows the OFFS indicator, eliminate the offset:
Press Amptd > More 10f2 > Amptd Offset > 0 > dB. See also “Setting an Output Offset” on page 109.
e If the AMPLITUDE area of the display shows the REF indicator, turn off the reference mode:
1. Press Amptd > More > Amptd Ref Off On until Off highlights.
2. Reset the output power to the desired level.
See also “Setting an Output Reference” on page 110.
e If you are using the signal generator with an external mixer, see page 311.
¢ If you are using the signal generator with a spectrum analyzer, see page 311.

e If pulse modulation is on, turn off the ALC, and check that pulse width is within specifications.

Distortion

If you edit and resave a segment in a waveform sequence, the sequence does not automatically
update the RMS value stored in it’s header. This can cause distortion on the output signal. Display
the sequence header information and recalculate the RMS value (see page 143).

Signal Loss While Working with a Spectrum Analyzer

The effects of reverse power can cause problems with the RF output when you use the signal
generator with a spectrum analyzer that does not have preselection. Use an unleveled operating mode
(described on page 107).

A spectrum analyzer can have as much as +5 dBm LO feedthrough at its RF input port at some
frequencies. If the frequency difference between the LO feedthrough and the RF carrier is less than
the ALC bandwidth, the LO’s reverse power can amplitude modulate the signal generator’s RF output.
The rate of the undesired AM equals the difference in frequency between the spectrum analyzer’s LO
feedthrough and the signal generator’s RF carrier.

Reverse power problems can be solved by using one of the unleveled operating modes.
See:
* “ALC Off Mode” on page 107

and

* “Power Search Mode” on page 108

Signal Loss While Working with a Mixer

To fix signal loss at the signal generator’s RF output during low-amplitude coupled operation with a
mixer, add attenuation and increase the RF output amplitude.
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Troubleshooting
RF Output

The figure at right shows a
configuration in which the Effects of Reverse Power on ALC
signal generator provides a
low amplitude signal to a
mixer.

Signal Generator
Output Control

The internally leveled signal
generator RF output (and ALC ALC Level RF Output Mixer
level) is —8 dBm. The mixer is =-8dBm =-8dBm
driven with an LO of +10 dBm A Lovel —
and has an LO-to-RF Control =
isolation of 15 dB. The
resulting -5 dBm LO

feedthrough enters the signal Detector Detector LO Feedthru LO Level

generator’s RF output measures G T;Zfsl:;es Sodem T HOdBm

connector and arrives at the ~8.dBm

) ALC level reverse
internal detector.

power

Depending on frequency, it is
possible for most of this LO
feedthrough energy to enter the detector. Because the detector responds to its total input power
regardless of frequency, this excess energy causes the ALC to reduce the RF output. In this example,
the reverse power across the detector is actually greater than the ALC level, which can result in loss
of signal at the RF output.

The solution at right shows a
similar configuration with the
addition of a 10 dB

attenuator connected between

Reverse Power Solution

the RF output of the signal Signal Generator
generator and the input of Output Control
the mixer. The signal ALC Level/ .
generator’s ALC level RF Output RF Output  Mixer
increases to +2 dBm and =+2dBm =-8dBm
transmits through a 10 dB RF Level > 1048 >
i > ———» L0
attenuator to achieve the Control ATTEN

required —8 dBm amplitude
at the mixer input.

.

L. Detector Detector LO Feedthru LO Level
Compared to the original measures measures =_5dBm =+10dBm
configuration, the ALC level +2 dBm ~15dBm
is 10 dB higher while the ALC level ;‘(;;sre F

attenuator reduces the LO
feedthrough (and the signal
generator’s RF output) by 10
dB. Using the attenuated
configuration, the detector is exposed to a +2 dBm desired signal versus the —15 dBm undesired LO
feedthrough. This 17 dB difference between desired and undesired energy results in a maximum

0.1 dB shift in the signal generator’s RF output level.
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Troubleshooting
Sweep

Sweep

Cannot Turn Off Sweep

Press Sweep > Sweep > Off.

Sweep Appears Stalled

The current status of the sweep is indicated as a shaded rectangle in the progress bar (see
“Configuring a Swept Output” on page 48). If the sweep appears to stall, check the following:

1. Turn on the sweep with one of the following key sequences:

Sweep > Sweep > Freq
Sweep > Sweep > Amptd
Sweep > Sweep > Waveform (vector instruments only)

2. If the sweep is in single mode, press the Single Sweep softkey.

3. If the sweep trigger (indicated by the Sweep Trigger softkey) is not set to Free Run, set it to Free
Run to determine if a missing sweep trigger is blocking the sweep.

4. If the point trigger (indicated by the Point Trigger softkey) is not set to Free Run, set it to Free
Run to determine if a missing point trigger is blocking the sweep.

5. Set the dwell time to one second to determine if the dwell time was set to a value that was too
slow or too fast to see.

6. Ensure that you set at least two points in the step sweep or list sweep.

Incorrect List Sweep Dwell Time
1. Press Sweep > More > Configure List Sweep.
2. Check that the list sweep dwell values are accurate.

3. If the dwell values are incorrect, edit them.
If the dwell values are correct, continue to the next step.

4. Press More, and ensure that the Dwell Type List Step softkey is set to List.

If Step is selected, the signal generator sweeps the list points using the dwell time set for step
sweep rather than list sweep.

See also “Configuring a Swept Output” on page 48.

List Sweep Information is Missing from a Recalled Register

List sweep information is not stored as part of the instrument state in an instrument state register.
Only the current list sweep is available to the signal generator. You can store list sweep data in the
instrument catalog (see “Loading (Recalling) a Stored File” on page 68).

Amplitude Does Not Change in List or Step Sweep

Verify that sweep type is set to amplitude (Amptd); the amplitude does not change when the sweep
type is set to frequency (Freq) or waveform.
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Internal Media Data Storage

Internal Media Data Storage

Instrument State Saved but the Register is Empty or Contains the Wrong State

If the register number you intended to use is empty or contains the wrong instrument state, recall
register 99. If you selected a register number greater than 99, the signal generator automatically saves
the instrument state in register 99.

See also “Working with Instrument State Files” on page 70.

USB Media Data Storage

Instrument Recognizes USB Media Connection, but Does Not Display Files

If the USB media works on other instruments or computers, it may simply be incompatible with the
signal generator; try a different USB media. Refer to http://www.agilent.com/find/mxg for details on
compatible USB media.

Preset

The Signal Generator Does Not Respond

If the signal generator does not respond to a preset, the instrument may be in remote mode, which
locks the keypad.

To exit remote mode and unlock the preset keys, press Local Cancel/(Esc).

Pressing Preset Performs a User Preset

This behavior results from the use of a backward-compatible SCPI command. To return the signal
generator to normal use, send the command :SYST:PRESet:TYPE NORM.

For information on SCPI commands, refer to the SCPI Command Reference.
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Error Messages

Error Messages

Error Message Types

Events do not generate more than one type of error. For example, an event that generates a query
error does not generate a device-specific, execution, or command error.

Query Errors (-499 to -400) indicate that the instrument’s output queue control has detected a
problem with the message exchange protocol described in IEEE 488.2) Chapter 6. Errors in this class
set the query error bit (bit 2) in the event status register (IEEE 488.2, section 11.5.1). These errors
correspond to message exchange protocol errors described in IEEE 488.2, 6.5. In this case:

¢ Either an attempt is being made to read data from the output queue when no output is either
present or pending, or

¢ data in the output queue has been lost.

Device Specific Errors (-399 to -300, 201 to 703, and 800 to 810) indicate that a device operation
did not properly complete, possibly due to an abnormal hardware or firmware condition. These codes
are also used for self-test response errors. Errors in this class set the device-specific error bit (bit 3)
in the event status register (IEEE 488.2, section 11.5.1).

The <error_message> string for a positive error is not defined by SCPI. A positive error indicates that
the instrument detected an error within the GPIB system, within the instrument’s firmware or
hardware, during the transfer of block data, or during calibration.

Execution Errors (-299 to -200) indicate that an error has been detected by the instrument’s
execution control block. Errors in this class set the execution error bit (bit 4) in the event status
register (IEEE 488.2, section 11.5.1). In this case:

¢ Either a <PROGRAM DATA> element following a header was evaluated by the device as outside of
its legal input range or is otherwise inconsistent with the device’s capabilities, or

¢ a valid program message could not be properly executed due to some device condition.

Execution errors are reported after rounding and expression evaluation operations are completed.
Rounding a numeric data element, for example, is not reported as an execution error.

Command Errors (-199 to -100) indicate that the instrument’s parser detected an IEEE 488.2
syntax error. Errors in this class set the command error bit (bit 5) in the event status register (IEEE
488.2, section 11.5.1). In this case:

¢ Either an IEEE 488.2 syntax error has been detected by the parser (a control-to—-device message
was received that is in violation of the IEEE 488.2 standard. Possible violations include a data
element that violates device listening formats or whose type is unacceptable to the device.), or

e an unrecognized header was received. These include incorrect device-specific headers and
incorrect or unimplemented IEEE 488.2 common commands.

Error Message File

A complete list of error messages is provided on the CDROM supplied with the instrument. In the
error message file, an explanation is generally included with each error to further clarify its meaning.
The error messages are listed numerically. In cases where there are multiple listings for the same
error number, the messages are in alphabetical order.
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Front Panel Tests

Front Panel Tests

Utility

I/0 ConfigM

Instrument Info

Dimgnostic Infom

Front Panel Test

Pixel
Screen Tests?|

Set all display pixels to the selected color.
/ To return to normal operation, press any key.

LED Elink TestM

Blink RF On/Off, Mod on/Off, and More LEDs

ﬂé?ﬁé{#gﬁ%’ Options Infoe
Displauk Self Teste
Poner 0n/, Installed
Preset Board Info®

keu Testw

Displays a keyboard map.
As you press a key, the map indicates the key location.

Instrument InfoM

Front. Panel Testsk

fore 1 of 2

FPG Test

Correct operation:

Full CCW =-10

M\‘\

FullCW =10

For details on each key, use key help
as described on page 42.
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Self Test Overview

The self test is a series of internal tests that checks different signal generator functions. The self test,
is also available by via the remote web interface. For more information on the Web-Enabled MXG,

refer to the Programming Guide.

Utility > Instrument Info ———p»

FREQUEHCY

t Instrument. Info

Dimgnostic InfoM

Options Infom

Self Testh

6.000 000 000 00 &z

Installed

Bgerd 1oat

RF_OFF

Self Test Summary

Mot all tests hawve been run.

(\The current. status of self test is: Incomplete )

Self Test

Fun_Complete
Self Test

J

View Test Infok
_

Troubleshooting
Self Test Overview

Automatically runs
diagnostic self test.

Self Test Summary
displays current status.

Opens a table in which user
selects specific tests and
view details in Test Editor
display.

Displays detailed

\/
FREQUENCY Self Test
6.000 000 000 00 & View Detailse

Run Highlighted

information of
highlighted test. Refer
I to page 42

Executes highlighted
" operation.

Selects or deselects
. highlighted operation.

et Checks Select /Deselect
102 JTAG Chain Check MOT RUM
103 Digital Voltages MOT RUM
104 Sweep Out NOT RUN Select/Deselect
-——— Reference Self Tests ALl
201 Reference Voltages MOT RUM
202 100MHz Tank DAC MOT RUM
203 100MHz Tuning Woltage (Internal Ref) MOT RUM Run Selected
204 Internal Oscillator Check WOT RUM

Selects or deselects
all operations.

fore 1 of 2

For details on each key, use key help
as described on page 42.

Executes all selected
operations.

Self Test

Loop Selected |

Runs a loop of
| selected tests until a
failure occurs.

Go To TestM

Opens the Go To
| Menu. Adds
navigation keys to the

self test menu.
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Self Test Overview

NOTE N5183A MXG with non 1E1 Option (no attenuator), a warning message will be displayed on
the Self Test Summary window as shown below.

Self Test Summary

The current status of self test is: Success
All self tests have passed.

i

#%  WARNING ## WARNIMNG ## WARNING =
## To prevent damage to dour device, disconnect it ==

#= from the RF Output before running self tests. =%
#= Poder levels generated during the self tests can ==
#% damage sensitive dewvices. =%

For instruments with
attenuators the attenuators are auto set to maximum value before self-test executes and resets to nominal at conclusion.
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Licenses

Licenses

NOTE If your instrument has A.01.50 firmware loaded, two years after purchase, your MXG can
display the following time-based error message: "AUS license expires in xxd days.
Contact Agilent Technologies to renew." The error message will repeat three times over
90 days (e.g. first at 90-60 days remaining, second at 59-30 days remaining, and the last at
30-0 days remaining days).

This message can be ignored. This error does not indicate a performance problem with your
MXG. Pressing any softkey will clear the message and the instrument can be used normally.

Downloading a newer version of firmware will prevent further AUS license-related error
messages being displayed.

A Time—Based License Quits Working

¢ The instrument’s time or date may have been reset forward causing the time-based license to
expire.

¢ The instrument’s time or date may have been reset backward more than approximately 25 hours,
causing the instrument to ignore time-based licenses.

See page 28 for details and cautions on setting time and date.

Cannot Load a Time—Based License

The instrument’s time or date may have been reset backward more than approximately 25 hours,
causing the instrument to ignore time-based licenses.

See page 28 for details and cautions on setting time and date.

Contacting Agilent Technologies

* assistance with test and measurements needs, and information on finding a local Agilent office:
hitp://www.agilent.com/find/assist

e accessories or documentation: http:/www.agilent.com/find/maxg
* new firmware releases: hitp.//www.agilent.com/find/upgradeassistant.

If you do not have access to the Internet, please contact your field engineer.

NOTE In any correspondence or telephone conversation, refer to the signal generator by its model
number and full serial number. With this information, the Agilent representative can
determine whether your unit is still within its warranty period.

Returning a Signal Generator to Agilent
Use the following steps to return a signal generator to Agilent Technologies for servicing:
1. Gather as much information as possible regarding the signal generator’s problem.

2. Call the phone number listed on the Internet (http:/www.agilent.com/find/assist) that is specific
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Contacting Agilent Technologies

to your geographic location. If you do not have access to the Internet, contact your Agilent field
engineer.

After sharing information regarding the signal generator and its condition, you will receive
information regarding where to ship your signal generator for repair.

3. Ship the signal generator in the original factory packaging materials, if available, or use similar
packaging to properly protect the signal generator.

320 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Glossary

A

Active Entry The currently selected, and
therefore editable, entry or parameter

ARB Arbitrary waveform generator

AWG Arbitrary waveform generator. Additive
white Gaussian noise

BBG Media Baseband generator media. Volatile
memory, where waveform files are played or
edited.

BNC Connector Bayonet Neill- Concelman
connector. A type of RF connector used to
terminate coaxial cable.

c

CCW Counterclockwise
C/N Carrier-to-noise ratio

CW Continuous wave. Clockwise
D

DHCP Dynamic host communication protocol

Dwell Time In a step sweep (see page 49), the
time that the signal is settled and you can make
a measurement before the sweep moves to the
next point.

E

EVM Error vector magnitude; the magnitude of
the vector difference at a given instant between
the ideal reference signal and the measured
signal.

Filter factor Alpha The filter’s alpha coefficient.
It is only valid for root nyquist and nyquist
filters.

Filter Factor BbT The filter’s

bandwidth-bit- time (BbT). It is only valid for a
Gaussian filter (similar to alpha). BbT is defined
by the GSM standard as 0.3 and by the DECT
standard as 0.5.

G

Gaussian filter The Gaussian filter does not
have a zero Inter-Symbol Interference (ISI).
Wireless system architects must decide just how
much of the ISI can be tolerated in a system and
combine that with noise and interference. The
Gaussian filter is gaussian shaped in both the
time and frequency domains, and it does not
ring like the root nyquist filters do. The effects
of this filter in the time domain are relatively
short and each symbol interacts significantly (or
causes ISI) with only the preceding and
succeeding symbols. This reduces the tendency
for particular sequences of symbols to interact,
which makes amplifiers easier to build and more
efficient.

GPIB General purpose interface bus. An 8-bit
parallel bus common on test equipment.

Hardkey A labeled button on the instrument.

IF Intermediate frequency

Int Media Internal media. Non—volatile signal
generator memory, where waveform files are
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stored.

IP Internet protocol. The network layer for the
TCP/IP protocol suite widely used on Ethernet
networks.

L

LAN Local area network
LO Local oscillator

LXI LAN eXtension for Instrumentation. An
instrumentation platform based on industry
standard Ethernet technology designed to
provide modularity, flexibility, and performance
to small- and medium-sized systems. See also
hitp://www.lxistandard.org

Modulation Format Custom modulation, Two
Tone, or Multitone.

Modulation Mode Dual ARB, Custom
modulation, Two Tone, or Multitone.

Modulation Standard Refers to a Cellular
standard format (i.e. NADC, PDC, PHS, etc.).

Modulation Type Refers to the various 1/Q
constellation types (i.e. PSK, MSK, FSK, C4FM,
etc.)

N

Non-volatile That which survives a power cycle
(such as files stored in USB media).

Nyquist filter Also referred to as a cosine filter.
These filters have the property that their
impulse response rings at the symbol rate.
Adjacent symbols do not interfere with each
other at the symbol times because the response

equals zero at all symbol times except the center
(desired) one.

P

Persistent That which is unaffected by preset,
user preset, or power cycle.

Point- to- point Time In a step sweep (page 49),
the sum of the dwell time, processing time,
switching time, and settling time.

Rectangular filter Also referred to as a ideal
low pass filter. These filters have very steep
cut- off characteristics. The pass band is set to
equal the symbol rate of the signal. Due to a
finite number of coefficients, the filter has a
predefined length and is not truly “ideal”. The
resulting ripple in the cut-off band is effectively
minimized with a Hamming window. This filter
is recommended for achieving optimal ACP. A
symbol length of 32 or greater is recommended
for this filter.

Root Nyquist filter Also referred to as a Root
cosine filter. These filters have the property that
their impulse response rings at the symbol rate.
Adjacent symbols do not interfere with each
other at the symbol times because the response
equals zero at all symbol times except the center
(desired) one. Root nyquist filters heavily filter
the signal without blurring the symbols together
at the symbol times. This is important for
transmitting information without errors caused
by ISI. Note that ISI does exist at all times
except the symbol (decision) times. A cascade of
two of these filters has the transfer function of
a Nyquist filter. One is in the transmitter, the
other in the receiver, so that the system taken
as a whole has the zero-ISI properties of an ISI
filter.

RMS Root mean square. A time-varying signal’s
effective value (the equivalent DC voltage

required to generate the equivalent heat across
a given resistor). For a sinewave, RMS = 0.707 x
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peak value.

S

Softkey A button located along the instrument’s
display that performs whatever function is
shown next to it on that display.

T

TCP Transmission control protocol. The most
common transport layer protocol used on
Ethernet and the Internet.

Terminator A unit indicator (such as Hz or
dBm) that completes an entry. For example, for
the entry 100 Hz, Hz is the terminator.

Type-N Connector Threaded RF connector used
to join coaxial cables.

U

USB Universal serial bus. See also
hitp://www.usb.org

User FIR Selects a user-defined set of
coefficient values. Each line in the FIR values
table contains one coefficient value. The number
of coefficient values listed must be a multiple of
the selected oversampling ratio. Each coefficient
applies to both I and Q components.

vV

Volatile That which does not survive a power
cycle (such as files stored in BBG media).
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Symbols
,200
oM
annunciator, 11, 13
dc offset, removing, 79
hardkey, 77
softkeys, 77, 79
# points softkey, 52
# Skipped Points softkey, 154

Numerics
10 MHz OUT connector, 17,23
100Base-T LAN cable, 31
128 QAM softkey, 261
1410, application note, 290
16-Lvl FSK softkey, 261
16QAM softkey, 261
256 QAM softkey, 261
2-Lvl FSK softkey, 261
32QAM softkey, 261
430, option
multitone mode, 296
two-tone, 290
two-tone mode, 290
4-Lvl FSK softkey, 261
4QAM softkey, 261
5-Pack
history, waveform files, 237
licensing, 230
licensing, installing, 230
licensing, understanding, 230
licensing, waveform file, 231
status messages, 233
warning messages, 241
628, error, 188
64QAM softkey, 261
651/652/654, option
description, 4
multitone mode, 296
two-tone mode, 290
670/671/672, option
description, 4
8557D GPIB only softkey, 33, 35
8648A/B/C/D GPIB only softkey, 33, 35
8656B,8657A/B GPIB only softkey, 33, 35
8-Lvl FSK softkey, 261

A
AC power receptacle, 15, 21
ACP, 258
Activate Secure Display softkey, 26
active
entry, 321
entry area, 11
Active High softkey, 167

Active Low softkey, 167
Add Comment To softkey, 70
additive white Gaussian noise. See AWGN
address, GPIB, 30
Adjust Phase softkey, 45, 47
Adjustable doublet softkey, 124
adjustments

1/Q, 130, 195

quadrature, 195

real-time phase noise, 255
advance, segment, 169
Advanced Settings softkey, 31
Aeroflex softkey, 33, 35
Agilent MXG

modes of operation, 4
Agilent sales and service offices, 319
ALC

hold, 150, 151

OFF annunciator, 11, 13

off mode, 107

softkeys, 45, 47, 154
alc

setting, 47
ALC Input

connector, 24
All softkey, 64
Alpha, 321
AM

annunciator, 11,13

connector, 16, 22

external source, 79

hardkey, 77

softkeys, 77
amplitude

display area, 12

hardkey, 45, 47

modulation, 77

offset, 109

reference, 110

setting, 45, 47

troubleshooting sweep, 313
AMPTD hardkey, 45, 47
analog modulation, 4, 77
angle, quadrature, 130
annunciators, 11, 13
APCO 25 w/C4FM softkey, 260
APCO 25 w/CQPSK softkey, 260
apodization settings, FIR filter, 207, 279
application notes

1410, 290
Apply To Waveform softkey, 154
ARB

definition, 321

player, dual, 134

softkeys, 134, 165, 244, 245, 246, 247, 252

Index
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waveform clipping, 173 baseband generator, 258
arb, 258 custom arb mode, 4
Arb Custom dual arb mode, 5
FIR filters, 273 multiple BBG synchronization, 211
FIR table editor, 278 multitone mode, 4, 5, 296
Arb Segment softkey, 69 two-tone mode, 290
Arb Sequence softkey, 69 BB GEN, 194
arb setup BBG
softkey, 210 media, 134, 136
ARMED annunciator, 11,13 media (definition), 321
arrow keys, 43 Memory softkey, 69
ASK Depth softkey, 261 Memory to USB softkey, 69
ASK softkey, 261 routing, 194
ATTEN HOLD annunciator, 11,13 Segments softkey, 64, 143
Atten/ALC Control softkey, 45, 47 BBG sync, 211
Auto softkeys configure setup, 215
(DHCP/Auto-IP), 31 equipment setup, 215
Auto, 107 resynchronization, 217
Recall, 121 system, 214
AUTOGEN_WAVEFORM file, 258 system delay, 214
auto-IP, 31 trigger setup, 214
Auto-IP softkey, 31 BbT, 321
Automatically Use USB Media If Present softkey, 64 Binary softkey, 64
AUX I/0 connector, 20 bits per symbol, equation, 283
Auxiliary Software Options softkey, 38 Bk Sp hardkey, 43
AWGN Bluetooth softkey, 260, 261
adding, 243 BNC, 321
annunciator, 11, 13 bootrom memory, 301
definition, 321 Bright Color softkey, 26
dual ARB player, 243 brightness adjustment, 26
softkeys, 249 Brightness softkey, 26
AWGN softkeys, 244, 245, 246, 247 Buffered Trig softkey, 167
Build New Waveform Sequence softkey, 139, 163
B Burst Envelope softkey, 192

backspace hardkey, 43 Bus softkey, 49

Bandwidth softkey, 249

baseband, 20 c
aligning signals at, 150 C/N, 321
clipping, 173 C4FM softkey, 261
frequency offset cables
softkey location, 188 crossover, 31
frequency offset, setting, 188 multi- BBG sync, 214
I/Q output connectors, 18 cables, 100Base-T LAN, 31
memory, 134, 301 Calculate softkey, 143
noise, 243 calibration
noise annunciator, 11,13 data, 301
quadrature adjustment, 195 data memory, 303
real time I/Q AWGN, 244, 245, 246, 247, 249 1/Q, 196
softkey, 188 softkey, 196
summing signals, 194 Calibration Type softkey, 196
waveforms convert to analog, 183 Cancel hardkey, 6
baseband frequency offset carrier
DAC over range & scaling, 190 bandwidth, 243
softkey, 188 configuring, 46
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feedthrough, 130
modulating, 61
softkeys, 244, 245, 246, 247
to noise ratio, 243
Carrier Bandwidth softkey, 244, 245, 246, 247
carrier feedthrough, minimizing, 293
Carrier Softkey, 244, 245, 246, 247
Carrier to Noise softkey, 244, 245
Carrier+Noise softkey, 244, 246, 247
Catalog Type softkey, 64, 65, 69, 143
catalog, state files, 73
cew, 321
CDPD softkey, 260, 261
ceiling function, bits per symbol, 283
Channel Band softkey, 45, 47
Channel Number softkey, 45, 47
circular clipping, 177, 180
classified. See security
Clear softkeys
Error Queue(s), 75
Header, 143
Text, 43
clipping
circular, 177, 180
rectangular, 178, 181
softkeys, 173
clock, sample rate, 20
coefficient values, entering, 201, 274
color palette, display, 26
comments, adding & editing (instrument state), 71
component test, 258
Config Type softkey, 31
Configure softkeys
Cal Array, 91
List Sweep, 49, 57
Step Array, 91
Step Sweep, 49, 52
Confirm Load From File softkey, 68
Connection Monitoring softkey, 31
Connection Type softkeys
Sockets, 94
USB, 94
VXI-11, 94
connectors
external triggering source, 170, 172
front panel, 5, 9
rear panel
n5161a, 15
n5162a, 15
n5181a, 15
n5182a, 15
n5183a, 21
routing signals, 49
Continuous softkey, 167
continuous step sweep example, 60

continuous wave

description, 4
continuous wave output, 46
contrast adjustment, 26
Contrast softkey, 26
Copy & softkeys

Play Sequence, 68

Play Waveform, 68

Select User Flatness, 68

Select User Flatness Corrections, 68
Copy softkeys

All Files, 69

File, 64

File to Instrument, 64, 69

File to USB, 69
correction array (user flatness), 96

viewing, 97

See also user flatness correction
cosine filter. See nyquist filter
Create Directory softkey, 64, 69
crossover cable, 31
custom

multicarrier TDMA waveforms

creating, 270

TDMA digital modulation, 263
Custom ARB softkeys, 259
custom arb waveform generator, 4
custom mode, 258
custom modulation

adding to a waveform, 263

waveform, adding to, 263
cw, 321
CW (no modulation) softkey, 57
CW mode

description, 4

DAC over range error, 183, 188
DAC over range protection
baseband frequency offset, 190
phase noise, 256
Dark Color softkey, 26
data
calibration, 301
entry softkeys, 43
erasing, 304
files, 6370
removing, 304
serial, synchronizing, 20
storage
comments, adding and editing, 71
troubleshooting, 314
type, 74
using, 63
date, setting, 28

Index
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dc offset, 130
dc offset, removing, 79
DCFM®/DCfM Cal softkey, 77
DECT softkey, 260
Default Gateway softkey, 31
default settings

restoring, 27, 31, 196

system, restoring, 42
Default softkey, 260
delay

1/Q, 195

multiple BBG sync, 214
Delete softkeys

All Regs in Seq, 70

All Segments On Int Media, 136

All Segments On USB Media, 136

All Sequence Files, 64

All Sequences, 70, 121

All Waveforms, 139

All Waveforms softkey, 163

File, 64

File or Directory, 64, 66, 69, 74

Item, 57

Row, 57

Selected Waveform, 139, 163

Seq Reg, 70

Waveform Sequence, 163
description & plots, phase noise, 253
DETHTR annunciator, 12, 13
Device softkey, 45, 47
DHCP, 31, 321
DHCP softkey, 31
Diff Mode softkeys, 195
differential encoding, 281
differential encoding, bits per symbol, 283
differential state map, bits per symbol, 283
DIGBUS annunciator, 12,13
digital bus, 19
digital modulation

formats, 4

1Q map, QAM, 282

multitone, 296-299

TDMA, 263

two tone, 290-295
digital modulation type

modifying, 266
digital operation, 133, 222, 230
digital signal to analog waveform, 183
display

blanking, 307

error message area, 12

memory, 301

overview, 5, 13

overview, N5161A/62A, 13

overview, N5181A/82A/83A, 11

secure, 307

settings, 26

softkey labels, 13

softkeys, 25, 43, 154

tests, 316

text area, 13

troubleshooting, 310
Display softkeys

Case, 43

display, 25

Waveform And Markers, 154
Displayed Case softkeys, 43
distortion, troubleshooting, 311
DNS Server Override softkey, 31
DNS Server softkey, 31
documentation, xiii
Domain Name softkey, 31
doublet

adjustable, 126

softkeys, 124

trigger, 126
Dual ARB

FIR table editor, 201,206

real-time modulation, 210

user-defined FIR, 201
dual ARB

multi- BBG sync, 211

player, 134

real-time noise, 243

softkeys, 135, 244, 245, 246, 247, 252
dual arb, 258
dual ARB player, 5
Dual ARB Real-Time

filters, 200
dual arbitrary waveform generator, 5
dual display, power meter, 82
dwell time, 57, 321
Dwell Type softkey, 57
dwell, troubleshooting, 313
Dynamic DNS Naming softkey, 31
Dynamic Hostname Services softkey, 31

E

E4428C, E4438C softkey, 33, 35
E442xB, E443xB softkey, 33, 35
E8241A, E8244A, E8251A, E8254A softkey, 33, 35
E8247C, E8257C, E8267C softkey, 33, 35
E8257D, E8267D softkey, 33, 35
EDGE

custom digital modulation, predefined, 263
EDGE softkey, 260
Edit softkeys

Description, 143

Noise RMS Override, 143
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Repetitions, 163
RMS, 143
Selected Waveform Sequence, 139, 163
Editing Keys softkey, 43
Editing Mode softkey, 43
EEPROM, 301
Enable/Disable Markers softkey, 139, 163
Enter Directory softkey, 68
entry, active, 321
equalization
filter, 198
filter, user, 198
equipment setup, 215
equipment, user flatness correction, 92, 93
ERR annunciator, 12, 14
Error hardkey, 75
error messages, 75
DAC over range, 183, 188
display area, 12
file, 315
message format, 75
types, 315
Esc hardkey, 6
EVENT
connector, AUX 1/0, 20
connector, BNC, 19, 149
output jitter, 165
outputs, 149
EVM, 321
EVM error, 130
example
5-Pack License, adding, 234
5-Pack License, history, 239
Waveform 5-Pack License, adding, 234
Waveform 5-Pack License, history, 239
Waveform license, Opt 25x
adding a waveform, 227
locking a slot, 227
examples
FIR filters
creating, 201, 273
modifying, 206, 278
Execute Cal softkey, 196
EXT CLOCK connector, 18
EXT REF annunciator, 11,12,13, 14
Ext softkeys
Delay, 168
Delay Time, 168
Ext, 49
I/Q Output, 192, 193
Pulse, 124
Source, 168
extension, file, 68
external
I and Q signals, 194

Index

media, 74, 314
modulation source, 79
reference oscillator, using, 46
trigger source, 170, 172
triggering, 172
external leveling, 99-106
softkeys, 99
external leveling, configuring, 103
External softkeys
External, 192
Input, 195
Input I Offset, 130
Input Q Offset, 130
Output, 195

F

factory defaults, restoring, 27, 31, 196
features, 2
feedthrough, 130
feedthrough, carrier, minimizing, 293
File hardkey, 64, 73
file headers
creating, 143
editing, 145
example, 146
viewing a different file, 147
files
catalog. See data storage
extensions, 68
working with, 63
filter
equalization, 198
real-time modulation
softkey location, 210
user, equalization, 198
filter, interpolator, 183
filters
finite impulse response, 200, 273
FIR, 200, 273
gaussian, loading default, 207, 279
nyquist, selecting, 267
filters Dual ARB, 200
finite impulse response filters
using, 200, 273
FIR filter
apodization settings, 207, 279
Hamming, 207, 279
Hann, 207, 279
Kaiser, 207, 279
window settings, 207, 279
FIR filters
Arb Custom, 273
creating, 201, 273
modifying, 206, 278
storing, 205, 277
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using, 200, 273
FIR table editor
accessing, 201, 273
Arb Custom, 278
coefficients, duplicating, 203, 276
coefficients, entering values, 201, 274
coefficients, modifying, 208, 280
Dual ARB, 201, 206
files, loading, 207, 279
filters
creating, 201, 273
modifying, 206, 278
storing, 205, 209, 277, 281
oversample ratio, setting, 204, 276
firmware
memory, 301
upgrading, 29, 319
First Mkr Point softkey, 154
First Sample Point softkey, 154
Fixed softkey, 107
flash memory, 301
flatness correction. See user flatness correction
Flatness softkey, 91
FM
annunciator, 12, 14
connector, 16, 22
dc offset, removing, 79
external source, 79
hardkey, 77
softkeys, 77
Free Run softkey, 49, 113, 167
Free-Run softkey, 124
Freq Dev softkey, 261
FREQ hardkey, 45, 47
Freq softkeys, 91
frequency
display area, 11
hardkey, 7, 8, 45, 47
modulation, 77
multiplier, 111
offset, 109
offset, baseband, 188
offset, softkeys, 188
reference, 110
setting, 45, 47
softkeys, 45, 47
step sweep, b3
frequency units, 45
front panel
disabling keys, 307
display, 13
display, N5161A, 13
display, N5181A, 11
display, N5182A, 11
display, N5183A, 11

1/Q inputs, using, 131
knob resolution, 28
overview, 5, 9
tests, 316
FSK softkey, 261
FTP Server softkey, 32
fundamental operation See basic operation

G

Gated softkey, 124, 167
gated triggering, 168,170
Gaussian
definition, 321
gaussian filter, loading default, 207, 279
Gaussian. See AWGN
glossary, 321
Go To Default Path softkey, 64, 66, 74
Goto Row softkey, b7, 64
GPIB
connector, 17, 23
definition, 321
setup, 30
softkeys
Address, 30
Setup, 30
green LED, 8,10
GSM softkey, 260
guides, content of, xiii

hardkeys

definition, 321

help on, 42

overview, 5, 9

See also specific key
header utilities softkeys, 143
Help hardkey, 7, 42
Hostname softkey, 31
hostname, setting, 31
HP 3300A, emulating, 121

I connector, 7

I Offset softkey, 195

I OUT connector, 18

I/O Config softkey, 25

/Q
adjustments, 130, 195
front panel inputs, using, 131, 194
Int Equalization Filter softkeys location, 199
modulation, 130, 192
optimizing, 193
rear panel outputs, 18
rear panel outputs, using, 193
signal path, optimizing, 193
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signal, aligning, 150
softkey, 199
softkeys, 130, 192-197
waveform, clipping, 173
ideal low-pass filter. See rectangular filter
IF, 321
images, 130
impairments
I/Q adjustments, 130
impairments, real-time
phase noise, 251
Import Waveform softkey, 163
Incr Set hardkey, 8
information, removing from memory, 304
Insert softkeys
Insert, 139
Item, 57
Row, 57
Waveform, 139
Waveform Sequence Contents, 139
Install Assembly softkey, 39
Install licenses softkey, 68
installation guide content, xiii
instrument
8757D Scalar Network Analyzer, 55
firmware, upgrading, 29
scalar network analyzer, 55
softkeys
Adjustments, 25
Info, 25
Options, 38
state
associating with waveform, 71
files, 70, 73
register. See data storage
softkey, 69
Int Equalization Filter
softkeys, 199
int media, 321
Int Phase Polarity softkey, 192
interface
GPIB, 30
LAN, 31
internal
reference oscillator, using, 29
Internal Baseband Adjustments softkey, 195
internal media, 74
Internal Storage to USB softkey, 69
Internal/USB Storage Selection softkey, 64
interpolator filter, 183
IP
Address softkey, 31
address, setting, 31
auto, 31
definition, 322

1IQ map, QAM modulation, 282

J

jitter on EVENT output, 165
K

keyboard, using, 121

keys

disabling, 307

front panel, 5,9

help on, 42

numeric, 6

test, 316

See also specific key
knob, 8, 28, 43

L

L annunciator, 12, 14
LAN
connector, 17, 23
definition, 322
Services Setup softkey, 30
setup, 31
Setup softkey, 30
Last Mkr Point softkey, 154
Last softkey, 27
LCD display memory, 301
LEDs, 8,10
blink test, 316
front panel, 8, 10
modulation, 62
leveling
external, 99-106
turn off ALC, 107
licenses
manager, 37
service software, 37
signal studio, 37
time- based, 28
troubleshooting, 319
viewing, 37
waveform, 37
line power (green) LED, 8, 10
linear sweep, 49
list mode values, 58
List softkey, 64
list sweep
parameters, 58
status information, 58
troubleshooting, 313
using, 57
waveform, 59

listener mode annunciator, 12, 14

LO, 322

Load From Selected File softkey, 66, 68

Index
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Load List softkey, 68 types, 301

Load softkeys See also media
All From Int Media, 136 menu keys, 6
All From USB Media, 136 messages, error, 315
Cal Array From Step Array, 91 messages, warning
From Selected File, 67, 68 5-Pack Licensing, 241
Load/Store, 57, 67, 68 Opt 25x Licensing, 229

Segment From Int Media, 136 Waveform 5-Pack Licensing, 241
Segment From USB Media, 136 mirror table, duplicating coefficients, 203, 276
Store, 136 mixer, troubleshooting signal loss, 311

Sweep List, 68
Load/Store softkey, 57, 66, 68
Local hardkey, 6
lock up, troubleshooting, 310
logarithmic sweep, 49
LVDS
MXG, 2
PXB, 2
LVDS compatibility with the PXB, 2
LXIT, 322
configuring the output events, 119
configuring the subsystem, 117

configuring the trigger input events, 118

getting started, 117
understanding the clocks, 115
using, 115

LXI, option ALB, 115,117

main memory, 301
manual control, sweep, 61
Manual softkey, 107
Manual softkeys

Config Settings, 31

Manual, 31

Mode, 49

Point, 49
manuals, content of, xiii
Marker softkeys, 154
markers

frequency

N5183A, b5
step sweep, 55

markers, aligning signal, 150
markers, waveform, 149-165
media

BBG, 321

erasing, 304

Flash Drive, 74

int, 321

storage, 74

types, 134, 301

USB, 74, 314
memory

erasing data from, 304

Mod On/Off hardkey, 7, 61, 62
Mod On/Off, Option UNT, 77
Mod Type Softkeys, 261

Mode hardkey, 135, 244, 245, 246, 247, 249, 252

mode, modulation, 322
modes of operation, 4
Modulated softkey, 107
modulation

AM, 77

analog, 4

annunciators, 12, 14

carrier signal, 61

digital, 4

external source, using, 79

FM, 77

generating, 61

1/Q, 130, 192

phase, 77

pulse, 4,123

real-time filter, softkeys, 210

simultaneous, 63

troubleshooting, 310
Modulator Atten softkey, 249
monochrome display, setting, 26
Monochrome softkey, 26
MSK softkey, 261
MULT annunciator, 12, 14
multi- BBG sync, 211

configure setup, 215

equipment setup, 215

resynchronize, 217

system delay, 214

system sync, 214

trigger setup, 214
multicarrier setup

APCO 25 w/C4FM, 270

APCO 25 w/CQPSK, 270

Bluetooth, 270

CDPD, 270

DECT, 270

Default, 270

EDGE, 270

GSM, 270

NADC, 270

PDC, 270
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PHS, 270
PWT, 270
TETRA, 270
multicarrier setup softkeys, 270
multicarrier TDMA waveforms
creating, 270
multicarrier, Default softkey. See quick setup, Default
softkey, settings
multiplier, using, 111
multitone, 258, 296-299
multitone mode, 4,5
Multitone softkeys, 296
multitone waveform, setup, 289
MXG
LVDS, 2
MXG ATE N5161A/82A Front Panel Functions, 9, 10

N

NADC softkey, 260
Name And Store softkey, 163
Next REG softkey, 121
Next SEQ softkey, 121
No action softkey, 68
No Retrigger softkey, 167
noise, 243
noise bandwidth factor, 243
Noise Bandwidth softkey, 244
Noise Mux softkeys, 246, 247
Noise softkey, 244, 246, 247
non-volatile memory, 134
non-volatile, definition, 322
number keys, 43
numeric keypad, 6
nyquist filter

definition
nyquist filter, selecting, 267

0

OFFS annunciator, 12, 14
offset, 130
offsets
baseband frequency, 188
1/Q. 195
output, using, 109
on/off switch, 8,10
operation
modes of, 4
operation, basic, 41
operation, remote, 30
optimization, 1/Q, 130, 192
option
430
multitone mode, 296
two tone mode, 290
two-tone mode, 290

Index

Option 22x, 230
option ALB, LXI, 115, 117
Option UNT
Mod On/Off hardkey, 77
options
651/652/654
description, 4
multitone mode, 296
two-tone mode, 290
670/671/672, description, 4
enabling, 25, 37
resource, 3
UNT, 4
UNU, 4
UNW, 4
Options 221-229, 230
Options 250-259, 222
Options Info softkey, 38
oscillator, external reference, 46
oscillator, internal reference, 29
Output Blanking softkey, 45, 47
Output Mux softkeys, 244
output, swept, 48
over range error, DAC, 183, 190, 256
overshoot, 183
overview, signal generator, 1

P

Page Up hardkey, 6
parameters, saving a waveform’s, 143
path delay, 130
PATT TRIG IN connector, 19
Patt Trig In softkeys, 168
PDC softkey, 260
peak- to-average power, reducing, 177
performance, optimizing, 81
persistent
memory, 303
persistent settings
definition, 322
resetting, 42
restoring defaults, 27
phase noise
adjustments, 255
DAC over range & scaling, 256
description & plots, 253
impairments, 251
softkeys, 252
Phase Ref Set softkey, 45, 47
phase skew, 130
PHS softkey, 260
pixel test, 316
Plot CDDF softkey, 182
PM Config
Calibrate Sensor, 94

Agilent N5181A/82A MXG Signal Generators User’s Guide

333



Index

Zero Sensor, 94
PM Config softkeys

Connection Type, 94

PM VXI-11 Device Name, 94

Power Meter IP Address, 94

Power Meter IP Port, 94
Point Trigger softkey, 49
point- to- point time, 322
polarity, external trigger, 168
polarity, marker, setting, 162
power

meter, 90, 95

on, settings, 27

peak-to-average, reducing, 177

receptacle, 15, 21

search, 108

search automatic, 109

search settings, 108

sensor, models, 92, 93

setting, 45, 47

softkeys, 25, 27, 107

supply, troubleshooting, 310

switch, 8, 10

troubleshooting, 311

user settable, maximum, 47
Power Control Mode softkeys, 245
power meter

configuration, 95

U2000 Series, 95
U2000A/01A/02A/04A, 95
dual display, 82

power meter configuration sofkeys. See PM Config soft-

keys

power meter sofkeys. See PM Config softkeys

Power Search Reference softkey, 107
Power Search References, 108
Power softkeys
On, 27
On/Preset, 25
Search, 107
power units, 45
preferences, setting, 25
preset
hardkey location, 7
settings, 27
troubleshooting, 314
using, 42
Preset softkeys
Language, 27
List, 57, 91
Preset, 27
Prev REG softkey, 121
Prev SEQ softkey, 121
Proceed With Reconfiguration softkey, 31, 32
programming guide content, xiii

protection, DAC over range
baseband offset frequency, 190
phase noise impairment, 256
PSK softkey, 261
pulse
annunciator, 12, 14
characteristics, 125
connector, 16, 22
marker, viewing, 159
modulation, 123
narrow, 107
sync signal, 49
video signal, 49
Pulse hardkey, 124
pulse modulation, 4
Pulse softkeys, 49, 124
Pulse/RF Blank softkey, 154
PWT softkey, 260
PXB
LVDS compatibility, 2

Q

Q connector, 8

Q Offset softkey, 195

QAM modulation IQ map, 282
QAM softkey, 261

quadrature adjustment, 195
quadrature angle, 130

Quadrature Angle Adjustment softkey, 130, 195

queue, error, 75
quick setup
Default softkey
settings, 260
Quick Setup Softkeys, 260

R annunciator, 12, 14

raised cosine filter. See nyquist filter

RAM, 301, 303
real-time
AWGN
softkeys, 244, 245, 246, 247

I/Q Baseband AWGN softkeys, 249

modulation filter, 210
modulation filter, setting, 210
noise, 243
phase noise, 251
adjustments, 255
DAC over range & scaling, 256
description & plots, 253
impairments, 251
softkeys, 252
real-time modulation
Dual ARB, 210
real-time modulation filter
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softkey, 210
rear panel
I/Q outputs, 193
overview
n5161a, 15
n5162a, 15
n5181a, 15
n5182a, 15
n5183a, 21
Recall hardkey, 70
Recall keys
hardkey, 121
Instrument State, 64, 68
Reg, 121
State, 68
recall register, troubleshooting, 313
receiver test, 258
rectangular clipping, 178, 181
rectangular filter
definition, 322
REF annunciator, 12, 14
REF IN connector, 17,22
Ref Oscillator Ext Bandwidth key, 46
Ref Oscillator Ext Freq key, 46
Ref Oscillator Source softkey, 45, 47
Ref Oscillator Tune key, 29
reference oscillator tune, internal, 29
reference oscillator, external, 46
reference, using, 110
references, content of, xiii
regrowth, spectral, 176
remote interface, emulate HP 3300A, 121
Remote Language softkey, 30, 33, 35
remote operation annunciator, 12, 14
remote operation preferences, 30
Remove Assembly softkey, 39
Rename File softkey, 64
Rename Segment softkey, 136
Reset & Run softkey, 167
Restart on Trig softkey, 167
Restore softkeys
LAN Settings to Default Values, 31
System Settings to Default Values, 27
resynchronize, multi- BBGs, 217
Return hardkey, 8
Reverse Power Protection softkey, 27
Revert to Default Cal Settings softkey, 196
RF
blanking
marker function, 160
settings, saving, 150
hardkey, 7
output
configuring, 46
connector, 7

leveling, external, 99-106
troubleshooting, 310
RF During Power Search softkey, 107
RF Output softkey, 192, 193
RFC NETBIOS Naming softkey, 31
ringing, 183
ripple, 183
RMS, 322
RMS softkey, 107
Rohde & Schwarz softkey, 33, 35
roort, 322
root cosine filter. See root nyquist filter
root mean square, 322
Root Nyquist Filter
definition, 322
root nyquist filter
definition, 322
rotary knob, 43
Route Connectors softkey, 49, 124
Route To softkeys, 49, 124
routing
1/Q, 130, 192
marker
ALC hold, 151
RF blanking, 160
saving settings, 150
RPG test, 316
runtime scaling, 185

S

S annunciator, 12, 14
sales, Agilent offices, 319
sample rate clock, 20
sample rate softkey, 165
Save hardkey, 70
SAVE Seq Reg softkey, 70
Save Setup To Header softkey, 143
Scale Waveform Data softkey, 182
scaling softkeys, 182
SCPI

enabling, 32

reference content, xiii

softkey, 33, 35
screen saver settings, 26
Screen Saver softkey, 26
search, power, 108
secure

display, 307

mode, 306
security, 301
Security softkey, 64
Segment Advance softkey, 167
segment advance triggering, 167
segments

advance triggering, 169
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file headers, 143

loading, 136

softkeys, 136

storing, loading, & playing, 136
Select hardkey, 43
Select Seq softkey, 121
Select softkeys

Color Palette, 26

Different Header, 143, 147

Header, 143

Internal File(s) to Copy to USB, 69

Reg, 70

Seq, 70

Waveform, 57
self test, 317
Sequence softkey, 64, 143
sequences

editing, 141

file headers, 143

marker control, 162

playing, 142

waveform, 139
serial data, synchronizing, 20
server, enabling, 32
service

Agilent offices, 319

guide content, xiii

request annunciator, 12, 14
Set Marker softkeys, 154
settings, persistent, 322
settings, phase noise, 255
Show softkeys

Alpha Table, 43

Waveform Sequence, 139

Waveform Sequence Contents, 139, 163
signal generator

modes, 4
Signal Studio, 3
signal studio licenses, 37
sinewave, 322
Single softkey, 167
Single Sweep softkey, 49
skew, 1/Q, 195
Sockets SCPI softkey, 32
sockets, enabling, 32
softkeys

definition of, 323

help on, 42

label area, 13

location, 5

See also specific key
source settled signal, 49
Source Settled softkey, 49, 124
Span softkey, 107

Specify Default Storage Path for User Media softkey, 64

spectral regrowth, 176

spectrum analyzer, troubleshooting signal loss, 311
square root raised cosine filter. See root nyquist filter

Square softkey, 124
standard, modulation, 322
standby (yellow) LED, 8, 10
State softkey, 64
states, persistent, 322
step array (user flatness), 96
See also user flatness correction
Step Dwell softkey, 52, 113
Step Spacing softkey, 52
step sweep
spacing, 49
troubleshooting, 313
using, 49
Step/Knob Ratio softkey, 28
Storage Type softkey, 66, 74
Store Custom Dig Mod State softkey, 262
Store To File softkey, 66, 67, 68
Stored Segments softkey, 64, 143
Subnet Mask softkey, 31
Sum softkey, 192
sweep
annunciator, 12, 14
hardkey, 49
linear, 49
list parameters, 58
list status information, 58
logarithmic, 49
manual control, 61
mode, 4
out connector, 15, 21,49
out signal, 49
softkeys, 49-61, 124
step, 49
troubleshooting, 313
waveform, including, 59
SWEEP hardkey, 49
Sweep softkeys, 49-61, 69, 124
swept output, 48
switch, power, 8, 10
SWMAN annunciator, 12, 14
synchronize multi- BBGs, 211
configure setup, 215
equipment setup, 215
resynchronize, 217
system delay, 214
system sync, 214
trigger setup, 214
system defaults, restoring, 27

T

T annunciator, 12, 14
talker mode annunciator, 12, 14

336

Agilent N5181A/82A MXG Signal Generators User’s Guide



TCP, 323
TCP Keep Alive softkeys, 31
TDMA

custom digital modulation, predefined, 263
TDMA digital modulation, 263
terminator, 323
test, self, 317
test, self-web-enabled, 317
tests, front panel, 316
TETRA softkey, 260
text area (on display), 13
text entry softkeys, 136
time, dwell, 321
time, setting, 28
time/date reference point, 28
Time/Date softkey, 28
time-based license, 28, 319
Timer Trigger softkey, 49,113
Toggle softkeys, 163
Total Noise softkey, 245
Total softkey, 245
Trig

in connector, 16, 22

out connector, 16, 22, 49

out signal, 49
trigger

connectors, 16, 22

hardkey, 6

initiating, 6

multiple BBG sync, 214
Trigger setup softkeys, 114
Trigger softkeys

& Run, 167

Doublet, 124

Key, 49

Out Polarity, 49

Source, 166

Triggered, 124

Type, 166
Triggered softkey, 124
triggering

gated, 168, 170

multiple BBG sync, 214

equipment setup, 215

segment advance, 167

softkeys, 166

waveforms, 166
troubleshooting, 309
two tone, 258, 290-295
two tone softkeys, 291
two-tone softkeys, 291
two-tone waveform, setup, 289
type, modulation, 322

U

UNLEVEL annunciator, 12, 14
unleveled operation, 107
UNLOCK annunciator, 12, 14
Unspecified softkey, 143
UNT, option, 4
UNU, option, 4
UNW, option, 4
Up Directory softkey, 64, 66, 69
Update in Remote softkey, 26
urls, 3, 29, 37, 319
USB
connecting media, 74
definition, 323
device connector, 17, 23
host connector, 5, 9
keyboard, using, 121
softkeys
File Manager, 64, 65
Keyboard Control, 121
to BBG Memory softkey, 69
to Internal Storage softkey, 69
troubleshooting, 314
Use softkeys
As, 68
Current Directory As Default Path, 64, 74
Only Internal Storage, 64
Only USB Media, 64
user
documentation content, xiii
files, backup and restore, 63
flatness correction, 90
preset, 42
preset, troubleshooting, 314
user FIR
definition, 323
User softkeys
Configure Power Meter, 91
Current Directory As Default Path, 66
Do Cal, 91
Flatness, 45, 47, 64
Flatness Correction, 91
Flatness Corrections, 69
Span, 107
User, 27
user-defined FIR
Dual ARB, 201
Utility hardkey, 25
Utility softkey, 39

v

vector operation, 133, 222, 230

View Next Error Page softkey, 75
View Previous Error Page softkey, 75
volatile memory, 134, 136
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volatile, definition, 323
VXI- 11, enabling, 32
VXT-11 SCPI softkey, 32

W

waveform
adding custom modulation, 263
Waveform 5-Pack
history, using, 237
history, waveform files, 237
installing, 230
licensing, 230
licensing, understanding, 230
licensing, warning messages, 241
licensing, waveform file, 231
status messages, 233
using, 230
Waveform license, Opt 25x
adding a waveform, 224
backup warning, 229
file missing warning, 229
license status messages, 226
licensing, installing, 222
licensing, understanding, 222
licensing, warning messages, 229
lock warning, 229
replacing a waveform, 224
status messages, 226
using, 222
waveform licensing softkeys, 224
Waveform softkeys
Licenses, 38
Runtime Scaling, 182
Segments, 136
Sequences, 139, 163
Utilities, 182
Waveform, 49, 57
waveforms
clipping, 173
file headers, 143
from digital baseband waveform, 183
in a sweep, b9
license, 37
markers, 149, 150
memory, 303
multiple BBG synchronization, 211
multitone, 296-299
overview, 134
saving instrument state, 71
scaling, 182
segment softkeys, 136
sequence, 139
storing, loading, & playing, 136
triggering, 166
two-tone, 290-295

Waveform 5-Pack, 237
Web Server softkey, 32
window settings, FIR filter, 207, 279
WINIT annunciator, 12, 14

Y
yellow LED, 8, 10

Z

Z- axis output
connector, 23

Zoom softkeys, 154
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